[RFC RESEND 00/10] Create separate header for ehci-dbgp driver

2014-11-02 Thread Chris Rorvick
One more attempt at getting some feedback. Original: The FUSBH200 and FOTG210 are not EHCI-compatible and require standalone drivers. See discussion at: http://comments.gmane.org/gmane.linux.usb.general/84169 But these controllers do implement an EHCI-compatible debug port and therefore leve

[RFC RESEND 05/10] fusbh200: Use ehci_dbg_port struct

2014-11-02 Thread Chris Rorvick
The FUSBH200 debug port has a EHCI-compatible register layout so there is no need to define a custom struct. Signed-off-by: Chris Rorvick --- drivers/usb/host/fusbh200.h | 13 + 1 file changed, 1 insertion(+), 12 deletions(-) diff --git a/drivers/usb/host/fusbh200.h b/drivers/usb/ho

[RFC RESEND 03/10] fusbh200: Remove superfluous macro definitions

2014-11-02 Thread Chris Rorvick
The fusbh200_dbg_port struct is a copy of the ehci_dbg_port definition in the header. Embedded in this definition are a number of macros which came along for the ride. These macros are not used in the fusbh200 driver and will conflict those in the new header. Signed-off-by: Chris Rorvick ---

[RFC RESEND 02/10] fusbh200: Make Xen notificaiton consistent with EHCI

2014-11-02 Thread Chris Rorvick
If CONFIG_XEN_DOM0 is enabled, the ehci-dbgp driver notifies Xen of controller reset events via xen_dbgp_reset_prep() and xen_dbgp_external_startup() (via calls to xen_dbgp_op().) Otherwise defines them as no-ops to disable this logic. The fusbh200 driver copies much of the dbgp code from ehci_d

[RFC RESEND 04/10] fusbh200: Remove duplicate ehci-dbgp declarations

2014-11-02 Thread Chris Rorvick
Now that ehci-dbgp has its own header, use it rather than duplicating the declarations, etc. Signed-off-by: Chris Rorvick --- drivers/usb/host/fusbh200.h | 40 ++-- 1 file changed, 2 insertions(+), 38 deletions(-) diff --git a/drivers/usb/host/fusbh200.h b/dr

[RFC RESEND 06/10] fotg210: Make Xen notificaiton consistent with EHCI

2014-11-02 Thread Chris Rorvick
If CONFIG_XEN_DOM0 is enabled, the ehci-dbgp driver notifies Xen of controller reset events via xen_dbgp_reset_prep() and xen_dbgp_external_startup() (via calls to xen_dbgp_op().) Otherwise defines them as no-ops to disable this logic. The fotg210 driver copies much of the dbgp code from ehci_de

[RFC RESEND 07/10] fotg210: Remove superfluous macro definitions

2014-11-02 Thread Chris Rorvick
The fotg210_dbg_port struct is a copy of the ehci_dbg_port definition in the header. Embedded in this definition are a number of macros which came along for the ride. These macros are not used in the fotg210 driver and will conflict those in the new header. Signed-off-by: Chris Rorvick --- d

[RFC RESEND 09/10] fotg210: Use ehci_dbg_port struct

2014-11-02 Thread Chris Rorvick
The FUSBH200 debug port has a EHCI-compatible register layout so there is no need to define a custom struct. Signed-off-by: Chris Rorvick --- drivers/usb/host/fotg210.h | 13 + 1 file changed, 1 insertion(+), 12 deletions(-) diff --git a/drivers/usb/host/fotg210.h b/drivers/usb/host

[RFC RESEND 10/10] usb: Remove __init from early_dbgp_init() prototype

2014-11-02 Thread Chris Rorvick
Specifying these attributes in both the prototype and the function definition is unnecessary and could cause confusion or bugs if they are inconsistent. As such, __init should only be specified at the function definition. Keith Owens suggested this as a janitorial task on LKML several years ago:

[RFC RESEND 08/10] fotg210: Remove duplicate ehci-dbgp declarations

2014-11-02 Thread Chris Rorvick
Now that ehci-dbgp has its own header, use it rather than duplicating the declarations, etc. Signed-off-by: Chris Rorvick --- drivers/usb/host/fotg210.h | 40 ++-- 1 file changed, 2 insertions(+), 38 deletions(-) diff --git a/drivers/usb/host/fotg210.h b/driv

[RFC RESEND 01/10] usb: Create separate header for ehci-dbgp

2014-11-02 Thread Chris Rorvick
The FUSBH200 and FOTG210 controllers implement sufficiently EHCI- compatible debug ports to leverage ehci-dbgp from their respective drivers. Rather than including header, though, they replicate the necessary declarations in their own headers. Move the ehci-dbgp stuff into its own header as a fi

Re: [PATCH net-next v2 2/3] r8152: clear the flagofSCHEDULE_TASKLET in tasklet

2014-11-02 Thread Francois Romieu
Hayes Wang : > David Miller [da...@davemloft.net] [...] > > If another thread of control sets the bit between the test and the > > clear, you will lose an event. > > It is fine. The flag is used to schedule a tasklet, so if the tasklet is > starting running, all the other plans for scheduling a

[PATCH] printk: Add and use LOGLEVEL_ defines for KERN_ equivalents

2014-11-02 Thread Joe Perches
Use #defines instead of magic values. Signed-off-by: Joe Perches --- drivers/usb/storage/debug.c | 2 +- include/linux/kern_levels.h | 13 + kernel/printk/printk.c | 28 +--- lib/dynamic_debug.c | 4 ++-- 4 files changed, 29 insertions(+), 18 de

[PATCH v1 1/3] usb: phy: device-tree documentation for gpio-vbus

2014-11-02 Thread Robert Jarzmik
Add documentation for device-tree binding of the generic gpio-vbus phy controller. Signed-off-by: Robert Jarzmik Cc: devicet...@vger.kernel.org --- .../devicetree/bindings/phy/gpio-vbus.txt | 23 ++ 1 file changed, 23 insertions(+) create mode 100644 Documentation/d

[PATCH v1 3/3] usb: phy: add device-tree support for gpio-vbus

2014-11-02 Thread Robert Jarzmik
Add device-tree support for the generic gpio-vbus driver. Signed-off-by: Robert Jarzmik Cc: devicet...@vger.kernel.org --- drivers/usb/phy/phy-gpio-vbus-usb.c | 15 +++ 1 file changed, 15 insertions(+) diff --git a/drivers/usb/phy/phy-gpio-vbus-usb.c b/drivers/usb/phy/phy-gpio-vbus

[PATCH v1 2/3] usb: phy: convert gpio-vbus to gpio_desc

2014-11-02 Thread Robert Jarzmik
In order to prepare device-tree conversion, port gpio_vbus to use gpio_desc. Signed-off-by: Robert Jarzmik --- drivers/usb/phy/phy-gpio-vbus-usb.c | 105 +++- 1 file changed, 56 insertions(+), 49 deletions(-) diff --git a/drivers/usb/phy/phy-gpio-vbus-usb.c b/dr

RE: [PATCH net-next v2 2/3] r8152: clear the flagofSCHEDULE_TASKLET in tasklet

2014-11-02 Thread Hayes Wang
David Miller [da...@davemloft.net] > This is racey. > If another thread of control sets the bit between the test and the > clear, you will lose an event. It is fine. The flag is used to schedule a tasklet, so if the tasklet is starting running, all the other plans for scheduling a tasklet could

Arndale ethernet regression

2014-11-02 Thread Charles Keepax
Hi Guys, I have been having an issue with the ethernet on Arndale and it bisects down to this commit: commit 3cc81d85ee01e5a0b7ea2f4190e2ed1165f53c31 Author: Michel Stam asix: Don't reset PHY on if_up for ASIX 88772 I am afraid I am not overly familiar with the USB or networking subsystems. But

Re: [PATCH] usb: option: Add ID for Peiker LTE NAD

2014-11-02 Thread Matthias Klein
Am 02.11.2014 um 04:35 schrieb Lars Melin: On 2014-11-01 23:01, Matthias Klein wrote: Add ID of the Peiker LTE NAD for legacy serial interface Signed-off-by: Matthias Klein --- drivers/usb/serial/option.c | 1 + 1 file changed, 1 insertion(+) diff --git a/drivers/usb/serial/option.c b/dri