This full-speed USB device generates spurious remote wakeup event
as soon as USB_DEVICE_REMOTE_WAKEUP feature is set. As the result,
Linux can't enter system suspend and S0ix power saving modes once
this keyboard is used.
This patch tries to introduce USB_QUIRK_IGNORE_REMOTE_WAKEUP quirk.
With thi
On 09/18/2014 10:40 PM, Alan Stern wrote:
Is this quirk doable? What's your opinions?
It's okay with me.
Acked-by: Alan Stern
Thank you Alan.
--
To unsubscribe from this list: send the line "unsubscribe linux-usb" in
the body of a message to majord...@vger.kernel.org
More majordomo info at
> From: Dinh Nguyen [mailto:dingu...@opensource.altera.com]
> Sent: Thursday, September 18, 2014 8:54 AM
>
> On 09/12/2014 10:49 AM, Bartlomiej Zolnierkiewicz wrote:
> >
> > [ added linux-kernel ML to cc: ]
> >
> > Hi,
> >
> > On Tuesday, August 26, 2014 11:19:52 AM dingu...@opensource.altera.com
On 09/12/2014 11:18 AM, Bartlomiej Zolnierkiewicz wrote:
>
> [ added linux-kernel ML to cc: ]
>
> Hi,
>
> On Tuesday, August 26, 2014 11:19:55 AM dingu...@opensource.altera.com wrote:
>> From: Dinh Nguyen
>>
>> Add the proper init calls for either host, gadget or both in platform.c
>>
>> Signed
On Thu, 18 Sep 2014, Petr [iso-8859-1] Ml�dek wrote:
> > This routine can be called from multiple work_structs, because a USB
> > bus can have multiple hubs.
>
> The easiest solution would be to allocate the work queue with
> the flag WQ_UNBOUND and max_active = 1. It will force serialization
>
On Thu, Sep 18, 2014 at 06:15:02PM +0200, Petr Mládek wrote:
> The easiest solution would be to allocate the work queue with
> the flag WQ_UNBOUND and max_active = 1. It will force serialization
> of all work items.
Please use alloc_ordered_workqueue() for that purpose. WQ_UNBOUND +
max_active ==
On Thu 18-09-14 10:24:23, Alan Stern wrote:
> On Thu, 18 Sep 2014, Tejun Heo wrote:
>
> > Hello, Alan, Petr.
> >
> > On Wed, Sep 17, 2014 at 01:36:26PM -0400, Alan Stern wrote:
> > > > - /* If khubd ever becomes multithreaded, this will need a lock */
> > > > + /* If hub_wq ever becom
Hi Bartlomiej,
On 09/12/2014 10:49 AM, Bartlomiej Zolnierkiewicz wrote:
>
> [ added linux-kernel ML to cc: ]
>
> Hi,
>
> On Tuesday, August 26, 2014 11:19:52 AM dingu...@opensource.altera.com wrote:
>> From: Dinh Nguyen
>>
>> Update DWC2 kconfig and makefile to support dual-role mode. The plat
On Thu, Sep 18, 2014 at 3:46 PM, Johan Hovold wrote:
> On Thu, Sep 18, 2014 at 03:43:07PM +0300, Octavian Purdila wrote:
>> On Thu, Sep 18, 2014 at 1:54 PM, Johan Hovold wrote:
>> > On Tue, Sep 09, 2014 at 10:24:46PM +0300, Octavian Purdila wrote:
>
>> > Either way, it looks like this could race
On Thu, Sep 18, 2014 at 10:17 AM, Dinh Nguyen
wrote:
> Hi Robert,
>
> On 09/17/2014 03:52 PM, Stephen Warren wrote:
>> On 09/17/2014 02:47 PM, Dinh Nguyen wrote:
>>> Hi Robert,
>>>
>>> On 9/12/14, 7:13 AM, Robert Baldyga wrote:
Hi Dinh,
On 08/26/2014 06:19 PM, dingu...@opensource.al
Hi Robert,
On 09/17/2014 03:52 PM, Stephen Warren wrote:
> On 09/17/2014 02:47 PM, Dinh Nguyen wrote:
>> Hi Robert,
>>
>> On 9/12/14, 7:13 AM, Robert Baldyga wrote:
>>> Hi Dinh,
>>>
>>> On 08/26/2014 06:19 PM, dingu...@opensource.altera.com wrote:
From: Dinh Nguyen
Add the proper i
On Thu, 18 Sep 2014, Vivek Gautam wrote:
> Now that we have completely moved from older USB-PHY drivers
> to newer GENERIC-PHY drivers for PHYs available with USB controllers
> on Exynos series of SoCs, we can remove the support for the same
> in our host drivers too.
>
> We also defer the probe
Hi Greg,
Here you go. This one should be good to go. Sorry for the last minute
change but it was better to revert those patches than having a broken
v3.17 final. Let me know if you want any changes.
cheers
The following changes since commit 9e82bf014195d6f0054982c463575cdce24292be:
Linux 3.17
On Wed, Sep 17, 2014 at 12:56:42PM -0500, Felipe Balbi wrote:
> Hi Greg,
>
> Here's my pull request for v3.18. Now I'll ignore linux-usb for a while and
> get
> a beer or two.
>
> Anyway, let me know if you want anything to be changed, but I tested these
> patches with beaglebone black and am437
On Thu, 18 Sep 2014, Lu Baolu wrote:
> Hi Greg and Alan,
>
> Do you have any comments for this patch?
>
> I was working on system suspend/resume on T100 tablet. I found once the
> T100 base station keyboard has been stroked, system will not be able to
> enter freeze or S3 mode.
>
> I narrowed
This reverts commit f2267089ea17fa97b796b1b4247e3f8957655df3.
That commit causes more problem than fixes. Firstly, kfree()
should be called after usb_ep_dequeue() and secondly, the way
things are, we will try to dequeue a request that has already
completed much more frequently than one which is pe
On Tue, Sep 09, 2014 at 10:24:44PM +0300, Octavian Purdila wrote:
> +MODULE_AUTHOR("Octavian Purdila ");
> +MODULE_DESCRIPTION(DRIVER_NAME " driver");
> +MODULE_LICENSE("GPL");
Just noticed both the i2c and gpio driver is lacking a MODULE_ALIAS to
enable module auto-loading.
Johan
--
To unsubscr
On Thu, 18 Sep 2014, Tejun Heo wrote:
> Hello, Alan, Petr.
>
> On Wed, Sep 17, 2014 at 01:36:26PM -0400, Alan Stern wrote:
> > > - /* If khubd ever becomes multithreaded, this will need a lock */
> > > + /* If hub_wq ever becomes multithreaded, this will need a lock */
> > > if (udev->wusb) {
>
On Thu, Sep 18, 2014 at 11:25:04AM +0200, Mickael Maison wrote:
> Fixed typos in comments of various drivers/usb files
>
> Signed-off-by: Mickael Maison
for MUSB:
Acked-by: Felipe Balbi
--
balbi
signature.asc
Description: Digital signature
On Mon, Sep 15, 2014 at 01:48:09PM +0200, Andreas Bomholtz wrote:
> Hi,
>
> I just want to know what is need for adding a new USB device to the
> cp210x driver?
>
> The new USB Device:
>
> { USB_DEVICE(0x1D6F, 0x0010) }, /* Seluxit ApS RF Dongle */
You could send use a patch adding this ID to
On Thu, Sep 18, 2014 at 03:43:07PM +0300, Octavian Purdila wrote:
> On Thu, Sep 18, 2014 at 1:54 PM, Johan Hovold wrote:
> > On Tue, Sep 09, 2014 at 10:24:46PM +0300, Octavian Purdila wrote:
> > Either way, it looks like this could race with get_direction() if you
> > get a set_direction() while
On Thu, Sep 18, 2014 at 1:54 PM, Johan Hovold wrote:
> On Tue, Sep 09, 2014 at 10:24:46PM +0300, Octavian Purdila wrote:
>
>
>
>> +#define DLN2_GPIO_DIRECTION_IN 0
>> +#define DLN2_GPIO_DIRECTION_OUT 1
>> +
>> +static int dln2_gpio_get_direction(struct gpio_chip *chip,
2014-09-17 19:46 GMT+04:00 Felipe Balbi :
> On Wed, Sep 17, 2014 at 07:35:14PM +0400, Matwey V. Kornilov wrote:
>> 2014-09-17 19:25 GMT+04:00 Felipe Balbi :
>> > On Wed, Sep 17, 2014 at 10:46:57AM +0400, Matwey V. Kornilov wrote:
>> >> 2014-09-16 22:39 GMT+04:00 Felipe Balbi :
>> >> > Hi,
>> >> >
>
On Tue, Sep 09, 2014 at 10:24:44PM +0300, Octavian Purdila wrote:
> +static int alloc_rx_slot(struct dln2_mod_rx_slots *rxs)
> +{
> + int ret;
> + int slot;
> +
> + /* No need to timeout here, the wait is bounded by the timeout
> + * in _dln2_transfer
> + */
> + ret = wai
On Tue, Sep 09, 2014 at 10:24:46PM +0300, Octavian Purdila wrote:
> +#define DLN2_GPIO_DIRECTION_IN 0
> +#define DLN2_GPIO_DIRECTION_OUT 1
> +
> +static int dln2_gpio_get_direction(struct gpio_chip *chip, unsigned offset)
> +{
> + int ret;
> + struct dln2_gpio
On Mon, Sep 15, 2014 at 03:35:08PM +0300, Heikki Krogerus wrote:
> On Fri, Sep 12, 2014 at 08:16:01PM +0530, Kishon Vijay Abraham I wrote:
> > Assume you have 2 phys in your system..
> > static struct phy_lookup usb_lookup = {
> > .phy_name = "phy-usb.0",
> > .dev_id = "usb.0"
Hi Greg,
On 09/10/2014 10:34 PM, Greg KH wrote:
> On Tue, Sep 09, 2014 at 10:44:51AM +0200, Robert Baldyga wrote:
>> Hi,
>>
>> I have splitted my patchset "usb: dwc2/gadget: fix series" into two series.
>> This patch series contains improvements for dwc2/gadget driver. It's intended
>> for 3.18.
>
Fixed typos in comments of various drivers/usb files
Signed-off-by: Mickael Maison
---
drivers/usb/core/hcd.c | 2 +-
drivers/usb/musb/musb_regs.h | 2 +-
drivers/usb/storage/realtek_cr.c | 4 ++--
drivers/usb/storage/scsiglue.c | 2 +-
drivers/usb/storage/usb.c| 2 +-
5
On Thu, Sep 18, 2014 at 11:49:19AM +0300, Octavian Purdila wrote:
> On Thu, Sep 18, 2014 at 11:19 AM, Johan Hovold wrote:
> > On Wed, Sep 17, 2014 at 01:07:51PM +0300, Octavian Purdila wrote:
> >> On Wed, Sep 17, 2014 at 12:44 PM, Johan Hovold wrote:
> >>
> >>
> >>
> >> >> + /*
> >> >> +
On Thu, Sep 18, 2014 at 11:19 AM, Johan Hovold wrote:
> On Wed, Sep 17, 2014 at 01:07:51PM +0300, Octavian Purdila wrote:
>> On Wed, Sep 17, 2014 at 12:44 PM, Johan Hovold wrote:
>>
>>
>>
>> >> + /*
>> >> + * Buffer to hold the packet for read or write transfers. One
>> >> + * is e
On Wed, Sep 17, 2014 at 01:07:51PM +0300, Octavian Purdila wrote:
> On Wed, Sep 17, 2014 at 12:44 PM, Johan Hovold wrote:
>
>
>
> >> + /*
> >> + * Buffer to hold the packet for read or write transfers. One
> >> + * is enough since we can't have multiple transfers in
> >> + *
31 matches
Mail list logo