[PATCH 3/7] staging: dwc2: add helper variable to simplify code

2013-05-13 Thread Paul Zimmerman
From: Matthijs Kooijman Now a register is masked only in once place, instead of twice. This makes the two uses of this value shorter so they no longer need to be linewrapped. Signed-off-by: Matthijs Kooijman Acked-by: Paul Zimmerman --- drivers/staging/dwc2/hcd_intr.c | 8 1 file cha

[PATCH 7/7] staging: dwc2: remove some useless debug prints

2013-05-13 Thread Paul Zimmerman
From: Matthijs Kooijman This removes some debug prints from pci.c and makes platform.c and pci.c a bit more similar again. Signed-off-by: Matthijs Kooijman Acked-by: Paul Zimmerman --- drivers/staging/dwc2/pci.c | 5 - 1 file changed, 5 deletions(-) diff --git a/drivers/staging/dwc2/pci.

[PATCH 6/7] staging: dwc2: add const to handling of dwc2_core_params

2013-05-13 Thread Paul Zimmerman
From: Stephen Warren Now the functions use proper const annotations, the global variable with default params can be marked const, which prevents these values from being changed for a specific device (in theory there could be multiple controllers with different settings, for example). Signed-off-

[PATCH 5/7] staging: dwc2: remove unneeded check

2013-05-13 Thread Paul Zimmerman
From: Matthijs Kooijman The value in params->enable_dynamic_fifo can only be true if the corresponding bit in hwcfg2 is set, this is already checked by dwc2_set_param_enable_dynamic_fifo. Signed-off-by: Matthijs Kooijman Acked-by: Paul Zimmerman --- drivers/staging/dwc2/core.c | 3 +-- 1 file

[PATCH 4/7] staging: dwc2: remove some device-mode related debug code

2013-05-13 Thread Paul Zimmerman
From: Matthijs Kooijman This code appears to be partially incorrect. Since this is only debug code and only applies to device mode, it seems better to remove this code for now than to invest time fixing it. Signed-off-by: Matthijs Kooijman Acked-by: Paul Zimmerman --- drivers/staging/dwc2/cor

[PATCH 2/7] staging: dwc2: use dwc2_hcd_get_frame_number where possible

2013-05-13 Thread Paul Zimmerman
From: Matthijs Kooijman Before, there were two places that manually read the FRNUM registers, while there is a function to do this. Signed-off-by: Matthijs Kooijman Acked-by: Paul Zimmerman --- drivers/staging/dwc2/core.c | 8 +--- drivers/staging/dwc2/hcd_intr.c | 5 + 2 files ch

[PATCH 1/7] staging: dwc2: replace some magic numbers by constants

2013-05-13 Thread Paul Zimmerman
From: Matthijs Kooijman There were already macros for these, they just weren't being used in a few places. Signed-off-by: Matthijs Kooijman Acked-by: Paul Zimmerman --- drivers/staging/dwc2/core.c | 12 ++-- 1 file changed, 6 insertions(+), 6 deletions(-) diff --git a/drivers/staging

[PATCH 0/7] staging: dwc2: miscellaneous cleanups

2013-05-13 Thread Paul Zimmerman
Hi Greg, Here are some dwc2 patches which Matthijs submitted just before the merge window opened, looks like they did not get picked up. Please apply. -- Paul Matthijs Kooijman (6): staging: dwc2: replace some magic numbers by constants staging: dwc2: use dwc2_hcd_get_frame_number where pos

Re: UHCI/EHCI interrupt storm after resume from S3

2013-05-13 Thread Peter P Waskiewicz Jr
On 05/03/2013 08:27 AM, Alan Stern wrote: On Tue, 19 Mar 2013, Waskiewicz Jr, Peter P wrote: On 3/18/2013 1:35 PM, Greg KH wrote: On Mon, Mar 18, 2013 at 01:30:47PM -0700, Waskiewicz Jr, Peter P wrote: I have an Atom-based machine (N450) with an ICH8 running Ubuntu LTS 12.04.2. This has the

Re: [PATCH] usb: phy: samsung: adding usbphy for Exynos4X12

2013-05-13 Thread Tomasz Figa
Hi Vivek, On Tuesday 14 of May 2013 01:10:32 Vivek Gautam wrote: > Hi Dongjin, > > On Mon, May 13, 2013 at 11:55 PM, Dongjin Kim wrote: > > This patch adds usb host phy (USB 2.0 PHY) support for Samsung > > Exynos4X12 SoC. New functions, > > samsung_exynos4x12_usb2phy_enable/_disable and select

Re: [PATCH] usb: phy: samsung: adding usbphy for Exynos4X12

2013-05-13 Thread Vivek Gautam
Hi Dongjin, On Mon, May 13, 2013 at 11:55 PM, Dongjin Kim wrote: > This patch adds usb host phy (USB 2.0 PHY) support for Samsung Exynos4X12 SoC. > New functions, samsung_exynos4x12_usb2phy_enable/_disable and selecting > reference clock, for Exynos4X12 are added. Since it has different register

RE: dwc2: Transaction errors with device connected at boot

2013-05-13 Thread Paul Zimmerman
> From: Matthijs Kooijman [mailto:matth...@stdin.nl] > Sent: Wednesday, May 08, 2013 2:02 PM > > I'm running into an issue with the dwc2 driver. When I power on my board > with an usb device (mass storage in this case) connected, the hardware > is returning transaction errors (e.g., triggering cha

[PATCH] usb: phy: samsung: adding usbphy for Exynos4X12

2013-05-13 Thread Dongjin Kim
This patch adds usb host phy (USB 2.0 PHY) support for Samsung Exynos4X12 SoC. New functions, samsung_exynos4x12_usb2phy_enable/_disable and selecting reference clock, for Exynos4X12 are added. Since it has different register set up with Exynos4210 or Exynos5250, "samsung,exynos4x12-usb2phy" is add

RE: [PATCH] usb: phy: remove CONFIG_USB_OTG_UTILS once more

2013-05-13 Thread Paul Zimmerman
> From: Paul Bolle [mailto:pebo...@tiscali.nl] > Sent: Monday, May 13, 2013 1:43 AM > > The Kconfig symbol USB_OTG_UTILS was removed in the v3.10 merge window, > in commit fd89149875 ("usb: phy: remove CONFIG_USB_OTG_UTILS"). But that > symbol popped up again in a few places. Remove it there too.

RE: [PATCH] dwc2/pci.c: add STMICRO vendor and device ID for STA2X11 board

2013-05-13 Thread Paul Zimmerman
> From: Federico Vaga [mailto:federico.v...@gmail.com] > Sent: Monday, May 13, 2013 10:54 AM > > add STMICRO vendor and device ID for STA2X11 board > > Signed-off-by: Federico Vaga > Acked-by: Giancarlo Asnaghi > --- > drivers/staging/dwc2/pci.c | 4 > 1 file changed, 4 insertions(+) > >

[PATCH] dwc2/pci.c: add STMICRO vendor and device ID for STA2X11 board

2013-05-13 Thread Federico Vaga
Signed-off-by: Federico Vaga Acked-by: Giancarlo Asnaghi --- drivers/staging/dwc2/pci.c | 4 1 file changed, 4 insertions(+) diff --git a/drivers/staging/dwc2/pci.c b/drivers/staging/dwc2/pci.c index 69c65eb..7029b9f 100644 --- a/drivers/staging/dwc2/pci.c +++ b/drivers/staging/dwc2/pci.c

Re: [PATCH v3 03/10] ARM: tegra: update device trees for USB binding rework

2013-05-13 Thread Stephen Warren
On 05/10/2013 07:54 AM, Venu Byravarasu wrote: > This patch updates all Tegra board files so that they contain all the > properties required by the updated USB DT binding. Note that this patch > only adds the new properties and does not yet remove the old properties, > in order to maintain bisectab

Re: [PATCH v3 02/10] arm: dt: Tegra20: Modify ULPI reset GPIO properties

2013-05-13 Thread Stephen Warren
On 05/10/2013 07:54 AM, Venu Byravarasu wrote: > changes with this patch: Nit: You can simply delete the line above; the patch description should always describe the changes in the patch it's describing! -- To unsubscribe from this list: send the line "unsubscribe linux-usb" in the body of a messa

Re: [PATCH v3 01/10] ARM: tegra: finalize USB EHCI and PHY bindings

2013-05-13 Thread Stephen Warren
On 05/10/2013 07:54 AM, Venu Byravarasu wrote: > The existing Tegra USB bindings have a few issues: > > 1) Many properties are documented as being part of the EHCI controller > node, yet they apply more to the PHY device. They should be moved. > > 2) Some registers in PHY1 are shared with PHY3, a

Re: Linux USB file storage gadget with new UDC

2013-05-13 Thread Alan Stern
On Mon, 13 May 2013, victor yeo wrote: > Thanks, i will enable the CONFIG_PRINTK_TIME. Nonetheless, now the > gadget driver and UDC driver are able to process some SCSI_WRITE_10 > commands (i ignore the USB reset interrupt in UDC driver). Please see > the attached usbmon log. Will the log help? A

Re: Linux USB file storage gadget with new UDC

2013-05-13 Thread victor yeo
Hi, >> Ok, i just fixed the last three bytes in the bulk-out transfer >> problem. Please see below for the log. Now the last three bytes are >> read correctly. After SCSI_WRITE_10 is received, the gadget driver >> prints "g_file_storage gadget: disconnect or port reset", it means USB >> reset inte

Re: musb throughput issues

2013-05-13 Thread Ming Lei
On Mon, May 13, 2013 at 9:00 PM, Frederik Schmid wrote: > On Monday 13 May 2013 20.46.40 Ming Lei wrote: >> On Mon, May 13, 2013 at 12:58 PM, Frederik Schmid >> >> wrote: >> > Ming, >> > >> > The ehci controller is bogged down because the frames from the camera and >> > other stuff are being rela

Re: usb: why we need a msleep(5) in ehci_bus_suspend/resume

2013-05-13 Thread Alan Stern
On Mon, 13 May 2013, linux fddl wrote: > Hi, > > From the ehci-hub.c, I find that ehci_bus_suspend/resume have some > code like this: > > if (time_before(jiffies, ehci->netx_statechange)) > msleep(5); > ... > ehci->next_statechange = jiffies + msec_to_jiffies(10); > > and > > if (time_be

Re: [PATCh V10 04/12] usb: ehci: ehci-mv: use PHY driver for ehci

2013-05-13 Thread Alan Stern
On Mon, 13 May 2013, Chao Xie wrote: > Originaly, ehci driver will call the callbacks in platform data > for PHY initialization and shut down. > With PHY driver, it will call the APIs provided by PHY driver > for PHY initialization and shutdown. It removes the callbacks > in platform data, and at

Re: musb throughput issues

2013-05-13 Thread Frederik Schmid
On Monday 13 May 2013 20.46.40 Ming Lei wrote: > On Mon, May 13, 2013 at 12:58 PM, Frederik Schmid > > wrote: > > Ming, > > > > The ehci controller is bogged down because the frames from the camera and > > other stuff are being relayed over ethernet. > > If you mean usb camera and usb ethernet

Re: musb throughput issues

2013-05-13 Thread Ruslan Bilovol
Hi Frederik, On Fri, May 10, 2013 at 2:22 PM, Frederik Schmid wrote: > Hi Ruslan, > > Thanks for the tips! A few comments below: > > On Friday 10 May 2013 13.54.53 Ruslan Bilovol wrote: >> Hello Frederic, >> >> On Fri, May 10, 2013 at 12:54 PM, Frederik Schmid >> >> wrote: >> > Well, my conclusi

Re: musb throughput issues

2013-05-13 Thread Frederik Schmid
On Monday 13 May 2013 05.44.22 Greg KH wrote: > On Mon, May 13, 2013 at 02:23:55PM +0200, Frederik Schmid wrote: > > On Monday 13 May 2013 05.01.01 Greg KH wrote: > > > Why do the two have any relation to each other, with the exception of > > > possible CPU usage? Are they sharing an interrupt and

Re: musb throughput issues

2013-05-13 Thread Ming Lei
On Mon, May 13, 2013 at 12:58 PM, Frederik Schmid wrote: > Ming, > > The ehci controller is bogged down because the frames from the camera and > other stuff are being relayed over ethernet. If you mean usb camera and usb ethernet need to be used at the same time, it might be a problem, suppose yo

Re: musb throughput issues

2013-05-13 Thread Greg KH
On Mon, May 13, 2013 at 02:23:55PM +0200, Frederik Schmid wrote: > On Monday 13 May 2013 05.01.01 Greg KH wrote: > > Why do the two have any relation to each other, with the exception of > > possible CPU usage? Are they sharing an interrupt and that is somehow a > > problem? > > They don't have a

Re: musb throughput issues

2013-05-13 Thread Frederik Schmid
On Monday 13 May 2013 05.01.01 Greg KH wrote: > Why do the two have any relation to each other, with the exception of > possible CPU usage? Are they sharing an interrupt and that is somehow a > problem? They don't have any relation. The reason why we're trying to use the musb controller is so th

Re: musb throughput issues

2013-05-13 Thread Greg KH
On Mon, May 13, 2013 at 06:58:37AM +0200, Frederik Schmid wrote: > Ming, > > The ehci controller is bogged down because the frames from the camera and > other stuff are being relayed over ethernet. Why do the two have any relation to each other, with the exception of possible CPU usage? Are the

RE: [PATCH 0/5] Equivalent of g_cdc.ko with configfs

2013-05-13 Thread Andrzej Pietrasiewicz
On Wednesday, April 24, 2013 11:41 AM I wrote: > Here I present the conversion of everthing that is required to provide > the equivalent of g_cdc.ko with configfs. > > A branch will be available here (from 24th April 2013, afternoon UTC): > git://git.infradead.org/users/kmpark/linux-samsung usb-ga

RE: [PATCH v2 0/8] Equivalent of g_ncm.ko with configfs

2013-05-13 Thread Andrzej Pietrasiewicz
On Tuesday, April 23, 2013 1:43 PM I wrote: > Here I present the conversion of everthing that is required to provide > the equivalent of g_ncm.ko with configfs. > > This is the second version of the series after discussion with Alan > and Michal's review - thank you guys. > > A branch will be ava

Scanner fails on USB3 port

2013-05-13 Thread Martin van Es
Hi, I have exactly the same problem as described by Harald Judt in this mail: http://www.spinics.net/lists/linux-usb/msg58841.html The thread ends here, in mid conversation with Sarah Sharp: http://www.spinics.net/lists/linux-usb/msg69636.html ... so I'd like to take it up from there. The scann

[PATCH] usb: phy: remove CONFIG_USB_OTG_UTILS once more

2013-05-13 Thread Paul Bolle
The Kconfig symbol USB_OTG_UTILS was removed in the v3.10 merge window, in commit fd89149875 ("usb: phy: remove CONFIG_USB_OTG_UTILS"). But that symbol popped up again in a few places. Remove it there too. Signed-off-by: Paul Bolle --- Untested. drivers/staging/dwc2/Kconfig | 1 - drivers/usb/g

usb: why we need a msleep(5) in ehci_bus_suspend/resume

2013-05-13 Thread linux fddl
Hi, From the ehci-hub.c, I find that ehci_bus_suspend/resume have some code like this: if (time_before(jiffies, ehci->netx_statechange)) msleep(5); ... ehci->next_statechange = jiffies + msec_to_jiffies(10); and if (time_before(jiffies, ehci->netx_statechange)) msleep(5); ... ehci->ne