[PATCH vhost v3 19/19] virtio_net: sq support premapped mode

2024-02-28 Thread Xuan Zhuo
If the xsk is enabling, the xsk tx will share the send queue. But the xsk requires that the send queue use the premapped mode. So the send queue must support premapped mode. cmd: sh samples/pktgen/pktgen_sample01_simple.sh -i eth0 \ -s 16 -d 10.0.0.128 -m 00:16:3e:2c:c8:2e -n 0 -p 100

[PATCH vhost v3 17/19] virtio_net: unify the code for recycling the xmit ptr

2024-02-28 Thread Xuan Zhuo
There are two completely similar and independent implementations. This is inconvenient for the subsequent addition of new types. So extract a function from this piece of code and call this function uniformly to recover old xmit ptr. Signed-off-by: Xuan Zhuo Acked-by: Jason Wang --- drivers/net/

[PATCH vhost v3 18/19] virtio_net: rename free_old_xmit_skbs to free_old_xmit

2024-02-28 Thread Xuan Zhuo
Since free_old_xmit_skbs not only deals with skb, but also xdp frame and subsequent added xsk, so change the name of this function to free_old_xmit. Signed-off-by: Xuan Zhuo Acked-by: Jason Wang --- drivers/net/virtio_net.c | 10 +- 1 file changed, 5 insertions(+), 5 deletions(-) diff

[PATCH vhost v3 16/19] virtio_ring: introduce virtqueue_dma_map_sg_attrs

2024-02-28 Thread Xuan Zhuo
Introduce a helper to do dma map for scatterlist. That can be used by other drivers. Signed-off-by: Xuan Zhuo --- drivers/virtio/virtio_ring.c | 32 include/linux/virtio.h | 3 +++ 2 files changed, 35 insertions(+) diff --git a/drivers/virtio/virtio_ring.

[PATCH vhost v3 15/19] virtio_ring: introduce dma map api for page

2024-02-28 Thread Xuan Zhuo
The virtio-net sq will use these APIs to map the scatterlist. For scatterlist, the page dma APIs are more appropriate. dma_addr_t virtqueue_dma_map_page_attrs(struct virtqueue *_vq, struct page *page, size_t offset, size_t size,

[PATCH vhost v3 11/19] virtio: find_vqs: add new parameter premapped

2024-02-28 Thread Xuan Zhuo
If the premapped mode is enabled, the dma array(struct vring_desc_dma) of virtio core will not be allocated. That is judged when find_vqs() is called. To avoid allocating dma array in find_vqs() and releasing it immediately by virtqueue_set_dma_premapped(). This patch introduces a new parameter to

[PATCH vhost v3 14/19] virtio_ring: remove api of setting vq premapped

2024-02-28 Thread Xuan Zhuo
The virtio-net sets the premapped mode by find_vqs(). So the below API is not used by anyone, we remove it. int virtqueue_set_dma_premapped(struct virtqueue *_vq); Signed-off-by: Xuan Zhuo --- drivers/virtio/virtio_ring.c | 56 include/linux/virtio.h

[PATCH vhost v3 13/19] virtio_net: set premapped mode by find_vqs()

2024-02-28 Thread Xuan Zhuo
Now, the virtio core can set the premapped mode by find_vqs(). If the premapped can be enabled, the dma array will not be allocated. So virtio-net use the api of find_vqs to enable the premapped. Judge the premapped mode by the vq->premapped instead of saving local variable. Signed-off-by: Xuan Z

[PATCH vhost v3 12/19] virtio_ring: export premapped to driver by struct virtqueue

2024-02-28 Thread Xuan Zhuo
Export the premapped to drivers, then drivers can check the vq premapped mode after the find_vqs(). Because the find_vqs() just try to enable the vq premapped mode, the driver must check that after find_vqs(). Signed-off-by: Xuan Zhuo --- drivers/virtio/virtio_ring.c | 13 + include/

[PATCH vhost v3 09/19] virtio: vring_new_virtqueue(): pass struct instead of multi parameters

2024-02-28 Thread Xuan Zhuo
Just like find_vqs(), it is time to refactor the vring_new_virtqueue(). We pass the similar struct to vring_new_virtqueue. Signed-off-by: Xuan Zhuo --- drivers/platform/mellanox/mlxbf-tmfifo.c | 13 +--- drivers/remoteproc/remoteproc_virtio.c | 11 --- drivers/virtio/virtio_ring.c

[PATCH vhost v3 07/19] virtio: find_vqs: pass struct instead of multi parameters

2024-02-28 Thread Xuan Zhuo
Now, we pass multi parameters to find_vqs. These parameters may work for transport or work for vring. And find_vqs has multi implements in many places: But every time, arch/um/drivers/virtio_uml.c drivers/platform/mellanox/mlxbf-tmfifo.c drivers/remoteproc/remoteproc_virtio.c drivers/s390/vir

[PATCH vhost v3 10/19] virtio_ring: simplify the parameters of the funcs related to vring_create/new_virtqueue()

2024-02-28 Thread Xuan Zhuo
As the refactor of find_vqs()/vring_new_virtqueue()/vring_create_virtqueue the struct cfg/tp_cfg are passed to vring. This patch refactors the vring by these structures. This can simplify the code. Signed-off-by: Xuan Zhuo --- drivers/virtio/virtio_ring.c | 157 +++--

[PATCH vhost v3 08/19] virtio: vring_create_virtqueue: pass struct instead of multi parameters

2024-02-28 Thread Xuan Zhuo
Now, we pass multi parameters to vring_create_virtqueue. These parameters may from transport or from driver. vring_create_virtqueue is called by many places. Every time, we try to add a new parameter, that is difficult. If parameters from the driver, that should directly be passed to vring. Then

[PATCH vhost v3 03/19] virtio_ring: packed: structure the indirect desc table

2024-02-28 Thread Xuan Zhuo
This commit structure the indirect desc table. Then we can get the desc num directly when doing unmap. And save the dma info to the struct, then the indirect will not use the dma fields of the desc_extra. The subsequent commits will make the dma fields are optional. But for the indirect case, we m

[PATCH vhost v3 06/19] virtio_ring: no store dma info when unmap is not needed

2024-02-28 Thread Xuan Zhuo
As discussed: http://lore.kernel.org/all/CACGkMEug-=C+VQhkMYSgUKMC==04m7-uem_yc21bggkkzh8...@mail.gmail.com When the vq is premapped mode, the driver manages the dma info is a good way. So this commit make the virtio core not to store the dma info and release the memory which is used to store the

[PATCH vhost v3 04/19] virtio_ring: split: remove double check of the unmap ops

2024-02-28 Thread Xuan Zhuo
In the functions vring_unmap_one_split and vring_unmap_one_split_indirect, multiple checks are made whether unmap is performed and whether it is INDIRECT. These two functions are usually called in a loop, and we should put the check outside the loop. And we unmap the descs with VRING_DESC_F_INDIR

[PATCH vhost v3 02/19] virtio_ring: packed: remove double check of the unmap ops

2024-02-28 Thread Xuan Zhuo
In the functions vring_unmap_extra_packed and vring_unmap_desc_packed, multiple checks are made whether unmap is performed and whether it is INDIRECT. These two functions are usually called in a loop, and we should put the check outside the loop. And we unmap the descs with VRING_DESC_F_INDIRECT

[PATCH vhost v3 01/19] virtio_ring: introduce vring_need_unmap_buffer

2024-02-28 Thread Xuan Zhuo
To make the code readable, introduce vring_need_unmap_buffer() to replace do_unmap. use_dma_api premapped -> vring_need_unmap_buffer() 1. false falsefalse 2. truefalsetrue 3. truetrue false Signed-off-by: Xuan Zhuo Acked-by: Jason Wang --- drive

[PATCH vhost v3 05/19] virtio_ring: split: structure the indirect desc table

2024-02-28 Thread Xuan Zhuo
This commit structure the indirect desc table. Then we can get the desc num directly when doing unmap. And save the dma info to the struct, then the indirect will not use the dma fields of the desc_extra. The subsequent commits will make the dma fields are optional. But for the indirect case, we m

[PATCH vhost v3 00/19] virtio: drivers maintain dma info for premapped vq

2024-02-28 Thread Xuan Zhuo
As discussed: http://lore.kernel.org/all/cacgkmevq0no8qgc46u4mgsmtud44fd_cflcpavmj3rhyqrz...@mail.gmail.com If the virtio is premapped mode, the driver should manage the dma info by self. So the virtio core should not store the dma info. So we can release the memory used to store the dma info. Bu

Re: [PATCH 3/4] arch: define CONFIG_PAGE_SIZE_*KB on all architectures

2024-02-28 Thread Stafford Horne
On Mon, Feb 26, 2024 at 05:14:13PM +0100, Arnd Bergmann wrote: > From: Arnd Bergmann > > Most architectures only support a single hardcoded page size. In order > to ensure that each one of these sets the corresponding Kconfig symbols, > change over the PAGE_SHIFT definition to the common one and

Re: [PATCH v4 5/7] arm64: Unconditionally call unflatten_device_tree()

2024-02-28 Thread Rob Herring
On Tue, Feb 27, 2024 at 05:34:58PM +, Mark Rutland wrote: > On Fri, Feb 23, 2024 at 11:17:02AM -0700, Rob Herring wrote: > > On Fri, Feb 23, 2024 at 3:23 AM Will Deacon wrote: > > > > > > On Thu, Feb 22, 2024 at 05:03:17PM -0700, Rob Herring wrote: > > > > On Fri, Feb 16, 2024 at 05:05:54PM -0