Am 22.03.2017 19:50, schrieb Colin King:
> From: Colin Ian King
>
> Currently the misx and intx variables of the interrupt enable/disable
> helper functions are built in no matter what the setting of the
> macro PM8001_USE_MSIX. Clean this up by just building in the
> necessary helper function
On Thu, Mar 23, 2017 at 9:34 AM, walter harms wrote:
>> @@ -4613,15 +4616,15 @@ static int pm8001_chip_phy_ctl_req(struct
>> pm8001_hba_info *pm8001_ha,
>>
>> static u32 pm8001_chip_is_our_interupt(struct pm8001_hba_info *pm8001_ha)
>> {
>> - u32 value;
>> #ifdef PM8001_USE_MSIX
>>
On Wed, Mar 22, 2017 at 7:50 PM, Colin King wrote:
> From: Colin Ian King
>
> Currently the misx and intx variables of the interrupt enable/disable
> helper functions are built in no matter what the setting of the
> macro PM8001_USE_MSIX. Clean this up by just building in the
> necessary helper
We don't call the remove() function unless probe() succeeds so "oud"
can't be NULL here. Plus, if it were NULL, we dereference it on the
next line so it would crash anyway.
Signed-off-by: Dan Carpenter
diff --git a/drivers/scsi/osd/osd_uld.c b/drivers/scsi/osd/osd_uld.c
index 4101c3178411..8b99
From: Tomohiro Kusumi
These aren't really falling through to anywhere meaningful.
Signed-off-by: Tomohiro Kusumi
---
drivers/scsi/ufs/ufshcd.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/drivers/scsi/ufs/ufshcd.c b/drivers/scsi/ufs/ufshcd.c
index dc6efbd..b7e5128 1006
On Wed, Mar 22, 2017 at 07:42:08PM +, Colin Ian King wrote:
> On 22/03/17 19:39, Dan Carpenter wrote:
> > On Wed, Mar 22, 2017 at 02:01:37PM +, Colin King wrote:
> >> From: Colin Ian King
> >>
> >> Reading and writing to mode[count - 1] implies the count should not
> >> be less than 1 so a
From: Colin Ian King
All error paths to label out_term2 result in sess being null, so the
check for sess being non-null and the call to put_sess is dead code
and can therefore be removed.
Detected with CoverityScan, CID#1420664 ("Logically dead code")
Signed-off-by: Colin Ian King
---
drivers
On 03/21/2017 08:05 PM, Benjamin Block wrote:
> On Thu, Mar 16, 2017 at 12:53:45PM +0100, Hannes Reinecke wrote:
>> On 03/16/2017 12:01 PM, Benjamin Block wrote:
>>> On Wed, Mar 15, 2017 at 02:54:16PM +0100, Hannes Reinecke wrote:
On 03/14/2017 06:56 PM, Benjamin Block wrote:
> Hello Hanne
Use sg_virt() instead of open-coding it.
Signed-off-by: Geliang Tang
---
drivers/scsi/qla2xxx/qla_isr.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/scsi/qla2xxx/qla_isr.c b/drivers/scsi/qla2xxx/qla_isr.c
index 3203367..9610d85 100644
--- a/drivers/scsi/qla2xxx/qla
On Wed, 2017-03-22 at 19:19 +0100, Christoph Hellwig wrote:
> On Tue, Mar 21, 2017 at 02:59:01PM -0400, Tejun Heo wrote:
> > I do like the fact that this is a lot simpler than the previous
> > implementation but am not quite sure we want to deviate
> > significantly from what we do for other comma
From: Chad Dupuis
We need to initialize qedf->fipvlan_compl in __qedf_probe so that if we receive
an unsolicited FIP VLAN response, the system doesn't crash due to trying to
complete an uninitialized completion.
Also add a check to see if there are any waiters on the completion so we don't
inadv
On Thu, Mar 23, 2017 at 09:47:41AM -0400, James Bottomley wrote:
> > The current implementation already has the issue of that it does
> > corrupt user data reliably if the using SG_IO for WRITE SAME
> > commands.
>
> That does need fixing.
I don't think it's fixable as long as we translate the da
"Satish Kharat (satishkh)" writes:
Satish,
> Apologies for the delay. I was not able to verify this because of
> another fnic issue blocking this test. Just now submitted a fix for
> that 'fnic issue' (in the patch => [PATCH 1/1] fnic: bug fix for
> fip.fip_subcode in fnic_fcoe_send_vlan_req)
>
Brian King writes:
> Following a command abort or device reset, ipr's EH handlers wait
> for the commands getting aborted to get sent back from the adapter
> prior to returning from the EH handler. This fixes up some cases
> where the completion handler was not getting called, which would
> have
Jitendra Bhivare writes:
Somebody please review!
Thanks!
--
Martin K. Petersen Oracle Linux Engineering
Tomas Henzl writes:
> In a previous patch a hpsa_scsi_dev_t.volume_offline update line
> has been removed, so let us put it back..
>
> Fixes: 85b29008d8 (hpsa: update check for logical volume status)
Applied to 4.11/scsi-fixes.
--
Martin K. Petersen Oracle Linux Engineering
Arnd Bergmann writes:
> gcc points out that we are converting a 16-bit integer into a 32-bit
> little-endian type and assigning that to 16-bit little-endian
> will end up with a zero:
>
> drivers/scsi/qedf/drv_fcoe_fw_funcs.c: In function
> 'init_initiator_rw_fcoe_task':
> include/uapi/linux/byt
This series makes REQ_OP_WRITE_ZEROES the only zeroing offload
supported by the block layer, and switches existing implementations
of REQ_OP_DISCARD that correctly set discard_zeroes_data to it,
removes incorrect discard_zeroes_data, and also switches WRITE SAME
based zeroing in SCSI to this new me
Copy and past the REQ_OP_WRITE_SAME code to prepare to implementations
that limit the write zeroes size.
Signed-off-by: Christoph Hellwig
---
block/blk-merge.c | 17 +++--
1 file changed, 15 insertions(+), 2 deletions(-)
diff --git a/block/blk-merge.c b/block/blk-merge.c
index c62a6
It seems like the code currently passes whatever it was using for writes
to WRITE SAME. Just switch it to WRITE ZEROES, although that doesn't
need any payload.
Untested, and confused by the code, maybe someone who understands it
better than me can help..
Not-yet-signed-off-by: Christoph Hellwig
On Thu, 2017-03-23 at 14:55 +0100, Christoph Hellwig wrote:
> On Thu, Mar 23, 2017 at 09:47:41AM -0400, James Bottomley wrote:
> > > The current implementation already has the issue of that it does
> > > corrupt user data reliably if the using SG_IO for WRITE SAME
> > > commands.
> >
> > That does
Make life easy for implementations that needs to send a data buffer
to the device (e.g. SCSI) by numbering it as a data out command.
Signed-off-by: Christoph Hellwig
---
include/linux/blk_types.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/include/linux/blk_types.h b/incl
It seems like DRBD assumes its on the wire TRIM request always zeroes data.
Use that fact to implement REQ_OP_WRITE_ZEROES.
XXX: will need a careful audit from the drbd team!
Signed-off-by: Christoph Hellwig
---
drivers/block/drbd/drbd_main.c | 3 ++-
drivers/block/drbd/drbd_nl.c | 2
rbd only supports discarding on large alignments, so the zeroing code
would always fall back to explicit writings of zeroes.
Signed-off-by: Christoph Hellwig
---
drivers/block/rbd.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/block/rbd.c b/drivers/block/rbd.c
index 517838b65964..0
mmc only supports discarding on large alignments, so the zeroing code
would always fall back to explicit writings of zeroes.
Signed-off-by: Christoph Hellwig
---
drivers/mmc/core/queue.c | 2 --
1 file changed, 2 deletions(-)
diff --git a/drivers/mmc/core/queue.c b/drivers/mmc/core/queue.c
inde
drbd always wants its discard wire operations to zero the blocks, so
use blkdev_issue_zeroout with the BLKDEV_ZERO_UNMAP flag instead of
reinventing it poorly.
Signed-off-by: Christoph Hellwig
---
drivers/block/drbd/drbd_debugfs.c | 3 --
drivers/block/drbd/drbd_int.h | 6 ---
drivers/bl
Now that we use the proper REQ_OP_WRITE_ZEROES operation everywhere we can
kill this hack.
Signed-off-by: Christoph Hellwig
---
Documentation/ABI/testing/sysfs-block | 10 ++
Documentation/block/queue-sysfs.txt | 5 -
block/blk-lib.c | 7 +--
block/blk-s
Now that we have REQ_OP_WRITE_ZEROES implemented for all devices that
support efficient zeroing of devices we can remove the call to
blkdev_issue_discard. This means we only have two ways of zeroing left
and can simply the code.
Signed-off-by: Christoph Hellwig
---
block/blk-lib.c | 11 +---
Just the same as discard if the block size equals the system page size.
Signed-off-by: Christoph Hellwig
---
drivers/block/zram/zram_drv.c | 13 -
1 file changed, 8 insertions(+), 5 deletions(-)
diff --git a/drivers/block/zram/zram_drv.c b/drivers/block/zram/zram_drv.c
index dceb5ed
rsxx only supports discarding on large alignments, so the zeroing code
would always fall back to explicit writings of zeroes.
Signed-off-by: Christoph Hellwig
---
drivers/block/rsxx/dev.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/block/rsxx/dev.c b/drivers/block/rsxx/dev.c
index
If this flag is set logical provisioning capable device should
release space for the zeroed blocks if possible, if it is not set
devices should keep the blocks anchored.
Also remove an out of sync kerneldoc comment for a static function
that would have become even more out of data with this change
Turn the existin discard flag into a new BLKDEV_ZERO_UNMAP flag with
similar semantics, but without referring to diѕcard.
Signed-off-by: Christoph Hellwig
---
block/blk-lib.c | 31 ++-
block/ioctl.c| 3 +--
drivers/nvme/target/io-cmd.c |
But now for the real NVMe Write Zeroes yet, just to get rid of the
discard abuse for zeroing. Also rename the quirk flag to be a bit
more self-explanatory.
Signed-off-by: Christoph Hellwig
---
drivers/nvme/host/core.c | 10 +-
drivers/nvme/host/nvme.h | 6 +++---
drivers/nvme/host/pci.
Signed-off-by: Christoph Hellwig
---
drivers/scsi/sd.c | 45 -
drivers/scsi/sd_zbc.c | 1 +
2 files changed, 41 insertions(+), 5 deletions(-)
diff --git a/drivers/scsi/sd.c b/drivers/scsi/sd.c
index af632e350ab4..b6f70a09a301 100644
--- a/drivers/
This gets us support for non-discard efficient write of zeroes (e.g. NVMe)
and preparse for removing the discard_zeroes_data flag.
Also remove a pointless discard support check, which is done in
blkdev_issue_discard already.
Signed-off-by: Christoph Hellwig
---
fs/block_dev.c | 16 +
Try to use a write same with unmap bit variant if the device supports it
and the caller asks for it.
Signed-off-by: Christoph Hellwig
---
drivers/scsi/sd.c | 10 ++
1 file changed, 10 insertions(+)
diff --git a/drivers/scsi/sd.c b/drivers/scsi/sd.c
index b6f70a09a301..ca96bb33471b 10064
Copy & paste from the REQ_OP_WRITE_SAME code.
Signed-off-by: Christoph Hellwig
---
drivers/md/dm-core.h | 1 +
drivers/md/dm-io.c| 10 +++---
drivers/md/dm-linear.c| 1 +
drivers/md/dm-mpath.c | 1 +
drivers/md/dm-rq.c| 11 ---
driv
Copy & paste from the REQ_OP_WRITE_SAME code.
Signed-off-by: Christoph Hellwig
---
drivers/md/linear.c| 1 +
drivers/md/md.h| 7 +++
drivers/md/multipath.c | 1 +
drivers/md/raid0.c | 2 ++
drivers/md/raid1.c | 4 +++-
drivers/md/raid10.c| 1 +
drivers/md/raid5.c
It's identical to discard as hole punches will always leave us with
zeroes on reads.
Signed-off-by: Christoph Hellwig
---
drivers/block/loop.c | 4
1 file changed, 4 insertions(+)
diff --git a/drivers/block/loop.c b/drivers/block/loop.c
index 0ecb6461ed81..265cd2e33ff0 100644
--- a/drivers
This avoids fallbacks to explicit zeroing in (__)blkdev_issue_zeroout if
the caller doesn't want them.
Also clean up the convoluted check for the return condition that this
new flag is added to.
Signed-off-by: Christoph Hellwig
---
block/blk-lib.c| 5 -
include/linux/blkdev.h | 1 +
We'll always use the WRITE ZEROES code for zeroing now.
Signed-off-by: Christoph Hellwig
---
block/blk-lib.c | 4
1 file changed, 4 deletions(-)
diff --git a/block/blk-lib.c b/block/blk-lib.c
index ed1e78e24db0..a93115ccf461 100644
--- a/block/blk-lib.c
+++ b/block/blk-lib.c
@@ -364,10 +36
On Thu, Mar 23, 2017 at 10:35:06AM -0400, James Bottomley wrote:
> I'm certainly not saying we blindly follow t10, but I believe their
> intent is to issue the next command from the completion of the first
> (we can do this using qc->complete_fn, like atapi_request_sense). That
> way we don't get
It's just a in-driver reimplementation of writing zeroes to the pages,
which fails if the discards aren't page aligned.
Signed-off-by: Christoph Hellwig
---
drivers/block/brd.c | 56 -
1 file changed, 56 deletions(-)
diff --git a/drivers/block
On Thu, Mar 23 2017 at 10:33am -0400,
Christoph Hellwig wrote:
> It seems like the code currently passes whatever it was using for writes
> to WRITE SAME. Just switch it to WRITE ZEROES, although that doesn't
> need any payload.
>
> Untested, and confused by the code, maybe someone who understa
On a randconfig build without CONFIG_SCSI_LPFC_DEBUG_FS, I ran into
multiple compile failures:
drivers/scsi/lpfc/lpfc_debugfs.h: In function 'lpfc_debug_dump_wq':
drivers/scsi/lpfc/lpfc_debugfs.h:405:15: error: 'DUMP_FCP' undeclared (first
use in this function); did you mean 'DUMP_VAR'?
drivers/s
On Thu, Mar 23, 2017 at 10:55:22AM -0400, Mike Snitzer wrote:
> See commit 70d6c400a ("dm kcopyd: add WRITE SAME support to dm_kcopyd_zero")
> drivers/md/dm-io.c:do_region() adjusts the WRITE SAME payload to be a
> single page.
>
> So you'd want to tweak dm-io.c accordingly for WRITE ZEROES (presu
gcc-7.0.1 now warns about a previously unnoticed access of
uninitialized struct members:
drivers/scsi/advansys.c: In function 'AscMsgOutSDTR':
drivers/scsi/advansys.c:3860:26: error: '*((void *)&sdtr_buf+5)' may be used
uninitialized in this function [-Werror=maybe-uninitialized]
((ushor
Hello, Christoph.
On Thu, Mar 23, 2017 at 03:43:30PM +0100, Christoph Hellwig wrote:
> > That's up to you ... from the point of view of code documenting itself,
> > forming the ATA_16 TRIM in sd and not doing any satl transformation is
> > easier for others to follow, but if it's going to cause mo
On Thu, Mar 23 2017 at 10:56am -0400,
Christoph Hellwig wrote:
> On Thu, Mar 23, 2017 at 10:55:22AM -0400, Mike Snitzer wrote:
> > See commit 70d6c400a ("dm kcopyd: add WRITE SAME support to dm_kcopyd_zero")
> > drivers/md/dm-io.c:do_region() adjusts the WRITE SAME payload to be a
> > single page
John Garry writes:
John,
> This patchset introduces a range of error handling
> and other misc improvements for the HiSilicon SAS
> controller, including:
> - controller reset function
> - softreset for SATA error handling
> - fixes for slot free'ing
> - v2 hw error handling improvements
> - and
Dick Kennedy writes:
Dick,
> lpfc cannot establish connection with targets that send PRLI in P2P
> configurations.
>
> If lpfc rejects a PRLI that is sent from a target the target will not
> resend and will reject the PRLI send from the initiator.
Applied to 4.11/scsi-fixes (by hand, due to bei
On Thu, Mar 23, 2017 at 11:04:58AM -0400, Tejun Heo wrote:
> I kinda like the idea of sticking with satl as that's how libata has
> been doing most things even if the implementation is uglier. It'd be
> great to find out whether the ugliness would be acceptable or too
> much.
The SATL way is simp
On Thu, Mar 23, 2017 at 03:43:30PM +0100, Christoph Hellwig wrote:
> I tried this earlier before giving up on it because it looked to ugly.
> But I can complete that version of it and post it for people to compare.
Meh, I remember why I gave up on it - to support queued trim passthrough
we'd need
Christoph Hellwig writes:
> Meh, I remember why I gave up on it - to support queued trim passthrough
> we'd need to implement ATA 32 for the auxiliary fields and thus support
> 32-bit CDBs. I don't really want to go there..
I wish we could stick with SATL. However, I have attempted this a few
t
On 2017-03-15 16:58, Brian King wrote:
I have reviewed this serial of patches and tested them on IBM systems
successfully
Thanks for your help!
Wendy
Following a command abort or device reset, ipr's EH handlers wait
for the commands getting aborted to get sent back from the adapter
prior to r
Hello,
The following program causes random assorted memory corruptions:
https://gist.githubusercontent.com/dvyukov/da3463af2d1ff8c7d3624891b5d7427f/raw/09cf0f4af529f4506f9e0a9fa6bdb066a8777b9d/gistfile1.txt
It does some ioctl's on /dev/sg0.
general protection fault: [#1] SMP KASAN
Modules
On Thu, Mar 23, 2017 at 10:33:18AM -0400, Christoph Hellwig wrote:
> This series makes REQ_OP_WRITE_ZEROES the only zeroing offload
> supported by the block layer, and switches existing implementations
> of REQ_OP_DISCARD that correctly set discard_zeroes_data to it,
> removes incorrect discard_zer
Hi Xiubo,
On Tue, Mar 21, 2017 at 04:36PM, lixi...@cmss.chinamobile.com wrote:
> [...]
> tcmu: Fix possible overwrite of t_data_sg's last iov[]
> tcmu: Fix wrongly calculating of the base_command_size
I tested these two patches, which try to fix the broken support for
BIDI commands in target/
Brian King writes:
> Following a command abort or device reset, ipr's EH handlers wait
> for the commands getting aborted to get sent back from the adapter
> prior to returning from the EH handler. This fixes up some cases
> where the completion handler was not getting called, which would
> have
On 16.3.2017 04:24, Jitendra Bhivare wrote:
> CID needs to be freed even when invalidate or upload connection fails.
> Attempt to close connection 3 times before freeing CID.
>
> Set cleanup_type to INVALIDATE instead of force TCP_RST.
> This unnecessarily is terminating connection with reset inste
On 16.3.2017 04:24, Jitendra Bhivare wrote:
> scsi host12: BS_1377 : mgmt_invalidate_connection Failed for cid=256
> BUG: unable to handle kernel NULL pointer dereference at 0008
> IP: [] __list_add+0xf/0xc0
> PGD 0
> Oops: [#1] SMP
> Modules linked in:
> ...
> CPU: 9 PID: 1542 Com
On Thu, Mar 23 2017 at 11:54am -0400,
Lars Ellenberg wrote:
> On Thu, Mar 23, 2017 at 10:33:18AM -0400, Christoph Hellwig wrote:
> > This series makes REQ_OP_WRITE_ZEROES the only zeroing offload
> > supported by the block layer, and switches existing implementations
> > of REQ_OP_DISCARD that co
On 16.3.2017 04:24, Jitendra Bhivare wrote:
> spin_unlock_bh back_lock is used in beiscsi_eh_device_reset instead of
> spin_lock.
>
> Signed-off-by: Jitendra Bhivare
Reviewed-by: Tomas Henzl
tomash
From: "Martin K. Petersen"
Date: Thu, 23 Mar 2017 10:19:03 -0400
> Arnd Bergmann writes:
>
>> gcc points out that we are converting a 16-bit integer into a 32-bit
>> little-endian type and assigning that to 16-bit little-endian
>> will end up with a zero:
>>
>> drivers/scsi/qedf/drv_fcoe_fw_fun
Hi folks,
I am trying to use LIO on amd64 to provide block devices to some
AIX 6.1 and 7.1 hosts. It works pretty well, except that I cannot
create rootvg wpars on AIX 7.1. (rootvg wpars are containers
running on their own volume group.)
The error message on AIX is
bash-4.3# mkwpar -O -D rootvg=
On 03/23/2017 12:41 PM, Dan Carpenter wrote:
> We don't call the remove() function unless probe() succeeds so "oud"
> can't be NULL here. Plus, if it were NULL, we dereference it on the
> next line so it would crash anyway.
>
> Signed-off-by: Dan Carpenter
>
Thanks sure!
ACK-by Boaz Harrosh
Harald Dunkel writes:
> Mar 23 19:06:30 nasl003b kernel: [38396.624678] Unknown VPD Code: 0xc7
>
> What is it trying to tell me?
That is an IBM-specific VPD page containing device-unique configuration
data. I guess it is a prerequisite for installing AIX.
--
Martin K. Petersen Oracle Linu
David Miller writes:
>> Dave: Since you queued the firmware patch, mind taking this fix through
>> your tree?
>
> Ok, applied to net-next, thanks.
Great, thanks!
--
Martin K. Petersen Oracle Linux Engineering
On Thu, Mar 23, 2017 at 01:02:22PM -0400, Mike Snitzer wrote:
> On Thu, Mar 23 2017 at 11:54am -0400,
> Lars Ellenberg wrote:
>
> > On Thu, Mar 23, 2017 at 10:33:18AM -0400, Christoph Hellwig wrote:
> > > This series makes REQ_OP_WRITE_ZEROES the only zeroing offload
> > > supported by the block
Hi Gris,
Thanks for reviewing the patch. I have posted a v2 patch addressing your
review comments. Can you please take a look.
Patch-Link:
https://www.mail-archive.com/linux-scsi@vger.kernel.org/msg59720.html
Gris Ge writes:
> On Fri, Mar 17, 2017 at 10:08:40AM +0530, Vaibhav Jain wrote:
>> --
70 matches
Mail list logo