This patch is generated against for-next branch.
Jitendra Bhivare (11):
be2iscsi: Fix use of invalidate command table req
be2iscsi: Fix for crash in beiscsi_eh_device_reset
be2iscsi: Take iscsi_task ref in abort handler
be2iscsi: Set WRB invalid bit for SkyHawk
be2iscsi: Add checks to va
Hold the reference of iscsi_task till invalidation completes.
This prevents use of ICD when invalidation of that ICD is being processed.
Signed-off-by: Jitendra Bhivare
---
drivers/scsi/be2iscsi/be_main.c | 45 +
1 file changed, 19 insertions(+), 26 deleti
Prepare the IOCTL with appropriate sizes of buffers of V0 and V1.
Set missing chute number in V1 IOCTL.
Signed-off-by: Jitendra Bhivare
---
drivers/scsi/be2iscsi/be_cmds.c | 33 ++---
drivers/scsi/be2iscsi/be_main.c | 3 +--
2 files changed, 19 insertions(+), 17 dele
invalid bit in WRB indicates to FW that IO was invalidated before WRB
was fetched from host memory.
For SkyHawk, this invalid bit in WRB is at a different offset.
Use amap_iscsi_wrb_v2 to mark invalid bit for SkyHawk.
Signed-off-by: Jitendra Bhivare
---
drivers/scsi/be2iscsi/be_main.c | 19
Remove shared structure inv_tbl in phba for all sessions to post
invalidation IOCTL.
Always allocate and then free the table after use in reset handler.
Abort handler needs just one instance so define it on stack.
Add checks for BE_INVLDT_CMD_TBL_SZ to not exceed invalidation
command table size in
Added check in beiscsi_process_cq for pio_handle.
pio_handle is cleared in beiscsi_put_wrb_handle.
This catches any case where task gets cleaned up just before completion.
Use back_lock before accessing pio_handle.
Signed-off-by: Jitendra Bhivare
---
drivers/scsi/be2iscsi/be_main.c | 28 +++
This duplicate code got added during manual merging.
Signed-off-by: Jitendra Bhivare
---
drivers/scsi/be2iscsi/be_main.c | 8
1 file changed, 8 deletions(-)
diff --git a/drivers/scsi/be2iscsi/be_main.c b/drivers/scsi/be2iscsi/be_main.c
index 0fa24a3..9b8b79f 100644
--- a/drivers/scsi/b
System crashes when sg_reset is executed in a loop.
CPU: 13 PID: 7073 Comm: sg_reset Tainted: GE 4.8.0-rc1+ #4
RIP: 0010:[] []
beiscsi_eh_device_reset+0x160/0x520 [be2iscsi]
Call Trace:
[] ? scsi_host_alloc_command+0x47/0xc0
[] scsi_try_bus_device_reset+0x2a/0x50
[] scsi_ioctl_reset+
From: Ketan Mukadam
Add a warning message to indicate obsolete/unsupported
BE2 Adapter Family devices
Signed-off-by: Ketan Mukadam
Signed-off-by: Jitendra Bhivare
---
drivers/scsi/be2iscsi/be_main.c | 2 ++
drivers/scsi/be2iscsi/be_mgmt.c | 3 ++-
2 files changed, 4 insertions(+), 1 deletion(
Version 11.2.1.0
Signed-off-by: Jitendra Bhivare
---
drivers/scsi/be2iscsi/be_main.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/scsi/be2iscsi/be_main.h b/drivers/scsi/be2iscsi/be_main.h
index 02a9b2d..2188579 100644
--- a/drivers/scsi/be2iscsi/be_main.h
+++ b/dri
Fix errors reported in static analysis.
Signed-off-by: Jitendra Bhivare
---
drivers/scsi/be2iscsi/be.h | 3 --
drivers/scsi/be2iscsi/be_cmds.c | 8 +++---
drivers/scsi/be2iscsi/be_cmds.h | 17 ++--
drivers/scsi/be2iscsi/be_iscsi.c | 2 +-
drivers/scsi/be2iscsi/be_main.c | 24
Set CID slot to 0x to indicate empty.
Check if connection already exists in conn_table before binding.
Check if endpoint already NULL before putting back CID.
Break ep->conn link in free_ep to ignore completions after freeing.
Signed-off-by: Jitendra Bhivare
---
drivers/scsi/be2iscsi/be_iscs
wq_name is used only to set WQ name when its being allocated.
Remove it from beiscsi_hba structure and define locally.
Signed-off-by: Jitendra Bhivare
---
drivers/scsi/be2iscsi/be_main.c | 9 +
drivers/scsi/be2iscsi/be_main.h | 1 -
2 files changed, 5 insertions(+), 5 deletions(-)
diff
> > + if (ha->flags.msix_enabled) {
> > + for (i = 0; i < ha->msix_count; i++) {
> > + qentry = &ha->msix_entries[i];
> > + if (qentry->have_irq) {
> > + irq_set_affinity_notifier(qentry->vector, NULL);
> Not sure if that's s
On Fri, Dec 02, 2016 at 01:44:54PM -0800, Himanshu Madhani wrote:
> From: Michael Hernandez
>
> Replaces the old pci_enable_msi[x]* and pci_disable_msi[x] calls.
>
> Signed-off-by: Michael Hernandez
> Signed-off-by: Himanshu Madhani
> ---
> drivers/scsi/qla2xxx/qla_def.h | 1 +
> drivers/scs
[Hannes, can you please stop the damn full quotes? reading your answers
is a major pain]
> Have you modified the irq affinity for this?
> Typically the irq-affinity changes will treat all vectors identically,
> and spread them out across the available CPUS.
> But with this layout vector '0' appar
On Sat, Dec 3, 2016 at 7:19 PM, Johannes Thumshirn wrote:
> On Sat, Dec 03, 2016 at 04:22:39PM +0100, Dmitry Vyukov wrote:
>> On Sat, Dec 3, 2016 at 11:38 AM, Johannes Thumshirn
>> wrote:
>> > On Fri, Dec 02, 2016 at 05:50:39PM +0100, Dmitry Vyukov wrote:
>> >> On Fri, Nov 25, 2016 at 8:08 PM, D
On Mon, Dec 05, 2016 at 03:31:43PM +0100, Dmitry Vyukov wrote:
> On Sat, Dec 3, 2016 at 7:19 PM, Johannes Thumshirn wrote:
> > On Sat, Dec 03, 2016 at 04:22:39PM +0100, Dmitry Vyukov wrote:
> >> On Sat, Dec 3, 2016 at 11:38 AM, Johannes Thumshirn
> >> wrote:
> >> > On Fri, Dec 02, 2016 at 05:50:
On 12/02/2016 01:15 AM, Juergen Gross wrote:
>
> -static struct vscsiif_request *scsifront_pre_req(struct vscsifrnt_info *info)
> +static int scsifront_do_request(struct vscsifrnt_info *info,
> + struct vscsifrnt_shadow *shadow)
> {
> struct vscsiif_front_ring *
On 05/12/16 16:32, Boris Ostrovsky wrote:
> On 12/02/2016 01:15 AM, Juergen Gross wrote:
>>
>> -static struct vscsiif_request *scsifront_pre_req(struct vscsifrnt_info
>> *info)
>> +static int scsifront_do_request(struct vscsifrnt_info *info,
>> +struct vscsifrnt_shado
Can you describe the changes in the body a bit more? Why do you
only want these commands to be sent? Why is the warning added
when it takes longer than nessecary? Otherwise this patch
looks fine to me.
--
To unsubscribe from this list: send the line "unsubscribe linux-scsi" in
the body of a mess
On Fri, Dec 02, 2016 at 01:44:53PM -0800, Himanshu Madhani wrote:
> From: Samy
>
> This patch helps resolve some of the mailbox timeout issue discovered
> during large SAN emulation testing where 1000+ initiators are trying
> to log into target mode personality. Since current mailbox interface
>
On Mon, Dec 05, 2016 at 04:54:30AM -0800, Christoph Hellwig wrote:
> It shouldn't be required in the end, but keeping the switch to the
s/shouldn't/should/
> new IRQ helpers from the change to the affinity assignment separate
> makes sense.
But I can't see the switch anywhere else in the series,
> create mode 100644 drivers/scsi/qla2xxx/qla_bottom.c
> create mode 100644 drivers/scsi/qla2xxx/qla_mq.c
> create mode 100644 drivers/scsi/qla2xxx/qla_top.c
What's the point of three new fairly small files, two of them very
oddly named? Can't we keep the code together by logical groups?
> +
Sasikumar Chandrasekaran (11):
megaraid_sas: Add new pci device Ids for SAS3.5 Generic Megaraid
Controllers
megaraid_sas: 128 MSIX Support
megaraid_sas: EEDP Escape Mode Support for SAS3.5 Generic Megaraid
Controllers
megaraid_sas: SAS3.5 Generic Megaraid Controllers Stream Detecti
The Megaraid driver has to support the SAS3.5 Generic Megaraid Controllers
Firmware functionality.
This patch is depending on patch 6
Signed-off-by: Sasikumar Chandrasekaran
---
drivers/scsi/megaraid/megaraid_sas_base.c | 53 ++---
drivers/scsi/megaraid/megaraid_sas_f
Large SEQ IO workload should sent as non fast path commands
This patch is depending on patch 7
Signed-off-by: Sasikumar Chandrasekaran
---
drivers/scsi/megaraid/megaraid_sas.h| 8 +
drivers/scsi/megaraid/megaraid_sas_base.c | 48 +
drivers/scsi/megarai
Upgrade driver version.
This patch is depending on patch 10
Signed-off-by: Sasikumar Chandrasekaran
---
drivers/scsi/megaraid/megaraid_sas.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/scsi/megaraid/megaraid_sas.h
b/drivers/scsi/megaraid/megaraid_sas.h
index
ldio outstanding variable needs to be decremented in io completion path for
iMR dual queue depth
This patch is depending on patch 8
Signed-off-by: Sasikumar Chandrasekaran
---
drivers/scsi/megaraid/megaraid_sas_fusion.c | 9 +++--
1 file changed, 7 insertions(+), 2 deletions(-)
diff --git
Update Linux driver to use new pdTargetId field for JBOD target ID
This patch is depending on patch 9
Signed-off-by: Sasikumar Chandrasekaran
---
drivers/scsi/megaraid/megaraid_sas.h| 105 +---
drivers/scsi/megaraid/megaraid_sas_base.c | 3 +
drivers/scsi/meg
SAS3.5 Generic Megaraid Controllers FW will support new dynamic RaidMap to have
different
sizes for different number of supported VDs.
This patch is depending on patch 5
Signed-off-by: Sasikumar Chandrasekaran
---
drivers/scsi/megaraid/megaraid_sas.h| 7 +
drivers/scsi/megaraid/megar
To improve RAID 1/10 Write performance, OS drivers need to issue the required
Write
IOs as Fast Path IOs (after the appropriate checks allowing Fast Path to be
used)
to the appropriate physical drives (translated from the OS logical IO) and wait
for
all Write IOs to complete. If any of the Writ
SAS3.5 Generic Megaraid based Controllers will have the support for 128 MSI-X
vectors,
resulting in the need to support 128 reply queues
This patch is depending on patch 1
Signed-off-by: Sasikumar Chandrasekaran
---
drivers/scsi/megaraid/megaraid_sas.h| 1 +
drivers/scsi/megaraid/mega
Detect sequential IO streams and pass those IOs directly to FW.
This patch is depending on patch 3
Signed-off-by: Sasikumar Chandrasekaran
---
drivers/scsi/megaraid/megaraid_sas.h| 5 +-
drivers/scsi/megaraid/megaraid_sas_base.c | 43 +++-
drivers/scsi/megaraid/megaraid_sas_fp.
An UNMAP command on a PI formatted device will leave the Logical Block
Application
Tag and Logical Block Reference Tag as all F's (for those LBAs that are
unmapped).
To avoid IO errors if those LBAs are subsequently read before they are written
with
valid tag fields, the MPI SCSI IO requests nee
This patch contains new pci device ids for SAS3.5 Generic Megaraid Controllers
Signed-off-by: Sasikumar Chandrasekaran
---
drivers/scsi/megaraid/megaraid_sas.h| 11 ++-
drivers/scsi/megaraid/megaraid_sas_base.c | 20 ++-
drivers/scsi/megaraid/megaraid_sas_fusion
On 12/5/16, 8:01 AM, "Christoph Hellwig" wrote:
>Can you describe the changes in the body a bit more? Why do you
>only want these commands to be sent? Why is the warning added
>when it takes longer than nessecary? Otherwise this patch
>looks fine to me.
This patch is allowing only ROM mailbo
On 12/5/16, 8:03 AM, "Christoph Hellwig" wrote:
>On Fri, Dec 02, 2016 at 01:44:53PM -0800, Himanshu Madhani wrote:
>> From: Samy
>>
>> This patch helps resolve some of the mailbox timeout issue discovered
>> during large SAN emulation testing where 1000+ initiators are trying
>> to log into t
On Mon, Dec 05, 2016 at 04:17:53PM +0100, Johannes Thumshirn wrote:
> 633 hp = &srp->header;
> [...]
> 646 hp->dxferp = (char __user *)buf + cmd_size;
> So the memory for hp->dxferp comes from:
> 633 hp = &srp->header;
> >From my debug instrumentation I see t
On 12/4/16, 11:38 PM, "Hannes Reinecke" wrote:
>On 12/02/2016 10:44 PM, Himanshu Madhani wrote:
>> From: Michael Hernandez
>>
>> Replaced existing multiple queue functionality with framework
>> that allows for the creation of pairs of request and response queues,
>> either at start of day or d
On Mon, Nov 21, 2016 at 07:01:36AM +0100, Juergen Gross wrote:
> On 19/11/16 19:22, Quentin Lambert wrote:
> > Most error branches following the call to kmalloc contain
> > a call to kfree. This patch add these calls where they are
> > missing.
> >
> > This issue was found with Hector.
> >
> > Si
On 12/4/16, 11:42 PM, "Hannes Reinecke" wrote:
>On 12/02/2016 10:44 PM, Himanshu Madhani wrote:
>> From: Quinn Tran
>>
>> - Fix race condition between dpc_thread accessing Multiqueue resources
>> and qla2x00_remove_one thread trying to free resource.
>> - Fix out of order free for Multiqueue
On 12/5/16, 4:55 AM, "Christoph Hellwig" wrote:
>>+ void *handle;
>
>Just curious: why do you need this new handle field instead of just
>passing the rsp as the old code did?
We wanted to make it more generic pointer with new Q-pair frameworks.
So just renamed it. we’ll remove old rsp ref
> "John" == John Garry writes:
John> This patch addresses 4 problems in the module probe/remove:
John> - When hisi_sas_shost_alloc() fails after we alloc shost memory,
John> we should free shost memory before the function returns.
John> - When hisi_sas_probe() fails after we alloc the HBA mem
> "Souptick" == Souptick Joarder writes:
Souptick,
Souptick> Any comment on this patch?
The patch looked OK to me when you posted it. However, you need one
person in addition to me to review it. And you need convince us of the
merit of a presumably untested change to an unmaintained driver.
> "Rasmus" == Rasmus Villemoes writes:
Rasmus> Passing one instead of 8 or 16 arguments reduces the size of the
Rasmus> generated code somewhat:
Rasmus> add/remove: 2/3 grow/shrink: 1/4 up/down: 1772/-2137 (-365)
Rasmus> There's one more candidate, unique_id_show, but that uses %02X,
Rasmus
On 12/5/16, 12:43 PM, "linux-scsi-ow...@vger.kernel.org on behalf of Madhani,
Himanshu" wrote:
>
>We need to have the spinlock because currently our NPIV implementation does
>not utilizes
>Q-pair framework.
Looks like sent it prematurely. This comment should be read as following
We need to
> "Hannes" == Hannes Reinecke writes:
Hannes> Older SmartArray controllers (eg SmartArray 64xx) do not support
Hannes> the extended REPORT PHYS command, so fallback to use the legacy
Hannes> version here.
Applied to 4.10/scsi-queue.
--
Martin K. Petersen Oracle Linux Engineering
--
To
> "Pan" == Pan Bian writes:
Pan> Variable ret is reset in the loop, and its value will be 0 during
Pan> the second and after repeat of the loop. If pci_alloc_consistent()
Pan> returns a NULL pointer then, it will leaves with return value 0. 0
Pan> means no error, which is contrary to the fact
> "Pan" == Pan Bian writes:
Pan> Variable ret is reset in the loop, and its value will be 0 during
Pan> the after repeat of the loop. Then, if pci_alloc_consistent()
Pan> returns NULL, the return value is 0. 0 means no error, which may
Pan> make it impossible for the callers of beiscsi_create
On 12/5/16, 8:20 AM, "Christoph Hellwig" wrote:
>> create mode 100644 drivers/scsi/qla2xxx/qla_bottom.c
>> create mode 100644 drivers/scsi/qla2xxx/qla_mq.c
>> create mode 100644 drivers/scsi/qla2xxx/qla_top.c
>
>What's the point of three new fairly small files, two of them very
>oddly named?
Due to reported problems with Write Same on ATA devices,
commit 0ce1b18c42a5 ("libata: Some drives failing on SCT Write Same")
strived to report non-support for Write Same on non-zoned ATA devices.
However, due to the following control flow in sd_config_write_same() this
doesn't always take effect
This series has 2 bug fixes, 1 change related to device quirk and 1 change
to add UFS HCI 2.1 revision support.
Subhash Jadavani (2):
scsi: ufs: add quirk to increase host PA_SaveConfigTime
scsi: ufs-qcom: fix bug with read/modify write of UFS_CFG1
Yaniv Gardi (2):
scsi: ufs: add support fo
From: Yaniv Gardi
The UFS HCI v2.1 includes a few additional registers. This change
updates the HCI register, the UFS version register content and
the Interrupt Status register.
Signed-off-by: Yaniv Gardi
Signed-off-by: Subhash Jadavani
---
drivers/scsi/ufs/ufshcd.c | 29 +
From: Yaniv Gardi
In case UFS driver is probed before the phy driver does, the
UFS driver should return a PROBE_DEFER code.
Signed-off-by: Yaniv Gardi
Signed-off-by: Subhash Jadavani
---
drivers/scsi/ufs/ufs-qcom.c | 11 ++-
1 file changed, 10 insertions(+), 1 deletion(-)
diff --git
The maximum value PA_SaveConfigTime is 250 (10us) but this is not enough
for some vendors. Gear switch from PWM to HS may fail even with this max.
PA_SaveConfigTime. Gear switch can be issued by host controller as an
error recovery and any software delay will not help on this case so we
need to inc
ufs_qcom_print_hw_debug_reg_all() function is having a bug
where it might incorrectly modify undesired bits in UFS_CFG1 register,
this change fixes it.
Reviewed-by: Venkat Gopalakrishnan
Signed-off-by: Subhash Jadavani
---
drivers/scsi/ufs/ufs-qcom.c | 3 ++-
1 file changed, 2 insertions(+), 1
> "Nicolai" == Nicolai Stange writes:
Nicolai,
Nicolai> Due to reported problems with Write Same on ATA devices, commit
Nicolai> 0ce1b18c42a5 ("libata: Some drives failing on SCT Write Same")
Nicolai> strived to report non-support for Write Same on non-zoned ATA
Nicolai> devices.
Nicolai> H
On 05/12/16 21:53, Dan Carpenter wrote:
> On Mon, Nov 21, 2016 at 07:01:36AM +0100, Juergen Gross wrote:
>> On 19/11/16 19:22, Quentin Lambert wrote:
>>> Most error branches following the call to kmalloc contain
>>> a call to kfree. This patch add these calls where they are
>>> missing.
>>>
>>> Thi
kmalloc_reserve may fail to allocate memory inside skb_linearize,
which means skb_linearize's return value should not be ignored.
Following patch correct the uses of skb_linearize.
Compiled in x86_64
Signed-off-by: Zhouyi Zhou
---
drivers/infiniband/hw/nes/nes_nic.c | 5 +++--
drive
60 matches
Mail list logo