Re: [Lsf-pc] [LSF/MM ATTEND] Online Logical Head Depop and SMR disks chunked writepages

2016-02-24 Thread Jan Kara
On Wed 24-02-16 01:53:24, Damien Le Moal wrote: > > >On Tue 23-02-16 05:31:13, Damien Le Moal wrote: > >> > >> >On 02/22/16 18:56, Damien Le Moal wrote: > >> >> 2) Write back of dirty pages to SMR block devices: > >> >> > >> >> Dirty pages of a block device inode are currently processed using the

[PATCH] osd: remove deadcode

2016-02-24 Thread Sudip Mukherjee
The variable is_ver1 is always true and so OSD_CAP_LEN can never be used. Signed-off-by: Sudip Mukherjee --- drivers/scsi/osd/osd_initiator.c | 3 +-- 1 file changed, 1 insertion(+), 2 deletions(-) diff --git a/drivers/scsi/osd/osd_initiator.c b/drivers/scsi/osd/osd_initiator.c index d8a2b51..3

[PATCH] imm: check parport_claim

2016-02-24 Thread Sudip Mukherjee
parport_claim() can fail and we should be checking if we were able to claim the port. Signed-off-by: Sudip Mukherjee --- drivers/scsi/imm.c | 7 --- 1 file changed, 4 insertions(+), 3 deletions(-) diff --git a/drivers/scsi/imm.c b/drivers/scsi/imm.c index f8b88fa..9164ce12 100644 --- a/driv

[PATCH v2] osd: remove deadcode

2016-02-24 Thread Sudip Mukherjee
The variable is_ver1 is always true and so OSD_CAP_LEN can never be used. Reported by Coverity. Signed-off-by: Sudip Mukherjee --- v2: Joe Perches asked to mention the tool used in the commit log. drivers/scsi/osd/osd_initiator.c | 3 +-- 1 file changed, 1 insertion(+), 2 deletions(-) diff --

Re: [PATCH] imm: check parport_claim

2016-02-24 Thread Matthew R. Ochs
Reviewed-by: Matthew R. Ochs -- To unsubscribe from this list: send the line "unsubscribe linux-scsi" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html

Re: [PATCH v2] osd: remove deadcode

2016-02-24 Thread Matthew R. Ochs
Reviewed-by: Matthew R. Ochs -- To unsubscribe from this list: send the line "unsubscribe linux-scsi" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html

Re: [PATCH v2] osd: remove deadcode

2016-02-24 Thread Boaz Harrosh
On 02/24/2016 01:21 PM, Sudip Mukherjee wrote: > The variable is_ver1 is always true and so OSD_CAP_LEN can never be > used. > Reported by Coverity. > > Signed-off-by: Sudip Mukherjee ACK-by: Boaz harrosh Thanks > --- > > v2: Joe Perches asked to mention the tool used in the commit log. > >

Re: dm-multipath test scripts

2016-02-24 Thread Mike Snitzer
On Thu, Feb 18 2016 at 7:33pm -0500, Junichi Nomura wrote: > Hi Mike, > > On 02/19/16 02:17, Mike Snitzer wrote: > > > Taking a step back: > > These scripts don't belong in Documentation/device-mapper/mptest/ (or > > anywhere in the kernel tree for that matter). > > > > I'd really prefer it i

[PATCH 00/35 v4] separate operations from flags in the bio/request structs

2016-02-24 Thread mchristi
point, we abused them so much we just made cmd_flags 64 bits, so we could add more. The following patches seperate the operation (read, write discard, flush, etc) from cmd_flags/bi_rw. This patchset was made against linux-next from today Feb 24 2016 (git tag next-20160224). I put a git tre

[PATCH 05/35] fs: have ll_rw_block users pass in op and flags separately

2016-02-24 Thread mchristi
From: Mike Christie This has ll_rw_block users pass in the operation and flags separately, so we can setup the bio->bi_op and bio-bi_rw flags. v2: 1. Fix for kbuild error in ll_rw_block comments. Signed-off-by: Mike Christie --- fs/buffer.c | 19 ++- fs/ext4/i

[PATCH 32/35] block: shrink bi_rw and bi_op

2016-02-24 Thread mchristi
From: Mike Christie There is no need for bi_op/op and bi_rw to be so large now, so this patch shrinks them. Signed-off-by: Mike Christie --- block/blk-core.c | 2 +- drivers/md/dm-flakey.c | 2 +- drivers/md/raid5.c | 13 +++-- fs/btrfs/check-integrity.c | 4 ++

[PATCH 35/35] block, drivers, fs: rename REQ_FLUSH to REQ_PREFLUSH

2016-02-24 Thread mchristi
From: Mike Christie To avoid confusion between REQ_OP_FLUSH, which is handled by request_fn drivers, and upper layers requesting the block layer perform a flush sequence along with possibly a WRITE, this patch renames REQ_FLUSH to REQ_PREFLUSH. Signed-off-by: Mike Christie --- Documentation/bl

[PATCH 34/35] block: add QUEUE_FLAGs for flush and fua

2016-02-24 Thread mchristi
From: Mike Christie The last patch added a REQ_OP_FLUSH for request_fn drivers and the next patch renames REQ_FLUSH to REQ_PREFLUSH which will be used by file systems and make_request_fn drivers. This leaves REQ_FLUSH/REQ_FUA defined for drivers to tell the block layer if flush/fua is supported.

[PATCH 31/35] block, fs: remove old REQ definitions.

2016-02-24 Thread mchristi
From: Mike Christie We no longer use REQ_WRITE. REQ_WRITE_SAME and REQ_DISCARD, so this patch removes them. Signed-off-by: Mike Christie --- include/linux/blk_types.h | 21 ++--- include/linux/fs.h | 21 +++-- include/trace/events/f2fs.h | 1 - 3 fil

[PATCH 30/35] block, fs, drivers: do not test bi_rw for REQ_OPs

2016-02-24 Thread mchristi
From: Mike Christie We no longer use the bio->bi_rw field for REQ_OPs: REQ_WRITE, REQ_DISCARD, REQ_WRITE_SAME, so this patch stops checking for them in bi_rw and also removes the related compat code. v2: 1. Remove compat code in __get_request. Signed-off-by: Mike Christie --- block/bio.c

[PATCH 25/35] target: set bi_op to REQ_OP

2016-02-24 Thread mchristi
From: Mike Christie This patch has the target modules set the bio bi_op to a REQ_OP, and rq_flag_bits to bi_rw. This patch is compile tested only. Signed-off-by: Mike Christie Acked-by: Nicholas Bellinger --- drivers/target/target_core_iblock.c | 38 ++--- dri

[PATCH 33/35] block, drivers: add REQ_OP_FLUSH operation

2016-02-24 Thread mchristi
From: Mike Christie This adds a REQ_OP_FLUSH operation that is sent to request_fn based drivers by the block layer's flush code, instead of sending requests with the request->cmd_flags REQ_FLUSH bit set. For the following 3 flush related patches, I have not tested every driver. I have only teste

[PATCH 27/35] drivers: set request op to REQ_OP

2016-02-24 Thread mchristi
From: Mike Christie This patch has the block drivers use the request->op for REQ_OP operations and cmd_flags for rq_flag_bits. I have only tested scsi and rbd. Signed-off-by: Mike Christie --- drivers/block/loop.c | 6 +++--- drivers/block/mtip32xx/mtip32xx.c | 2 +- drivers/bl

[PATCH 11/35] f2fs: set bi_op to REQ_OP

2016-02-24 Thread mchristi
From: Mike Christie This patch has f2fs set the bio bi_op to a REQ_OP, and rq_flag_bits to bi_rw. This patch is compile tested only. Signed-off-by: Mike Christie --- fs/f2fs/checkpoint.c| 10 ++ fs/f2fs/data.c | 33 - fs/f2fs/f2fs.h

[PATCH 26/35] block: set op to REQ_OP

2016-02-24 Thread mchristi
From: Mike Christie This patch converts the request related block layer code to set request->op to a REQ_OP and cmd_flags to rq_flag_bits. There is some tmp compat code when setting up cmd_flags so it still carries both the op and flags. It will be removed in in later patches in this set when I

[PATCH 28/35] blktrace: get op from req->op/bio->bi_op

2016-02-24 Thread mchristi
From: Mike Christie The bio and request struct now store the operation in bio->bi_op/request->op. This patch has blktrace not check bi_rw/cmd_flags. This patch is only compile tested. Signed-off-by: Mike Christie --- include/linux/blktrace_api.h | 2 +- include/trace/events/bcache.h | 12 ++

[PATCH 20/35] dm: pass dm stats data dir instead of bi_rw

2016-02-24 Thread mchristi
From: Mike Christie It looks like dm stats cares about the data direction (READ vs WRITE) and does not need the bio/request flags. Commands like REQ_FLUSH, REQ_DISCARD and REQ_WRITE_SAME are currently always set with REQ_WRITE, so the extra check for REQ_DISCARD in dm_stats_account_io is not need

[PATCH 24/35] xen: set bi_op to REQ_OP

2016-02-24 Thread mchristi
From: Mike Christie This patch has xen set the bio bi_op to a REQ_OP, and rq_flag_bits to bi_rw. This patch is compile tested only. Signed-off-by: Mike Christie --- drivers/block/xen-blkback/blkback.c | 29 + 1 file changed, 17 insertions(+), 12 deletions(-) diff

[PATCH 09/35] btrfs: update __btrfs_map_block for bi_op transition

2016-02-24 Thread mchristi
From: Mike Christie We no longer pass in a bitmap of rq_flag_bits bits to __btrfs_map_block. It will always be a REQ_OP, or the btrfs specific REQ_GET_READ_MIRRORS, so this drops the bit tests. Signed-off-by: Mike Christie --- fs/btrfs/extent-tree.c | 2 +- fs/btrfs/inode.c | 2 +- fs/

[PATCH 07/35] btrfs: have submit_one_bio users setup bio bi_op

2016-02-24 Thread mchristi
From: Mike Christie This patch has btrfs's submit_one_bio callers set the bio->bi_op to a REQ_OP and the bi_rw to rq_flag_bits. The next patches will continue to convert btrfs, so submit_bio_hook and merge_bio_hook related code will be modified to take only the bio. I did not do it in this patch

[PATCH 06/35] direct-io: set bi_op to REQ_OP

2016-02-24 Thread mchristi
From: Mike Christie This patch has the dio code set the bio bi_op to a REQ_OP. It also begins to convert btrfs's dio_submit_t related code, because of the submit_io callout use. In the btrfs_submit_direct change, I OR'd the op and flag back together. It is only temporary. The next patch will com

[PATCH 23/35] md/raid: set bi_op to REQ_OP

2016-02-24 Thread mchristi
From: Mike Christie This patch has md/raid set the bio bi_op to a REQ_OP, and rq_flag_bits to bi_rw. This patch is compile tested only. Signed-off-by: Mike Christie --- drivers/md/bitmap.c | 2 +- drivers/md/dm-raid.c | 5 +++-- drivers/md/md.c | 11 +++ drivers/md

[PATCH 29/35] ide cd: do not set REQ_WRITE on requests.

2016-02-24 Thread mchristi
From: Mike Christie The block layer will set the correct READ/WRITE operation flags/fields when creating a request, so there is not need for drivers to set the REQ_WRITE flag. This patch is compile tested only. Signed-off-by: Mike Christie --- drivers/ide/ide-cd_ioctl.c | 3 --- 1 file change

[PATCH 17/35] ocfs2: set bi_op to REQ_OP

2016-02-24 Thread mchristi
From: Mike Christie This patch has ocfs2 set the bio bi_op to a REQ_OP, and rq_flag_bits to bi_rw. This patch is compile tested only. Signed-off-by: Mike Christie --- fs/ocfs2/cluster/heartbeat.c | 11 +++ 1 file changed, 7 insertions(+), 4 deletions(-) diff --git a/fs/ocfs2/cluster/

[PATCH 13/35] xfs: set bi_op to REQ_OP

2016-02-24 Thread mchristi
From: Mike Christie This patch has xfs set the bio bi_op to a REQ_OP, and rq_flag_bits to bi_rw. Signed-off-by: Mike Christie Acked-by: Dave Chinner --- fs/xfs/xfs_aops.c | 3 ++- fs/xfs/xfs_buf.c | 27 +++ 2 files changed, 17 insertions(+), 13 deletions(-) diff --

[PATCH 15/35] mpage: set bi_op to REQ_OP

2016-02-24 Thread mchristi
From: Mike Christie This patch has the mpage.c code set the bio bi_op to a REQ_OP, and rq_flag_bits to bi_rw. I have run xfstest with xfs, but I am not sure if I have stressed these code paths well. Signed-off-by: Mike Christie --- fs/mpage.c | 41 + 1

[PATCH 19/35] dm: set bi_op to REQ_OP

2016-02-24 Thread mchristi
From: Mike Christie This patch has dm set the bio bi_op to a REQ_OP, and rq_flag_bits to bi_rw. I did some basic dm tests, but I think this patch should be considered compile tested only. I have not tested all the dm targets and I did not stress every code path I have touched. Signed-off-by: Mi

[PATCH 22/35] drbd: set bi_op to REQ_OP

2016-02-24 Thread mchristi
From: Mike Christie This patch has drbd set the bio bi_op to a REQ_OP, and rq_flag_bits to bi_rw. Lars and Philip, I might have split this patch up a little weird. Thisi patch handles setting up the bio, and then patch 30 (0030-block-fs-drivers-do-not-test-bi_rw-for-REQ_OPs.patch) handles where

[PATCH 21/35] bcache: set bi_op to REQ_OP

2016-02-24 Thread mchristi
From: Mike Christie This patch has bcache set the bio bi_op to a REQ_OP, and rq_flag_bits to bi_rw. This patch is compile tested only Signed-off-by: Mike Christie --- drivers/md/bcache/btree.c | 2 ++ drivers/md/bcache/debug.c | 2 ++ drivers/md/bcache/io.c| 2 +- drivers/m

[PATCH 14/35] hfsplus: set bi_op to REQ_OP

2016-02-24 Thread mchristi
From: Mike Christie This patch has hfsplus set the bio bi_op to a REQ_OP, and rq_flag_bits to bi_rw. This patch is compile tested only. Signed-off-by: Mike Christie --- fs/hfsplus/hfsplus_fs.h | 2 +- fs/hfsplus/part_tbl.c | 5 +++-- fs/hfsplus/super.c | 6 -- fs/hfsplus/wrapper

[PATCH 10/35] btrfs: don't pass rq_flag_bits if there is a bio

2016-02-24 Thread mchristi
From: Mike Christie The bio bi_op and bi_rw is now setup, so there is no need to pass around the rq_flag_bits bits too. v2: 1. Fix merge_bio issue where instead of removing rw/op argument I passed it in again to the merge_bio related functions. Signed-off-by: Mike Christie --- fs/btrfs/compr

[PATCH 02/35] block: add REQ_OP definitions and bi_op/op fields

2016-02-24 Thread mchristi
From: Mike Christie The following patches separate the operation (write, read, discard, etc) from the flags in bi_rw/cmd_flags. This patch adds definitions for request/bio operations, adds fields to the request/bio to set them, and some temporary compat code so the kernel/modules can use either o

[PATCH 04/35] fs: have submit_bh users pass in op and flags separately

2016-02-24 Thread mchristi
From: Mike Christie This has submit_bh users pass in the operation and flags separately, so we can setup the bio->bi_op and bio-bi_rw flags. Signed-off-by: Mike Christie --- drivers/md/bitmap.c | 4 ++-- fs/btrfs/check-integrity.c | 24 ++-- fs/btrfs/check-integrity.h

[PATCH 03/35] block, fs, mm, drivers: set bi_op to REQ_OP

2016-02-24 Thread mchristi
From: Mike Christie This patch converts the simple bi_rw use cases in the block, drivers, mm and fs code to use bi_op for a REQ_OP and bi_rw for rq_flag_bits. These should be simple one liner cases, so I just did them in one patch. The next patches handle the more complicated cases in a module p

[PATCH 01/35] block/fs/drivers: remove rw argument from submit_bio

2016-02-24 Thread mchristi
From: Mike Christie This has callers of submit_bio/submit_bio_wait set the bio->bi_rw instead of passing it in. This makes that use the same as generic_make_request and how we set the other bio fields. v2. 1. Set bi_rw instead of ORing it. For cloned bios, I still OR it to keep the old behavior

[PATCH 12/35] gfs2: set bi_op to REQ_OP

2016-02-24 Thread mchristi
From: Mike Christie This patch has gfs2 set the bio bi_op to a REQ_OP, and rq_flag_bits to bi_rw. This patch is compile tested only. v2: Bob, I did not add your signed off, because there was the gfs2_submit_bhs changes since last time you reviewed it. Signed-off-by: Mike Christie --- fs/gfs

[PATCH 08/35] btrfs: set bi_op tp REQ_OP

2016-02-24 Thread mchristi
From: Mike Christie This patch has btrfs set the bio bi_op to a REQ_OP, and rq_flag_bits to bi_rw. Signed-off-by: Mike Christie --- fs/btrfs/check-integrity.c | 19 +-- fs/btrfs/compression.c | 4 fs/btrfs/disk-io.c | 7 --- fs/btrfs/inode.c | 2

[PATCH 18/35] pm: set bi_op to REQ_OP

2016-02-24 Thread mchristi
From: Mike Christie This patch has the pm swap code set the bio bi_op to a REQ_OP, and rq_flag_bits to bi_rw. This patch is compile tested only. Signed-off-by: Mike Christie --- kernel/power/swap.c | 31 +++ 1 file changed, 19 insertions(+), 12 deletions(-) diff -

[PATCH 16/35] nilfs: set bi_op to REQ_OP

2016-02-24 Thread mchristi
From: Mike Christie This patch has nilfs set the bio bi_op to a REQ_OP, and rq_flag_bits to bi_rw. This patch is compile tested only. Signed-off-by: Mike Christie --- fs/nilfs2/segbuf.c | 18 ++ 1 file changed, 10 insertions(+), 8 deletions(-) diff --git a/fs/nilfs2/segbuf.c

Re: [BUG] "block: make generic_make_request handle arbitrarily sized bios" breaks boot on parisc-linux

2016-02-24 Thread Helge Deller
Hi Ming Lei, On 24.02.2016 08:59, Ming Lei wrote: > On Wed, Feb 24, 2016 at 10:28 AM, John David Anglin > wrote: >> The following block change breaks boot on parisc-linux: >> >> commit 54efd50bfd873e2dbf784e0b21a8027ba4299a3e >> Author: Kent Overstreet >> Date: Thu Apr 23 22:37:18 2015 -0700 >

Re: [PATCH 26/35] block: set op to REQ_OP

2016-02-24 Thread kbuild test robot
Hi Mike, [auto build test WARNING on next-20160224] [cannot apply to dm/for-next v4.5-rc5 v4.5-rc4 v4.5-rc3 v4.5-rc5] [if your patch is applied to the wrong git tree, please drop us a note to help improving the system] url: https://github.com/0day-ci/linux/commits/mchristi-redhat-com

[PATCH v1 3/3] scsi: allow scsi devices to use direct complete

2016-02-24 Thread Derek Basehore
This allows scsi devices to remain runtime suspended for system suspend. Since runtime suspend is stricter than system suspend callbacks, this is just returning a positive number for the prepare callback. Signed-off-by: Derek Basehore Reviewed-by: Eric Caruso --- drivers/scsi/scsi_pm.c | 2 +-

[PATCH v1 1/3] PM / sleep: Check legacy pm callbacks for direct complete

2016-02-24 Thread Derek Basehore
This adds checks for legacy pm callbacks when setting no_pm_callbacks. This fixes an issue where these suspend/resume callbacks were incorrectly ignored during suspend/resume with direct complete. Fixes: 4534d9d881f9 "PM / sleep: Go direct_complete if driver has..." Signed-off-by: Derek Basehore

[PATCH v1 2/3] PM / sleep: try to runtime suspend for direct complete

2016-02-24 Thread Derek Basehore
This tries to runtime suspend devices that are still active for direct complete. This is for cases such as autosuspend delays which leaves devices able to runtime suspend but still active. It's beneficial in this case to runtime suspend the device to take advantage of direct complete when possible.

[PATCH v2 1/3] PM / sleep: Check legacy pm callbacks for direct complete

2016-02-24 Thread Derek Basehore
This adds checks for legacy pm callbacks when setting no_pm_callbacks. This fixes an issue where these suspend/resume callbacks were incorrectly ignored during suspend/resume with direct complete. Fixes: aa8e54b55947 "PM / sleep: Go direct_complete if driver has..." Signed-off-by: Derek Basehore

[PATCH v2 3/3] scsi: allow scsi devices to use direct complete

2016-02-24 Thread Derek Basehore
This allows scsi devices to remain runtime suspended for system suspend. Since runtime suspend is stricter than system suspend callbacks, this is just returning a positive number for the prepare callback. Signed-off-by: Derek Basehore Reviewed-by: Eric Caruso --- drivers/scsi/scsi_pm.c | 2 +-

[PATCH v2 2/3] PM / sleep: try to runtime suspend for direct complete

2016-02-24 Thread Derek Basehore
This tries to runtime suspend devices that are still active for direct complete. This is for cases such as autosuspend delays which leaves devices able to runtime suspend but still active. It's beneficial in this case to runtime suspend the device to take advantage of direct complete when possible.

Re: [PATCH 31/35] block, fs: remove old REQ definitions.

2016-02-24 Thread kbuild test robot
Hi Mike, [auto build test WARNING on next-20160224] [cannot apply to dm/for-next v4.5-rc5 v4.5-rc4 v4.5-rc3 v4.5-rc5] [if your patch is applied to the wrong git tree, please drop us a note to help improving the system] url: https://github.com/0day-ci/linux/commits/mchristi-redhat-com

Re: [BUG] "block: make generic_make_request handle arbitrarily sized bios" breaks boot on parisc-linux

2016-02-24 Thread Ming Lei
On Thu, Feb 25, 2016 at 7:28 AM, John David Anglin wrote: > On 2016-02-24, at 4:36 PM, Helge Deller wrote: > >> Maybe Dave has more luck, otherwise I'll continue to try to get some info. > > I tried your patch on the commit in linux-block which first failed to boot. > As with Helge, the > system