From: Nicholas Bellinger
Hi all,
Here is -v4 series for converting LIO target se_node_acl + se_lun
mapping tables from fixed size arrays to dynamic RCU (read-copy-update)
hlist_heads.
This turns fast-path I/O into a lock-less RCU reader using existing
percpu based se_lun->lun_ref logic, and con
From: Nicholas Bellinger
This patch changes __core_scsi3_do_alloc_registration() code to
drop pr_reg->pr_reg_tg_pt_lun pointer usage in favor of a new
pr_reg RPTI + existing pr_reg->pr_aptpl_target_lun used by
APTPL metadata logic.
It also includes changes to REGISTER, REGISTER_AND_MOVE and APTP
From: Nicholas Bellinger
Reviewed-by: Hannes Reinecke
Cc: Christoph Hellwig
Cc: Sagi Grimberg
Signed-off-by: Nicholas Bellinger
---
drivers/target/target_core_device.c | 15 ---
drivers/target/target_core_tpg.c| 4
include/target/target_core_base.h | 3 ---
3 files c
From: Nicholas Bellinger
This patch converts the core_scsi3_pr_seq_non_holder() check for non
reservation holding registrations to use an atomic bitop in ->deve_flags
to determine if a registration is currently active.
It also includes associated a set_bit() in __core_scsi3_add_registration()
an
From: Nicholas Bellinger
This patch converts the fixed size se_portal_group->tpg_lun_list[]
to use modern RCU with hlist_head in order to support an arbitary
number of se_lun ports per target endpoint.
It includes dropping core_tpg_alloc_lun() from core_dev_add_lun(),
and calling it directly fro
From: Nicholas Bellinger
This patch changes core_tpg_add_node_to_devs() to avoid unnecessarly
resetting every se_dev_entry in se_node_acl->tpg_lun_hlist when the
operation is driven by an explicit configfs se_lun->lun_group creation
via core_dev_add_lun() to only update a single se_lun.
Otherwis
From: Nicholas Bellinger
This patch converts se_node_acl->device_list[] table for mappedluns
to modern RCU hlist_head usage in order to support an arbitrary number
of node_acl lun mappings.
It converts transport_lookup_*_lun() fast-path code to use RCU read path
primitives when looking up se_dev
From: Christoph Hellwig
Clean up the mess of registered variables, and pass the isid mismatch
flag explicitly instead of overloading the registration type.
Signed-off-by: Christoph Hellwig
Reviewed-by: Hannes Reinecke
Signed-off-by: Nicholas Bellinger
---
drivers/target/target_core_pr.c | 44
From: Nicholas Bellinger
Now that se_portal_group->tpg_lun_hlist is a RCU protected hlist,
go ahead and drop the left-over lun->lun_status usage.
Reported-by: Christoph Hellwig
Reviewed-by: Hannes Reinecke
Signed-off-by: Nicholas Bellinger
---
drivers/target/target_core_tpg.c | 6 --
in
From: Nicholas Bellinger
This patch converts se_tpg->acl_node_lock to struct mutex, so that
->acl_node_acl walkers in core_clear_lun_from_tpg() can block when
calling core_disable_device_list_for_node().
It also updates core_dev_add_lun() to hold ->acl_node_mutex when
calling core_tpg_add_node_t
From: Nicholas Bellinger
This patch converts core_tpg_deregister() to perform a list splice
for any remaining dynamically generated se_node_acls attached to
se_tpg, before calling kfree(nacl) to free memory.
Reviewed-by: Hannes Reinecke
Cc: Christoph Hellwig
Cc: Sagi Grimberg
Signed-off-by: N
From: Nicholas Bellinger
Hi all,
Here is v3 series with HCH's recent changes to go ahead and drop
all se_port + t10_alua_tg_pt_gp_member usage within target-core in
favor of direct se_lun pointer dereference.
This includes the original patch + minor fixes, along with two other
improvements for
From: Nicholas Bellinger
This patch drops unnecessary target_core_fabric_ops parameter usage
for core_tpg_register() during fabric driver TFO->fabric_make_tpg()
se_portal_group creation callback execution.
Instead, use the existing se_wwn->wwn_tf->tf_ops pointer to ensure
fabric driver is really
From: Nicholas Bellinger
With se_port and t10_alua_tg_pt_gp_member being absored into se_lun,
there is no need for an extra lock to protect se_lun->lun_se_dev
assignment.
This patch also converts backend drivers to use call_rcu() release
to allow any se_device readers to complete. The call_rcu(
From: Nicholas Bellinger
With se_port_t and t10_alua_tg_pt_gp_member being absored into se_lun,
there is no need for an extra atomic_t based reference count for PR
ALL_TG_PT=1 and ALUA access state transition.
Go ahead and use the existing percpu se_lun->lun_ref instead, and
convert the two spec
From: Christoph Hellwig
This patch eliminates all se_port + t10_alua_tg_pt_gp_member usage,
and converts current users to direct se_lun pointer dereference.
This includes the removal of core_export_port(), core_release_port()
core_dev_export() and core_dev_unexport(). Along with conversion
of s
On Tue, 2015-05-26 at 11:41 +0200, Hannes Reinecke wrote:
> On 05/26/2015 08:25 AM, Nicholas A. Bellinger wrote:
> > From: Nicholas Bellinger
> >
> > Hi all,
> >
> > Here is -v3 series for converting LIO target se_node_acl + se_lun
> > mapping tables from fixed size arrays to dynamic RCU hlist_h
On Fri, May 29, 2015 at 01:29:16PM -0700, K. Y. Srinivasan wrote:
> - if (vstor_packet->operation != VSTOR_OPERATION_COMPLETE_IO ||
> - vstor_packet->status != 0)
> + if (vstor_packet->status != 0) {
> + ret = -EINVAL;
> goto cleanup;
> + }
There is no
On Fri, May 29, 2015 at 01:29:14PM -0700, K. Y. Srinivasan wrote:
> From: keith.ma...@microsoft.com
Keith's name is wrong.
regards,
dan carpenter
--
To unsubscribe from this list: send the line "unsubscribe linux-scsi" in
the body of a message to majord...@vger.kernel.org
More majordomo info at
On Wed, 2015-05-13 at 17:12 -0700, rajinikanth.panduran...@pmcs.com
wrote:
> diff --git a/drivers/scsi/aacraid/linit.c b/drivers/scsi/aacraid/linit.c
> index 9eec027..be30e43 100644
> --- a/drivers/scsi/aacraid/linit.c
> +++ b/drivers/scsi/aacraid/linit.c
> @@ -1317,6 +1317,149 @@ static int aac_pr
Use dev_printk() when possible to make messages more useful.
Signed-off-by: Bjorn Helgaas
---
drivers/scsi/megaraid.c | 92 ++-
1 file changed, 43 insertions(+), 49 deletions(-)
diff --git a/drivers/scsi/megaraid.c b/drivers/scsi/megaraid.c
index bc
FW to come to ready state
These patches use dev_printk() to include the driver name and device
address in the conventional format.
Changes between v1 and v2:
- Rebase to next-20150601
- Squash megaraid_sas_base.c and megaraid_sas_fusion.c changes into one patch
- Split
Fix whitespace and indentation errors. No code change.
Signed-off-by: Bjorn Helgaas
---
drivers/scsi/megaraid/megaraid_sas_base.c | 28 +---
1 file changed, 13 insertions(+), 15 deletions(-)
diff --git a/drivers/scsi/megaraid/megaraid_sas_base.c
b/drivers/scsi/megara
Use dev_printk() when possible to make messages more useful.
Signed-off-by: Bjorn Helgaas
---
drivers/scsi/megaraid/megaraid_sas_base.c | 263 +--
drivers/scsi/megaraid/megaraid_sas_fusion.c | 92 +
2 files changed, 177 insertions(+), 178 deletions(-)
diff -
On Mon, 2015-06-01 at 10:40 -0500, Bjorn Helgaas wrote:
> Use dev_printk() when possible to make messages more useful.
[]
> diff --git a/drivers/scsi/megaraid.c b/drivers/scsi/megaraid.c
[]
> @@ -268,7 +268,7 @@ mega_query_adapter(adapter_t *adapter)
> raw_mbox[2] = NC_SUBOP_PRODUCT_I
On Mon, Jun 1, 2015 at 11:10 AM, Joe Perches wrote:
> On Mon, 2015-06-01 at 10:40 -0500, Bjorn Helgaas wrote:
>> Use dev_printk() when possible to make messages more useful.
> []
>> diff --git a/drivers/scsi/megaraid.c b/drivers/scsi/megaraid.c
> []
>> @@ -268,7 +268,7 @@ mega_query_adapter(adapte
On Mon, 2015-06-01 at 11:40 -0500, Bjorn Helgaas wrote:
> On Mon, Jun 1, 2015 at 11:10 AM, Joe Perches wrote:
> > On Mon, 2015-06-01 at 10:40 -0500, Bjorn Helgaas wrote:
> >> Use dev_printk() when possible to make messages more useful.
> > []
> >> diff --git a/drivers/scsi/megaraid.c b/drivers/scs
On Mon, Jun 1, 2015 at 11:44 AM, Joe Perches wrote:
> On Mon, 2015-06-01 at 11:40 -0500, Bjorn Helgaas wrote:
>> On Mon, Jun 1, 2015 at 11:10 AM, Joe Perches wrote:
>> > On Mon, 2015-06-01 at 10:40 -0500, Bjorn Helgaas wrote:
>> >> Use dev_printk() when possible to make messages more useful.
>> >
On Mon, 2015-06-01 at 06:43 +, Seymour, Shane M wrote:
> +#if (BITS_PER_LONG == 64)
> +#define PRId64 "ld"
> +#else
> +#define PRId64 "lld"
> +#endif
I know this is the windows recommended way to do this, but lets not
pollute the kernel with it because the kernel accepts %lld everywhere
for 64
This fixes a regression caused by commit
d3557fc8be11d25f316884581f487684f8e7dad3
megaraid_sas : Add separate function for setting up IRQs
This makes boot end with 'root does not exist' message on certain adapters.
The bug is that the driver does not setup ints for cards
without msi-x support.
Thi
On Sat, May 30, 2015 at 10:24:41PM -0700, Nicholas A. Bellinger wrote:
> On Thu, 2015-05-28 at 08:57 -0700, Paul E. McKenney wrote:
> > On Wed, May 27, 2015 at 11:02:10PM -0700, Nicholas A. Bellinger wrote:
> > > On Wed, 2015-05-27 at 14:04 -0700, Paul E. McKenney wrote:
> > > > On Tue, May 26, 201
> -Original Message-
> From: Dan Carpenter [mailto:dan.carpen...@oracle.com]
> Sent: Monday, June 1, 2015 3:57 AM
> To: KY Srinivasan
> Cc: gre...@linuxfoundation.org; linux-ker...@vger.kernel.org;
> de...@linuxdriverproject.org; oher...@suse.com;
> jbottom...@parallels.com; h...@infradea
> -Original Message-
> From: Dan Carpenter [mailto:dan.carpen...@oracle.com]
> Sent: Monday, June 1, 2015 3:43 AM
> To: KY Srinivasan
> Cc: gre...@linuxfoundation.org; linux-ker...@vger.kernel.org;
> de...@linuxdriverproject.org; oher...@suse.com;
> jbottom...@parallels.com; h...@infradea
-Original Message-
From: James Bottomley [mailto:james.bottom...@hansenpartnership.com]
Sent: Monday, June 01, 2015 8:15 AM
To: Rajinikanth Pandurangan
Cc: linux-scsi@vger.kernel.org; aacr...@pmc-sierra.com; Harry Yang; Rich Bono;
Achim Leubner; Murthy Bhat
Subject: Re: [PATCH 2/9] [SCSI]
On Mon, 2015-06-01 at 21:16 +, Rajinikanth Pandurangan wrote:
> -Original Message-
> From: James Bottomley [mailto:james.bottom...@hansenpartnership.com]
> Sent: Monday, June 01, 2015 8:15 AM
> To: Rajinikanth Pandurangan
> Cc: linux-scsi@vger.kernel.org; aacr...@pmc-sierra.com; Harry
From: Stephen Rothwell
Date: Fri, 29 May 2015 19:18:47 +1000
> Nothing in asm/io.h uses anything from vmalloc.h, so remove the include
> and fix up the build problems in an allmodconfig (64 bit and 32 bit)
> build.
>
> This may be the place where x86 builds get vmalloc.h implicitly included
> an
Hi Dave,
On Mon, 01 Jun 2015 15:59:31 -0700 (PDT) David Miller
wrote:
>
> From: Stephen Rothwell
> Date: Fri, 29 May 2015 19:18:47 +1000
>
> > Nothing in asm/io.h uses anything from vmalloc.h, so remove the include
> > and fix up the build problems in an allmodconfig (64 bit and 32 bit)
> > bu
37 matches
Mail list logo