This reverts 4fbdf9cb is breaks LPFC on POWER7 machine, big endian kernel.
This is the hardware used for verification:
0005:01:00.0 Fibre Channel [0c04]: Emulex Corporation Saturn-X: LightPulse
Fibre Channel Host Adapter [10df:f100] (rev 03)
0005:01:00.1 Fibre Channel [0c04]: Emulex Corporation S
Alexey Kardashevskiy wrote:
> This reverts 4fbdf9cb is breaks LPFC on POWER7 machine, big endian kernel.
>
> This is the hardware used for verification:
> 0005:01:00.0 Fibre Channel [0c04]: Emulex Corporation Saturn-X: LightPulse
> Fibre Channel Host Adapter [10df:f100] (rev 03)
> 0005:01:00.1 Fi
On 04/28/2015 07:18 PM, Sebastian Herbszt wrote:
Alexey Kardashevskiy wrote:
This reverts 4fbdf9cb is breaks LPFC on POWER7 machine, big endian kernel.
This is the hardware used for verification:
0005:01:00.0 Fibre Channel [0c04]: Emulex Corporation Saturn-X: LightPulse
Fibre Channel Host Adap
Reviewed-by: Dov Levenglick
> From: Dolev Raviv
>
> This patch exposes the ioctl interface for UFS driver via SCSI device
> ioctl interface. As of now UFS driver would provide the ioctl for query
> interface to connected UFS device.
>
> Signed-off-by: Dolev Raviv
> Signed-off-by: Noa Rubens
>
Reviewed-by: Dov Levenglick
> From: Lee Susman
>
> Adding debugfs capability for ufshcd.
>
> debugfs attributes introduced in this patch:
> - View driver/controller runtime data
> - Command tag statistics for performance analisis
> - Dump device descriptor info
> - Track recoverable errors s
CONFIG_ACORNSCSI_CONSTANTS is a file local CPP identifier and thereby
violates the naming convention of Kconfig options in Make and CPP
syntax; only Kconfig options should carry the 'CONFIG_' prefix.
This patch removes the 'CONFIG_' prefix to apply to this convention and
to make static analysis to
Anil,
the issue you are fixing here is described in comments, but adding
the description to the body of your mail might make it more attractive
for reviewers.
Please add a proper description to your patches in the future.
> From: Anil Gurumurthy
>
> Signed-off-by: Sudarsana Kalluru
> Si
On 02/03/2015 09:45 AM, anil.gurumur...@qlogic.com wrote:
> From: Anil Gurumurthy
>
> Signed-off-by: Sudarsana Kalluru
> Signed-off-by: Anil Gurumurthy
Reviewed-by: Tomas Henzl
Tomas
--
To unsubscribe from this list: send the line "unsubscribe linux-scsi" in
the body of a message to majord..
On 02/03/2015 09:45 AM, anil.gurumur...@qlogic.com wrote:
> From: Anil Gurumurthy
>
> Signed-off-by: Sudarsana Kalluru
> Signed-off-by: Anil Gurumurthy
Reviewed-by: Tomas Henzl
Tomas
--
To unsubscribe from this list: send the line "unsubscribe linux-scsi" in
the body of a message to
On Tue, 2015-04-28 at 16:15 +0200, Valentin Rothberg wrote:
> CONFIG_ACORNSCSI_CONSTANTS is a file local CPP identifier and thereby
> violates the naming convention of Kconfig options in Make and CPP
> syntax; only Kconfig options should carry the 'CONFIG_' prefix.
>
> This patch removes the 'CONF
Hi Paul,
On Tue, Apr 28, 2015 at 9:10 PM, Paul Bolle wrote:
> On Tue, 2015-04-28 at 16:15 +0200, Valentin Rothberg wrote:
>> CONFIG_ACORNSCSI_CONSTANTS is a file local CPP identifier and thereby
>> violates the naming convention of Kconfig options in Make and CPP
>> syntax; only Kconfig options s
Hi Valentin,
On Tue, 2015-04-28 at 21:26 +0200, Valentin Rothberg wrote:
> On Tue, Apr 28, 2015 at 9:10 PM, Paul Bolle wrote:
> > Will the Erlangen bot still spot ACORNSCSI_CONSTANTS as a potential
> > issue?
>
> No, undertaker-checkpatch won't complain about this. There are
> thousands of such
From: "Ewan D. Milne"
Commit f75ae8ed.. ("aha152x: debug output update and whitespace cleanup")
removed all AHA152X_DEBUG code from aha152x.c, so the build option no longer
does anything useful.
Signed-off-by: Ewan D. Milne
---
Documentation/scsi/aha152x.txt | 3 ---
drivers/scsi/aha152x.h
On Tue, Apr 28, 2015 at 9:34 PM, Paul Bolle wrote:
> Hi Valentin,
>
> On Tue, 2015-04-28 at 21:26 +0200, Valentin Rothberg wrote:
>> On Tue, Apr 28, 2015 at 9:10 PM, Paul Bolle wrote:
>> > Will the Erlangen bot still spot ACORNSCSI_CONSTANTS as a potential
>> > issue?
>>
>> No, undertaker-checkpa
On Mon, 2015-04-27 at 09:02 +0200, Hannes Reinecke wrote:
> On 04/26/2015 08:52 PM, James Bottomley wrote:
> > On Sun, 2015-04-26 at 16:57 +0200, Ondrej Zary wrote:
> >> On Friday 24 April 2015 13:18:38 Hannes Reinecke wrote:
> >>> Ancient, and pretty much obsolete by now.
> >>>
> >>> Signed-off-by
On Mon, 2015-04-27 at 11:35 +0200, Hannes Reinecke wrote:
> During ALUA state transitions the device might return
> a sense code 02/04/0a (Logical unit not accessible, asymmetric
> access state transition). As this is a transient error
> we should just retry the READ CAPACITY call until
> the state
From: James Bottomley
Date: Sun, 26 Apr 2015 11:52:46 -0700
Subject: [PATCH] scsi_scan: fix queue depth initialisation problem
Currently we blindly use the value of cmd_per_lun as the initial setting for
queue_depth. This fails miserably (hangs the system) if it is zero, which is
the default val
On Sat, 25 Apr 2015 23:56:16 +0900 Akinobu Mita wrote:
> Some architectures enable sg chaining option while others do not.
>
> The requirement to enable sg chaining is that pages must be aligned
> at a 32-bit boundary in order to overload the LSB of the pointer.
> Regardless of whether ARCH_HAS_
On Tue, 2015-04-28 at 14:27 -0700, Andrew Morton wrote:
> On Sat, 25 Apr 2015 23:56:16 +0900 Akinobu Mita
> wrote:
>
> > Some architectures enable sg chaining option while others do not.
> >
> > The requirement to enable sg chaining is that pages must be aligned
> > at a 32-bit boundary in orde
The current megaraid driver messages are somewhat inconsistent, e.g.,
megasas: 06.803.01.00-rc1 Mon. Mar. 10 17:00:00 PDT 2014
megasas: 0x1000:0x005b:0x15d9:0x0690: bus 1:slot 0:func 0
megasas: FW now in Ready state
megaraid_sas :01:00.0: enabling device ( -> 0002)
megasas: Waiti
Use dev_printk() when possible to make messages more useful.
Signed-off-by: Bjorn Helgaas
---
drivers/scsi/megaraid/megaraid_sas_base.c | 281 ++---
1 file changed, 139 insertions(+), 142 deletions(-)
diff --git a/drivers/scsi/megaraid/megaraid_sas_base.c
b/drivers/scs
Use dev_printk() when possible to make messages more useful.
Signed-off-by: Bjorn Helgaas
---
drivers/scsi/megaraid/megaraid_sas_fusion.c | 96 ++-
1 file changed, 48 insertions(+), 48 deletions(-)
diff --git a/drivers/scsi/megaraid/megaraid_sas_fusion.c
b/drivers/scs
Use dev_printk() when possible to make messages more useful.
Signed-off-by: Bjorn Helgaas
---
drivers/scsi/megaraid.c | 92 ++-
1 file changed, 43 insertions(+), 49 deletions(-)
diff --git a/drivers/scsi/megaraid.c b/drivers/scsi/megaraid.c
index bc
2015-04-29 7:16 GMT+09:00 James Bottomley
:
> On Tue, 2015-04-28 at 14:27 -0700, Andrew Morton wrote:
>> On Sat, 25 Apr 2015 23:56:16 +0900 Akinobu Mita
>> wrote:
>>
>> > Some architectures enable sg chaining option while others do not.
>> >
>> > The requirement to enable sg chaining is that page
2015-04-16 4:10 GMT+09:00 Bjorn Andersson :
> The cleanup during the introduction of regulator_set_load() was a too
> optimistic and re-opened an issue with vreg being dereferenced while
> being NULL.
>
> So reinstate the NULL checks and add back the BUG_ON() to follow the
> general coding conventi
2015-02-02 22:01 GMT+09:00 Christoph Hellwig :
> This effectively reverts commits 85b6c7 ("[SCSI] sd: fix cache flushing on
> module removal (and individual device removal)" and dc4515ea ("scsi: always
> increment reference count").
>
> We now never call scsi_device_get from the shutdown path, and
On Wed, 2015-04-29 at 09:34 +0900, Akinobu Mita wrote:
> 2015-04-29 7:16 GMT+09:00 James Bottomley
> :
> > On Tue, 2015-04-28 at 14:27 -0700, Andrew Morton wrote:
> >> On Sat, 25 Apr 2015 23:56:16 +0900 Akinobu Mita
> >> wrote:
> >>
> >> > Some architectures enable sg chaining option while others
>-Original Message-
>From: Bjorn Helgaas [mailto:bhelg...@google.com]
>Sent: Wednesday, April 29, 2015 4:44 AM
>To: Kashyap Desai; Uday Lingala; Sumit Saxena
>Cc: megaraidlinux@avagotech.com; James E.J. Bottomley; linux-
>ker...@vger.kernel.org; linux-scsi@vger.kernel.org
>Subject: [PAT
>-Original Message-
>From: Bjorn Helgaas [mailto:bhelg...@google.com]
>Sent: Wednesday, April 29, 2015 4:44 AM
>To: Kashyap Desai; Uday Lingala; Sumit Saxena
>Cc: megaraidlinux@avagotech.com; James E.J. Bottomley; linux-
>ker...@vger.kernel.org; linux-scsi@vger.kernel.org
>Subject: [PAT
>-Original Message-
>From: Bjorn Helgaas [mailto:bhelg...@google.com]
>Sent: Wednesday, April 29, 2015 4:44 AM
>To: Kashyap Desai; Uday Lingala; Sumit Saxena
>Cc: megaraidlinux@avagotech.com; James E.J. Bottomley; linux-
>ker...@vger.kernel.org; linux-scsi@vger.kernel.org
>Subject: [PAT
On 04/28/2015 11:24 PM, James Bottomley wrote:
> From: James Bottomley
> Date: Sun, 26 Apr 2015 11:52:46 -0700
> Subject: [PATCH] scsi_scan: fix queue depth initialisation problem
>
> Currently we blindly use the value of cmd_per_lun as the initial setting for
> queue_depth. This fails miserably
'0' is now used as the default cmd_per_lun value,
so there's no need to explicitly set it to '1' in the
host template.
Signed-off-by: Hannes Reinecke
---
drivers/block/cciss_scsi.c | 1 -
drivers/firewire/sbp2.c | 1 -
drivers/s390/scsi/zfcp_scsi.c | 1 -
drivers/scsi/
32 matches
Mail list logo