On 09/01/2014 12:29 AM, Christoph Hellwig wrote:
> On Thu, Aug 28, 2014 at 07:33:36PM +0200, Hannes Reinecke wrote:
>> There is no need to print out the command result verbatim;
>> that will be done by the scsi stack if required.
>> Here we just should log the result in short if requested.
>
> Is
If scsi_normalize_sense() fails we couldn't decode the sense
buffer, and the scsi_sense_hdr fields are invalid.
For those cases we should rather dump the sense buffer
and not try to decode invalid fields.
Signed-off-by: Hannes Reinecke
---
drivers/scsi/constants.c | 32 ++
Implement a lookup array for SERVICE ACTION commands instead
of hardcoding it in a large switch statement.
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/constants.c | 132 +++
1 file changed, 54 insertions(+), 78 delet
libata already uses an internal buffer, so we should be using
__scsi_print_command() here.
Signed-off-by: Hannes Reinecke
---
drivers/ata/libata-eh.c | 12
1 file changed, 4 insertions(+), 8 deletions(-)
diff --git a/drivers/ata/libata-eh.c b/drivers/ata/libata-eh.c
index dad83df..
Last caller is gone, so we can remove it.
Signed-off-by: Hannes Reinecke
---
drivers/scsi/constants.c | 35 ---
include/scsi/scsi_dbg.h | 1 -
2 files changed, 36 deletions(-)
diff --git a/drivers/scsi/constants.c b/drivers/scsi/constants.c
index 2850062e..d391
Implement scsi_retval_string() to simplify logging.
Signed-off-by: Hannes Reinecke
---
drivers/scsi/constants.c | 28
drivers/scsi/scsi.c | 34 ++
include/scsi/scsi_dbg.h | 1 +
3 files changed, 35 insertions(+), 28 deletions(-)
Instead of having two versions of print_opcode_name() we
should be consolidating them into one version.
Signed-off-by: Hannes Reinecke
---
drivers/scsi/constants.c | 90 +++-
1 file changed, 35 insertions(+), 55 deletions(-)
diff --git a/drivers/scsi/
Like scmd_printk(), but the device name is passed in as
a string. Can be used by eg ULDs which do not have access
to the scsi_cmnd structure.
Signed-off-by: Hannes Reinecke
---
include/scsi/scsi_device.h | 9 +
1 file changed, 9 insertions(+)
diff --git a/include/scsi/scsi_device.h b/in
sd_done() was calling scsi_print_sense() for a sense code
of 'NO_SENSE'.
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/sd.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/scsi/sd.c b/drivers/scsi/sd.c
index aa43496..f5ca203 100644
--- a/drivers/scsi/
scsi_show_result() was only ever used in one place in sd.c.
So open-code scsi_show_result() in sd.c and remove it from
constants.c.
Signed-off-by: Hannes Reinecke
---
drivers/scsi/constants.c | 16 -
drivers/scsi/sd.c| 62 +---
incl
Signed-off-by: Hannes Reinecke
---
drivers/scsi/constants.c | 56 +---
include/scsi/scsi_dbg.h | 2 ++
2 files changed, 46 insertions(+), 12 deletions(-)
diff --git a/drivers/scsi/constants.c b/drivers/scsi/constants.c
index 85d2da0..630e272 100644
-
Consolidate the CDB opcode lookup in scsi_opcode_sa_name(),
so that we don't have to call several functions to figure
out the CDB opcode string.
Signed-off-by: Hannes Reinecke
---
drivers/scsi/constants.c | 36 +---
1 file changed, 21 insertions(+), 15 deletions(-
Unused.
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/constants.c | 14 --
include/scsi/scsi_dbg.h | 2 --
2 files changed, 16 deletions(-)
diff --git a/drivers/scsi/constants.c b/drivers/scsi/constants.c
index d35a5d6..2f44707 100644
--- a/driver
There is no need to print out the command result verbatim;
that will be done by the scsi stack if required.
Here we just should log the result in short if requested.
Signed-off-by: Hannes Reinecke
---
drivers/scsi/sd.c | 13 +++--
1 file changed, 7 insertions(+), 6 deletions(-)
diff --g
Remove all uncommented debugging code and move all
printk() statements over to dev_printk().
And while we're at it we should be doing a whitespace
cleanup, too.
Signed-off-by: Hannes Reinecke
---
drivers/scsi/aha152x.c | 944 +++--
1 file changed, 205
Convert scsi_normalize_sense() and frieds to return 'bool'
instead of an integer.
Signed-off-by: Hannes Reinecke
---
drivers/scsi/scsi_error.c | 14 +++---
drivers/scsi/scsi_lib.c | 2 +-
include/scsi/scsi_eh.h| 12 ++--
3 files changed, 14 insertions(+), 14 deletions(-)
We should be using the standard dev_printk() variants for
sense code printing.
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/53c700.c | 2 +-
drivers/scsi/ch.c | 2 +-
drivers/scsi/constants.c | 113 +--
Currently we're only decoding sense extras for tape devices.
And even there only for fixed format sense formats.
As this is of rather limited use in the general case we should
be stop trying to decode sense extras; the tape driver does
its own decoding anyway.
Signed-off-by: Hannes Reinecke
---
The CDB needs to be printed in one line (ie with one printk
statement) to avoid the individual bytes to be broken up
under high load.
As using individual printk() statements here would lead to
unnecessary complicated code and needs the stack space to
hold the format string we should be using a loca
Hi all,
here's the second version of my scsi logging updates.
Main feature is the update to have all logging
statements in one line so that they won't be broken
up even under high load.
This will dramatically improve debugging.
Additionally all printk() statements are moved
to dev_printk() varian
Decode the return value if the command abort failed.
Suggested-by: Robert Elliot
Signed-off-by: Hannes Reinecke
---
drivers/scsi/scsi_error.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/scsi/scsi_error.c b/drivers/scsi/scsi_error.c
index 8a6d382..eca63b2 1006
Some drivers use __scsi_print_command() although in fact
they refer to the scsi command. So move them over to use
scsi_print_command() instead.
Signed-off-by: Hannes Reinecke
---
drivers/scsi/aha152x.c | 6 ++
drivers/scsi/arm/acornscsi.c | 9 +
drivers/scsi/arm/fas216.c|
Hi all,
Thanks for reviewing the patches, I'm sorry for the late replay. I was
waiting for some comments before I address all at once and re-send the
series.
>>
>> +static int ufshcd_config_vreg_load(struct device *dev, struct ufs_vreg
>> *vreg,
>> + int ua)
>> +{
>>
Hi all,
Thanks for reviewing the patches, I'm sorry for the late replay. I was
waiting for some comments before I address all at once and re-send the
series.
>> > +/**
>> > + * ufshcd_resume - helper function for resume operations
>> > + * @hba: per adapter instance
>> > + * @pm_op: runtime PM or
--
This is to re-notify you of the 500,000.00 USD, was deposited
here in the money gram office in your name is available for pickup. Contact
this email responseuw...@gmail.com for your ref #
This message was sent using IMP, the
It is a typo issue, need use 'buf' instead of 'len', the related warning
with allmodconfig under microblaze:
drivers/target/target_core_transport.c: In function
‘transport_dump_vpd_ident_type’:
drivers/target/target_core_transport.c:956:9: warning: passing argument 1 of
‘strlen’ makes pointer fr
Update lpfc version to driver version 10.4.8000.0
This patch set updates the lpfc driver to revision 10.4.8000.0
The patches for 10.4.8000.0 contain:
- Incorporate patches posted to linux-scsi
- Mark functions as static in lpfc/lpfc_sli.c
- Mark functions as static in lpfc/lpfc_hbadisc.c
-
Incorporating prior patch:
http://marc.info/?l=linux-scsi&m=139611643606816&w=2
Rashika Kheria
[PATCH 22/55] scsi: Mark functions as static in lpfc/lpfc_sli.c
Mark functions as static in lpfc/lpfc_sli.c because they are not used
outside this file.
This eliminates the following warnin
Incorporating prior patch:
http://marc.info/?l=linux-scsi&m=140053378307936&w=2
manuel.schoell...@gmx.de
[PATCH] lpfc: Use time_after()
To be future-proof and for better readability the time comparisons
are modified to use time_after() instead of plain, error-prone math.
Signed-off-by:
Incorporating prior patch:
http://marc.info/?l=linux-scsi&m=139611665406898&w=2
Rashika Kheria
[PATCH 25/55] scsi: Mark functions as static in lpfc/lpfc_scsi.c
Mark functions as static in lpfc/lpfc_scsi.c because they are not used
outside this file.
This eliminates the following warn
Incorporating prior patch:
http://marc.info/?l=linux-scsi&m=139611657206858&w=2
Rashika Kheria
[PATCH 24/55] scsi: Mark functions as static in lpfc/lpfc_init.c
Mark functions as static in lpfc/lpfc_init.c because they are not used
outside this file.
This eliminates the following warn
Incorporating prior patch:
http://marc.info/?l=linux-scsi&m=139611670006912&w=2
Rashika Kheria
[PATCH 26/55] scsi: Mark function as static in lpfc/lpfc_bsg.c
Mark function as static in lpfc/lpfc_bsg.c because it is not used
outside this file.
This eliminates the following warning in
Incorporating prior patch:
http://marc.info/?l=linux-scsi&m=139611651106838&w=2
Rashika Kheria
[PATCH 23/55] scsi: Mark functions as static in lpfc/lpfc_hbadisc.c
Mark functions as static in lpfc/lpfc_hbadisc.c because they are not
used outside this file.
This eliminates the followin
Fix quarantined XRI recovery qualifier state in link bounce
Signed-off-by: James Smart
Signed-off-by: Dick Kennedy
---
drivers/scsi/lpfc/lpfc_crtn.h| 1 -
drivers/scsi/lpfc/lpfc_hbadisc.c | 1 -
drivers/scsi/lpfc/lpfc_sli.c | 36
3 files changed, 3
Incorporating prior patch:
http://marc.info/?l=linux-scsi&m=140688548016998&w=2
Daniel Borkmann
[PATCH] random32: do not feed jiffies as seed from lpfc driver
In prandom we have already reseeding mechanisms that trigger
periodically from a much better entropy source than just
feeding
Incorporating prior patch:
http://marc.info/?l=linux-scsi&m=140835226413990&w=2
Alexander Gordeev
[PATCH v3 11/13] lpfc: Use pci_enable_msix_range() instead of
pci_enable_msix()
As result of deprecation of MSI-X/MSI enablement functions
pci_enable_msix() and pci_enable_msi_block() all
Incorporating prior patch:
http://marc.info/?l=linux-scsi&m=140286492825640&w=2
Joe Perches
[PATCH -next 19/26] lpfc: Use dma_zalloc_coherent
Use the zeroing function instead of dma_alloc_coherent & memset(,0,)
Signed-off-by: Joe Perches
Reviewed-by: James Smart
---
drivers/scsi/lpfc/
Fix discovery timeout during nameserver login
Signed-off-by: James Smart
Signed-off-by: Dick Kennedy
---
drivers/scsi/lpfc/lpfc_els.c | 5 +
drivers/scsi/lpfc/lpfc_init.c | 15 +++
drivers/scsi/lpfc/lpfc_sli.c | 10 +-
3 files changed, 29 insertions(+), 1 deletion(-)
Fix IP Reset processing - wait for RDY before proceeding
Signed-off-by: James Smart
Signed-off-by: Dick Kennedy
---
drivers/scsi/lpfc/lpfc_init.c | 109 ++
1 file changed, 47 insertions(+), 62 deletions(-)
diff --git a/drivers/scsi/lpfc/lpfc_init.c b/dri
Fix race between LOGO/PLOGI handling causing NULL pointer
Signed-off-by: James Smart
Signed-off-by: Dick Kennedy
---
drivers/scsi/lpfc/lpfc_disc.h| 6 +-
drivers/scsi/lpfc/lpfc_els.c | 7 +++
drivers/scsi/lpfc/lpfc_hbadisc.c | 19 ++-
3 files changed, 30 insert
Fix locking issues with abort data paths
Signed-off-by: James Smart
Signed-off-by: Dick Kennedy
---
drivers/scsi/lpfc/lpfc_scsi.c | 12 -
drivers/scsi/lpfc/lpfc_sli.c | 118 +-
drivers/scsi/lpfc/lpfc_sli.h | 1 +
3 files changed, 83 insertions(+)
Fixed High priority issues from lpfc given by fortify source code scan.
Signed-off-by: James Smart
Signed-off-by: Dick Kennedy
---
drivers/scsi/lpfc/lpfc_bsg.c | 8 +---
drivers/scsi/lpfc/lpfc_els.c | 5 -
drivers/scsi/lpfc/lpfc_init.c | 32 +++
Fix for handling unmapped ndlp in target reset handler
Signed-off-by: James Smart
Signed-off-by: Dick Kennedy
---
drivers/scsi/lpfc/lpfc_scsi.c | 8 +++-
drivers/scsi/lpfc/lpfc_sli.c | 8 +++-
2 files changed, 14 insertions(+), 2 deletions(-)
diff --git a/drivers/scsi/lpfc/lpfc_scsi.c
Fixed Low priority issues from lpfc given by fortify source code scan.
Signed-off-by: James Smart
Signed-off-by: Dick Kennedy
---
drivers/scsi/lpfc/lpfc_attr.c| 2 +-
drivers/scsi/lpfc/lpfc_bsg.c | 5 -
drivers/scsi/lpfc/lpfc_ct.c | 14 --
drivers/scsi/lpfc/lpfc_d
Fixed crash from page fault caused by use after rport delete
Signed-off-by: James Smart
Signed-off-by: Dick Kennedy
---
drivers/scsi/lpfc/lpfc_hbadisc.c | 12
1 file changed, 12 insertions(+)
diff --git a/drivers/scsi/lpfc/lpfc_hbadisc.c b/drivers/scsi/lpfc/lpfc_hbadisc.c
index 2d
Update lpfc version to driver version 10.4.8000.0
Signed-off-by: James Smart
Signed-off-by: Dick Kennedy
---
drivers/scsi/lpfc/lpfc_version.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/scsi/lpfc/lpfc_version.h b/drivers/scsi/lpfc/lpfc_version.h
index 41675c1..89
> From: Alan Stern
>
> On Fri, 29 Aug 2014, Matthew Dharm wrote:
> > Is there an 'easy' way to override the detected size of a storage
> > device from userspace? If we had that, someone could write a helper
> > application which looked for this particular fubar and try to Do The
> > Right Thing(
On Wed, 3 Sep 2014, Dale R. Worley wrote:
> > From: Alan Stern
> >
> > On Fri, 29 Aug 2014, Matthew Dharm wrote:
> > > Is there an 'easy' way to override the detected size of a storage
> > > device from userspace? If we had that, someone could write a helper
> > > application which looked for t
On Sat, 30 Aug 2014, Matthew Dharm wrote
> I was thinking of something that could notice a USB device which is formatted
> NTFS and has a partition table and filesystem that indicates a much bigger
> capacity than what the drive reports. Under this circumstances, you could do
> something like po
> From: Alan Stern
> Anyway, I can try writing a patch to add this capability. We'll see if
> it can solve your problem.
Unfortunately, I think there is genuine value in such a hack. E.g.,
I've got two USB-to-SATA adapters. One works correctly. One does
not. But at this point, I can't atta
On Wed, 2014-09-03 at 15:05 -0400, Alan Stern wrote:
> On Wed, 3 Sep 2014, Dale R. Worley wrote:
>
> > > From: Alan Stern
> > >
> > > On Fri, 29 Aug 2014, Matthew Dharm wrote:
> > > > Is there an 'easy' way to override the detected size of a storage
> > > > device from userspace? If we had that
On Wed, 3 Sep 2014, James Bottomley wrote:
> Before we embark on elaborate hacks, why don't we just make the capacity
> writeable (by root) in sysfs from userspace (will require block change)?
> We can then encode all the nasty heuristics (including gpt reading) in
> userspace as a udev rule.
Tha
On Wed, 2014-09-03 at 16:30 -0400, Alan Stern wrote:
> On Wed, 3 Sep 2014, James Bottomley wrote:
>
> > Before we embark on elaborate hacks, why don't we just make the capacity
> > writeable (by root) in sysfs from userspace (will require block change)?
> > We can then encode all the nasty heurist
Hello folks,
I would like to know whether we have any standard test suite for
validating a low level driver by executing all the interfaces the low
level driver registers with SML?
Thanks
Sathya
--
To unsubscribe from this list: send the line "unsubscribe linux-scsi" in
the body of a message to ma
54 matches
Mail list logo