In the bnx2fc_map_sg() function, the original behaviour is to
allocate the DMA memory by directly calling dma_map_sg()
instead of using scsi_dma_map().
In contrast, bnx2fc_unmap_sg_list() calls scsi_dma_unmap().
The problem is that bnx2fc_map_sg() passes to the dma_map_sg() function
the pointer t
This series adds XEN pvSCSI support. With pvSCSI it is possible to use physical
SCSI devices from a XEN domain.
The support consists of a backend in the privileged Domain-0 doing the real
I/O and a frontend in the unprivileged domU passing I/O-requests to the backend.
The code is taken (and adapt
From: Juergen Gross
Add the definition of pvSCSI protocol used between the pvSCSI frontend in a
XEN domU and the pvSCSI backend in a XEN driver domain (usually Dom0).
This header was originally provided by Fujitsu for XEN based on Linux 2.6.18.
Changes are:
- added comment
- adapt to Linux style
From: Juergen Gross
Add myself as maintainer for the Xen pvSCSI stuff.
Signed-off-by: Juergen Gross
---
MAINTAINERS | 8
1 file changed, 8 insertions(+)
diff --git a/MAINTAINERS b/MAINTAINERS
index c2066f4..d020bfd 100644
--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -10046,6 +10046,14 @@ S
From: Juergen Gross
Introduces the XEN pvSCSI frontend. With pvSCSI it is possible for a XEN domU
to issue SCSI commands to a SCSI LUN assigned to that domU. The SCSI commands
are passed to the pvSCSI backend in a driver domain (usually Dom0) which is
owner of the physical device. This allows e.g
From: Juergen Gross
Introduces the XEN pvSCSI backend. With pvSCSI it is possible for a XEN domU
to issue SCSI commands to a SCSI LUN assigned to that domU. The SCSI commands
are passed to the pvSCSI backend in a driver domain (usually Dom0) which is
owner of the physical device. This allows e.g.
Use %llu for u64 and %u for int. Not the other way round.
Signed-off-by: Martin Kepplinger
---
applies to -next20140801
drivers/scsi/u14-34f.c |4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/scsi/u14-34f.c b/drivers/scsi/u14-34f.c
index 4e76fe8..d8dcf36 100644
From: Ching Huang
This patch rewrites the arcmsr_define_adapter_type function to precisely check
Areca adapter's ID.
This can prevent an unknown adapter being used as a default adapter type by
driver.
Signed-off-by: Ching Huang
---
Thanks for Christoph advice.
diff -uprN a/drivers/scsi/arc
From: Ching Huang
Revise message_isr_bh_fn to remove the duplicate code for each adapter type.
Signed-off-by: Ching Huang
---
diff -uprN a/drivers/scsi/arcmsr/arcmsr_hba.c b/drivers/scsi/arcmsr/arcmsr_hba.c
--- a/drivers/scsi/arcmsr/arcmsr_hba.c 2014-08-04 16:43:16.0 +0800
+++ b/drive
From: Ching Huang
Remove calling arcmsr_hbb_enable_driver_mode by in-line code.
Signed-off-by: Ching Huang
---
diff -uprN a/drivers/scsi/arcmsr/arcmsr_hba.c b/drivers/scsi/arcmsr/arcmsr_hba.c
--- a/drivers/scsi/arcmsr/arcmsr_hba.c 2014-08-04 16:43:06.0 +0800
+++ b/drivers/scsi/arcmsr/
From: Ching Huang
Adjust printing order of adapter model name and firmware version.
Signed-off-by: Ching Huang
---
diff -uprN a/drivers/scsi/arcmsr/arcmsr_hba.c b/drivers/scsi/arcmsr/arcmsr_hba.c
--- a/drivers/scsi/arcmsr/arcmsr_hba.c 2014-08-04 16:44:44.0 +0800
+++ b/drivers/scsi/arc
From: Ching Huang
Clear outbound doorbell buffer completely for adapter type C.
This is to prevent getting bad data input from IOP before ioctl command
beginning.
Signed-off-by: Ching Huang
---
diff -uprN a/drivers/scsi/arcmsr/arcmsr_hba.c b/drivers/scsi/arcmsr/arcmsr_hba.c
--- a/drivers/scsi
From: Ching Huang
Rename some variable and function name for readability and consistency.
Signed-off-by: Ching Huang
---
diff -uprN a/drivers/scsi/arcmsr/arcmsr.h b/drivers/scsi/arcmsr/arcmsr.h
--- a/drivers/scsi/arcmsr/arcmsr.h 2014-05-06 15:27:14.0 +0800
+++ b/drivers/scsi/arcms
From: Ching Huang
This modification is for consistency with up-coming adapter type D.
They have similar H/W and S/W structure.
Signed-off-by: Ching Huang
---
diff -uprN a/drivers/scsi/arcmsr/arcmsr.h b/drivers/scsi/arcmsr/arcmsr.h
--- a/drivers/scsi/arcmsr/arcmsr.h 2014-05-06 15:27:38.000
From: Ching Huang
Rewrite ioctl entry and its relate functions.
This patch fix ioctl data read/write error and change data I/O access from byte
to Dword.
Signed-off-by: Ching Huang
---
diff -uprN a/drivers/scsi/arcmsr/arcmsr_attr.c
b/drivers/scsi/arcmsr/arcmsr_attr.c
--- a/drivers/scsi/arcms
>>> On 04.08.14 at 10:27, wrote:
> +/* Requests from the frontend to the backend */
> +
> +/*
> + * Request a SCSI operation specified via a CDB in vscsiif_request.cmnd.
> + * The target is specified via channel, id and lun.
> + */
> +#define VSCSIIF_ACT_SCSI_CDB 1
> +
> +/*
> + * Request
From: Ching Huang
Fix sparse utility checking error and warning.
Signed-off-by: Ching Huang
---
diff -uprN a/drivers/scsi/arcmsr/arcmsr_hba.c b/drivers/scsi/arcmsr/arcmsr_hba.c
--- a/drivers/scsi/arcmsr/arcmsr_hba.c 2014-08-04 16:46:30.0 +0800
+++ b/drivers/scsi/arcmsr/arcmsr_hba.c 2
From: Ching Huang
Revise comment and some character strings.
Signed-off-by: Ching Huang
---
diff -uprN a/drivers/scsi/arcmsr/arcmsr_hba.c b/drivers/scsi/arcmsr/arcmsr_hba.c
--- a/drivers/scsi/arcmsr/arcmsr_hba.c 2014-08-04 16:45:46.0 +0800
+++ b/drivers/scsi/arcmsr/arcmsr_hba.c 2014-
From: Ching Huang
Add code for supporting Areca new Raid adapter ARC12x4 series.
Signed-off-by: Ching Huang
---
diff -uprN a/drivers/scsi/arcmsr/arcmsr.h b/drivers/scsi/arcmsr/arcmsr.h
--- a/drivers/scsi/arcmsr/arcmsr.h 2014-05-06 15:29:54.0 +0800
+++ b/drivers/scsi/arcmsr/arcmsr.
From: Ching Huang
Modify calling scsi_scan_host until all initialization done.
And fix error path of free allocated resource.
Signed-off-by: Ching Huang
---
diff -uprN a/drivers/scsi/arcmsr/arcmsr_hba.c b/drivers/scsi/arcmsr/arcmsr_hba.c
--- a/drivers/scsi/arcmsr/arcmsr_hba.c 2014-08-04 16:46
From: Ching Huang
To prevent flushing entire workqueue, replace flush_scheduled_work() by
flush_work().
Signed-off-by: Ching Huang
---
diff -uprN a/drivers/scsi/arcmsr/arcmsr_hba.c b/drivers/scsi/arcmsr/arcmsr_hba.c
--- a/drivers/scsi/arcmsr/arcmsr_hba.c 2014-08-04 16:47:02.0 +0800
+
On 08/04/2014 12:10 PM, Jan Beulich wrote:
On 04.08.14 at 10:27, wrote:
+/* Requests from the frontend to the backend */
+
+/*
+ * Request a SCSI operation specified via a CDB in vscsiif_request.cmnd.
+ * The target is specified via channel, id and lun.
+ */
+#define VSCSIIF_ACT_SCSI_CDB
On Mon, Aug 04, 2014 at 10:48:37AM +0200, Martin Kepplinger wrote:
> Use %llu for u64 and %u for int. Not the other way round.
I've already queued up an equivalent fix in my core-for-3.17 branch,
I just need James to pull it into the scsi for-next tree.
--
To unsubscribe from this list: send the
On Mon, Aug 04, 2014 at 06:22:59AM +0200, Juergen Gross wrote:
> OTOH it would be possible to just delete .cmd_pool in the template when
> deleting the pool. I'll send a patch doing this and you can decide
> whether to take it or to use the other solution.
>
> I'm not sure which to prefer: the ini
On Sat, Aug 02, 2014 at 12:24:34AM +0400, James Bottomley wrote:
> Wait, that's not right at all. There looks to be a thinko in the
> command pool handling code. We have both a cmd_pool in the host
> structure and in the host template structure, but there's confusion
> about which one we're suppo
On Mon, Aug 04, 2014 at 06:26:09AM +0200, jgr...@suse.com wrote:
> From: Juergen Gross
>
> If a scsi host driver specifies .cmd_len in it's scsi_host_template, a
> driver's
> private command pool is needed. scsi_find_host_cmd_pool() will locate it, but
> scsi_alloc_host_cmd_pool() isn't saving t
On Fri, Aug 01, 2014 at 04:32:01PM -0400, James Bottomley wrote:
> On Fri, 2014-08-01 at 05:20 -0700, Christoph Hellwig wrote:
> > I've pushed out updates to both the core-for-3.17 and drivers-for-3.17
> > branches.
>
> So I'm afraid we missed the last -next build on these, so they can't go
> in w
To modify the timeout on a queue please use blk_queue_rq_timeout in
the slave_configure method instead of poking directly into the block
timer, which won't work e.g. for the blk-mq path.
But this really needs an explanation on why you'd need a configurable
timeout to start with.
--
To unsubscribe
On 08/04/2014 01:08 PM, Christoph Hellwig wrote:
On Mon, Aug 04, 2014 at 06:26:09AM +0200, jgr...@suse.com wrote:
From: Juergen Gross
If a scsi host driver specifies .cmd_len in it's scsi_host_template, a driver's
private command pool is needed. scsi_find_host_cmd_pool() will locate it, but
sc
From: Juergen Gross
If a scsi host driver specifies .cmd_len in it's scsi_host_template, a driver's
private command pool is needed. scsi_find_host_cmd_pool() will locate it, but
scsi_alloc_host_cmd_pool() isn't saving the pool address in the host template.
This will result in an access error whe
On 08/04/2014 01:24 PM, jgr...@suse.com wrote:
From: Juergen Gross
If a scsi host driver specifies .cmd_len in it's scsi_host_template, a driver's
private command pool is needed. scsi_find_host_cmd_pool() will locate it, but
scsi_alloc_host_cmd_pool() isn't saving the pool address in the host t
From: Juergen Gross
If a scsi host driver specifies .cmd_len in it's scsi_host_template, a driver's
private command pool is needed. scsi_find_host_cmd_pool() will locate it, but
scsi_alloc_host_cmd_pool() isn't saving the pool address in the host template.
This will result in an access error whe
Hi Christoph,
On Mon, 4 Aug 2014 04:11:47 -0700 Christoph Hellwig wrote:
>
> On Fri, Aug 01, 2014 at 04:32:01PM -0400, James Bottomley wrote:
> > On Fri, 2014-08-01 at 05:20 -0700, Christoph Hellwig wrote:
> > > I've pushed out updates to both the core-for-3.17 and drivers-for-3.17
> > > branches
On Mon, Aug 04, 2014 at 09:30:59PM +1000, Stephen Rothwell wrote:
> You realise that neither of these in linux-next as the scsi-core and
> scsi-drivers trees had for-3.16 branches in the last round. I assume I
> should just drop these trees completely from linux-next?
Well, they get pulled in thr
Hi Christoph,
On Mon, 4 Aug 2014 04:34:04 -0700 Christoph Hellwig wrote:
>
> On Mon, Aug 04, 2014 at 09:30:59PM +1000, Stephen Rothwell wrote:
> > You realise that neither of these in linux-next as the scsi-core and
> > scsi-drivers trees had for-3.16 branches in the last round. I assume I
> > s
On 08/04/2014 02:30 PM, jgr...@suse.com wrote:
> From: Juergen Gross
>
> If a scsi host driver specifies .cmd_len in it's scsi_host_template, a
> driver's
> private command pool is needed. scsi_find_host_cmd_pool() will locate it, but
> scsi_alloc_host_cmd_pool() isn't saving the pool address in
On 08/04/2014 01:49 PM, Boaz Harrosh wrote:
On 08/04/2014 02:30 PM, jgr...@suse.com wrote:
From: Juergen Gross
If a scsi host driver specifies .cmd_len in it's scsi_host_template, a driver's
private command pool is needed. scsi_find_host_cmd_pool() will locate it, but
scsi_alloc_host_cmd_pool(
On 04/08/14 09:27, jgr...@suse.com wrote:
>
> +
> +static void scsifront_backend_changed(struct xenbus_device *dev,
> + enum xenbus_state backend_state)
> +{
> + struct vscsifrnt_info *info = dev_get_drvdata(&dev->dev);
> +
> + DPRINTK("%p %u %u\n", dev, d
On 04/08/14 09:27, jgr...@suse.com wrote:
> From: Juergen Gross
>
> Introduces the XEN pvSCSI backend. With pvSCSI it is possible for a XEN domU
> to issue SCSI commands to a SCSI LUN assigned to that domU. The SCSI commands
> are passed to the pvSCSI backend in a driver domain (usually Dom0) whi
On 07/31/2014 05:16 PM, scame...@beardog.cce.hp.com wrote:
> On Thu, Jul 31, 2014 at 03:56:13PM +0200, Tomas Henzl wrote:
>> Hi Steve, Webb,
>>
>> let me start with the part most important for me - from my previous mail
>> "And please have a look at "[PATCH] hpsa: refine the pci enble/disable
>> h
On 08/01/2014 06:40 PM, Webb Scales wrote:
> On 7/31/14 9:56 AM, Tomas Henzl wrote:
In cmd_tagged_alloc "Thus, there should never be a collision here between
two requests" if this is true you don't need the refcount and just a simple
flag were sufficient for your other needs. (And ma
On Tue 2014-07-15 15:34:47, Mikulas Patocka wrote:
> This is Martin Petersen's xcopy patch
> (https://git.kernel.org/cgit/linux/kernel/git/mkp/linux.git/commit/?h=xcopy&id=0bdeed274e16b3038a851552188512071974eea8)
> with some bug fixes, ported to the current kernel.
>
> This patch makes it possibl
On Mon, 2014-08-04 at 04:11 -0700, Christoph Hellwig wrote:
> On Fri, Aug 01, 2014 at 04:32:01PM -0400, James Bottomley wrote:
> > On Fri, 2014-08-01 at 05:20 -0700, Christoph Hellwig wrote:
> > > I've pushed out updates to both the core-for-3.17 and drivers-for-3.17
> > > branches.
> >
> > So I'm
On 07/28/2014 03:28 PM, Brian King wrote:
>
> Export kexec_in_progress for use by device drivers and other modules
> to optimize kexec boot.
>
> Signed-off-by: Brian King
> ---
>
> kernel/kexec.c |2 ++
> 1 file changed, 2 insertions(+)
>
> diff -puN kernel/kexec.c~kexec_export_in_prog ke
On Mon, 2014-08-04 at 04:03 -0700, Christoph Hellwig wrote:
> On Mon, Aug 04, 2014 at 06:22:59AM +0200, Juergen Gross wrote:
> > OTOH it would be possible to just delete .cmd_pool in the template when
> > deleting the pool. I'll send a patch doing this and you can decide
> > whether to take it or t
45 matches
Mail list logo