This is a first stab at implementing SMR support.
The powers that be decided to call the ATA implementation
'ZAC' (zoned access commands), and the SCSI implementation
'ZBC' (zoned block commands).
This is just basic enablement to get ZAC and ZBC drives
handled correctly.
The first three patches up
ZBC drives are close to disk devices, so sd.c is well
suited as a testbed for ZBC devices.
This patch introduces a module option 'attach_zbc' to
sd which will make the sd driver accept ZBC
devices as normal disk drives.
Signed-off-by: Hannes Reinecke
---
drivers/scsi/sd.c | 25 ++
Add new ATA device type for ZAC devices.
Signed-off-by: Hannes Reinecke
---
drivers/ata/libata-core.c | 20 ++--
drivers/ata/libata-eh.c| 7 +--
drivers/ata/libata-scsi.c | 5 +++--
drivers/ata/libata-transport.c | 1 +
include/linux/libata.h | 6
ZAC (zoned-access command) drives translate into ZBC (Zoned block
command) device type for SCSI. So implement the correct mappings
into libata-scsi and update the SCSI command set versions.
Signed-off-by: Hannes Reinecke
---
drivers/ata/libata-scsi.c | 25 -
1 file change
ata_dev_classify() just uses the 'lbah' and 'lbam'
fields from the taskfile, so we can as well use those
as arguments and rip out the custom code from sas_ata.
Cc: Dan Williams
Signed-off-by: Hannes Reinecke
---
drivers/ata/libahci.c | 11 +++
drivers/ata/libata-core.c
On 07/29/2014 08:19 PM, Ross Zwisler wrote:
> On Tue, 2014-07-29 at 19:37 +0300, Boaz Harrosh wrote:
>> Hi folks
>>
>> I've been playing with yet unseen prd block device, and hit an issue with
>> partitioning
>> but since prd.c is a copy/paste of brd.c the same exact issue exists with
>> brd.
>>
On Wed, Jul 30, 2014 at 08:41:55AM +0200, Hannes Reinecke wrote:
> Yes, eventually. But can't we defer that to a next patchset?
> I'd really like to have this one in, as it makes dealing with ZAC devices
> _so much_ easier ...
I'm happy to put the sd patch in if I can get another review for it.
B
Can I get reviews for the remaining patches, please?
On Sat, Jul 12, 2014 at 03:51:47PM -0500, micha...@cs.wisc.edu wrote:
> The following patches were made over Chrisoph's scsi-queue drivers-for-3.17
> branch. They are some fixes to the get_host_stats code and new error code
> for when a iscsi pi
From: Suresh Thiagarajan
The current implementation may mix the negative value returned
from pm8001_set_nvmd with with count. -(-ENOMEM) could be interpreted
as bytes programmed, this patch fixes it.
Signed-off-by: Tomas Henzl
Signed-off-by: Suresh Thiagarajan
---
drivers/scsi/pm8001/pm8001_c
From: Suresh Thiagarajan
The loopcount is calculated by using some weird magic.
Use instead a boring macro
Signed-off-by: Tomas Henzl
Signed-off-by: Suresh Thiagarajan
---
drivers/scsi/pm8001/pm8001_ctl.c |7 ++-
1 files changed, 2 insertions(+), 5 deletions(-)
diff --git a/drivers/s
From: Suresh Thiagarajan
Update pmcs mail list for pm8001 driver support
Signed-off-by: Suresh Thiagarajan
---
MAINTAINERS |1 +
1 files changed, 1 insertions(+), 0 deletions(-)
diff --git a/MAINTAINERS b/MAINTAINERS
index 3f2e171..a63259c 100644
--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -69
On Wed, 2014-07-30 at 17:33 +0530, Suresh Thiagarajan wrote:
> From: Suresh Thiagarajan
>
> The current implementation may mix the negative value returned
> from pm8001_set_nvmd with with count. -(-ENOMEM) could be interpreted
> as bytes programmed, this patch fixes it.
>
> Signed-off-by: Tomas
On Wed, 2014-07-30 at 17:37 +0530, Suresh Thiagarajan wrote:
> From: Suresh Thiagarajan
>
> Update pmcs mail list for pm8001 driver support
>
> Signed-off-by: Suresh Thiagarajan
> ---
> MAINTAINERS |1 +
> 1 files changed, 1 insertions(+), 0 deletions(-)
>
> diff --git a/MAINTAINERS b/MAI
On Tue, Jul 29, 2014 at 02:26:11PM +0200, Christoph Hellwig wrote:
> On Mon, Jul 28, 2014 at 11:49:22AM +0400, James Bottomley wrote:
> > That needs to be
> >
> > From: James Bottomley
> >
> > As well. I do list handling on hansenpartnership.com to minimise
> > exchange wreckage on mailinglists
On Wed, Jul 30, 2014 at 5:40 PM, James Bottomley
wrote:
> On Wed, 2014-07-30 at 17:33 +0530, Suresh Thiagarajan wrote:
>> From: Suresh Thiagarajan
>>
>> The current implementation may mix the negative value returned
>> from pm8001_set_nvmd with with count. -(-ENOMEM) could be interpreted
>> as
On 07/12/2014 10:51 PM, micha...@cs.wisc.edu wrote:
From: Mike Christie
iscsi_get_host_stats was dropping the error code returned
by drivers like qla4xxx.
Signed-off-by: Mike Christie
---
drivers/scsi/scsi_transport_iscsi.c |4
1 files changed, 4 insertions(+), 0 deletions(-)
dif
On 07/12/2014 10:51 PM, micha...@cs.wisc.edu wrote:
From: Mike Christie
qla4xxx was not always returning -EXYZ error codes when
qla4xxx_get_host_stats failed.
Signed-off-by: Mike Christie
Acked-by: Vikas Chaudhary
---
drivers/scsi/qla4xxx/ql4_os.c |2 ++
1 files changed, 2 insertions
On 13/07/14 3:20 pm, "Christoph Hellwig" wrote:
>On Sat, Jul 12, 2014 at 03:51:47PM -0500, micha...@cs.wisc.edu wrote:
>> The following patches were made over Chrisoph's scsi-queue
>>drivers-for-3.17
>> branch. They are some fixes to the get_host_stats code and new error
>>code
>> for when a is
On 07/12/2014 10:51 PM, micha...@cs.wisc.edu wrote:
From: Mike Christie
When the get_host_stats call was not supported we were
returing EINVAL. This has us return ENOSYS, because for
software iscsi drivers where there is no host it is ok to not
have this callout.
Signed-off-by: Mike Christie
On 07/12/2014 10:51 PM, micha...@cs.wisc.edu wrote:
From: Mike Christie
When a iscsi nop as ping timedout we were failing with the
common connection error code, ISCSI_ERR_CONN_FAILED. This
patch adds a new error code for this problem so can properly
track/distinguish in userspace.
Signed-off-b
From: Tomas Henzl
The current implementation may mix the negative value returned
from pm8001_set_nvmd with with count. -(-ENOMEM) could be interpreted
as bytes programmed, this patch fixes it.
Signed-off-by: Tomas Henzl
Signed-off-by: Suresh Thiagarajan
---
drivers/scsi/pm8001/pm8001_ctl.c |
On 07/10/2014 03:30 PM, Tomas Henzl wrote:
> On 07/10/2014 08:43 AM, Christoph Hellwig wrote:
>> On Mon, Jul 07, 2014 at 05:20:01PM +0200, Tomas Henzl wrote:
>>> The current implementation may mix the negative value returned
>>> from pm8001_set_nvmd with with count. -(-ENOMEM) could be interpreted
From: Tomas Henzl
The loopcount is calculated by using some weird magic.
Use instead a boring macro
Signed-off-by: Tomas Henzl
Signed-off-by: Suresh Thiagarajan
---
drivers/scsi/pm8001/pm8001_ctl.c |7 ++-
1 files changed, 2 insertions(+), 5 deletions(-)
diff --git a/drivers/scsi/pm8
With current code after a call to:
bdev = blkdev_get_by_path(dev_name, mode, fs_type);
size = i_size_read(bdev->bd_inode);
part_size = bdev->bd_part->nr_sects << 9;
I get the following bad results:
dev_name == /dev/ram0
foo: [foo_mount:880] size=0x4000 bdev=8800
When brd_direct_access() is called on a partition-bdev
it would access the wrong sector. And caller would then
corrupt the device's data.
This is a preliminary fix, Matthew Wilcox has a patch
in his DAX patchset which will define a global wrapper
to bdev->bd_disk->fops->direct_access that will do
On Wed, Jul 30, 2014 at 11:22:14AM +0900, Tetsuo Handa wrote:
> Luis R. Rodriguez wrote:
> > Tetsuo is it possible / desirable to allow tasks to not kill unless the
> > reason is OOM ? Its unclear if this was discussed before, sorry if it was,
> > have just been a bit busy today to review the archi
V2 - 'from' string removed (as it comes from me now) and changed a signed-off
to acked-by (Suresh is the maintainer)
Tomas
The loopcount is calculated by using some weird magic.
Use instead a boring macro
Signed-off-by: Tomas Henzl
Acked-by: Suresh Thiagarajan
---
drivers/scsi/pm8001/pm8001_
On Wed, Jul 30, 2014 at 08:21:35AM -0400, Josh Boyer wrote:
> > Thanks, I've update the author, added a Cc to ћtable and pushed it out to
> > the core-for-3.17 branch.
>
> This fixes a bug in the 3.16 kernel. Why wouldn't it be sent to Linus
> for inclusion in the final release there?
I'm only c
Hi Martin,
Sorry for the delay as I was on vacation.
Here are the change set when compared to the initial patch
1. Declared the following functions at the beginning of the
mpt2sas_base.c file instead of moving all these functions before
mpt2sas_base_map_resources() function
a. _base_wait
On 07/25/2014 09:28 PM, scame...@beardog.cce.hp.com wrote:
>
> hpsa: Work In Progress: "lockless monster" patches
>
> To be clear, I am not suggesting that these patches be merged at this time.
>
> This patchset is vs. Christoph Hellwig's scsi-mq.4 branch which
> may be found here: git://git.infrad
On Wed, 2014-07-30 at 16:52 +0200, Christoph Hellwig wrote:
> On Wed, Jul 30, 2014 at 08:21:35AM -0400, Josh Boyer wrote:
> > > Thanks, I've update the author, added a Cc to ћtable and pushed it out to
> > > the core-for-3.17 branch.
> >
> > This fixes a bug in the 3.16 kernel. Why wouldn't it be
On Wed, Jul 30, 2014 at 05:18:47PM +0300, Boaz Harrosh wrote:
> When brd_direct_access() is called on a partition-bdev
> it would access the wrong sector. And caller would then
> corrupt the device's data.
>
> This is a preliminary fix, Matthew Wilcox has a patch
> in his DAX patchset which will d
On 07/30/2014 06:34 PM, Matthew Wilcox wrote:
> On Wed, Jul 30, 2014 at 05:18:47PM +0300, Boaz Harrosh wrote:
>> When brd_direct_access() is called on a partition-bdev
>> it would access the wrong sector. And caller would then
>> corrupt the device's data.
>>
>> This is a preliminary fix, Matthew W
On Wed, Jul 30, 2014 at 07:04:59PM +0400, James Bottomley wrote:
> It's been remarkably current, I believe ... it's already up to date.
I've updated the drivers tree today and it will get a few more updates
さoon.
> However, we only have 2 -next builds between now and the anticipated
> 3.16 releas
On Wed, 2014-07-30 at 17:15 +0300, Boaz Harrosh wrote:
> With current code after a call to:
> bdev = blkdev_get_by_path(dev_name, mode, fs_type);
> size = i_size_read(bdev->bd_inode);
> part_size = bdev->bd_part->nr_sects << 9;
>
> I get the following bad results:
> dev_name ==
On 07/26/2014 11:21 AM, Christoph Hellwig wrote:
> Here's a formal one.
>
> James, can I get your signoff for it?
>
> Vladimir, can I get a reviewed-by from you (or anyone else)?
>
> ---
> From 73b1034ab1418e2dea75ccf642bc85c728b57313 Mon Sep 17 00:00:00 2001
> From: James Bottomley
> Date: Sat
On Wed, Jul 30, 2014 at 12:22:11PM -0500, Mike Christie wrote:
> Some drivers like qla2xxx do not set proc_name. I think if 2 drivers
> like that are loaded then you will hit some other warns/bugs in the kmem
> cache setup code right?
Drivers have to opt into using their own caches by setting .cmd
On 07/30/2014 07:50 PM, Ross Zwisler wrote:
<>
>> + */
>> +printk(KERN_EROR "brd: brd_find unexpected device %d\n", i);
>
> s/KERN_EROR/KERN_ERR/
>
Yes thanks, sigh, code should compile
driver error. I used pr_err but last inspection I saw that printk is used
everywhere and, crapped ...
Hi Tomas,
Thanks for taking a look and for the feedback. I'm actually the one
responsible for the changes you refer to, so I'll try to address your
comments.
On 7/30/14 10:55 AM, Tomas Henzl wrote:
I'm not sure if I got it right,
it seems it uses the same cmd_pool for both alloc function,
If you are going to use memset before strncpy you must copy sizeof -1.
And removed unnecessary magic numbers.
Signed-off-by: Rickard Strandqvist
---
drivers/scsi/ch.c | 12
1 file changed, 8 insertions(+), 4 deletions(-)
diff --git a/drivers/scsi/ch.c b/drivers/scsi/ch.c
index 2a
If you use kzalloc before strncpy you must copy sizeof -1.
And removed unnecessary magic numbers.
Signed-off-by: Rickard Strandqvist
---
drivers/scsi/csiostor/csio_init.c |3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/scsi/csiostor/csio_init.c
b/drivers/scsi/cs
Code clarification using strlcpy instead of strncpy.
And removed unnecessary memset
Signed-off-by: Rickard Strandqvist
---
drivers/scsi/hpsa.c | 16 +++-
1 file changed, 7 insertions(+), 9 deletions(-)
diff --git a/drivers/scsi/hpsa.c b/drivers/scsi/hpsa.c
index 31184b3..814d64d 1
From: "Luis R. Rodriguez"
Date: Mon, 28 Jul 2014 11:28:28 -0700
> Tetsuo bisected and found that commit 786235ee "kthread: make
> kthread_create() killable" modified kthread_create() to bail as
> soon as SIGKILL is received. This is causing some issues with
> some drivers and at times boot. Josep
And as I understand it, it is fine to replace strncpy to strlcpy here.
But if any of this code do not want a null terminated, or want to have the
whole rest of size filled with null characters.
If that is the case this is not a good patch.
Rickard Strandqvist (1):
scsi: ibmvscsi: ibmvfc.c: Cl
Replacing strncpy with strlcpy to avoid strings that lacks null terminate.
Signed-off-by: Rickard Strandqvist
---
drivers/scsi/ibmvscsi/ibmvfc.c | 10 ++
1 file changed, 6 insertions(+), 4 deletions(-)
diff --git a/drivers/scsi/ibmvscsi/ibmvfc.c b/drivers/scsi/ibmvscsi/ibmvfc.c
index
Greetings from gulf region
Thanks for the e-mail. I am very interested on funding lucrative
business partnership with you acting as the manager and sole
controller of the investment while i remain a silent investor for a
period of ten yrs , though I am only looking at investment
opportunities with
46 matches
Mail list logo