On 07/25/2014 07:38 PM, Konrad Rzeszutek Wilk wrote:
On Fri, Jul 25, 2014 at 01:37:29PM +0200, jgr...@suse.com wrote:
This series adds XEN pvSCSI support. With pvSCSI it is possible to use physical
SCSI devices from a XEN domain.
The support consists of a backend in the privileged Domain-0 doin
On Wed, Jul 16, 2014 at 08:05:09PM +0200, Alexander Gordeev wrote:
> There is no need to call pci_disable_msix() in case
> the previous call to pci_enable_msix() failed
Hi Naresh, Arvind,
Could you please review csiostor patches in this series?
Thanks!
> Signed-off-by: Alexander Gordeev
> Cc:
On Wed, Jul 16, 2014 at 08:05:11PM +0200, Alexander Gordeev wrote:
> As result of deprecation of MSI-X/MSI enablement functions
> pci_enable_msix() and pci_enable_msi_block() all drivers
> using these two interfaces need to be updated to use the
> new pci_enable_msi_range() or pci_enable_msi_exact
On Wed, Jul 16, 2014 at 08:05:12PM +0200, Alexander Gordeev wrote:
> Currently the driver falls back to INTx mode when MSI-X
> initialization failed. This is a suboptimal behaviour
> for chips that also support MSI. This update changes that
> behaviour and falls back to MSI mode in case MSI-X mode
On Wed, Jul 16, 2014 at 08:05:16PM +0200, Alexander Gordeev wrote:
> As result of deprecation of MSI-X/MSI enablement functions
> pci_enable_msix() and pci_enable_msi_block() all drivers
> using these two interfaces need to be updated to use the
> new pci_enable_msi_range() or pci_enable_msi_exact
On Wed, Jul 16, 2014 at 08:05:19PM +0200, Alexander Gordeev wrote:
> As result of deprecation of MSI-X/MSI enablement functions
> pci_enable_msix() and pci_enable_msi_block() all drivers
> using these two interfaces need to be updated to use the
> new pci_enable_msi_range() or pci_enable_msi_exact
On Wed, Jul 16, 2014 at 08:05:22PM +0200, Alexander Gordeev wrote:
> As result of deprecation of MSI-X/MSI enablement functions
> pci_enable_msix() and pci_enable_msi_block() all drivers
> using these two interfaces need to be updated to use the
> new pci_enable_msi_range() or pci_enable_msi_exact
On Wed, Jul 16, 2014 at 08:05:24PM +0200, Alexander Gordeev wrote:
> As result of deprecation of MSI-X/MSI enablement functions
> pci_enable_msix() and pci_enable_msi_block() all drivers
> using these two interfaces need to be updated to use the
> new pci_enable_msi_range() or pci_enable_msi_exact
On Wed, Jul 16, 2014 at 08:05:25PM +0200, Alexander Gordeev wrote:
> As result of deprecation of MSI-X/MSI enablement functions
> pci_enable_msix() and pci_enable_msi_block() all drivers
> using these two interfaces need to be updated to use the
> new pci_enable_msi_range() or pci_enable_msi_exact
On Wed, Jul 16, 2014 at 08:05:26PM +0200, Alexander Gordeev wrote:
> As result of deprecation of MSI-X/MSI enablement functions
> pci_enable_msix() and pci_enable_msi_block() all drivers
> using these two interfaces need to be updated to use the
> new pci_enable_msi_range() or pci_enable_msi_exact
> -Original Message-
> From: James Bottomley [mailto:jbottom...@parallels.com]
> Sent: Friday, July 25, 2014 10:10 AM
> To: KY Srinivasan
> Cc: linux-ker...@vger.kernel.org; h...@infradead.org; sits...@gmail.com;
> de...@linuxdriverproject.org; a...@canonical.com;
> martin.peter...@oracle
> -Original Message-
> From: Martin K. Petersen [mailto:martin.peter...@oracle.com]
> Sent: Friday, July 25, 2014 9:57 AM
> To: KY Srinivasan
> Cc: Martin K. Petersen; Sitsofe Wheeler; Christoph Hellwig;
> gre...@linuxfoundation.org; linux-ker...@vger.kernel.org;
> de...@linuxdriverprojec
Replacing strncpy with strlcpy to avoid strings that lacks null terminate.
Signed-off-by: Rickard Strandqvist
---
block/bsg.c |2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/block/bsg.c b/block/bsg.c
index ff46add..b2688c5 100644
--- a/block/bsg.c
+++ b/block/bsg.c
@@ -790
Replacing strncpy with strlcpy to avoid strings that lacks null terminate.
Signed-off-by: Rickard Strandqvist
---
drivers/scsi/bfa/bfad_attr.c |2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/scsi/bfa/bfad_attr.c b/drivers/scsi/bfa/bfad_attr.c
index 40be670..6d21bc6
Replacing strncpy with strlcpy to avoid strings that lacks null terminate.
Signed-off-by: Rickard Strandqvist
---
drivers/scsi/ibmvscsi/ibmvscsi.c |7 +++
1 file changed, 3 insertions(+), 4 deletions(-)
diff --git a/drivers/scsi/ibmvscsi/ibmvscsi.c b/drivers/scsi/ibmvscsi/ibmvscsi.c
ind
Replacing strncpy with strlcpy to avoid strings that lacks null terminate.
Signed-off-by: Rickard Strandqvist
---
drivers/scsi/qla4xxx/ql4_os.c | 14 +++---
1 file changed, 7 insertions(+), 7 deletions(-)
diff --git a/drivers/scsi/qla4xxx/ql4_os.c b/drivers/scsi/qla4xxx/ql4_os.c
index
Replacing strncpy with strlcpy to avoid strings that lacks null terminate.
Signed-off-by: Rickard Strandqvist
---
drivers/scsi/bfa/bfad_bsg.c |4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/scsi/bfa/bfad_bsg.c b/drivers/scsi/bfa/bfad_bsg.c
index 8994fb8..f22993
Just a quick glance:
a) this should move to drivers/target with the other target code
b) you're still having your own CDB emulation in there, the target code
should be taking care of all that.
--
To unsubscribe from this list: send the line "unsubscribe linux-scsi" in
the body of a message
Not sure what this buys us until other uses show up, but it looks
fine to me:
Reviewed-by: Christoph Hellwig
--
To unsubscribe from this list: send the line "unsubscribe linux-scsi" in
the body of a message to majord...@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-inf
Looks good,
Reviewed-by: Christoph Hellwig
--
To unsubscribe from this list: send the line "unsubscribe linux-scsi" in
the body of a message to majord...@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
On Fri, Jul 25, 2014 at 04:34:21PM -0400, Martin K. Petersen wrote:
> + return sectors >> (ilog2(bi->interval) - 9);
I was going to say this should be 'SECTOR_SHIFT', but that constant
or variants of it are only defined locally in various subsystems..
Looks good,
Reviewed-by: Christoph Hellw
> Christoph Hellwig (1):
> reserve block tags in scsi host
So you found this one useful. This begs the question how we should
move forward with it, as it will only work with the blk-mq path in
it's current form.
I can see three ways:
- we implement equivalent functionality in the old block t
I just saw this patch showing up again in the hpsa series, so let's get
the discussiong going on how to proceed again:
I think we can't simply apply the current version as it breaks the intended
semantics in the FC drivers that expect an array with target-wide ressources.
So if we want to go ahea
On Sat, Jul 26, 2014 at 11:14:35AM -0500, Stephen Cameron wrote:
> Hmm, I forgot that that patch was in there, I wasn't trying to keep pushing
> it along. From the previous discussion, I got the impression I was simply
> wrong, and that this patch wasn't needed, so I had meant to drop it, I just
>
Here's a formal one.
James, can I get your signoff for it?
Vladimir, can I get a reviewed-by from you (or anyone else)?
---
>From 73b1034ab1418e2dea75ccf642bc85c728b57313 Mon Sep 17 00:00:00 2001
From: James Bottomley
Date: Sat, 26 Jul 2014 12:21:26 -0400
Subject: scsi: use short driver name fo
I haven't done an in-depth review of the whole series, but it looks
generally good to me. How should we pull it in? Normally block
stuff should go through Jens, but the sd changes won't apply without
the various patches in the scsi tree.
--
To unsubscribe from this list: send the line "unsubscri
Can I get a quick review for this one?
On Mon, Jul 14, 2014 at 10:26:33AM +0200, Christoph Hellwig wrote:
> port_detect is only called from the module_init routine and thus implicitly
> serialized, so remove the driver lock which was held over potentially
> sleeping function calls.
>
> Signed-off
> "Christoph" == Christoph Hellwig writes:
Christoph> How should we pull it in? Normally block stuff should go
Christoph> through Jens, but the sd changes won't apply without the
Christoph> various patches in the scsi tree.
Typically Jens and James stagger their merges when we do this. But
> "Christoph" == Christoph Hellwig writes:
Christoph> Here's a formal one. James, can I get your signoff for it?
Christoph> Vladimir, can I get a reviewed-by from you (or anyone else)?
Reviewed-by: Martin K. Petersen
--
Martin K. Petersen Oracle Linux Engineering
--
To unsubscribe
> "Christoph" == Christoph Hellwig writes:
Christoph> Can I get a quick review for this one?
Reviewed-by: Martin K. Petersen
--
Martin K. Petersen Oracle Linux Engineering
--
To unsubscribe from this list: send the line "unsubscribe linux-scsi" in
the body of a message to majord...@v
Replacing strncpy with strlcpy to avoid strings that lacks null terminate.
And removed unnecessary magic numbers.
Signed-off-by: Rickard Strandqvist
---
drivers/scsi/mpt2sas/mpt2sas_base.c | 31 +++
1 file changed, 15 insertions(+), 16 deletions(-)
diff --git a/dri
Replacing strncpy with strlcpy to avoid strings that lacks null terminate.
And removed unnecessary magic numbers.
Signed-off-by: Rickard Strandqvist
---
drivers/scsi/mpt3sas/mpt3sas_base.c |2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/scsi/mpt3sas/mpt3sas_base.c
> "KY" == KY Srinivasan writes:
>> The LBP VPD page flags UNMAP as being supported. Do you actually
>> support UNMAP to DSM TRIM SCSI-ATA translation?
KY> I have been told by the Windows folks that this is done. I am trying
KY> to get additional details.
Great! I'd just like to have a reaso
> -Original Message-
> From: Martin K. Petersen [mailto:martin.peter...@oracle.com]
> Sent: Saturday, July 26, 2014 9:55 AM
> To: KY Srinivasan
> Cc: Martin K. Petersen; Sitsofe Wheeler; Christoph Hellwig;
> gre...@linuxfoundation.org; linux-ker...@vger.kernel.org;
> de...@linuxdriverproj
> "KY" == KY Srinivasan writes:
>> Great! I'd just like to have a reasonable level of confidence in
>> what's happening down the stack before I entertain turning something
>> on that's not being properly advertised.
KY> As I look at the output of inquiry between Linux on Hyper-V and
KY> nati
Hello,
First of all I've just subscribed the linux-scsi thread. I hope you
get my email the right way.
I have also problems with Jmicron JMS567 mobile rack.
I tried on different kernels:
3.15.5
3.16.rc6
the 'Invalid field in cdb' errors disappeared but still not ok.
I got the following errors w
On Fri, Jul 25, 2014 at 07:46:56AM -0700, James Bottomley wrote:
> On Fri, 2014-07-25 at 15:23 +0100, Pawel Moll wrote:
> > The host devices without a parent were "forcefully adopted"
> > by platform bus. This patch removes this assignment. In
> > effect the dev_dev may be NULL now, which means ISA
If you are going to use memset before strncpy you must copy sizeof -1
Signed-off-by: Rickard Strandqvist
---
drivers/scsi/scsi_tgt_if.c |2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/scsi/scsi_tgt_if.c b/drivers/scsi/scsi_tgt_if.c
index 6209110..7dc98eb 100644
---
On Sat, 26 Jul 2014, Laszlo T. wrote:
> Hello,
>
> First of all I've just subscribed the linux-scsi thread. I hope you
> get my email the right way.
>
> I have also problems with Jmicron JMS567 mobile rack.
>
> I tried on different kernels:
> 3.15.5
> 3.16.rc6
> the 'Invalid field in cdb' error
> -Original Message-
> From: Martin K. Petersen [mailto:martin.peter...@oracle.com]
> Sent: Saturday, July 26, 2014 12:25 PM
> To: KY Srinivasan
> Cc: Martin K. Petersen; Sitsofe Wheeler; Christoph Hellwig;
> gre...@linuxfoundation.org; linux-ker...@vger.kernel.org;
> de...@linuxdriverpro
On Sat, 2014-07-26 at 13:11 -0700, Greg Kroah-Hartman wrote:
> On Fri, Jul 25, 2014 at 07:46:56AM -0700, James Bottomley wrote:
> > On Fri, 2014-07-25 at 15:23 +0100, Pawel Moll wrote:
> > > The host devices without a parent were "forcefully adopted"
> > > by platform bus. This patch removes this a
41 matches
Mail list logo