Thanks Himanshu,
Reviewed-by: Johannes Thumshirn
--
Johannes Thumshirn Storage
jthumsh...@suse.de+49 911 74053 689
SUSE LINUX GmbH, Maxfeldstr. 5, 90409 Nürnberg
GF: Felix Imendörffer, Jane Smithard, Graham Norton
HRB 21284
With an updated changelog,
Reviewed-by: Johannes Thumshirn
--
Johannes Thumshirn Storage
jthumsh...@suse.de+49 911 74053 689
SUSE LINUX GmbH, Maxfeldstr. 5, 90409 Nürnberg
GF: Felix Imendörffer, Jane Smithard, Graham Norton
On Wed, Jul 19, 2017 at 08:44:13PM +, Bart Van Assche wrote:
> "cleaned up code" is a very vague description. Please be more specific and
> please also mention in the patch description what functionality has been
> changed (if any).
Hi Bart,
These are just some style changes I requested when
On Wed, 2017-07-19 at 14:50 +0200, Greg KH wrote:
> From: Greg Kroah-Hartman
>
> It's better to use the DRIVER_ATTR_RW() and DRIVER_ATTR_RO() macros to
> explicitly show that this is a read/write or read/only sysfs file. So
> convert the remaining SCSI drivers that use the old style to use the
>
On Wed, 2017-07-19 at 17:06 -0500, Gustavo A. R. Silva wrote:
> Remove unnecessary static on local variables raid_device.
> Such variables are initialized before being used, on
> every execution path throughout the functions. The
> static has no benefit and, removing it reduces the
> object file si
This patch adds 3 helper functions to set the initial target id, expander
id and port id numbers.
The ARC/HBA1000 product line exposes RAID drives on bus number 0 and
sas transport HBA drives use bus 0 as well. We wanted to differentiate
between the RAID and HBA targets when the adapter in mixed
Remove unnecessary static on local variables raid_device.
Such variables are initialized before being used, on
every execution path throughout the functions. The
static has no benefit and, removing it reduces the
object file size.
This issue was detected using Coccinelle and the following semantic
Hi Bart,
> On Jul 19, 2017, at 1:44 PM, Bart Van Assche wrote:
>
> On Wed, 2017-07-19 at 11:51 -0700, Himanshu Madhani wrote:
>> This patch cleaned up code to make it more readable
>
> Hello Himanshu,
>
> "cleaned up code" is a very vague description. Please be more specific and
> please also
On Wed, 2017-07-19 at 11:51 -0700, Himanshu Madhani wrote:
> From: Duane Grigsby
Hello Himanshu and Duane,
Too many drivers create workqueues for all kinds of purposes. Why is it
necessary to execute qla_nvme_io_work() on the context of a new workqueue?
If any of the existing system workqueues c
On Wed, 2017-07-19 at 11:51 -0700, Himanshu Madhani wrote:
> This patch cleaned up code to make it more readable
Hello Himanshu,
"cleaned up code" is a very vague description. Please be more specific and
please also mention in the patch description what functionality has been
changed (if any).
B
From: Duane Grigsby
Add support to the driver to set the exchange threshold value for
the number of outstanding AENs.
Signed-off-by: Duane Grigsby
Signed-off-by: Darren Trapp
Signed-off-by: Anil Gurumurthy
Signed-off-by: Himanshu Madhani
---
drivers/scsi/qla2xxx/qla_dbg.c | 2 +-
drivers/
From: Quinn Tran
Cc: Bart Van Assche
Signed-off-by: Quinn Tran
Signed-off-by: Himanshu Madhani
---
drivers/scsi/qla2xxx/qla_bsg.c| 51 ---
drivers/scsi/qla2xxx/qla_def.h| 31 +++-
drivers/scsi/qla2xxx/qla_init.c | 7 +++---
dr
Hi Martin,
This series addresses review comments for previously submitted series for
Target MQ and FC-NVMe support.
Patch 1, 2 addresses review comments by Johannes for FC-NVMe series
(https://www.spinics.net/lists/linux-scsi/msg110077.html)
(https://www.spinics.net/lists/linux-scsi/msg109985.h
Cc: Johannes Thumshirn
Signed-off-by: Himanshu Madhani
---
drivers/scsi/qla2xxx/qla_gbl.h | 11 ---
drivers/scsi/qla2xxx/qla_isr.c | 4 ++--
drivers/scsi/qla2xxx/qla_nvme.c | 9 -
drivers/scsi/qla2xxx/qla_nvme.h | 17 +
4 files changed, 23 insertions(+), 18 de
From: Duane Grigsby
When NVMe commands encounter error NVMe FC transport needs to
teardown the connection. This patch adds worker thread to process
these IO errors.
Signed-off-by: Duane Grigsby
Signed-off-by: Himanshu Madhani
---
drivers/scsi/qla2xxx/qla_def.h | 2 ++
drivers/scsi/qla2xxx/q
Simplified waiting for unregister local/remote FC-NVMe ports
to complete cleanup.
Signed-off-by: Duane Grigsby
Signed-off-by: Darren Trapp
Signed-off-by: Anil Gurumurthy
Signed-off-by: Himanshu Madhani
---
drivers/scsi/qla2xxx/qla_def.h | 5 ++--
drivers/scsi/qla2xxx/qla_nvme.c | 59 +++
This patch cleaned up code to make it more readable
Cc: Johannes Thumshirn
Signed-off-by: Himanshu Madhani
---
drivers/scsi/qla2xxx/qla_def.h | 6 ++--
drivers/scsi/qla2xxx/qla_nvme.c | 61 ++---
drivers/scsi/qla2xxx/qla_os.c | 6 ++--
3 files changed, 3
Signed-off-by: Duane Grigsby
Signed-off-by: Himanshu Madhani
---
drivers/scsi/qla2xxx/qla_isr.c | 37 +++--
drivers/scsi/qla2xxx/qla_nvme.c | 11 ---
2 files changed, 39 insertions(+), 9 deletions(-)
diff --git a/drivers/scsi/qla2xxx/qla_isr.c b/drivers/
From: Greg Kroah-Hartman
It's better to use the DRIVER_ATTR_RW() and DRIVER_ATTR_RO() macros to
explicitly show that this is a read/write or read/only sysfs file. So
convert the remaining SCSI drivers that use the old style to use the
newer macros.
Bonus is that this removes some checkpatch.pl
qedi uses iscsi_boot_sysfs to export the targets used
for boot to sysfs. Select the config option to make sure
the module is built.
This addresses the compile time issue,
drivers/scsi/qedi/qedi_main.o: In function `qedi_remove':
qedi_main.c:(.text+0x3bbd): undefined reference to `iscsi_boo
> -Original Message-
> From: Shivasharan Srikanteshwara
> [mailto:shivasharan.srikanteshw...@broadcom.com]
> Sent: Wednesday, July 12, 2017 1:51 PM
> To: Kashyap Desai; 'Christoph Hellwig'
> Cc: 'linux-scsi@vger.kernel.org'; 'martin.peter...@oracle.com';
> 'the...@redhat.com'; 'j...@linux.v
On Wed, Jul 19, 2017 at 03:13:34AM -0500, Jason L Tibbitts III wrote:
> [ 46.304530] sg_is_valid_dxfer: dxfer_direction: -2, dxfer_len: 0
Ahh now I see the -2 (SG_DXFER_TO_DEV) is the crucial point here. It is 0 in
your case.
This would "fix" it but I'm not generally sure it is _the_ solution:
> "JT" == Johannes Thumshirn writes:
JT> Can you please apply this debugging patch, so I can see what's going
JT> on.
Sure, no problem.
I generally run "mtx -f /dev/sg7 status" first just to make sure the
library is there; this has always worked as expected. With the debug
patch applied, t
Hi Elliott,
We are maintaining NVMe drives as scsi device in mpt3sas driver.
There are lot of firmware/hardware level dependencies and after lot of
discussions we arrived this value (128).
So, we prefer not to provide module parameter to change this at least for now.
Thanks,
Suganath Prabu S
On T
On Tue, Jul 18, 2017 at 12:33:59PM -0500, Jason L Tibbitts III wrote:
> I have verified that building a clean v4.12 with
> 68c59fcea1f2c6a54c62aa896cc623c1b5bc9b47 cherry picked on top still
> shows the problem:
>
> [root@backup2 ~]# mtx -f /dev/sg7 next 0
> Unloading drive 0 into Storage Element
26 matches
Mail list logo