lib/sg_pool.c:152:3-18: WARNING: NULL check before freeing functions like
kfree, debugfs_remove, debugfs_remove_recursive or usb_free_urb is not needed.
Maybe consider reorganizing relevant code to avoid passing NULL values.
lib/sg_pool.c:154:3-21: WARNING: NULL check before freeing functions lik
Hi Ming,
[auto build test WARNING on scsi/for-next]
[also build test WARNING on v4.5 next-20160322]
[if your patch is applied to the wrong git tree, please drop us a note to help
improving the system]
url:
https://github.com/0day-ci/linux/commits/Ming-Lin/mempool-based-chained-scatterlist
On Tue, 22 Mar 2016, Ondrej Zary wrote:
> Tested on HP C2502 (53C400A chip), Canon FG2-5202 (53C400 chip) and
> DTC-3181L (DTCT-436P chip) ISA cards - everything works fine!
>
> Thanks.
Thanks for testing, Ondrej.
>
> Tested-by: Ondrej Zary
Hannes, would you please take a look at patches 0
On Monday 21 March 2016 03:31:49 Finn Thain wrote:
>
> This patch series has more macro elimination and some tweaks to the
> DMA hooks so that all the wrapper drivers can share the same core
> DMA algorithm. This resolves the major discrepancies between the two
> core drivers, which relate to code
From: Ming Lin
Parameter "bool mq" is block driver specific.
Change it to "first_chunk" to make it more generic.
Signed-off-by: Ming Lin
---
drivers/scsi/scsi_lib.c | 20 ++--
1 file changed, 10 insertions(+), 10 deletions(-)
diff --git a/drivers/scsi/scsi_lib.c b/drivers/scsi
From: Ming Lin
The fist 4 patches make the SG related definitions/structs/functions
in SCSI code generic and the last patch move it to lib/sg_pool.c.
I still keep the macro "SG_MEMPOOL_NR" since it's used in 3 places.
v2:
- do modification in scsi code first then move to lib/sg_pool.c
- add
From: Ming Lin
Replace parameter "struct scsi_data_buffer" with "struct sg_table" in
SG alloc/free functions to make them generic.
Signed-off-by: Ming Lin
---
drivers/scsi/scsi_lib.c | 41 +++--
1 file changed, 23 insertions(+), 18 deletions(-)
diff --git a
From: Ming Lin
Rename SCSI_MAX_SG_SEGMENTS to SG_CHUNK_SIZE, which means the amount
we fit into a single scatterlist chunk.
Rename SCSI_MAX_SG_CHAIN_SEGMENTS to SG_MAX_SEGMENTS.
Will move these 2 generic definitions to scatterlist.h later.
Signed-off-by: Ming Lin
---
drivers/ata/pata_icside.
From: Ming Lin
Rename SCSI specific struct and functions to more genenic names.
Signed-off-by: Ming Lin
---
drivers/scsi/scsi_lib.c | 52 -
1 file changed, 26 insertions(+), 26 deletions(-)
diff --git a/drivers/scsi/scsi_lib.c b/drivers/scsi/scs
From: Ming Lin
Now it's ready to move the mempool based SG chained allocator code from
SCSI driver to lib/sg_pool.c, which will be compiled only based on a Kconfig
symbol CONFIG_SG_POOL.
SCSI selects CONFIG_SG_POOL.
Signed-off-by: Ming Lin
---
drivers/scsi/Kconfig| 1 +
drivers/scsi
Hi Sreekanth,
Am 22.03.2016 um 11:52 schrieb Sreekanth Reddy:
> Hi Matthias,
>
> Thanks for providing detail explanation.
>
> Currently I am trying to reproduce this issue locally. I have used the
> same HBA card but still I am not able to reproduce this issue on 4.5
> kernel.
>
> I will try fo
> -Original Message-
> From: KY Srinivasan
> Sent: Sunday, March 20, 2016 11:59 AM
> To: 'James Bottomley' ; Martin
> K. Petersen
> Cc: Christoph Hellwig ; gre...@linuxfoundation.org;
> linux-ker...@vger.kernel.org; de...@linuxdriverproject.org;
> oher...@suse.com; jbottom...@parallels.c
There's little point in breaking these strings over multiple lines.
Signed-off-by: Rasmus Villemoes
Reviewed-by: Hannes Reinecke
---
drivers/scsi/constants.c | 27 +--
1 file changed, 9 insertions(+), 18 deletions(-)
diff --git a/drivers/scsi/constants.c b/drivers/scsi/
On 64 bit, struct error_info has 6 bytes of padding, which amounts to
over 4k of wasted space in the additional[] array. We could easily get
rid of that by instead using separate arrays for the codes and the
pointers. However, we can do even better than that and save an
additional 6 bytes per entry
This is a purely mechanical move of the list of additional sense codes
to a separate file, in preparation for reducing the impact of choosing
CONFIG_SCSI_CONSTANTS=y by about 8k.
Signed-off-by: Rasmus Villemoes
Reviewed-by: Hannes Reinecke
---
drivers/scsi/constants.c | 830 +-
This is mostly identical to v2 sent in November, rebased (cleanly) to
current mainline. The only change is that I've this time also updated
the Kconfig help text in 3/3, since the 75 KB was a bit
exaggerated. After these patches are applied, the impact of choosing
CONFIG_SCSI_CONSTANTS=y is about 3
Hello Linus,
Here are the target updates for v4.6-rc1 code.
Please go ahead and pull from:
git://git.kernel.org/pub/scm/linux/kernel/git/nab/target-pending.git for-next
The highlights this round include:
- Add target_alloc_session() w/ callback helper for doing se_session
allocation +
On 03/21/2016 09:40 PM, Laurence Oberman wrote:
> Hello Hannes
>
> Please share latest scripts and an example of how you are using them.
> I have some scripts from last November, that you posted but I am sure they
> have changed.
> If not then I will modify them as appropriate, just let me know.
On 03/18/2016 01:45 PM, Calvin Owens wrote:
In _base_make_ioc_operational(), we walk ioc->reply_queue_list and pull
a pointer out of successive elements of ioc->reply_post[] for each entry
in that list if RDPQ is enabled.
Since the code pulls the pointer for the next iteration at the bottom of
t
On Tuesday 22 March 2016 07:43:19 James Bottomley wrote:
> > diff --git a/drivers/scsi/ufs/Kconfig b/drivers/scsi/ufs/Kconfig
> > index 5f4530744e0a..097894a1fab5 100644
> > --- a/drivers/scsi/ufs/Kconfig
> > +++ b/drivers/scsi/ufs/Kconfig
> > @@ -37,6 +37,7 @@ config SCSI_UFSHCD
> > depends
On Tue, 2016-03-22 at 08:14 +0100, Hannes Reinecke wrote:
> On 03/22/2016 02:16 AM, Martin K. Petersen wrote:
> >> "Hannes" == Hannes Reinecke writes:
> >
> > Hannes> in sd_read_capacity() the sdkp->capacity field changes its
> > Hannes> meaning: after the call to read_capacity_XX() it carrie
On Thu, 2016-03-17 at 13:29 +0100, Arnd Bergmann wrote:
> A recent change to ufshcd introduced a call to utf16s_to_utf8s,
> a function that is provided by the NLS module, so we get a link
> error when that is not present:
>
> drivers/scsi/built-in.o: In function `ufshcd_read_string_desc':
> :(.tex
> -Original Message-
> From: Colin King [mailto:colin.k...@canonical.com]
> Sent: Sunday, March 20, 2016 10:34 PM
> To: Kashyap Desai; Sumit Saxena; James Bottomley; Martin K . Petersen;
> megaraidlinux@avagotech.com; linux-scsi@vger.kernel.org
> Cc: linux-ker...@vger.kernel.org
> Subje
Hi Matthias,
Thanks for providing detail explanation.
Currently I am trying to reproduce this issue locally. I have used the
same HBA card but still I am not able to reproduce this issue on 4.5
kernel.
I will try for few more times and I will also try to get the diff
between 4.1 to 4.5 kernels w
Martin,
This patch is being reviewed , we shall get back with reviews by
tomorrow.
Thanks,
Chaitra
-Original Message-
From: Martin K. Petersen [mailto:martin.peter...@oracle.com]
Sent: Tuesday, March 22, 2016 6:00 AM
To: Calvin Owens
Cc: Sathya Prakash; Chaitra P B; Suganath Prabu Subra
On Tue, Mar 08, 2016 at 08:52:32PM +0100, Rasmus Villemoes wrote:
> On Tue, Nov 24 2015, Rasmus Villemoes wrote:
>
> > This reduces the impact of choosing CONFIG_SCSI_CONSTANTS by about 8KB.
> >
>
> ping? does anyone feel like picking these up?
Please resend them against the current tree. I'm
On 03/22/2016 02:16 AM, Martin K. Petersen wrote:
>> "Hannes" == Hannes Reinecke writes:
>
> Hannes> in sd_read_capacity() the sdkp->capacity field changes its
> Hannes> meaning: after the call to read_capacity_XX() it carries the
> Hannes> _unscaled_ values, making the comparison between the
27 matches
Mail list logo