On Mon, Feb 15, 2016 at 07:01:29PM +, Alan wrote:
> Check the array size *before* dereferencing it with a user provided offset
>
> Signed-off-by: Alan Cox
> ---
> drivers/scsi/esas2r/esas2r_ioctl.c |5 +++--
> 1 file changed, 3 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/scsi
On Mon, Feb 15, 2016 at 07:11:56PM +, Alan wrote:
> If you feed 32 bytes in then the kstrtoull() doesn't receive a terminated
> string so will run off the end.
>
> Signed-off-by: Alan Cox
> ---
> drivers/scsi/lpfc/lpfc_debugfs.c |4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
On 02/15/2016 07:53 PM, Alan wrote:
> We were setting the queue depth correctly, then setting it back to two. If
> you hit this as a bisection point then please send me an email as it would
> imply we've been hiding other bugs with this one.
>
> Signed-off-by: Alan Cox
> ---
> drivers/scsi/aic7x
the failure of ioc->reset_work_q is checked,
but not ioc->fw_event_q.
Signed-off-by: Insu Yun
---
drivers/message/fusion/mptbase.c | 7 +++
1 file changed, 7 insertions(+)
diff --git a/drivers/message/fusion/mptbase.c b/drivers/message/fusion/mptbase.c
index 5dcc031..d4907a1 100644
--- a/dr
https://bugzilla.kernel.org/show_bug.cgi?id=111341
--- Comment #4 from walter59 ---
sorry --- bug is always on -- only on the one board with c600 intel it works,
five other boards doesnt . all asus boards x79 / 2011 Intel.
in next days me look for differenz between bios and so on !
regards
-
https://bugzilla.kernel.org/show_bug.cgi?id=111341
--- Comment #3 from walter59 ---
fine --- changes in kernel 4.5-rc4 ahci for c600 intel id 1d02 now ok !
thanks to all !
--
You are receiving this mail because:
You are watching the assignee of the bug.
--
To unsubscribe from this list: s
If you feed 32 bytes in then the kstrtoull() doesn't receive a terminated
string so will run off the end.
Signed-off-by: Alan Cox
---
drivers/scsi/lpfc/lpfc_debugfs.c |4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/scsi/lpfc/lpfc_debugfs.c b/drivers/scsi/lpfc/l
Hi Nic,
On 2/12/16, 11:03 PM, "Nicholas A. Bellinger" wrote:
>Hi Himanshu & Co,
>
>On Fri, 2016-02-12 at 00:48 -0800, Nicholas A. Bellinger wrote:
>> On Fri, 2016-02-12 at 05:30 +, Himanshu Madhani wrote:
>
>
>
>> Thanks for the crash dump output.
>>
>> So it's a t_state = TRANSPORT_WRITE
On Mon, 2016-02-15 at 18:53 +, Alan wrote:
> We were setting the queue depth correctly, then setting it back to
> two. If you hit this as a bisection point then please send me an
> email as it would imply we've been hiding other bugs with this one.
>
> Signed-off-by: Alan Cox
> ---
> drive
Check the array size *before* dereferencing it with a user provided offset
Signed-off-by: Alan Cox
---
drivers/scsi/esas2r/esas2r_ioctl.c |5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/drivers/scsi/esas2r/esas2r_ioctl.c
b/drivers/scsi/esas2r/esas2r_ioctl.c
index baf
We were setting the queue depth correctly, then setting it back to two. If
you hit this as a bisection point then please send me an email as it would
imply we've been hiding other bugs with this one.
Signed-off-by: Alan Cox
---
drivers/scsi/aic7xxx/aic7xxx_osm.c |1 +
1 file changed, 1 inser
On Fri, Feb 12, 2016 at 09:54:51AM -0800, James Bottomley wrote:
> On Fri, 2016-02-12 at 09:38 -0800, Lee Duncan wrote:
> > The scsi_transport_iscsi module already uses the ida_simple
> > routines for managing the target ID, if requested to do
> > so. This change replaces an ever-increasing atomic
call Rx thread function if registered
by transport driver, so that transport
drivers can use iscsi-target Rx thread
for Rx processing.
update iSER target driver to use this
interface.
Signed-off-by: Varun Prakash
Other than the handler name, looks harmless.
Acked-by: Sagi Grimberg
--
To u
1. void (*iscsit_rx_pdu)(struct iscsi_conn *);
Rx thread uses this for receiving and processing
iSCSI PDU in full feature phase.
Is iscsit_rx_pdu the best name for this? it sounds like
a function that would handle A pdu, but it's actually the
thread function dequeuing pdus correct?
--
On 14/02/2016 19:42, Varun Prakash wrote:
clear tx_thread_active for ISCSI_TCP_CXGB4
transport in logout_post_handler functions.
Signed-off-by: Varun Prakash
---
drivers/target/iscsi/iscsi_target.c | 6 --
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a/drivers/target/isc
On 14/02/2016 19:42, Varun Prakash wrote:
ISCSI_TCP_CXGB4 driver waits on conn_logout_comp as
ISCSI_TCP driver so call complete if transport type
is ISCSI_TCP_CXGB4.
Signed-off-by: Varun Prakash
---
drivers/target/iscsi/iscsi_target.c | 10 ++
1 file changed, 6 insertions(+), 4 del
Adding UFS 2.0 support to the UFS core driver.
Signed-off-by: Joao Pinto
---
Changes v7->v8:
- Added "jedec, ufs-2.0" to the ufschd-platform compatibility strings
Changes v0->v7:
- Nothing changed (just to keep up with patch set version).
.../devicetree/bindings/ufs/ufshcd-pltfrm.txt | 4
Fixed typo in ufshcd-pltfrm.
Signed-off-by: Joao Pinto
---
Changes v0->v8:
- Nothing changed (just to keep up with patch set version).
drivers/scsi/ufs/ufshcd-pltfrm.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/scsi/ufs/ufshcd-pltfrm.c b/drivers/scsi/ufs/ufshcd-
This patch has the goal to add support for DesignWare UFS Controller
specific operations and to add specific platform and pci drivers.
Signed-off-by: Joao Pinto
---
Changes v7->v8 (Akinobu Mita):
- DME sets were simplified for easier reading
- CLK DIV default values definitions names were changed
The work consisted of:
- Fixed typo in ufshcd-pltfrm.c
- Tweak ufshcd.c for UFS 2.0 support
- Implement ufshcd-dwc which contains all DWC HW specific code
- Unipro attributes were added and new registers were added to the driver
- Implement a ufs-dwc glue platform driver
- Implement a ufs-dwc-pci g
Hi Akinobu,
On 2/13/2016 1:27 PM, Akinobu Mita wrote:
> Hi Joao,
>
> 2016-02-11 21:13 GMT+09:00 Joao Pinto :
>> +static int ufshcd_dwc_connection_setup(struct ufs_hba *hba)
>> +{
>> + int ret = 0;
>> +
>> + /* Local side Configuration */
>> + ret = ufshcd_dme_set(hba, UIC_ARG_MI
The RTPG buffer will only evaluated within alua_rtpg(),
so we can allocate it locally there and avoid having to
put it into the global structure.
Reviewed-by: Ewan Milne
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/device_handler/scsi_dh_alua.c | 57 ++
as promised here is now the second part of my ALUA device handler update.
This contains a major rework of the ALUA device handler as execution is
moved onto a workqueue. This has the advantage that we avoid having to
do multiple calls to the same LUN (as happens frequently when failing
over a LUN w
The 'activate_complete' function needs to be executed after
stpg has finished, so we can as well execute stpg synchronously
and call the function directly.
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/device_handler/scsi_dh_alua.c | 156 ++--
If the call to SET TARGET PORT GROUPS fails we have no idea what
state the array is left in, so we need to issue a call to
REPORT TARGET PORT GROUPS in these cases.
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/device_handler/scsi_dh_alua.c | 2 ++
1 file change
When we read in the target port group state we should be
updating all affected port groups, otherwise we risk
running out of sync.
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/device_handler/scsi_dh_alua.c | 35 ++
1 file changed, 26
Some arrays may only capable of handling one STPG at a time,
so this patch adds a singlethreaded workqueue for STPGs to be
submitted synchronously.
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/device_handler/scsi_dh_alua.c | 21 ++---
1 file cha
Rework alua_check_vpd() to use scsi_vpd_get_tpg()
and move the port group selection into the function, too.
With that we can simplify alua_initialize() to just
call alua_check_tpgs() and alua_check_vpd();
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/device_hand
If a device needs to be rescanned the device_handler might need
to be rechecked, too.
So add a 'rescan' callback to the device handler and call it
upon scsi_rescan_device(). The rescan callback will be invoked
from the Unit Attention handling of ASC/ASCQ 3F 03
(INQUIRY DATA HAS CHANGED).
Reviewed-
Sending a 'REPORT TARGET PORT GROUP' command is a costly operation,
as the array has to gather information about all ports.
So instead of using RTPG to poll for a status update when a port
is in transitioning we should be sending a TEST UNIT READY, and
wait for the sense code to report success.
Si
The 'relative port' field is not used, and might get stale when
the port group changes. So remove the field altogether.
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/device_handler/scsi_dh_alua.c | 6 +-
1 file changed, 1 insertion(+), 5 deletions(-)
diff -
When we receive a unit attention code of 'ALUA state changed'
we should recheck the state, as it might be due to an implicit
ALUA state transition. This allows us to return NEEDS_RETRY
instead of ADD_TO_MLQUEUE, allowing to terminate the retries
after a certain time.
At the same time a workqueue it
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/device_handler/scsi_dh_alua.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/scsi/device_handler/scsi_dh_alua.c
b/drivers/scsi/device_handler/scsi_dh_alua.c
index 3199aef..c718318 100644
All commands are issued synchronously, so no need to open-code
scsi_execute_req_flags() anymore. And we can get rid of the
static sense code structure element. scsi_execute_req_flags()
will be setting REQ_QUIET and REQ_PREEMPT, but that is
perfectly fine as we're evaluating and logging any errors
o
The port group needs to be a separate structure as several
LUNs might belong to the same group.
Reviewed-by: Christoph Hellwig
Reviewed-by: Ewan Milne
Signed-off-by: Hannes Reinecke
---
drivers/scsi/device_handler/scsi_dh_alua.c | 181 -
include/scsi/scsi_dh.h
Track attached SCSI devices and update the 'access_state' field
whenever an ALUA state change has been detected.
Reviewed-by: Ewan Milne
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/device_handler/scsi_dh_alua.c | 48 --
1 file chan
scsi_proto.h now contains definitions for the ALUA state,
so we don't have to carry them in the device handler.
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/device_handler/scsi_dh_alua.c | 58 +-
1 file changed, 25 insertions(+), 33
Pass in the buffer as a function argument for submit_rtpg().
Reviewed-by: Martin K. Petersen
Reviewed-by: Christoph Hellwig
Reviewed-by: Bart Van Assche
Signed-off-by: Hannes Reinecke
---
drivers/scsi/device_handler/scsi_dh_alua.c | 13 +++--
1 file changed, 7 insertions(+), 6 deletio
Add a new blacklist flag BLIST_SYNC_ALUA to instruct the
alua device handler to use synchronous command submission
for ALUA commands.
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/device_handler/scsi_dh_alua.c | 2 ++
drivers/scsi/scsi_devinfo.c|
Add an 'access_state' attribute to struct scsi_device to
display the asymmetric LUN access state.
Reviewed-by: Ewan Milne
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/scsi_scan.c | 1 +
drivers/scsi/scsi_sysfs.c | 49 +++
The current ALUA device_handler has two drawbacks:
- We're sending a 'SET TARGET PORT GROUP' command to every LUN,
disregarding the fact that several LUNs might be in a port group
and will be automatically switched whenever _any_ LUN within
that port group receives the command.
- Whenever a L
When the optimize_stpg module option is set we should just set it
once during port_group allocation. Doing so allows us to override
it later with device specific settings.
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/device_handler/scsi_dh_alua.c | 13 ++---
This reverts commit a8e5a2d593cbfccf530c3382c2c328d2edaa7b66
Obsoleted by the next patch.
Reviewed-by: Christoph Hellwig
Reviewed-by: Ewan Milne
Signed-off-by: Hannes Reinecke
---
drivers/scsi/device_handler/scsi_dh_alua.c | 31 --
1 file changed, 12 insertions(+),
Use scsi_vpd_lun_id() to assign a unique device identification
to the alua port group structure.
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/device_handler/scsi_dh_alua.c | 55 +++---
1 file changed, 50 insertions(+), 5 deletions(-)
di
Separate out SET TARGET PORT GROUP functionality into a separate
function alua_stpg().
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/device_handler/scsi_dh_alua.c | 95 +++---
1 file changed, 61 insertions(+), 34 deletions(-)
diff --git
45 matches
Mail list logo