On 09/29/2015 03:47 AM, Hannes Reinecke wrote:
The 'activate_complete' function needs to be executed after
stpg has finished, so we can as well execute stpg synchronously
and call the function directly.
Hello Hannes,
Another patch in this series moves invocation of the STPG commands to
the co
On Thu, Oct 01, James Bottomley wrote:
> On Thu, 2015-10-01 at 20:30 +, KY Srinivasan wrote:
> > > +#if defined(CONFIG_X86_32)
> Um, this is a bit architecture specific (I know Azure is x86, but
> still). Can you make the define check CONFIG_32BIT rather than
> CONFIG_X86_32?
According to
On 09/29/2015 03:47 AM, Hannes Reinecke wrote:
If the call to SET TARGET PORT GROUPS fails we have no idea what
state the array is left in, so we need to issue a call to
REPORT TARGET PORT GROUPS in these cases.
Signed-off-by: Hannes Reinecke
Reviewed-by: Bart Van Assche
--
To unsubscribe fr
Hi James,
This series has been fairly well vetted. With cxlflash being a new driver the
majority
of these patches fix critical bugs. Is there anything else you're looking for
in order to
get this set pulled into 4.3-rc?
-matt
> On Oct 1, 2015, at 10:52 AM, Matthew R. Ochs
> wrote:
>
> This
On 09/27/2015 12:28 PM, Gionatan Danti wrote:
> Il 23-09-2015 17:18 Emmanuel Florac ha scritto:
>>
>> Use XFS. XFS won't let you mount it several time on different machines
>> without various "force" options.
>> Alternatively, use a cluster-aware FS like ocfs2. Ocfs2 is quite easy
>> to set up.
>
Le Sun, 27 Sep 2015 12:28:41 +0200
Gionatan Danti écrivait:
> Il 23-09-2015 17:18 Emmanuel Florac ha scritto:
> >
> > Use XFS. XFS won't let you mount it several time on different
> > machines without various "force" options.
> > Alternatively, use a cluster-aware FS like ocfs2. Ocfs2 is quite
>
On 10/01/2015 11:06 PM, Hannes Reinecke wrote:
On 10/02/2015 02:07 AM, Bart Van Assche wrote:
The old implementation calls the callback function 'fn' if the flag
TPGS_MODE_EXPLICIT has not been set but the new implementation not.
Please mention this in the patch description if this behavior chan
On Fri, 2015-10-02 at 15:34 +0200, Christoph Hellwig wrote:
> On Fri, Oct 02, 2015 at 06:25:01AM -0700, James Bottomley wrote:
> > That doesn't matter: if you modprobe alua after all devices are
> > discovered, it will attach correctly to all potential devices from the
> > alua module_init. This m
On Fri, Oct 02, 2015 at 06:25:01AM -0700, James Bottomley wrote:
> That doesn't matter: if you modprobe alua after all devices are
> discovered, it will attach correctly to all potential devices from the
> alua module_init. This means the effect is the same whether the
> request_module is sync or
On Fri, 2015-10-02 at 14:56 +0200, Christoph Hellwig wrote:
> On Wed, Sep 30, 2015 at 03:34:54PM -0700, James Bottomley wrote:
> > Perhaps we don't have to be that draconian. There's no real reason we
> > can't autoload asynchronously. If the module isn't ready by the time we
> > come to check th
On Fri, Oct 02, 2015 at 03:09:33PM +0200, Johannes Thumshirn wrote:
> Having the list_move() outside of the host_lock was purely by
> accident. Interestingly the stressing didn't mind it. But yes you're
> right, __scsi_remove_target() should be made host_lock() save for being
> called under the hos
On 1.10.2015 17:55, Matthew R. Ochs wrote:
> Found during code inspection, that the following functions are not
> being used outside of the file where they are defined. Make them static.
>
> int cxlflash_send_cmd(struct afu *, struct afu_cmd *);
> void cxlflash_wait_resp(struct afu *, struct afu_cm
On 1.10.2015 17:55, Matthew R. Ochs wrote:
> Limbo is not an accurate representation of this state and is
> also not consistent with the terminology that other drivers
> use to represent this concept. Rename the state and and its
> associated waitq to 'reset'.
>
> Signed-off-by: Matthew R. Ochs
>
On 1.10.2015 17:55, Matthew R. Ochs wrote:
> During an EEH freeze event, certain CXL services should not be
> called until after the hardware reset has taken place. Doing so
> can result in unnecessary failures and possibly cause other ill
> effects by triggering hardware accesses. This translates
Christoph Hellwig writes:
>> -list_for_each_entry(starget, &shost->__targets, siblings) {
>> +list_for_each_entry_safe(starget, tmp, &shost->__targets, siblings) {
>> if (starget->state == STARGET_DEL)
>> continue;
>> if (starget->dev.parent
On 1.10.2015 17:55, Matthew R. Ochs wrote:
> The context encode mask covers more than 32-bits, making it
> a long integer. This should be noted by appending the ULL
> width suffix to the mask.
>
> Signed-off-by: Matthew R. Ochs
> Signed-off-by: Manoj N. Kumar
> Reviewed-by: Brian King
> Reviewed
On 1.10.2015 17:55, Matthew R. Ochs wrote:
> Using sizeof(bool) is considered poor form for various reasons and
> sparse warns us of that. Correct by changing type from bool to u8.
>
> Signed-off-by: Matthew R. Ochs
> Signed-off-by: Manoj N. Kumar
> Reviewed-by: Brian King
> Reviewed-by: Daniel
On 1.10.2015 17:55, Matthew R. Ochs wrote:
> If the same virtual LUN is accessed over multiple cards, only accesses
> made over the first card will be valid. Accesses made over the second
> card will go to the wrong LUN causing data corruption.
>
> This is because the global LUN's mode word was bei
On Wed, Sep 30, 2015 at 03:34:54PM -0700, James Bottomley wrote:
> Perhaps we don't have to be that draconian. There's no real reason we
> can't autoload asynchronously. If the module isn't ready by the time we
> come to check the attachment, then it will attach to the device later
> when the mod
On 1.10.2015 17:55, Matthew R. Ochs wrote:
> When a LUN is removed, the sdev that is associated with the LUN
> remains intact until its reference count drops to 0. In order
> to prevent an sdev from being removed while a context is still
> associated with it, obtain an additional reference per-cont
On Thu, Oct 01, 2015 at 02:34:54PM +1000, Paul Mackerras wrote:
> I still get the warning:
Ok, I sent you the wrong patch. scsi_dh_add_device is the function that
needs to switch to use __scsi_dh_lookup. New version below:
diff --git a/drivers/scsi/scsi_dh.c b/drivers/scsi/scsi_dh.c
index edb04
> - list_for_each_entry(starget, &shost->__targets, siblings) {
> + list_for_each_entry_safe(starget, tmp, &shost->__targets, siblings) {
> if (starget->state == STARGET_DEL)
> continue;
> if (starget->dev.parent == dev || &starget->dev == d
On 1.10.2015 17:54, Matthew R. Ochs wrote:
> From: Manoj Kumar
>
> The timeout value for read capacity is too small. Certain devices
> may take longer to respond and thus the command may prematurely
> timeout. Additionally the literal used for the timeout is stale.
>
> Update the timeout to 30 sec
On 1.10.2015 17:54, Matthew R. Ochs wrote:
> From: Manoj Kumar
>
> Magic numbers are not meaningful and can create confusion. As a
> remedy, replace them with descriptive literals.
>
> Replace 512 with literal MAX_SECTOR_UNIT.
> Replace 5 with literal CMD_RETRIES.
>
> Signed-off-by: Matthew R. Och
On 1.10.2015 17:54, Matthew R. Ochs wrote:
> From: Manoj Kumar
>
> If two concurrent MANAGE_LUN ioctls are issued with the same
> WWID parameter, it would result in an incorrect value of port_sel.
>
> This is because port_sel is modified without any locks being
> held. If the first caller stalls a
On 2.10.2015 02:52, Joel Stanley wrote:
> On Thu, Oct 1, 2015 at 6:01 PM, Johannes Thumshirn wrote:
>>> diff --git a/drivers/scsi/be2iscsi/be_main.c
>>> b/drivers/scsi/be2iscsi/be_main.c
>>> index 7a6dbfb..0b87abb 100644
>>> --- a/drivers/scsi/be2iscsi/be_main.c
>>> +++ b/drivers/scsi/be2iscsi/be
Lee Duncan writes:
> Simplify ida index allocation and removal by
> using the ida_simple_* helper functions
>
> Signed-off-by: Lee Duncan
> ---
> drivers/block/mtip32xx/mtip32xx.c | 26 ++
> 1 file changed, 6 insertions(+), 20 deletions(-)
>
> diff --git a/drivers/block/
Lee Duncan writes:
> Simplify ida index allocation and removal by
> using the ida_simple_* helper functions
>
> Signed-off-by: Lee Duncan
> ---
> drivers/base/soc.c | 21 +
> 1 file changed, 5 insertions(+), 16 deletions(-)
>
> diff --git a/drivers/base/soc.c b/drivers/base/
Lee Duncan writes:
> Simplify ida index allocation and removal by
> using the ida_simple_* helper functions.
>
> Signed-off-by: Lee Duncan
> ---
> drivers/block/rsxx/core.c | 20
> 1 file changed, 4 insertions(+), 16 deletions(-)
>
> diff --git a/drivers/block/rsxx/core.c b
Lee Duncan writes:
> Simplify ida index allocation and removal by
> using the ida_simple_* helper functions.
>
> Signed-off-by: Lee Duncan
> ---
> drivers/block/nvme-core.c | 16
> 1 file changed, 4 insertions(+), 12 deletions(-)
>
> diff --git a/drivers/block/nvme-core.c b/dri
Lee Duncan writes:
> Simplify ida index allocation and removal by
> using the ida_simple_* helper functions.
>
> Signed-off-by: Lee Duncan
> ---
> drivers/scsi/sd.c | 22 +-
> 1 file changed, 5 insertions(+), 17 deletions(-)
>
> diff --git a/drivers/scsi/sd.c b/drivers/scsi/
On 10/02/2015 10:21 AM, Johannes Thumshirn wrote:
> Removing a SCSI target via scsi_remove_target() suspected to be racy. When a
> sibling get's removed from the list it can occassionly happen that one CPU is
> stuck endlessly looping around this code block
>
> list_for_each_entry(starget, &shost-
Removing a SCSI target via scsi_remove_target() suspected to be racy. When a
sibling get's removed from the list it can occassionly happen that one CPU is
stuck endlessly looping around this code block
list_for_each_entry(starget, &shost->__targets, siblings) {
if (starget->state == STARGE
On Wed, Sep 16, 2015 at 08:47:43AM -0600, Khalid Aziz wrote:
> On 09/16/2015 08:06 AM, Sudip Mukherjee wrote:
> >We have been getting a warning about non ANSI function.
> >warning: non-ANSI function declaration of function 'FPT_SccbMgrTableInitAll'
> >
> >Signed-off-by: Sudip Mukherjee
> >---
> >
Joel Stanley writes:
> GCC 5 helpfully warns us that the WARN_ON check may be buggy:
>
> drivers/scsi/be2iscsi/be_main.c: In function ‘be_sgl_create_contiguous’:
> drivers/scsi/be2iscsi/be_main.c:3187:18: warning: logical not is only
> applied to the left hand side of comparison [-Wlogical-not-pa
Rasmus Villemoes writes:
> This saves a little .text and avoids the sizeof(...) style
> inconsistency.
>
> Signed-off-by: Rasmus Villemoes
> ---
> drivers/scsi/fnic/fnic_fcs.c | 4 +---
> 1 file changed, 1 insertion(+), 3 deletions(-)
>
> diff --git a/drivers/scsi/fnic/fnic_fcs.c b/drivers/scsi
36 matches
Mail list logo