On Thu, Nov 13, 2014 at 11:55:38PM +0100, Barto wrote:
> it's interesting, with this commit
> 74665016086615bbaa3fa6f83af410a0a4e029ee I have the bug :
>
> scsi: convert host_busy to atomic_t :
At this point we'll need a bisction between v3.16 as the last good
point, and 74665016086615bbaa3fa6f83
On Thu, Nov 13, 2014 at 12:50:58PM -0800, Andy Grover wrote:
> The tpg_check_* functions in the fabric_ops struct return 1 or 0,
> so we can make their return type bool. Change fabrics to match.
All these true/false stub sounds like some of them methods should be
optional, and a useful default sho
On 11/13/2014 06:07 PM, Charles Chiou wrote:
On 11/13/2014 01:27 AM, Christoph Hellwig wrote:
+static int stex_reboot_callback(struct notifier_block *self,
+ unsigned long val,
+ void *data)
+{
+if (val == SYS_RESTART)
+is
sg3_utils is a package of command line utilities for sending
SCSI and some ATA commands to devices. This package targets
the Linux 3, 2.6 and 2.4 kernel series. It has ports to
FreeBSD, Tru64, Solaris, and Windows (cygwin and MinGW).
There are three new utilities and major additions to several
ot
Hello Christoph,
> Please explicitly test commits:
>
> 71e75c97f97a9645d25fbf3d8e4165a558f18747
with commit 71e75c97f97a9645d25fbf3d8e4165a558f18747 there is no problem
> and
>
> 74665016086615bbaa3fa6f83af410a0a4e029ee
it's interesting, with this commit
74665016086615bbaa3fa6f83af410a0a4e029e
Only used as a param to core_disable_device_list_for_node(), but that
function doesn't use it.
Change function signature to remove that param, and change all callsites
to not pass LUNFLAGS_NO_ACCESS.
Signed-off-by: Andy Grover
---
drivers/target/target_core_device.c | 8 +++-
drivers/targ
The tpg_check_* functions in the fabric_ops struct return 1 or 0,
so we can make their return type bool. Change fabrics to match.
Signed-off-by: Andy Grover
---
drivers/infiniband/ulp/srpt/ib_srpt.c| 8
drivers/scsi/qla2xxx/tcm_qla2xxx.c | 10 +-
drivers/targe
LUNFLAGS_READ_WRITE is always the inverse of LUNFLAGS_READ_ONLY.
Removing this enum value resulted in some spots where a parameter's value
can be just true or false, which we can represent with a bool instead of
u32. Change to a bool named "lun_access_ro".
Signed-off-by: Andy Grover
---
drivers
On Thu, Nov 13, 2014 at 06:59:01PM +0100, Christoph Hellwig wrote:
All drivers use the implementation for ramping the queue up and down, so
instead of overloading the change_queue_depth method call the
implementation diretly if the driver opts into it by setting the
track_queue_depth flag in the
Dear Sir
Did your website get hit by Google Penguin update on October 17th 2014? What
basically is Google Penguin Update? It is actually a code name for Google
algorithm which aims at decreasing your websites search engine rankings that
violate Googles guidelines by using black hat SEO techniq
From: Anish Bhatt
Date: Wed, 12 Nov 2014 17:15:57 -0800
> Refactored all macros used in cxgb4i as part of previously started cxgb4 macro
> names cleanup. Makes them more uniform and avoids namespace collision.
> Minor changes in other drivers where required as some of these macros are used
> by
Merge two functions, and remove overly verbose debugging output that pokes
into mid-layer internal structures.
Signed-off-by: Christoph Hellwig
---
drivers/scsi/mpt2sas/mpt2sas_scsih.c | 34 +-
1 file changed, 5 insertions(+), 29 deletions(-)
diff --git a/drivers
Remove overly verbose debugging output that pokes into mid-layer internal
structures that looks like copy & paste from the mpt2/3 drivers.
Signed-off-by: Christoph Hellwig
---
drivers/scsi/vmw_pvscsi.c | 10 +-
1 file changed, 1 insertion(+), 9 deletions(-)
diff --git a/drivers/scsi/vmw
All drivers use the implementation for ramping the queue up and down, so
instead of overloading the change_queue_depth method call the
implementation diretly if the driver opts into it by setting the
track_queue_depth flag in the host template.
Note that a few drivers validated the new queue depth
Merge two functions, and remove overly verbose debugging output that pokes
into mid-layer internal structures.
Signed-off-by: Christoph Hellwig
---
drivers/scsi/mpt3sas/mpt3sas_scsih.c | 36 ++--
1 file changed, 10 insertions(+), 26 deletions(-)
diff --git a/driv
Drop the now unused reason argument from the ->change_queue_depth method.
Also add a return value to scsi_adjust_queue_depth, and rename it to
scsi_change_queue_depth now that it can be used as the default
->change_queue_depth implementation.
Signed-off-by: Christoph Hellwig
---
Documentation/sc
Overloading ->change_queue_depth with the queue ramp up / down
functionality has been a bad idea. It lead to a large amount
of code duplication, and driver keep getting the the API
wrong and end up accidentally enabling the queue depth tracking
while getting it wrong.
This serie instead adds a f
James Smart said the userspace to consume these events never emerged. Given
that these get in the way of the following patches remove support for them.
Signed-off-by: Christoph Hellwig
---
drivers/scsi/lpfc/lpfc_scsi.c | 66 ---
1 file changed, 66 deletio
We won't ever queue more commands than the host allows. Instead of
letting drivers either reject or ignore this case handle it in
common code. Note that various driver use internal constant or
variables that are assigned to both shost->can_queue and checked
in ->change_queue_depth - I did remove
On Thu, Nov 13, 2014 at 06:14:14PM +0100, Barto wrote:
> Hello Christoph,
>
> I tested this commit :
>
> 7ae65c0f9646c29432b69580b80e08632e6cd813 scsi: convert target_busy to an
> atomic_t
>
> http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=7ae65c0f9646c29432b69580b80e0
Hello Christoph,
I tested this commit :
7ae65c0f9646c29432b69580b80e08632e6cd813 scsi: convert target_busy to an
atomic_t
http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=7ae65c0f9646c29432b69580b80e08632e6cd813
there is no bug, boot process is ok whit this commit,
whe
I am not sure to understand your request, it's quite confusing,
you ask me to revert this commit and see if the bug is gone ? :
74665016086615bbaa3fa6f83af410a0a4e029ee scsi: convert host_busy to atomic_t
http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=74665016086615bba
Guenters commit just fixes the inversion from commit
71e75c97f97a9645d25fbf3d8e4165a558f18747 scsi: convert device_busy to atomic_t
Can you please test the commit before that:
74665016086615bbaa3fa6f83af410a0a4e029ee scsi: convert host_busy to atomic_t
and check if that works for you or not.
--
[adding the mpt maintainers as this seems to be a driver and not
midlayer issue]
On Wed, Nov 12, 2014 at 02:59:11PM -0500, Douglas Gilbert wrote:
> From a correspondent and my own testing I have seen way
> too many of these messages in the log:
>log_info(0x3116): originator(PL), code(0x16)
From: Martin Peschke
This patch removes some leftovers for commit
663e0890e31cb85f0cca5ac1faaee0d2d52880b5
"[SCSI] zfcp: remove access control tables interface".
The "access denied" case for ports is gone, as well.
The corresponding flag was cleared, but never set.
So clean it up.
Sysfs flag is
Through sysfs attributes, zfcp unit objects
provide a trigger for manual LUN recovery
and export information for problem determination.
With commit
f8210e34887e1feb977a9b6b8caa086855af40c9
"[SCSI] zfcp: Allow midlayer to scan for LUNs when running in NPIV mode"
and when attaching SCSI devices thro
James,
Here is a series of zfcp features for the upcoming merge window
preparing kernel v3.19.
The patches apply on top of the current misc branch of your scsi.git.
Steffen
Linux on System z Development
IBM Deutschland Research & Development GmbH
Vorsitzender des Aufsichtsrats: Martin Jetter
Ge
From: Martin Peschke
This patch improves the Fibre Channel port scan behaviour of the zfcp lldd.
Without it the zfcp device driver may churn up the storage area network by
excessive scanning and scan bursts, particularly in big virtual server
environments, potentially resulting in interference of
On Thu, Nov 13, 2014 at 12:33:41AM +, Elliott, Robert (Server Storage)
wrote:
> A queue_type of "none" disables the SCSI midlayer automatic queue depth
> adjustments based on TASK SET FULL vs. other status values, while
> "simple" enables them. That's the feature where TASK SET FULL reception
On 11/13/2014 01:27 AM, Christoph Hellwig wrote:
+static int stex_reboot_callback(struct notifier_block *self,
+ unsigned long val,
+ void *data)
+{
+ if (val == SYS_RESTART)
+
On 11/12/2014 06:43 PM, Christoph Hellwig wrote:
+ u8 yellowstone;
Calling this flag yellowstone seems a bit confusing as there already
is a st_yel card type, and this only seems a subset of those. Maybe
a ->support_pm flag or similar would be useful?
OK, I'll modify it.
+
Hello,
> Were you running with scsi_mod.use_blk_mq=Y or =N?
I don't find this value in my .config file related to kernel modules
options,
perhaps you talk about a kernel boot option for grub ?
I don't use this kernel option boot in grub ( scsi_mod.use_blk_mq ),
I use archlinux and his default k
32 matches
Mail list logo