The .eh_abort_handler needs to return SUCCESS, FAILED, or
FAST_IO_FAIL. So fixup all callers to adhere to this requirement.
Cc: Robert Elliott
Cc:
Signed-off-by: Hannes Reinecke
---
drivers/scsi/NCR5380.c| 2 +-
drivers/scsi/aha1740.c| 2 +-
drivers/scsi/esas2r/esas2r_m
Open-code scsi_print_result in sd.c, and cleanup logging to
not print duplicate informations.
With that we can remove scsi_show_result in constants.c
Reviewed-by: Robert Elliott
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/constants.c | 16
d
Simplify scsi_log_(send|completion) by externalizing
scsi_mlreturn_string() and always print the command address.
Reviewed-by: Robert Elliott
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/constants.c | 41 ++---
drivers/scsi/
Use the matching scope for logging messages to allow for
better command tracing.
Suggested-by: Robert Elliott
Reviewed-by: Robert Elliott
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/hosts.c | 4 +--
drivers/scsi/scsi_error.c | 77 ++
scsi_try_to_abort_cmd() should only return
SUCCESS, FAILED, or FAST_IO_FAIL. So document
that in the function description and simplify the
logging message.
Suggested-by: Christoph Hellwig
Reviewed-by: Robert Elliott
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scs
Like scmd_printk(), but the device name is passed in as
a string. Can be used by eg ULDs which do not have access
to the scsi_cmnd structure.
Reviewed-by: Robert Elliott
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/ch.c | 3 +--
drivers/scsi/sd.h
The EH statistics are per host, so we should be using
shost_printk() here.
Suggested-by: Robert Elliott
Reviewed-by: Robert Elliott
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/scsi_error.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/d
scsi_try_to_abort_cmd() might return SUCCESS, FAILED, or
FAST_IO_FAIL. So just checking for FAILED will treat
FAST_IO_FAIL as SUCCESS, which is wrong.
Cc: Robert Elliott
Signed-off-by: Hannes Reinecke
---
drivers/scsi/scsi_error.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --gi
Export functions for later use.
Reviewed-by: Robert Elliott
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/constants.c | 58
include/scsi/scsi_dbg.h | 2 ++
2 files changed, 46 insertions(+), 14 deletions(-)
di
Update acornscsi to use scsi_print_command() instead of the
underscore version and use scmd_printk() in acornscsi_done().
This will add correct device annotations in the resulting message.
And we should be using set_host_byte() for setting the
final result.
Reviewed-by: Robert Elliott
Reviewed-by
fas216 returns DID_BAD_TARGET for an incomplete data
transfer. The midlayer uses DID_BAD_TARGET to signal
a non-existing or not reachable target. So we should
rather be using DID_ERROR here.
Reviewed-by: Robert Elliott
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/s
There can be quite a lot of I/O error messages, even on smaller
machines. So we need to ratelimit them to not overwhelm logging.
Signed-off-by: Hannes Reinecke
---
drivers/scsi/scsi_lib.c | 30 ++
1 file changed, 18 insertions(+), 12 deletions(-)
diff --git a/drivers
Last caller is gone, so we can remove it.
Reviewed-by: Robert Elliott
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/constants.c | 35 ---
include/scsi/scsi_dbg.h | 1 -
2 files changed, 36 deletions(-)
diff --git a/drivers/scs
We should be using the standard dev_printk() variants for
sense code printing.
Reviewed-by: Robert Elliott
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/53c700.c | 2 +-
drivers/scsi/ch.c | 2 +-
drivers/scsi/constants.c | 117 ++
Remove all uncommented debugging code and move all
printk() statements over to dev_printk().
And while we're at it we should be doing a whitespace
cleanup, too.
Reviewed-by: Robert Elliott
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/aha152x.c | 994 ++
Instead of having two versions of print_opcode_name() we
should be consolidating them into one version.
Reviewed-by: Robert Elliott
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/constants.c | 88 ++--
1 file changed,
Calling scsi_print_command should not be necessary during abort;
if the information is required one should enable scsi logging.
Reviewed-by: Robert Elliott
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/53c700.c| 4 +---
drivers/scsi/NCR5380.c |
Currently we're only decoding sense extras for tape devices.
And even there only for fixed format sense formats.
As this is of rather limited use in the general case we should
be stop trying to decode sense extras; the tape driver does
its own decoding anyway.
Reviewed-by: Robert Elliott
Reviewed
Convert scsi_normalize_sense() and frieds to return 'bool'
instead of an integer.
Reviewed-by: Robert Elliott
Reviewed-by: Yoshihiro Yunomae
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/scsi_error.c | 16
drivers/scsi/scsi_lib.c | 2 +-
in
The 53c700 driver would be using scsi_print_sense() in a debug
statement, which was never compiled in. Plus the same information
can get retrieved with logging. So remove it.
Reviewed-by: Robert Elliott
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/53c700.c | 9
sd_done() was calling scsi_print_sense() for a sense code
of 'NO_SENSE'.
Reviewed-by: Robert Elliott
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/sd.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/scsi/sd.c b/drivers/scsi/sd.c
index 0cb5c9f..0ccb4
here is now the seventh iteration of my scsi logging update.
With this I've included another patch for ratelimiting
I/O error messages, which resolves the outstanding issue
noted by Robert Elliot.
Hannes Reinecke (27):
Remove scsi_cmd_print_sense_hdr()
sd: Remove scsi_print_sense() in sd_done(
print_opcode_name() was only ever called with a '0' argument
from LLDDs and ULDs which were _not_ supporting variable length
CDBs, so the 'if' clause was never triggered.
Instead we should be using the last argument to specify
the cdb length to avoid accidental overflow when reading
the cdb buffer.
Unused.
Reviewed-by: Robert Elliott
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/constants.c | 14 --
include/scsi/scsi_dbg.h | 2 --
2 files changed, 16 deletions(-)
diff --git a/drivers/scsi/constants.c b/drivers/scsi/constants.c
index d35a5d6
Implement a lookup array for SERVICE ACTION commands instead
of hardcoding it in a large switch statement.
Reviewed-by: Robert Elliott
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/constants.c | 131 +++
1 file change
Consolidate the CDB opcode lookup in scsi_opcode_sa_name(),
so that we don't have to call several functions to figure
out the CDB opcode string.
Reviewed_by: Robert Elliott
Reviewed-by: Christoph Hellweg
Signed-off-by: Hannes Reinecke
---
drivers/scsi/constants.c | 37 ++---
If scsi_normalize_sense() fails we couldn't decode the sense
buffer, and the scsi_sense_hdr fields are invalid.
For those cases we should rather dump the sense buffer
and not try to decode invalid fields.
Reviewed-by: Robert Elliott
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
Update logging messages to use dev_printk() variants for correct
device annotations.
Reviewed-by: Robert Elliott
Reviewed-by: Christoph Hellwig
Signed-off-by: Hannes Reinecke
---
drivers/scsi/arm/fas216.c | 26 +++---
1 file changed, 11 insertions(+), 15 deletions(-)
diff
> On 19.10.2014, at 16.44, Laurence Oberman wrote:
>
> Hello Kai
>
> Thanks.
>
> Here is v3
>
> This patch adds a debug_flag parameter that can be set on module load, and
> allows the DEBUG facility without a module recompile.
> Note that now DEBUG 1 is the default with this patch.
>
> Usa
>> Anything that is an urgent and/or very small fix should just be against
>> Linus' current tree and will go into the drivers branch for that tree.
>
>> Anything bigger and/or less urgent should be sent against the drivers
>> branch for the next release.
> Linux 3.17 has been released. The curr
From: Boaz Harrosh
I forgot to update Documentation/*.txt
Signed-off-by: Boaz Harrosh
---
Documentation/scsi/osd.txt | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/Documentation/scsi/osd.txt b/Documentation/scsi/osd.txt
index da162f7..5a9879b 100644
--- a/Documentation/s
On 10/7/2014 4:07 PM, Bart Van Assche wrote:
Improve performance by using multiple RDMA/RC channels per SCSI
host for communication with an SRP target. About the
implementation:
- Introduce a loop over all channels in the code that uses
target->ch.
- Set the SRP_MULTICHAN_MULTI flag during log
From: Boaz Harrosh
I no longer have access to the Panasas email.
So change to an email that can always reach me.
Signed-off-by: Boaz Harrosh
---
drivers/scsi/osd/Kbuild | 2 +-
drivers/scsi/osd/Kconfig| 2 +-
drivers/scsi/osd/osd_debug.h| 2 +-
drivers/scsi/osd/
From: Boaz Harrosh
I have moved on, and do no longer have Panasas email access.
Update to an email that can reach me.
So change bharr...@panasas.com => o...@electrozaur.com
Explain of email address:
* electrozaur.com is a domain owned by me.
* ooo - Stands for Open Osd . Org
Another email alia
On 10/17/2014 1:59 PM, Christoph Hellwig wrote:
On Tue, Oct 07, 2014 at 03:06:54PM +0200, Bart Van Assche wrote:
The free_reqs list is no longer needed now that we are using
tags assigned by the block layer. Hence remove it.
Is there any good reason not to fold this into the previous patch?
On 10/7/2014 4:05 PM, Bart Van Assche wrote:
Changes in this patch:
- Move channel variables into a new structure (struct srp_rdma_ch).
- Add an srp_target_port pointer, 'lock' and 'comp_vector' members
in struct srp_rdma_ch.
- Add code to initialize these three new member variables.
- Many bo
On 10/7/2014 4:05 PM, Bart Van Assche wrote:
Introduce the srp_target_port member variables 'sgid' and 'pkey'.
Change the type of 'orig_dgid' from __be16[8] into union ib_gid.
This patch does not change any functionality but makes the
"Separate target and channel variables" patch easier to verify
On 10/7/2014 4:05 PM, Bart Van Assche wrote:
If a cable is pulled during LUN scanning it can happen that the
SRP rport and the SCSI host have been created but no LUNs have been
added to the SCSI host. Since multipathd only sends SCSI commands
to a SCSI target if one or more SCSI devices are prese
On 10/13/2014 1:15 PM, Christoph Hellwig wrote:
On Mon, Oct 13, 2014 at 11:21:54AM +0200, Bart Van Assche wrote:
With the approach for block layer tag management proposed in this patch
series SCSI LLDs no longer need to call this function. This means that the
blk_mq_build_unique_tag() function c
On 10/7/2014 4:04 PM, Bart Van Assche wrote:
Modify scsi_find_tag() and scsi_host_find_tag() such that these
fuctions can translate a tag generated by blk_mq_unique_tag().
Signed-off-by: Bart Van Assche
Cc: Christoph Hellwig
Cc: Sagi Grimberg
---
include/scsi/scsi_tcq.h | 19 +++
https://bugzilla.kernel.org/show_bug.cgi?id=81861
linux-...@crashplan.pro changed:
What|Removed |Added
Kernel Version|3.16.0 |3.17.1
--- Comment #18 from linu
On 10/7/2014 4:03 PM, Bart Van Assche wrote:
Allow a SCSI LLD to declare how many hardware queues it supports
by setting Scsi_Host.nr_hw_queues before calling scsi_add_host().
Note: it is assumed that each hardware queue has a queue depth of
shost->can_queue. In other words, the total queue dept
> -Original Message-
> From: Christoph Hellwig [mailto:h...@lst.de]
> Sent: Sunday, October 19, 2014 8:18 AM
> To: KY Srinivasan
> Cc: linux-scsi@vger.kernel.org
> Subject: hyperv storvsc cleanup / optimization
>
> Hi KY,
>
> can you throw the patch below into your testing rig? It conv
Hi KY,
can you throw the patch below into your testing rig? It converts
the storvsc driver to use our new cmd_size field, and thus avoids
all the slab/mepool infrastructure for private data in the driver.
--
To unsubscribe from this list: send the line "unsubscribe linux-scsi" in
the body of a m
Signed-off-by: Christoph Hellwig
---
drivers/scsi/storvsc_drv.c | 118 +++--
1 file changed, 7 insertions(+), 111 deletions(-)
diff --git a/drivers/scsi/storvsc_drv.c b/drivers/scsi/storvsc_drv.c
index 733e5f7..0ddb0b6 100644
--- a/drivers/scsi/storvsc_drv
To generate the right SPI tag messages we need to properly set
QUEUE_FLAG_QUEUED in the request_queue and mirror it to the
request.
Reported-by: Meelis Roos
Signed-off-by: Christoph Hellwig
Cc: sta...@vger.kernel.org
---
drivers/scsi/scsi_lib.c | 5 +
include/scsi/scsi_tcq.h | 8
2
This reverts commit fb3ccb5da71273e7f0d50b50bc879e50cedd60e7.
SCSI-2/SPI actually needs the tagged/untagged flag in the request to
work properly. Revert this patch and add a follow on to set it in
the right place.
Reported-by: Meelis Roos
Signed-off-by: Christoph Hellwig
Cc: sta...@vger.kernel
Fix the assumption that we can treat all blk-mq requests as tagged. For
traditional SCSI that's wrong, as being tagged has a very explicit meaning
on the wire.
This is a little bit different from the version Meelis tested earlier, but
the concept is the same. I didn't want to add a Tested-by tag
On Sun, Oct 19, 2014 at 04:07:59AM +, Anish Bhatt wrote:
> Aah, thanks for the clarification. I have made mistakenly made this patch
> against drivers-for-3.18 then, but it applies cleanly to drivers-for-3.17 as
> well, please apply this to drivers-for-3.17.
Linux 3.17 has been released. Th
On Sun, Oct 19, 2014 at 03:10:00PM +0300, mr...@linux.ee wrote:
> > > Christoph, I don't see how the new tagging code with blk-mq can
> > > be providing compatible behavior for existing SCSI drivers.
> >
> > It doesn't, and that's my fault.
> >
> > Please try the patch below:
>
> Seems to have w
Hello Kai
Thanks.
Here is v3
This patch adds a debug_flag parameter that can be set on module load, and
allows the DEBUG facility without a module recompile.
Note that now DEBUG 1 is the default with this patch.
Usage: modprobe st debug_flag=1
Signed-off-by: Laurence Oberman
diff -Nur a/Do
https://bugzilla.kernel.org/show_bug.cgi?id=85151
--- Comment #16 from linux-...@crashplan.pro ---
Created attachment 154171
--> https://bugzilla.kernel.org/attachment.cgi?id=154171&action=edit
dmesg after first pm80xx patch, having 2 expanders attached in parallel
--
You are receiving this ma
https://bugzilla.kernel.org/show_bug.cgi?id=85151
--- Comment #15 from linux-...@crashplan.pro ---
After the patch there are less issues. However only 1 HP SAS expander is usable
on the Adaptec/Pmcs 2280800-R 7805H.
# uname -a
Linux ubuntu14 3.17.0-031700rc7-generic #201409281835 SMP Sun Sep 28
> > Christoph, I don't see how the new tagging code with blk-mq can
> > be providing compatible behavior for existing SCSI drivers.
>
> It doesn't, and that's my fault.
>
> Please try the patch below:
Seems to have worked - the machine booted up with scsi blk mq enabled, I
just can not log in s
Hello,
I am responding to this, but noticed your next, fixed version.
> On 17.10.2014, at 23.20, Laurence Oberman wrote:
>
> Hello Kai
>
> You have seen this patch before. The first time around, given that we don't
> enable DEBUG by default, I let it go.
> However we have been looking into de
55 matches
Mail list logo