On Fri, 2012-07-27 at 15:19 +1000, Benjamin Herrenschmidt wrote:
> On Wed, 2012-07-18 at 18:49 +0200, o...@aepfle.de wrote:
> > From: Linda Xie
>
> James, can I assume you're picking up those two ?
If they get acked by the maintiners ...
James
--
To unsubscribe from this list: send the line "
Il 27/07/2012 05:12, Wang Sen ha scritto:
>> > No this code is correct, though you will need to make sure to properly
>> > terminate the destination sg_list.
> Yes, the terminate marker in the destination list is set when initialization.
> sg_set_page would not break this marker because it saved bo
On Wed, 2012-07-18 at 18:49 +0200, o...@aepfle.de wrote:
> From: Linda Xie
James, can I assume you're picking up those two ?
Cheers,
Ben.
> Expected result:
> It should show something like this:
> x1521p4:~ # cat /sys/class/scsi_host/host1/config
> PARTITIONNAME='x1521p4'
> NWSDNAME='X1521P4'
>
2012/7/25 Boaz Harrosh :
> On 07/25/2012 02:44 PM, Sen Wang wrote:
>
>> 2012/7/25 Paolo Bonzini :
>>> Il 25/07/2012 10:29, Wang Sen ha scritto:
When using the commands below to write some data to a virtio-scsi LUN of
the
QEMU guest(32-bit) with 1G physical memory(qemu -m 1024), the
From: Nicholas Bellinger
Hello KVM + QEMU folks,
This is -v5 of the in-flight tcm_vhost fabric driver for KVM host virtualized
target support using the in-kernel storage stack with for-3.6 code.
The changes since -v4 have been pretty minimal. A new GET_ABI_VERSION ioctl
has been added as reque
On Thu, 2012-07-26 at 11:58 +0300, Avi Kivity wrote:
> On 07/26/2012 05:34 AM, Nicholas A. Bellinger wrote:
> >
> > In that case, respinning a -v5 for tcm_vhost to start from ABI=0 and
> > will post an updated patch shortly.
> >
> >> The main thing I would like to confirm is that this only versio
On 07/25/2012 06:35 PM, tomm wrote:
>
> If this is a driver or firmware bug, then why would commit
> 85ef06d1d252f6a2e73b678591ab71caad4667bb
> cause this to happen? What is the interaction between this issue
> and this commit which just flushes events?
That's confusing to me as well. Tejun's p
On 07/25/2012 07:56 PM, Matthias Prager wrote:
>
> I don't yet understand all the code but I'm following your discussion
> with Tejun: I've set up a minimal vm running gentoo with a mpt2sas
> driven controller in passthrough mode. I've applied your proposed patch
> against the vanilla 3.5.0 kernel
On Wed, Jul 25, 2012 at 02:02:15PM +0200, Hannes Reinecke wrote:
> On 07/11/2012 05:18 PM, Alasdair G Kergon wrote:
> > On Tue, Jun 26, 2012 at 02:32:05PM -0400, Mike Snitzer wrote:
> >> The new 'no_partitions' feature serves as a notifier to kpartx to _not_
> >> create partitions on these multipat
On 07/26/2012 10:41 AM, Aaron Lu wrote:
On Thu, Jul 26, 2012 at 09:43:37AM -0400, Jeff Garzik wrote:
On 07/26/2012 06:05 AM, Aaron Lu wrote:
I can't set a flag in libata-acpi.c since a related function is
missing in scsi-misc tree. Will fix this when 3.6-rc1 released.
What does this mean? W
On Wed, Jul 25, 2012 at 7:10 PM, Jeff Garzik wrote:
>
> Thanks, so noted. I guess if the merge gets more complex than something
> easily described in an email, that implies that maintainers should do more
> cross-coordination and maybe a merge tree.
It's fairly rare. It happens mostly with the a
From: Stephen M. Cameron
I think ioremap() ends up being equivalent to ioremap_nocache
by default, but we should signal our intent that these mappings
should be non-cacheable.
Signed-off-by: Stephen M. Cameron
---
drivers/scsi/hpsa.c |3 ++-
1 files changed, 2 insertions(+), 1 deletions(-)
From: Stephen M. Cameron
In the abort handler, when asked to abort a command which
is not known to the driver, SUCCESS is returned, but the
diagnostic message incorrectly indicates the abort failed.
Signed-off-by: Stephen M. Cameron
---
drivers/scsi/hpsa.c |2 +-
1 files changed, 1 inserti
Only one important bug fix, we should use LUN reset rather
than target reset in the reset error handler as Smart Array
logical drives don't actually support target reset and end up
getting offlined, which is pretty bad. I had done my reset
testing with tape drives only, which turns out to have bee
From: Stephen M. Cameron
It turns out Smart Array logical drives do not support target
reset and when the target reset fails, the logical drive will
be taken off line. Symptoms look like this:
hpsa :03:00.0: Abort request on C1:B0:T0:L0
hpsa :03:00.0: resetting device 1:0:0:0
hpsa :
On Thu, 26 Jul 2012, Aaron Lu wrote:
> On 07/26/2012 01:05 PM, James Bottomley wrote:
> > On Thu, 2012-07-26 at 12:47 +0800, Aaron Lu wrote:
> >> On 07/26/2012 05:38 AM, Jeff Garzik wrote:
> >>> On 07/25/2012 04:35 PM, Jeff Garzik wrote:
> * Updating libata to directly bind with ACPI / runtim
On Thu, Jul 26, 2012 at 09:43:37AM -0400, Jeff Garzik wrote:
> On 07/26/2012 06:05 AM, Aaron Lu wrote:
> >v3:
> >Rebase on top of scsi-misc tree;
> >Add the sr related patches previously in Jeff's libata tree;
> >Re-organize the sr patches.
> >A problem for now: for patch
> >scsi: sr: support zero
On 07/26/2012 06:05 AM, Aaron Lu wrote:
v3:
Rebase on top of scsi-misc tree;
Add the sr related patches previously in Jeff's libata tree;
Re-organize the sr patches.
A problem for now: for patch
scsi: sr: support zero power ODD(ZPODD)
I can't set a flag in libata-acpi.c since a related function i
virtio-scsi needs to report LUNs greater than 256 using the "flat"
format. Because the Linux SCSI layer just maps the SCSI LUN to
an u32, without any parsing, these end up in the range from 16640
to 32767. Fix max_lun to account for the possibility that logical
unit numbers are encoded with the "
Support the LUN parameter change event. Currently, the host fires this event
when the capacity of a disk is changed from the virtual machine monitor.
The resize then appears in the kernel log like this:
sd 0:0:0:0: [sda] 46137344 512-byte logical blocks: (23.6 GB/22.0 GIb)
sda: detected capac
James,
patch 1 fixes scanning of LUNs whose number is greater than 255. QEMU
passes a max_lun of 16383 (because it uses SAM numbering) but in Linux
it must become 32768 (because LUNs above 255 are "relocated" to 16640).
Patch 2 is a resubmission of the patch for online resizing of virtio-scsi
LUN
Il 26/07/2012 09:58, Paolo Bonzini ha scritto:
>
>> > Please CC me on the "convert to sg copy-less" patches, It looks interesting
> Sure.
Well, here is the gist of it (note it won't apply on any public tree,
hence no SoB yet). It should be split in multiple changesets and you
can make more simpl
On Thursday 26 July 2012 20:43:32 Aaron Lu wrote:
> > What is the purpose of this approach?
>
> The purpose is to let scsi layer driver(sd, sr, etc.) use the same pm
> api(scsi_autopm_put_device) to put the device to runtime suspended
> state.
> When the device is ready to be suspended, if it does
On Thu, Jul 26, 2012 at 02:54:01PM +0400, Sergei Shtylyov wrote:
> Hello.
>
> On 26-07-2012 14:05, Aaron Lu wrote:
>
> >When the ODD is resumed, disk_unblock_events should be called when:
> >1 The ODD is runtime resumed;
> >2 System is resuming from S3 and the ODD is runtime suspended before S3;
On Thu, Jul 26, 2012 at 12:44:24PM +0200, Oliver Neukum wrote:
> On Thursday 26 July 2012 18:05:24 Aaron Lu wrote:
> > If the device is using autosuspend, when scsi_autopm_put_device is
> > called for it, use autosuspend runtime pm calls instead of the sync
> > call.
>
> What is the purpose of thi
On Thu, 12 Jul 2012, Andy Shevchenko wrote:
Signed-off-by: Andy Shevchenko
---
drivers/scsi/qla2xxx/qla_attr.c |5 +
1 file changed, 1 insertion(+), 4 deletions(-)
diff --git a/drivers/scsi/qla2xxx/qla_attr.c b/drivers/scsi/qla2xxx/qla_attr.c
index 5ab9530..095ba85 100644
--- a/driver
In function megaraid_abort() there are calls to megaraid_abort_and_reset()
and mega_rundoneq() which access shared data (like pending_list) without
synchronization.In function megaraid_reset() the same calls were done with
spin_lock held. So, the patch adds spin_lock_irq and spin_unlock_irq to
mega
On Thu, Jul 26, 2012 at 5:05 PM, S, Venkatraman wrote:
> On Thu, Jul 26, 2012 at 4:42 PM, vinayak holikatti
> wrote:
>> On Thu, Jul 26, 2012 at 4:02 PM, S, Venkatraman wrote:
>>> On Thu, Jul 26, 2012 at 2:12 PM, Vinayak Holikatti
>>> wrote:
This patch set adds following features
- Se
On Thu, Jul 26, 2012 at 4:42 PM, vinayak holikatti
wrote:
> On Thu, Jul 26, 2012 at 4:02 PM, S, Venkatraman wrote:
>> On Thu, Jul 26, 2012 at 2:12 PM, Vinayak Holikatti
>> wrote:
>>> This patch set adds following features
>>> - Seggregate PCI specific code in ufshcd.c
>>> - Adds PCI glue drive
On Thu, 2012-07-26 at 12:43 +0200, Paolo Bonzini wrote:
> Il 26/07/2012 12:33, James Bottomley ha scritto:
> >> > Has it already been considered to modify scsilun_to_int() such that LUN
> >> > numbers start at zero even for addressing method 1 ? This is what e.g.
> >> > the function scst_unpack_lun
On Thu, Jul 26, 2012 at 4:02 PM, S, Venkatraman wrote:
> On Thu, Jul 26, 2012 at 2:12 PM, Vinayak Holikatti
> wrote:
>> This patch set adds following features
>> - Seggregate PCI specific code in ufshcd.c
>> - Adds PCI glue driver ufshcd-pci.c and ufshcd.c become core module
>> - Adds Platform
Hello.
On 26-07-2012 14:05, Aaron Lu wrote:
When the ODD is resumed, disk_unblock_events should be called when:
1 The ODD is runtime resumed;
2 System is resuming from S3 and the ODD is runtime suspended before S3;
But not when the system is resuming from S3 and the ODD is runtime
active before
On Thursday 26 July 2012 18:05:24 Aaron Lu wrote:
> If the device is using autosuspend, when scsi_autopm_put_device is
> called for it, use autosuspend runtime pm calls instead of the sync
> call.
What is the purpose of this approach?
You need a very good reason to have an API do two different thi
Il 26/07/2012 12:33, James Bottomley ha scritto:
>> > Has it already been considered to modify scsilun_to_int() such that LUN
>> > numbers start at zero even for addressing method 1 ? This is what e.g.
>> > the function scst_unpack_lun() already does. See also
>> > http://scst.svn.sourceforge.net/v
On Thu, 2012-07-26 at 10:17 +, Bart Van Assche wrote:
> On 07/26/12 09:21, James Bottomley wrote:
> > On Thu, 2012-07-26 at 11:04 +0200, Paolo Bonzini wrote:
> >> Il 26/07/2012 10:52, James Bottomley ha scritto:
> > +static unsigned int virtscsi_get_lun(u8 *lun_bytes)
> > +{
> > +
On Thu, Jul 26, 2012 at 2:12 PM, Vinayak Holikatti
wrote:
> This patch set adds following features
> - Seggregate PCI specific code in ufshcd.c
> - Adds PCI glue driver ufshcd-pci.c and ufshcd.c become core module
> - Adds Platform glue driver ufshcd-pltfrm.c
> - Update correct transfer size i
On 07/26/12 09:21, James Bottomley wrote:
> On Thu, 2012-07-26 at 11:04 +0200, Paolo Bonzini wrote:
>> Il 26/07/2012 10:52, James Bottomley ha scritto:
> +static unsigned int virtscsi_get_lun(u8 *lun_bytes)
> +{
> + unsigned int lun = (lun_bytes[2] << 8) | lun_bytes[3];
> + return l
Signed-off-by: Aaron Lu
---
drivers/scsi/sr.c | 23 +++
drivers/scsi/sr.h | 1 +
include/linux/cdrom.h | 43 +++
3 files changed, 67 insertions(+)
diff --git a/drivers/scsi/sr.c b/drivers/scsi/sr.c
index 5fc97d2..abfefab 10064
If the device is using autosuspend, when scsi_autopm_put_device is
called for it, use autosuspend runtime pm calls instead of the sync
call.
Signed-off-by: Aaron Lu
---
drivers/scsi/scsi_pm.c | 8 +++-
1 file changed, 7 insertions(+), 1 deletion(-)
diff --git a/drivers/scsi/scsi_pm.c b/driv
v3:
Rebase on top of scsi-misc tree;
Add the sr related patches previously in Jeff's libata tree;
Re-organize the sr patches.
A problem for now: for patch
scsi: sr: support zero power ODD(ZPODD)
I can't set a flag in libata-acpi.c since a related function is
missing in scsi-misc tree. Will fix this
The ODD will be placed into suspend state when:
1 For tray type ODD, no media inside and door closed;
2 For slot type ODD, no media inside;
And together with ACPI, when we suspend the ODD, we will omit the power
altogether to reduce power consumption(done in libata-acpi.c).
The ODD can be resumed
When the ODD is runtime suspended, there is no need to poll it for
events, so block events poll for it and unblock when resumed.
Signed-off-by: Aaron Lu
---
block/genhd.c | 2 ++
drivers/scsi/sr.c | 7 ---
2 files changed, 6 insertions(+), 3 deletions(-)
diff --git a/block/genhd.c b/blo
Set the ODD's in kernel poll interval to 2s for the user in case the
user is using an old distro on which udev will not set the system wide
block parameter events_dfl_poll_msecs.
Signed-off-by: Aaron Lu
---
block/genhd.c | 23 +--
drivers/scsi/sr.c | 1 +
include
When the ODD is resumed, disk_unblock_events should be called when:
1 The ODD is runtime resumed;
2 System is resuming from S3 and the ODD is runtime suspended before S3;
But not when the system is resuming from S3 and the ODD is runtime
active before S3.
So seperate the resume calls, one for syst
When runtime resume a scsi device, if the device's driver has
implemented runtime resume callback, use that.
sr driver needs this to do different things for system resume and
runtime resume.
Signed-off-by: Aaron Lu
---
drivers/scsi/scsi_pm.c | 15 ++-
1 file changed, 10 insertions(+
Il 26/07/2012 11:41, James Bottomley ha scritto:
> On Thu, 2012-07-26 at 11:27 +0200, Paolo Bonzini wrote:
>> Il 26/07/2012 11:21, James Bottomley ha scritto:
> Because scsilun_to_int does not do the AND, so it would have exactly the
> same bug I'm fixing.
>>> It's not a bug ... it's the en
On Thu, 2012-07-26 at 11:27 +0200, Paolo Bonzini wrote:
> Il 26/07/2012 11:21, James Bottomley ha scritto:
> >> > Because scsilun_to_int does not do the AND, so it would have exactly the
> >> > same bug I'm fixing.
> > It's not a bug ... it's the encoding. All the other devices use this
> > too.
Il 26/07/2012 11:21, James Bottomley ha scritto:
>> > Because scsilun_to_int does not do the AND, so it would have exactly the
>> > same bug I'm fixing.
> It's not a bug ... it's the encoding. All the other devices use this
> too. Ideally we should have switched to 64 bit lun numbers for the
> en
On Thu, 2012-07-26 at 11:04 +0200, Paolo Bonzini wrote:
> Il 26/07/2012 10:52, James Bottomley ha scritto:
> >> > +static unsigned int virtscsi_get_lun(u8 *lun_bytes)
> >> > +{
> >> > +unsigned int lun = (lun_bytes[2] << 8) | lun_bytes[3];
> >> > +return lun & 16383;
> >> > +}
> >>
2012/7/25 Ben Hutchings :
> On Wed, 2012-07-25 at 20:13 +0800, Wang Sen wrote:
>> When using the commands below to write some data to a virtio-scsi LUN of the
>> QEMU guest(32-bit) with 1G physical memory(qemu -m 1024), the qemu will
>> crash.
>>
>> # sudo mkfs.ext4 /dev/sdb (/dev/sdb is
Il 26/07/2012 10:52, James Bottomley ha scritto:
>> > +static unsigned int virtscsi_get_lun(u8 *lun_bytes)
>> > +{
>> > + unsigned int lun = (lun_bytes[2] << 8) | lun_bytes[3];
>> > + return lun & 16383;
>> > +}
>> > +
> Why are you rolling your own incomplete version of scsilun_to_int here?
Bec
On 07/26/2012 05:34 AM, Nicholas A. Bellinger wrote:
>
> In that case, respinning a -v5 for tcm_vhost to start from ABI=0 and
> will post an updated patch shortly.
>
>> The main thing I would like to confirm is that this only versions the
>> tcm_vhost ioctls? In that case a single version number
On Mon, 2012-07-16 at 18:05 +0200, Paolo Bonzini wrote:
> Hotplug/hot-unplug of a LUN whose number is greater than 255
> uses the "flat" format for LUNs, which has bit 14 set. Clear
> the bit when parsing the event structs.
>
> Signed-off-by: Paolo Bonzini
> ---
> drivers/scsi/virtio_scsi.c |
This patch corrects the expected data transfer size of the
command UPIU. The current implementation of cmd->transfersize
is wrong as it probably equal to sector size. With this
implementation the transfer size is updated correctly
Reported-by: KOBAYASHI Yoshitake
Reviewed-by: Namjae Jeon
Signed-
This patch adds Platform glue driver for ufshcd.
Reviewed-by: Namjae Jeon
Signed-off-by: Vinayak Holikatti
Signed-off-by: Santosh Yaraganavi
---
drivers/scsi/ufs/Kconfig | 11 ++
drivers/scsi/ufs/Makefile|1 +
drivers/scsi/ufs/ufshcd-pltfrm.c | 222 ++
This patch separates PCI code from ufshcd.c and makes it as a
core driver module and adds a new file ufshcd-pci.c as PCI glue
driver.
Reviewed-by: Namjae Jeon
Signed-off-by: Vinayak Holikatti
Signed-off-by: Santosh Yaraganavi
---
drivers/scsi/ufs/Kconfig | 26 ++-
drivers/scsi/ufs/Ma
This patch seggregates the PCI specific code in ufshcd.c to make it
ready for splitting into core ufs driver and PCI glue driver.
Reviewed-by: Namjae Jeon
Signed-off-by: Vinayak Holikatti
Signed-off-by: Santosh Yaraganavi
---
drivers/scsi/ufs/ufshcd.c | 277 ---
This patch set adds following features
- Seggregate PCI specific code in ufshcd.c
- Adds PCI glue driver ufshcd-pci.c and ufshcd.c become core module
- Adds Platform glue driver ufshcd-pltfrm.c
- Update correct transfer size in Command UPIU
Vinayak Holikatti (4):
[SCSI] drivers/scsi/ufs: Seg
On Tue, 2012-07-17 at 18:20 -0700, adam radford wrote:
> Cc: stable
That's not how to add a stable tag, please see
Documentation/stable_kernel_rules.txt
> James/linux-scsi,
>
> The following patch from Kashyap Desai for megaraid_sas moves the
That's also not how you do someone else's patch ...
Il 26/07/2012 09:56, Boaz Harrosh ha scritto:
>> > In the meanwhile, we still have a bug to fix, and we need to choose
>> > between Sen Wang's v1 (sg_set_page) or v2 (value assignment). I'm still
>> > leaning more towards v2, if only because I already tested that one myself.
>
> It's your call, y
On 07/26/2012 10:23 AM, Paolo Bonzini wrote:
>
> In the meanwhile, we still have a bug to fix, and we need to choose
> between Sen Wang's v1 (sg_set_page) or v2 (value assignment). I'm still
> leaning more towards v2, if only because I already tested that one myself.
>
It's your call, you kno
* Linus Torvalds wrote:
> I couldn't find an example of that in a quick look, it's
> fairly uncommon to have non-conflicting merges that had
> semantic - but not contextual - conflicts. [...]
This:
git log --grep='Semantic merge\|Semantic conflict'
gives over a dozen examples of such sema
Il 25/07/2012 23:04, Boaz Harrosh ha scritto:
>> That not all architectures have ARCH_HAS_SG_CHAIN (though all those I
>> care about do). So I need to go through all architectures and make sure
>> they use for_each_sg, or at least to change ARCH_HAS_SG_CHAIN to a
>> Kconfig define so that dependen
63 matches
Mail list logo