ds,
> Javier
>
Hello all,
Tested this using the same GStreamer pipeline as Javier mentions above.
It works nicely.
Thanks,
Luis
Tested-by: Luis de Bethencourt
--
To unsubscribe from this list: send the line "unsubscribe linux-media" in
the body of a message to majord...@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
A
> not being enabled), the fail will no longer happen on VIDIOC_QBUF but
> later (i.e: in VIDIOC_STREAMON).
>
> I don't know if that's an issue though but I think is worth mentioning.
>
> Best regards,
> Javier
>
Just run this path on the ODROID using GStreamer an
ork_pending) from []
> (slow_work_pending+0xc/0x20)
> odroid kernel: Code: eb3edacc e5953078 e3a06000 e2833c11 (e5836004)
>
> Signed-off-by: Shuah Khan
> ---
Thanks Shuah.
I've been following this while playing with an ODROID XU4 to fix some issues
in v4l2 usage in GStreamer. So
On 24/06/16 16:31, Mauro Carvalho Chehab wrote:
> The PCI device ID table is only used if compiled with modules
> support. When compiled with modules disabled, this is now
> producing this bogus warning:
>
> drivers/media/pci/cx25821/cx25821-alsa.c:696:35: warning:
> 'cx25821_audio_pci_tbl' defin
On 11/04/16 21:09, Gustavo Padovan wrote:
> Hi Luis,
>
> 2016-04-11 Luis de Bethencourt :
>
>> The members child_list and active_list were added to the fence struct
>> without descriptions for the Documentation. Adding these.
>>
>> Fixes: b55b54b5db33 (&qu
The members child_list and active_list were added to the fence struct
without descriptions for the Documentation. Adding these.
Fixes: b55b54b5db33 ("staging/android: remove struct sync_pt")
Signed-off-by: Luis de Bethencourt
Reviewed-by: Javier Martinez Canillas
---
Hi,
Just rese
The members child_list and active_list were added to the fence struct
without descriptions for the Documentation. Adding these.
Fixes: b55b54b5db33 ("staging/android: remove struct sync_pt")
Signed-off-by: Luis de Bethencourt
Reviewed-by: Javier Martinez Canillas
---
Hi,
This seco
On 19/03/16 23:55, Javier Martinez Canillas wrote:
> Hello Luis,
>
> On Sat, Mar 19, 2016 at 4:50 PM, Luis de Bethencourt
> wrote:
>> Commit b55b54b5db33 ("staging/android: remove struct sync_pt")
>> added the members child_list and active_list to the fence stru
Commit b55b54b5db33 ("staging/android: remove struct sync_pt")
added the members child_list and active_list to the fence struct, but
didn't add descriptions for these. Adding the descriptions.
Signed-off-by: Luis de Bethencourt
---
Hi,
Noticed this missing descriptions wh
Greg Kroah-Hartman writes:
> On Mon, Dec 07, 2015 at 10:25:19AM -0500, Steven Rostedt wrote:
>> Hi,
>>
>> The attached config doesn't build on 4.2.6, but changing it to the
>> following:
>>
>> VIDEO_V4L2_SUBDEV_API n -> y
>> +V4L2_FLASH_LED_CLASS n
>>
>> does build.
>
> Did this work on older ke
() warn: returning -1 instead of -ENOMEM is sloppy
gen_mpeg1hdr_to_package() warn: returning -1 instead of -ENOMEM is sloppy
gen_mpeg4hdr_to_package() warn: returning -1 instead of -ENOMEM is sloppy
Signed-off-by: Luis de Bethencourt
---
drivers/media/usb/go7007/go7007-fw.c | 6 +++---
1 file changed
Instead of manually initializing the bool array enable, use the
SNDRV_DEFAULT_ENABLE_PNP macro. As most drivers do.
Signed-off-by: Luis de Bethencourt
---
Hi,
I don't see any good reason to use = 1 instead of = SNDRV_DEFAULT_ENABLE_PNP.
Semantically it is the same, and I don't find
On Wed, Apr 08, 2015 at 08:09:03AM -0300, Mauro Carvalho Chehab wrote:
> Em Sun, 8 Feb 2015 20:55:36 +
> luisbg escreveu:
>
> > Improve code readability by moving out all pre-init values from the init
> > function.
> >
> > Signed-off-by: Luis de Bethenco
On Mon, Feb 16, 2015 at 11:04:47AM -0500, Abylay Ospan wrote:
> Hello,
>
> We're fully opening firmware sources for our new card - NetUP Dual
> Universal DVB CI. License is GPLv3. Sources is VHDL for Altera FPGA
> EP4CGX22CF19C8
> and can be compiled with Altera Quartus II (free edition). Hope thi
On Mon, Feb 16, 2015 at 01:36:43PM +0100, Hans Verkuil wrote:
> On 02/16/2015 01:18 PM, Luis de Bethencourt wrote:
> > Hi all,
> >
> > As can be seen in Han's build log:
> > http://hverkuil.home.xs4all.nl/logs/Saturday.log
> >
> > The recent com
Hi all,
As can be seen in Han's build log:
http://hverkuil.home.xs4all.nl/logs/Saturday.log
The recent commit bc0c5aa35ac88342831933ca7758ead62d9bae2b introduces a
compiler error in some platforms.
/home/hans/work/build/media_build/v4l/ir-hix5hd2.c: In function
'hix5hd2_ir_config':
/home/hans/w
On Wed, Feb 11, 2015 at 11:08:51AM +, Luis de Bethencourt wrote:
> Cleaning up the following compiler warning:
> rtl2832.c:703:12: warning: 'tmp' may be used uninitialized in this function
>
> Even though it could never happen since if rtl2832_rd_demod_reg () doesn&
Remove unused macros RC_REPEAT_DELAY and RC_REPEAT_DELAY_V1_20
Signed-off-by: Luis de Bethencourt
---
drivers/media/usb/dvb-usb/dib0700_core.c| 3 ---
drivers/media/usb/dvb-usb/dib0700_devices.c | 3 ---
2 files changed, 6 deletions(-)
diff --git a/drivers/media/usb/dvb-usb/dib0700_core.c
On Thu, Feb 12, 2015 at 06:34:40PM +0100, David Cimbůrek wrote:
> 2015-02-12 12:50 GMT+01:00 Mauro Carvalho Chehab :
> > Em Wed, 11 Feb 2015 17:41:01 +0100
> > David Cimbůrek escreveu:
> >
> > Please don't top post. I reordered the messages below in order to get some
> > sanity.
> >
> >>
> >> 2015
only my guess but my patch is really working for me :-)
>
Hi David,
I am away from the keyboard most of today. Busy with a training.
I will follow the code you describe as soon as I can in a few hours and report
back.
Thanks,
Luis
>
>
> 2015-02-12 1:10 GMT+01:00 Luis de Bethenco
On Thu, Feb 12, 2015 at 01:42:45AM +0200, Antti Palosaari wrote:
> On 02/12/2015 01:38 AM, Luis de Bethencourt wrote:
> >On Wed, Feb 11, 2015 at 10:45:01PM +0100, Matthias Schwarzott wrote:
> >>On 11.02.2015 21:58, Christian Engelmayer wrote:
> >>&g
On Tue, Feb 10, 2015 at 11:38:11AM +0100, David Cimbůrek wrote:
> Please include this patch to kernel! It takes too much time for such a
> simple fix!
>
The patch is simple but why it fixes the issue isn't that simple. Could you
explain why the order of the variables inside the structure is break
if (ret)
> > - return ret;
> > + goto error;
> >
> > ret = si2165_upload_firmware_block(state, data, len,
> >&offset, block_count);
> >
> Good catch.
>
> Signed-off-by: Matthias Schwarzott
On Tue, Feb 10, 2015 at 09:35:52PM -0200, Mauro Carvalho Chehab wrote:
> Em Tue, 10 Feb 2015 12:57:24 +0200
> Antti Palosaari escreveu:
>
> > On 02/09/2015 12:44 AM, Luis de Bethencourt wrote:
> > > Cleaning the following compiler warning:
> > > rtl2832.c:7
mpiler warnings.
Signed-off-by: Luis de Bethencourt
---
drivers/media/dvb-frontends/rtl2832.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/media/dvb-frontends/rtl2832.c
b/drivers/media/dvb-frontends/rtl2832.c
index 5d2d8f4..20fa245 100644
--- a/drivers/media/dvb-fron
On Tue, Feb 10, 2015 at 12:57:24PM +0200, Antti Palosaari wrote:
> On 02/09/2015 12:44 AM, Luis de Bethencourt wrote:
> >Cleaning the following compiler warning:
> >rtl2832.c:703:12: warning: 'tmp' may be used uninitialized in this function
> >
> >Even
On Mon, Feb 09, 2015 at 01:56:56PM -0200, Mauro Carvalho Chehab wrote:
> Em Mon, 09 Feb 2015 10:23:48 +
> Luis de Bethencourt escreveu:
>
> > On Sun, Feb 08, 2015 at 06:07:45PM -0800, Linus Torvalds wrote:
> > > I got this, and it certainly seems relevant,.
> &g
On Sun, Feb 08, 2015 at 06:07:45PM -0800, Linus Torvalds wrote:
> I got this, and it certainly seems relevant,.
>
> It would seem that that whole 'quality' thing needs some range
> checking, it should presumably be in the range [1..100] in order to
> avoid negative 'sc' values or the divide-by-zer
On Mon, Feb 09, 2015 at 10:16:25AM +, Luis de Bethencourt wrote:
> As reported by Peter Kovar, there's a potential risk of a division by zero on
> calls to jpeg_set_qual() when quality is zero.
>
> As quality can't be 0 or lower than that, add an extra clause to cov
As reported by Peter Kovar, there's a potential risk of a division by zero on
calls to jpeg_set_qual() when quality is zero.
As quality can't be 0 or lower than that, add an extra clause to cover this
special case.
Signed-off-by: Luis de Bethencourt
---
drivers/media/usb/gspca/t
On Sun, Feb 08, 2015 at 10:44:22PM +, Luis de Bethencourt wrote:
> Cleaning the following compiler warning:
> rtl2832.c:703:12: warning: 'tmp' may be used uninitialized in this function
>
> Even though it could never happen since if rtl2832_rd_demod_reg () doesn't
mpiler warnings.
Signed-off-by: Luis de Bethencourt
---
drivers/media/dvb-frontends/rtl2832.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/media/dvb-frontends/rtl2832.c
b/drivers/media/dvb-frontends/rtl2832.c
index 5d2d8f4..ad36d1c 100644
--- a/drivers/media/dvb-fron
Integer return of bcm2048_parse_rds_rt () is never used, changing the return
type to void.
Signed-off-by: Luis de Bethencourt
---
drivers/staging/media/bcm2048/radio-bcm2048.c | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)
diff --git a/drivers/staging/media/bcm2048/radio-bcm2048.c
b
On Fri, Feb 06, 2015 at 01:23:15PM -0500, Jonathan Corbet wrote:
> On Fri, 6 Feb 2015 18:17:52 +
> Luis de Bethencourt wrote:
>
> > -video streams. Besides usually several of such audio and video streams
> > -it also contains data streams with information about th
---
Documentation/DocBook/media/dvb/intro.xml | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/Documentation/DocBook/media/dvb/intro.xml
b/Documentation/DocBook/media/dvb/intro.xml
index 2048b53..e98bfa9 100644
--- a/Documentation/DocBook/media/dvb/intro.xml
+++ b/Documenta
Fixing a few checkpatch errors of type: space required after that ','
Signed-off-by: Luis de Bethencourt
---
drivers/media/usb/dvb-usb/dvb-usb-dvb.c | 17 +
1 file changed, 9 insertions(+), 8 deletions(-)
diff --git a/drivers/media/usb/dvb-usb/dvb-usb-dvb.c
b/drivers
Signed-off-by: Luis de Bethencourt
---
drivers/media/usb/dvb-usb/dvb-usb-dvb.c | 16
1 file changed, 8 insertions(+), 8 deletions(-)
diff --git a/drivers/media/usb/dvb-usb/dvb-usb-dvb.c
b/drivers/media/usb/dvb-usb/dvb-usb-dvb.c
index 719413b..c901d15 100644
--- a/drivers/media
Missing newline character at the end of string passed to dev_err()
Signed-off-by: Luis de Bethencourt
---
drivers/staging/media/lirc/lirc_zilog.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/media/lirc/lirc_zilog.c
b/drivers/staging/media/lirc
The previous patch switched some dev functions to move the string to a second
line. Doing this for all similar functions because it makes the driver easier
to read if all similar lines use the same criteria.
Signed-off-by: Luis de Bethencourt
---
drivers/staging/media/lirc/lirc_zilog.c | 57
checkpatch makes an exception to the 80-colum rule for quotes strings, and
Documentation/CodingStyle recommends not splitting quotes strings across lines
because it breaks the ability to grep for the string. Fixing these.
WARNING: quoted string split across lines
Signed-off-by: Luis de
On Wed, Dec 10, 2014 at 04:01:04PM -0800, Joe Perches wrote:
> On Wed, 2014-12-10 at 23:57 +0000, Luis de Bethencourt wrote:
> > On Wed, Dec 10, 2014 at 03:39:09PM -0800, Joe Perches wrote:
> > > On Wed, 2014-12-10 at 22:33 +, Luis de Bethencourt wrote:
> > > >
On Wed, Dec 10, 2014 at 03:39:09PM -0800, Joe Perches wrote:
> On Wed, 2014-12-10 at 22:33 +0000, Luis de Bethencourt wrote:
> > checkpatch makes an exception to the 80-colum rule for quotes strings, and
> > Documentation/CodingStyle recommends not splitting quotes strings ac
The previous patch switched some dev functions to move the string to a second
line. Doing this for all similar functions because it makes the driver easier
to read if all similar lines use the same criteria.
Signed-off-by: Luis de Bethencourt
---
drivers/staging/media/lirc/lirc_zilog.c | 57
checkpatch makes an exception to the 80-colum rule for quotes strings, and
Documentation/CodingStyle recommends not splitting quotes strings across lines
because it breaks the ability to grep for the string. Fixing these.
WARNING: quoted string split across lines
Signed-off-by: Luis de
On Thu, Dec 04, 2014 at 01:16:11PM -0200, Mauro Carvalho Chehab wrote:
> Hi Luis,
>
> Em Tue, 25 Nov 2014 20:36:29 +0000
> Luis de Bethencourt escreveu:
>
> > checkpatch makes an exception to the 80-colum rule for quotes strings, and
> > Documentation/CodingStyle reco
The previous patch switched some dev functions to move the string to a second
line. Doing this for all similar functions because it makes the driver easier
to read if all similar lines use the same criteria.
Signed-off-by: Luis de Bethencourt
---
drivers/staging/media/lirc/lirc_zilog.c | 155
checkpatch makes an exception to the 80-column rule for quotes strings, and
Documentation/CodingStyle recommends not splitting quotes strings across lines
because it breaks the ability to grep for the string. Fixing these.
WARNING: quoted string split across lines
Signed-off-by: Luis de
On Wed, Nov 26, 2014 at 08:05:55AM -0800, Joe Perches wrote:
> On Wed, 2014-11-26 at 15:42 +0000, Luis de Bethencourt wrote:
> > On 26 November 2014 at 01:49, Joe Perches wrote:
> []
> > > There is a script I posted a while back that
> > > groups various c
On Tue, Nov 25, 2014 at 01:00:07PM -0800, Joe Perches wrote:
> On Tue, 2014-11-25 at 20:40 +0000, Luis de Bethencourt wrote:
> > On Tue, Nov 25, 2014 at 12:27:24PM -0800, Joe Perches wrote:
> > > On Tue, 2014-11-25 at 20:19 +, Luis de Bethencourt wrote:
> > > > ch
On Tue, Nov 25, 2014 at 12:27:24PM -0800, Joe Perches wrote:
> On Tue, 2014-11-25 at 20:19 +0000, Luis de Bethencourt wrote:
> > checkpatch makes an exception to the 80-colum rule for quotes strings, and
> > Documentation/CodingStyle recommends not splitting quotes strings ac
checkpatch makes an exception to the 80-colum rule for quotes strings, and
Documentation/CodingStyle recommends not splitting quotes strings across lines
because it breaks the ability to grep for the string. Fixing these.
WARNING: quoted string split across lines
Signed-off-by: Luis de
checkpatch makes an exception to the 80-colum rule for quotes strings, and
Documentation/CodingStyle recommends not splitting quotes strings across lines
because it breaks the ability to grep for the string. Fixing these.
WARNING: quoted string split across lines
Signed-off-by: Luis de
52 matches
Mail list logo