cron job: media_tree daily build: WARNINGS

2019-04-11 Thread Hans Verkuil
This message is generated daily by a cron job that builds media_tree for the kernels and architectures in the list below. Results of the daily build of media_tree: date: Fri Apr 12 05:00:12 CEST 2019 media-tree git hash:1c3ec30bb23023d738b538e64ac3028902d53692 media_build gi

Re: [PATCH v3 1/9] staging: video: rockchip: add v4l2 decoder

2019-04-11 Thread ayaka
On 4/12/19 12:12 AM, Nicolas Dufresne wrote: Le jeudi 11 avril 2019 à 09:29 +0800, Randy Li a écrit : We agreed with Maxime and Ezequiel that there will be two distinct format, V4L2_PIX_FMT_H264_SLICE_RAW and V4L2_PIX_FMT_H264_SLICE_ANNEXB. And user-pace will take care of providing the right i

Re: [PATCH v3 1/9] staging: video: rockchip: add v4l2 decoder

2019-04-11 Thread Nicolas Dufresne
Le jeudi 11 avril 2019 à 09:29 +0800, Randy Li a écrit : > > We agreed with Maxime and Ezequiel that there will be two distinct > > format, V4L2_PIX_FMT_H264_SLICE_RAW and V4L2_PIX_FMT_H264_SLICE_ANNEXB. > > And user-pace will take care of providing the right information. > > I have no idea on wha

[PATCH v3 5/5] media: vsp1: Provide partition overlap algorithm

2019-04-11 Thread Kieran Bingham
To improve image quality, entities involved within the image partition algorithm may extend their partition window to account for their input requirements and to take consideration of the number of taps in their filters. Extend the partition algorithm to sweep first backwards, then forwards throug

[PATCH v3 1/5] media: vsp1: Define partition algorithm helper

2019-04-11 Thread Kieran Bingham
Provide a helper to describe when the partition algorithm is in use on a given pipeline. This improves readability to the purpose of the code, rather than obtusely checking the number of partitions. Signed-off-by: Kieran Bingham --- drivers/media/platform/vsp1/vsp1_pipe.c | 8 drivers

Re: [PATCH 07/10] media: coda: limit frame interval enumeration to supported frame sizes

2019-04-11 Thread Nicolas Dufresne
Le jeudi 11 avril 2019 à 14:00 +0200, Philipp Zabel a écrit : > On Thu, 2019-04-11 at 12:18 +0200, Hans Verkuil wrote: > > On 4/11/19 10:22 AM, Philipp Zabel wrote: > > > On Wed, 2019-04-10 at 18:24 +0200, Hans Verkuil wrote: > > > > On 4/10/19 6:11 PM, Nicolas Dufresne wrote: > > > > > Le mercredi

Re: [PATCH 07/10] media: coda: limit frame interval enumeration to supported frame sizes

2019-04-11 Thread Philipp Zabel
On Thu, 2019-04-11 at 12:18 +0200, Hans Verkuil wrote: > On 4/11/19 10:22 AM, Philipp Zabel wrote: > > On Wed, 2019-04-10 at 18:24 +0200, Hans Verkuil wrote: > > > On 4/10/19 6:11 PM, Nicolas Dufresne wrote: > > > > Le mercredi 10 avril 2019 à 16:22 +0200, Philipp Zabel a écrit : > > > > > On Wed,

Re: [PATCH 07/10] media: coda: limit frame interval enumeration to supported frame sizes

2019-04-11 Thread Ian Arkver
Hi, On 11/04/2019 11:18, Hans Verkuil wrote: On 4/11/19 10:22 AM, Philipp Zabel wrote: On Wed, 2019-04-10 at 18:24 +0200, Hans Verkuil wrote: On 4/10/19 6:11 PM, Nicolas Dufresne wrote: Le mercredi 10 avril 2019 à 16:22 +0200, Philipp Zabel a écrit : On Wed, 2019-04-10 at 15:43 +0200, Hans V

Hi dear,

2019-04-11 Thread Katie Huggins
Hi dear, I am still waiting for your Email response, you did receive my first email to you Respectfully Yours, Mrs Katie Huggins

Re: [RFC PATCH v2 1/7] media: v4l2: Get rid of ->vidioc_enum_fmt_vid_{cap,out}_mplane

2019-04-11 Thread Hans Verkuil
On 4/11/19 12:36 PM, Boris Brezillon wrote: > On Thu, 11 Apr 2019 09:59:19 +0200 > Hans Verkuil wrote: > >> On 4/4/19 10:16 AM, Boris Brezillon wrote: >>> Support for multiplanar and singleplanar formats is mutually exclusive, >>> at least in practice. In our attempt to unify support for support

Re: [RFC PATCH v2 1/7] media: v4l2: Get rid of ->vidioc_enum_fmt_vid_{cap,out}_mplane

2019-04-11 Thread Boris Brezillon
On Thu, 11 Apr 2019 09:59:19 +0200 Hans Verkuil wrote: > On 4/4/19 10:16 AM, Boris Brezillon wrote: > > Support for multiplanar and singleplanar formats is mutually exclusive, > > at least in practice. In our attempt to unify support for support for > > mplane and !mplane in v4l, let's get rid of

Re: [PATCH 07/10] media: coda: limit frame interval enumeration to supported frame sizes

2019-04-11 Thread Hans Verkuil
On 4/11/19 10:22 AM, Philipp Zabel wrote: > On Wed, 2019-04-10 at 18:24 +0200, Hans Verkuil wrote: >> On 4/10/19 6:11 PM, Nicolas Dufresne wrote: >>> Le mercredi 10 avril 2019 à 16:22 +0200, Philipp Zabel a écrit : On Wed, 2019-04-10 at 15:43 +0200, Hans Verkuil wrote: [...] >> @@ -11

[PATCH v2] media: omap_vout: potential buffer overflow in vidioc_dqbuf()

2019-04-11 Thread Dan Carpenter
The "b->index" is a u32 the comes from the user in the ioctl. It hasn't been checked. We aren't supposed to use it but we're instead supposed to use the value that gets written to it when we call videobuf_dqbuf(). The videobuf_dqbuf() first memsets it to zero and then re-initializes it inside th

Re: [RFC PATCH v2 2/7] media: v4l2: Extend pixel formats to unify single/multi-planar handling (and more)

2019-04-11 Thread Boris Brezillon
On Thu, 11 Apr 2019 10:24:16 +0200 Hans Verkuil wrote: > > static void v4l_print_framebuffer(const void *arg, bool write_only) > > { > > const struct v4l2_framebuffer *p = arg; > > @@ -951,11 +1027,15 @@ static int check_fmt(struct file *file, enum > > v4l2_buf_type type) > > switch (

Re: [RFC PATCH v2 2/7] media: v4l2: Extend pixel formats to unify single/multi-planar handling (and more)

2019-04-11 Thread Hans Verkuil
On 4/4/19 10:16 AM, Boris Brezillon wrote: > This is part of the multiplanar and singleplanar unification process. > v4l2_ext_pix_format is supposed to work for both cases. > > We also add the concept of modifiers already employed in DRM to expose > HW-specific formats (like tiled or compressed fo

Re: [PATCH 07/10] media: coda: limit frame interval enumeration to supported frame sizes

2019-04-11 Thread Philipp Zabel
On Wed, 2019-04-10 at 18:24 +0200, Hans Verkuil wrote: > On 4/10/19 6:11 PM, Nicolas Dufresne wrote: > > Le mercredi 10 avril 2019 à 16:22 +0200, Philipp Zabel a écrit : > > > On Wed, 2019-04-10 at 15:43 +0200, Hans Verkuil wrote: > > > [...] > > > > > @@ -1126,12 +1127,32 @@ static int coda_enum_f

Re: [RFC PATCH v2 1/7] media: v4l2: Get rid of ->vidioc_enum_fmt_vid_{cap,out}_mplane

2019-04-11 Thread Hans Verkuil
On 4/4/19 10:16 AM, Boris Brezillon wrote: > Support for multiplanar and singleplanar formats is mutually exclusive, > at least in practice. In our attempt to unify support for support for > mplane and !mplane in v4l, let's get rid of the > ->vidioc_enum_fmt_{vid,out}_cap_mplane() hooks and call >