Hi Wenyou,
I love your patch! Perhaps something to improve:
[auto build test WARNING on linuxtv-media/master]
[also build test WARNING on v4.14-rc7 next-20171018]
[if your patch is applied to the wrong git tree, please drop us a note to help
improve the system]
url:
https://github.com/0day-
This message is generated daily by a cron job that builds media_tree for
the kernels and architectures in the list below.
Results of the daily build of media_tree:
date: Mon Oct 30 05:00:15 CET 2017
media-tree git hash:bbae615636155fa43a9b0fe0ea31c678984be864
media_build git
Make use of the swap macro and remove unnecessary variable tmp_frame.
This makes the code easier to read and maintain.
This code was detected with the help of Coccinelle.
Signed-off-by: Gustavo A. R. Silva
---
drivers/media/platform/sti/hva/hva-h264.c | 5 +
1 file changed, 1 insertion(+),
Hello Michael,
Many thanks for taking the time to review the patches.
On 27 October 2017 at 13:27, Michael Ira Krufky wrote:
>> +static int tda18250_sleep(struct dvb_frontend *fe)
>> +{
>> + struct i2c_client *client = fe->tuner_priv;
>> + struct tda18250_dev *dev = i2c_get_clientdat
Add a new entry of the ov7740 sensor driver to the MAINTAINERS file.
Signed-off-by: Wenyou Yang
---
Changes in v3:
- Put the MAINTAINERS change to a separate patch.
Changes in v2:
- Split off the bindings into a separate patch.
- Add a new entry to the MAINTAINERS file.
MAINTAINERS | 8 +++
Add the device tree binding documentation for the ov7740 sensor driver.
Signed-off-by: Wenyou Yang
---
Changes in v3:
- Explicitly document the "remote-endpoint" property.
Changes in v2: None
.../devicetree/bindings/media/i2c/ov7740.txt | 47 ++
1 file changed, 47 i
The ov7740 (color) image sensor is a high performance VGA CMOS
image snesor, which supports for output formats: RAW RGB and YUV
and image sizes: VGA, and QVGA, CIF and any size smaller.
Signed-off-by: Songjun Wu
Signed-off-by: Wenyou Yang
---
Changes in v3: None
Changes in v2: None
drivers/me
Add a Video4Linux2 sensor-level driver for the OmniVision OV7740
VGA camera image sensor.
Changes in v3:
- Explicitly document the "remote-endpoint" property.
- Put the MAINTAINERS change to a separate patch.
Changes in v2:
- Split off the bindings into a separate patch.
- Add a new entry to
Hi Sakari,
Thank you very much for your review and advice.
I will send a new version to fix it.
On 2017/10/27 18:59, Sakari Ailus wrote:
Hi Wenyou,
On Fri, Oct 27, 2017 at 03:42:20PM +0800, Wenyou Yang wrote:
Add the device tree binding documentation for ov7740 driver and
add a new entry of
Fix the clock ID to do the runtime pm should be ISC_ISPCK,
instead of ISC_MCK in clk_prepare(), clk_unprepare() and
isc_clk_is_enabled().
Signed-off-by: Wenyou Yang
---
drivers/media/platform/atmel/atmel-isc.c | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/m
Hi Hans,
On 2017/10/27 20:41, Hans Verkuil wrote:
Hi Wenyou,
Unfortunately the v4 patch series was just merged instead of v5. Can you make a
new
patch applying just the v4 -> v5 changes?
Thank you for your merging.
Of course, I will send a patch to fix it.
Thanks!
Hans
On 10/27
Hi,
On Thu, Oct 26, 2017 at 10:53:42AM +0300, Sakari Ailus wrote:
> Add flash and indicator LED phandles to the sensor node.
>
> Signed-off-by: Sakari Ailus
> Acked-by: Hans Verkuil
> Acked-by: Pavel Machek
> ---
Reviewed-by: Sebastian Reichel
-- Sebastian
> arch/arm/boot/dts/omap3-n9.dts
Hi,
On Thu, Oct 26, 2017 at 10:53:41AM +0300, Sakari Ailus wrote:
> Parse async sub-devices related to the sensor by switching the async
> sub-device registration function.
>
> Signed-off-by: Sakari Ailus
> Acked-by: Hans Verkuil
> ---
Reviewed-by: Sebastian Reichel
-- Sebastian
> drivers/
Hi,
On Thu, Oct 26, 2017 at 10:53:40AM +0300, Sakari Ailus wrote:
> Parse async sub-devices related to the sensor by switching the async
> sub-device registration function.
>
> Signed-off-by: Sakari Ailus
> Acked-by: Hans Verkuil
> ---
Reviewed-by: Sebastian Reichel
-- Sebastian
> drivers/
Hi,
On Thu, Oct 26, 2017 at 10:53:39AM +0300, Sakari Ailus wrote:
> Parse async sub-devices related to the sensor by switching the async
> sub-device registration function.
>
> Signed-off-by: Sakari Ailus
> Acked-by: Hans Verkuil
> Acked-by: Pavel Machek
> ---
Reviewed-by: Sebastian Reichel
Hi,
On Thu, Oct 26, 2017 at 10:53:38AM +0300, Sakari Ailus wrote:
> Parse async sub-devices related to the sensor by switching the async
> sub-device registration function.
>
> These types devices aren't directly related to the sensor, but are
> nevertheless handled by the smiapp driver due to th
Hi,
On Thu, Oct 26, 2017 at 10:53:37AM +0300, Sakari Ailus wrote:
> Document optional lens-focus and flash-leds properties for the smiapp
> driver.
>
> Signed-off-by: Sakari Ailus
> Acked-by: Hans Verkuil
> Acked-by: Pavel Machek
Reviewed-by: Sebastian Reichel
-- Sebastian
> ---
> Documen
Hi,
On Thu, Oct 26, 2017 at 10:53:36AM +0300, Sakari Ailus wrote:
> Add a convenience function for parsing firmware for information on related
> devices using v4l2_async_notifier_parse_fwnode_sensor_common() registering
> the notifier and finally the async sub-device itself.
>
> This should be us
Hi,
On Thu, Oct 26, 2017 at 06:03:27PM +0300, Sakari Ailus wrote:
> Add v4l2_fwnode_parse_reference_sensor_common for parsing common
> sensor properties that refer to adjacent devices such as flash or lens
> driver chips.
>
> As this is an association only, there's little a regular driver needs t
Hi,
On Thu, Oct 26, 2017 at 06:01:58PM +0300, Sakari Ailus wrote:
> v4l2_fwnode_reference_parse_int_prop() will find an fwnode such that under
> the device's own fwnode, it will follow child fwnodes with the given
> property-value pair and return the resulting fwnode.
>
> Signed-off-by: Sakari Ai
Hi,
On Thu, Oct 26, 2017 at 10:53:33AM +0300, Sakari Ailus wrote:
> Add function v4l2_fwnode_reference_parse() for parsing them as async
> sub-devices. This can be done on e.g. flash or lens async sub-devices that
> are not part of but are associated with a sensor.
>
> Signed-off-by: Sakari Ailus
Hi,
On Thu, Oct 26, 2017 at 10:53:32AM +0300, Sakari Ailus wrote:
> In V4L2 the practice is to have the KernelDoc documentation in the header
> and not in .c source code files. This consequently makes the V4L2 fwnode
> function documentation part of the Media documentation build.
>
> Also correct
Hi,
On Thu, Oct 26, 2017 at 10:53:30AM +0300, Sakari Ailus wrote:
> Camera flash drivers (and LEDs) are separate from the sensor devices in
> DT. In order to make an association between the two, provide the
> association information to the software.
>
> Signed-off-by: Sakari Ailus
> Cc: Rob Herr
Hi,
On Fri, Oct 27, 2017 at 01:53:09PM +0300, Sakari Ailus wrote:
> While registering a notifier, check that each newly added fwnode is
> unique, and return an error if it is not. Also check that a newly added
> notifier does not have the same fwnodes twice.
>
> Signed-off-by: Sakari Ailus
> Ack
Hi,
On Fri, Oct 27, 2017 at 11:27:09AM +0300, Sakari Ailus wrote:
> Registering a notifier has required the knowledge of struct v4l2_device
> for the reason that sub-devices generally are registered to the
> v4l2_device (as well as the media device, also available through
> v4l2_device).
>
> This
If you try to store u64 in a kfifo (or a struct with u64 members),
then the buf member of __STRUCT_KFIFO_PTR will cause 4 bytes
padding due to alignment (note that struct __kfifo is 20 bytes
on 32 bit).
That in turn causes the __is_kfifo_ptr() to fail, which is caught
by kfifo_alloc(), which now r
Lirc supports a new mode which requires documentation.
Signed-off-by: Sean Young
---
Documentation/media/lirc.h.rst.exceptions | 26 +++
Documentation/media/uapi/rc/lirc-dev-intro.rst | 51 +++---
Documentation/media/uapi/rc/lirc-get-features.rst | 16 ++
If you want to poll for both decoded scancodes and raw IR, then this
ioctl will help you.
int fd = open("/dev/lirc0", O_RDONLY | O_NONBLOCK);
for (;;) {
unsigned mode = LIRC_MODE_SCANCODE | LIRC_MODE_MODE2;
ioctl(fd, LIRC_SET_POLL_MODES, &mode);
poll(&((struct pollfd){ .fd
Now that the lirc interface supports scancodes, RC scancode devices
can also have a lirc device. The only receiving feature they will have
enabled is LIRC_CAN_REC_SCANCODE.
Note that CEC devices have no lirc device, since they can be controlled
from their /dev/cecN chardev.
Signed-off-by: Sean Yo
This implements LIRC_MODE_SCANCODE reading from the lirc device. The
scancode can be read from the input device too, but with this interface
you get the rc protocol, keycode, toggle and repeat status in addition
to just the scancode.
int main()
{
int fd, mode, rc;
fd = open("/dev/l
The lirc device should get lirc repeats whether there is a keymap
match or not.
Signed-off-by: Sean Young
---
drivers/media/rc/rc-main.c | 27 +--
1 file changed, 17 insertions(+), 10 deletions(-)
diff --git a/drivers/media/rc/rc-main.c b/drivers/media/rc/rc-main.c
index
rc-core has replaced the lirc kapi many years ago, and now with the last
driver ported to rc-core, we can finally remove it.
Note this has no effect on userspace.
All future IR drivers should use the rc-core api.
Signed-off-by: Sean Young
---
Documentation/media/kapi/rc-core.rst | 5 --
driv
Replace the generic kernel lirc api with ones which use rc-core, further
reducing the lirc_dev members.
Signed-off-by: Sean Young
---
drivers/media/rc/ir-lirc-codec.c | 59 --
drivers/media/rc/lirc_dev.c | 68 ++--
include/
This is a duplicate of rcdev->driver_name.
Signed-off-by: Sean Young
---
Documentation/media/uapi/rc/lirc-dev-intro.rst | 2 +-
drivers/media/rc/ir-lirc-codec.c | 2 --
drivers/media/rc/lirc_dev.c| 9 +++--
include/media/lirc_dev.h | 2
When sending scancodes, load the encoder if we need it.
Signed-off-by: Sean Young
---
drivers/media/rc/rc-core-priv.h | 1 +
drivers/media/rc/rc-ir-raw.c| 2 ++
drivers/media/rc/rc-main.c | 2 +-
3 files changed, 4 insertions(+), 1 deletion(-)
diff --git a/drivers/media/rc/rc-core-priv
Now that lirc is no longer in the staging area, remove the entry.
Signed-off-by: Sean Young
---
MAINTAINERS | 6 --
1 file changed, 6 deletions(-)
diff --git a/MAINTAINERS b/MAINTAINERS
index adbf69306e9e..59c061d3d61a 100644
--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -12712,12 +12712,6 @@ S:
Calculate lirc features when necessary, and add LIRC_{S,G}ET_REC_MODE
cases to ir_lirc_ioctl.
This makes lirc_dev_fop_ioctl() unnecessary since all cases are
already handled by ir_lirc_ioctl().
Signed-off-by: Sean Young
---
drivers/media/rc/ir-lirc-codec.c | 79 -
Since the only mode lirc devices can handle is raw IR, handle this
in a plain kfifo.
Remove lirc_buffer since this is no longer needed.
Signed-off-by: Sean Young
---
drivers/media/rc/ir-lirc-codec.c | 79 +---
drivers/media/rc/lirc_dev.c | 199 -
If the lirc device supports it, set the carrier for the protocol.
Signed-off-by: Sean Young
---
drivers/media/rc/ir-jvc-decoder.c | 1 +
drivers/media/rc/ir-lirc-codec.c | 29 ++---
drivers/media/rc/ir-mce_kbd-decoder.c | 1 +
drivers/media/rc/ir-nec-decoder.c
LIRCCODE is a lirc mode where a driver produces driver-dependent
codes for receive and transmit. No driver uses this any more. The
LIRC_GET_LENGTH ioctl was used for this mode only.
Signed-off-by: Sean Young
---
Documentation/media/lirc.h.rst.exceptions | 5 +++
Documentation/media/uap
The lirc user interface exists as a raw decoder, which does not make
much sense for transmit-only devices.
In addition, we want to have lirc char devices for devices which do not
use raw IR, i.e. scancode only devices.
Note that rc-code, lirc_dev, ir-lirc-codec are now calling functions of
each o
This is done to further remove the lirc kernel api. Ensure that every
fops checks for this.
Signed-off-by: Sean Young
---
drivers/media/rc/ir-lirc-codec.c | 16 ++--
drivers/media/rc/lirc_dev.c | 4 +---
drivers/media/rc/rc-main.c | 8
include/media/lirc_dev.h
Ensure we reject an attempt to transmit invalid scancodes.
Signed-off-by: Sean Young
---
drivers/media/rc/ir-lirc-codec.c | 10
drivers/media/rc/rc-core-priv.h | 1 +
drivers/media/rc/rc-main.c | 53 +---
3 files changed, 44 insertions(+), 20
This code implements the transmitter which is currently implemented
in the staging lirc_zilog driver.
The new code does not need a signal database, iow. the
haup-ir-blaster.bin firmware file is no longer needed, and the driver
does not know anything about the keycodes in that file.
Instead, the n
This is a fix for commit 329d88da4df9 ("[media] media: i2c: Don't export
ir-kbd-i2c module alias") that stopped the module from being loaded
automagically.
The problems described only affect the HD-PVR, so it should not affect
other hardware; also if the module happens to be loaded, the i2c IR
par
If a lirc chardev is held open after a device is unplugged, rc_close()
will be called after rc_unregister_device(). The driver is not expecting
any calls at this point, and the iguanair driver causes an oops in
this scenario.
Signed-off-by: Sean Young
---
drivers/media/rc/rc-main.c | 2 +-
1 fil
For some IR protocols, some scancode values not valid, i.e. they're part
of a different protocol variant.
Signed-off-by: Sean Young
---
drivers/media/rc/rc-main.c | 18 --
1 file changed, 16 insertions(+), 2 deletions(-)
diff --git a/drivers/media/rc/rc-main.c b/drivers/media/rc
The ir-kbd-i2c driver is functionally equivalent to the lirc_zilog
driver.
The lirc_zilog driver only polls if the lirc chardev is opened;
similarly the ir-kbd-i2c driver only polls if the corresponding input
device is opened, or the lirc device.
Polling is disabled during IR transmission through
This introduces a new lirc mode: scancode. Any device which can send raw IR
can now also send scancodes.
int main()
{
int mode, fd = open("/dev/lirc0", O_RDWR);
mode = LIRC_MODE_SCANCODE;
if (ioctl(fd, LIRC_SET_SEND_MODE, &mode)) {
// kernel too old or lirc
The lirc_zilog driver only polls the device if the lirc chardev
is opened; do the same with the rc-core driver.
Signed-off-by: Sean Young
---
drivers/media/i2c/ir-kbd-i2c.c | 25 +
1 file changed, 21 insertions(+), 4 deletions(-)
diff --git a/drivers/media/i2c/ir-kbd-i2c
With the parent set for the rc device, the messages clearly state
that it is attached via i2c. The additional printk is unnecessary.
So these are the old messages:
rc rc1: i2c IR (Hauppauge WinTV PVR-150 as /devices/virtual/rc/rc1
ir-kbd-i2c: i2c IR (Hauppauge WinTV PVR-150 detected at i2c-10/10-
These two devices ids are really just one device with multiple
addresses. Probing becomes much simpler if we simply fold this into
one i2c device with two address.
Note that this breaks the lirc_zilog driver, however we will teach
ir-kbd-i2c to do what lirc_zilog does in a later commit.
Signed-of
Port lirc_zilog to rc-core, introduce lirc scancode mode for
sending and receiving, and then remove the lirc kernel api.
Note that the ported zilog driver needs the scancode interface,
since without it the RC_DRIVER_SCANCODE type IR driver would not
have a lirc chardev.
In summary:
- This remove
Use the dev_dbg dynamic infrastructure instead of rolling our own custom
debug logic.
Signed-off-by: Sean Young
---
drivers/media/i2c/ir-kbd-i2c.c | 61 +-
1 file changed, 25 insertions(+), 36 deletions(-)
diff --git a/drivers/media/i2c/ir-kbd-i2c.c b/dri
On Sun, Oct 29, 2017 at 06:54:28PM +0100, Laurent Caumont wrote:
> Hi Sean,
>
> I recompiled the modules by following the
> https://www.linuxtv.org/wiki/index.php/How_to_Obtain,_Build_and_Install_V4L-DVB_Device_Drivers
> page and applied the patch.
> But I still have problems (see below). It doesn
Hi Sean,
I recompiled the modules by following the
https://www.linuxtv.org/wiki/index.php/How_to_Obtain,_Build_and_Install_V4L-DVB_Device_Drivers
page and applied the patch.
But I still have problems (see below). It doesn't seem to be the same callstack.
Is it the right way to get the fix ?
Thank
From: Daniel Scheller
Follow-up to: ead666000a5f ("media: dvb_frontend: only use kref after
initialized")
The aforementioned commit fixed refcount OOPSes when demod driver attaching
succeeded but tuner driver didn't. However, the use count of the attached
demod drivers don't go back to zero and
From: Colin Ian King
Pointer pix is being initialized to a value and a little later
being assigned the same value again. Remove the initial assignment to
avoid a duplicate assignment. Cleans up the clang warning:
drivers/media/platform/sti/bdisp/bdisp-v4l2.c:726:26: warning: Value
stored to 'pix
Hi Mauro,
Here the timer updates and some IDs for mceusb and cx231xx.
Thanks
Sean
The following changes since commit bbae615636155fa43a9b0fe0ea31c678984be864:
media: staging: atomisp2: cleanup null check on memory allocation (2017-10-27
17:33:39 +0200)
are available in the git repository at
On 29/10/17 13:30, Julia Lawall wrote:
>
>
> On Sun, 29 Oct 2017, Colin King wrote:
>
>> From: Colin Ian King
>>
>> Pointer pix is being initialized to a value and a little later
>> being assigned the same value again. Remove the redundant second
>> duplicate assignment. Cleans up the clang war
On Sun, 29 Oct 2017, Colin King wrote:
> From: Colin Ian King
>
> Pointer pix is being initialized to a value and a little later
> being assigned the same value again. Remove the redundant second
> duplicate assignment. Cleans up the clang warning:
>
> drivers/media/platform/sti/bdisp/bdisp-v4l
From: Colin Ian King
Pointer pix is being initialized to a value and a little later
being assigned the same value again. Remove the redundant second
duplicate assignment. Cleans up the clang warning:
drivers/media/platform/sti/bdisp/bdisp-v4l2.c:726:26: warning: Value
stored to 'pix' during its
From: Colin Ian King
Variable j is being set to zero before a loop and also
immediately inside the loop and is not used after the loop.
Hence the first assignment is redundant and can be removed.
Cleans up clang warning:
drivers/media/usb/gspca/gspca.c:1078:2: warning: Value stored
to 'j' is nev
From: Colin Ian King
Variable index is set to zero and then set to zero again
a few lines later in a for loop initialization. Remove the
redundant setting of index to zero. Cleans up the clang
warning:
drivers/media/usb/dvb-usb-v2/mxl111sf-i2c.c:519:3: warning: Value
stored to 'index' is never r
64 matches
Mail list logo