Add the s_power operation which is responsible for manipulating the
power dowm mode through the PWDN pin and the reset operation through
the RESET pin.
Signed-off-by: Wenyou Yang
---
Changes in v4: None
Changes in v3: None
Changes in v2:
- Add the patch to support the get_fmt ops.
- Remove the
Add the get_fmt callback, also enable V4L2_SUBDEV_FL_HAS_DEVNODE flag
to make this subdev has device node.
Signed-off-by: Wenyou Yang
---
Changes in v4:
- Fix the build error when not enabling V4L2 sub-device userspace API option.
Changes in v3:
- Keep tried format info in the try_fmt member
Add the media entity pads initialization.
Signed-off-by: Wenyou Yang
---
Changes in v4:
- Fix the build error when not enabling Media Controller API option.
Changes in v3: None
Changes in v2: None
drivers/media/i2c/ov7670.c | 21 -
1 file changed, 20 insertions(+), 1 dele
This patch set is to add the media entity pads initialization,
the s_power operation and get_fmt callback support.
Changes in v4:
- Fix the build error when not enabling Media Controller API option.
- Fix the build error when not enabling V4L2 sub-device userspace API option.
Changes in v3:
-
To improve the readability of code, split the format array into two,
one for the format description, other for the register configuration.
Meanwhile, add the flag member to indicate the format can be achieved
from the sensor or be produced by the controller, and rename members
related to the regist
Remove the memeber *config from the isc_subdev_entity struct,
the member is useless afterward.
Signed-off-by: Wenyou Yang
---
Changes in v2: None
drivers/media/platform/atmel/atmel-isc.c | 10 ++
1 file changed, 2 insertions(+), 8 deletions(-)
diff --git a/drivers/media/platform/atmel
To meet the relationship, enable the HCLOCK and ispck during the
device probe, "isc_pck frequency is less than or equal to isc_ispck,
and isc_ispck is greater than or equal to HCLOCK."
Meanwhile, call the pm_runtime_enable() in the right place.
Signed-off-by: Wenyou Yang
---
Changes in v2: None
A software write operation to the ISC_CLKEN or ISC_CLKDIS register
requires double clock domain synchronization and is not permitted
when the ISC_SR.SIP is asserted. So add the .prepare and .unprepare
ops to make sure the ISC_CLKSR.SIP is unasserted before the write
operation to the ISC_CLKEN or IS
Add the spin lock for the clock enable and disable operations.
Signed-off-by: Wenyou Yang
---
Changes in v2: None
drivers/media/platform/atmel/atmel-isc.c | 14 +-
1 file changed, 13 insertions(+), 1 deletion(-)
diff --git a/drivers/media/platform/atmel/atmel-isc.c
b/drivers/medi
To improve the readability of code, rework the format list table,
split the format array into two.
Meanwhile, fix the clock operation issue.
Changes in v2:
- Add the new patch to remove the unnecessary member from
isc_subdev_entity struct.
- Rebase on the patch set,
[PATCH 0/6] [media
I have just upgraded to f24. I am now using the standard dvb_usb_rtl28xxu fe
which logs messages suggesting all is well (I get the /dev/dvb/adapter? etc.)
but I get no channels tuned when I run mythfrontend or scandvb.
Is anyone using this combination?
Is this the correct way to use this tuner?
It should be "LP-11".
Signed-off-by: Jacob Chen
---
drivers/media/i2c/tc358743.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/media/i2c/tc358743.c b/drivers/media/i2c/tc358743.c
index e6f5c36..c208c30 100644
--- a/drivers/media/i2c/tc358743.c
+++ b/drivers/media/i2
Hi Wenyou,
[auto build test ERROR on linuxtv-media/master]
[also build test ERROR on v4.14-rc1 next-20170915]
[if your patch is applied to the wrong git tree, please drop us a note to help
improve the system]
url:
https://github.com/0day-ci/linux/commits/Wenyou-Yang/media-ov7670-Add-entity-i
This message is generated daily by a cron job that builds media_tree for
the kernels and architectures in the list below.
Results of the daily build of media_tree:
date: Mon Sep 18 05:00:21 CEST 2017
media-tree git hash:1efdf1776e2253b77413c997bed862410e4b6aaf
media_build gi
Hi Wenyou,
[auto build test ERROR on linuxtv-media/master]
[also build test ERROR on v4.14-rc1 next-20170915]
[if your patch is applied to the wrong git tree, please drop us a note to help
improve the system]
url:
https://github.com/0day-ci/linux/commits/Wenyou-Yang/media-ov7670-Add-entity-i
Add the s_power operation which is responsible for manipulating the
power dowm mode through the PWDN pin and the reset operation through
the RESET pin.
Signed-off-by: Wenyou Yang
---
Changes in v3: None
Changes in v2:
- Add the patch to support the get_fmt ops.
- Remove the redundant invoking
Add the get_fmt callback, also enable V4L2_SUBDEV_FL_HAS_DEVNODE flag
to make this subdev has device node.
Signed-off-by: Wenyou Yang
---
Changes in v3:
- Keep tried format info in the try_fmt member of
v4l2_subdev__pad_config struct.
- Add the internal_ops callback to set default format.
Add the media entity pads initialization.
Signed-off-by: Wenyou Yang
---
Changes in v3: None
Changes in v2: None
drivers/media/i2c/ov7670.c | 13 -
1 file changed, 12 insertions(+), 1 deletion(-)
diff --git a/drivers/media/i2c/ov7670.c b/drivers/media/i2c/ov7670.c
index e88549f0e7
This patch set is to add the media entity pads initialization,
the s_power operation and get_fmt callback support.
Changes in v3:
- Keep tried format info in the try_fmt member of
v4l2_subdev__pad_config struct.
- Add the internal_ops callback to set default format.
Changes in v2:
- Add the
Hi Laurent,
On 15/09/17 17:58, Laurent Pinchart wrote:
> Hi Kieran,
>
> Thank you for the patch.
>
> On Friday, 15 September 2017 19:42:05 EEST Kieran Bingham wrote:
>> DRM pipelines utilising the VSP must stop all frame processing as part
>> of the suspend operation to ensure the hardware is id
I propose the following patch to support Hauppauge HVR-1200 analog
video, nothing more than a clone of HVR-1500. Patch based on Linux 4.9
commit 69973b830859bc6529a7a0468ba0d80ee5117826
I have tested composite and S-Video inputs.
With the change, HVR-1200 devices have a /dev/video entry which
From: Markus Elfring
Date: Sun, 17 Sep 2017 21:07:39 +0200
Add jump targets so that a bit of exception handling can be better reused
at the end of this function.
Signed-off-by: Markus Elfring
---
drivers/media/usb/cx231xx/cx231xx-417.c | 61 -
1 file changed, 29
From: Markus Elfring
Date: Sun, 17 Sep 2017 20:22:15 +0200
Add a jump target so that a bit of exception handling can be better reused
at the end of this function.
This issue was detected by using the Coccinelle software.
Signed-off-by: Markus Elfring
---
drivers/media/usb/cx231xx/cx231xx-card
From: Markus Elfring
Date: Sun, 17 Sep 2017 20:28:00 +0200
The local variable "ret" will be set to an appropriate value a bit later.
Thus omit the explicit initialisation at the beginning.
Signed-off-by: Markus Elfring
---
drivers/media/usb/cx231xx/cx231xx-cards.c | 2 +-
1 file changed, 1 ins
From: Markus Elfring
Date: Sun, 17 Sep 2017 20:10:34 +0200
Add jump targets so that a bit of exception handling can be better reused
at the end of this function.
Signed-off-by: Markus Elfring
---
drivers/media/usb/cx231xx/cx231xx-dvb.c | 135 +---
1 file changed, 53
From: Markus Elfring
Date: Sun, 17 Sep 2017 18:53:16 +0200
The variable "result" will eventually be set to an appropriate value
a bit later. Thus omit the explicit initialisation at the beginning.
Signed-off-by: Markus Elfring
---
drivers/media/usb/cx231xx/cx231xx-dvb.c | 2 +-
1 file changed,
From: Markus Elfring
Date: Sun, 17 Sep 2017 18:38:50 +0200
Replace the specification of data structures by variable references
as the parameter for the operator "sizeof" to make the corresponding size
determination a bit safer according to the Linux coding style convention.
Signed-off-by: Markus
From: Markus Elfring
Date: Sun, 17 Sep 2017 18:23:06 +0200
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
The script “checkpatch.pl” pointed information out like the following.
Comparison to NULL could be written …
Thus fix the affected source code pla
From: Markus Elfring
Date: Sun, 17 Sep 2017 17:43:47 +0200
Omit extra messages for a memory allocation failure in these functions.
This issue was detected by using the Coccinelle software.
Signed-off-by: Markus Elfring
---
drivers/media/usb/cx231xx/cx231xx-core.c | 14 ++
drivers/
From: Markus Elfring
Date: Sun, 17 Sep 2017 21:30:12 +0200
Some update suggestions were taken into account
from static source code analysis.
Markus Elfring (8):
Delete eight error messages for a failed memory allocation
Adjust 56 checks for null pointers
Improve six size determinations
D
Signed-off-by: Oleh Kravchenko
---
dvb-t/ua-Shostka | 55 +++
1 file changed, 55 insertions(+)
create mode 100644 dvb-t/ua-Shostka
diff --git a/dvb-t/ua-Shostka b/dvb-t/ua-Shostka
new file mode 100644
index 000..696a428
--- /dev/null
+++ b
Hello,
The hardware was working with kernel 4.4.
I'm trying to make my DVB-T to work with my Ubuntu 17.04 and kernel 4.10.
The complied version installed didn't work (with error:
dvb_usb_dibusb_mc_common: Unknown symbol __symbol_get (err 0))
So I'm trying to make it work with the latest code versi
From: Markus Elfring
Date: Sun, 17 Sep 2017 13:32:45 +0200
The script "checkpatch.pl" pointed information out like the following.
WARNING: void function return statements are not generally useful
Thus remove such a statement in the affected function.
Signed-off-by: Markus Elfring
---
drivers
From: Markus Elfring
Date: Sun, 17 Sep 2017 13:23:47 +0200
The script "checkpatch.pl" pointed information out like the following.
WARNING: kfree(NULL) is safe and this check is probably not required
Thus fix the affected source code place.
Signed-off-by: Markus Elfring
---
drivers/media/usb/
From: Markus Elfring
Date: Sun, 17 Sep 2017 12:56:50 +0200
The script "checkpatch.pl" pointed information out like the following.
ERROR: do not use assignment in if condition
Thus fix the affected source code places.
Signed-off-by: Markus Elfring
---
drivers/media/usb/cpia2/cpia2_usb.c | 7 +
From: Markus Elfring
Date: Sun, 17 Sep 2017 12:40:14 +0200
Add a jump target so that a bit of exception handling can be better reused
at the end of this function.
This issue was detected by using the Coccinelle software.
Signed-off-by: Markus Elfring
---
drivers/media/usb/cpia2/cpia2_usb.c | 1
From: Markus Elfring
Date: Sun, 17 Sep 2017 15:25:35 +0200
A few update suggestions were taken into account
from static source code analysis.
Markus Elfring (4):
Use common error handling code in cpia2_usb_probe()
Adjust two function calls together with a variable assignment
Delete unneces
From: Hans Verkuil
Add support for two new low-level events: PIN_HPD_LOW and PIN_HPD_HIGH.
This is specifically meant for use with the upcoming cec-gpio driver
and makes it possible to trace when the HPD pin changes. Some HDMI
sinks do strange things with the HPD and this makes it easy to debug
From: Hans Verkuil
Document these new CEC events.
Signed-off-by: Hans Verkuil
---
Documentation/media/uapi/cec/cec-ioc-dqevent.rst | 18 ++
1 file changed, 18 insertions(+)
diff --git a/Documentation/media/uapi/cec/cec-ioc-dqevent.rst
b/Documentation/media/uapi/cec/cec-ioc-dq
From: Hans Verkuil
Add a simple HDMI CEC GPIO driver that sits on top of the cec-pin framework.
While I have heard of SoCs that use the GPIO pin for CEC (apparently an
early RockChip SoC used that), the main use-case of this driver is to
function as a debugging tool.
By connecting the CEC line
From: Hans Verkuil
Add an entry for the CEC GPIO driver.
Signed-off-by: Hans Verkuil
---
MAINTAINERS | 9 +
1 file changed, 9 insertions(+)
diff --git a/MAINTAINERS b/MAINTAINERS
index eb930ebecfcb..5ef0d34ef502 100644
--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -3205,6 +3205,15 @@ F:
From: Hans Verkuil
This driver adds support for CEC implementations that use a pull-up
GPIO line. While SoCs exist that do this, the primary use-case is to
turn a single-board computer into a cheap CEC debugger.
Together with 'cec-ctl --monitor-pin' you can do low-level CEC bus
monitoring and do
From: Hans Verkuil
Document the bindings for the cec-gpio module for hardware where the
CEC line and optionally the HPD line are connected to GPIO lines.
Signed-off-by: Hans Verkuil
Reviewed-by: Linus Walleij
---
.../devicetree/bindings/media/cec-gpio.txt | 32 ++
From: Markus Elfring
Date: Sun, 17 Sep 2017 11:40:31 +0200
Omit an extra message for a memory allocation failure in this function.
This issue was detected by using the Coccinelle software.
Signed-off-by: Markus Elfring
---
drivers/media/usb/au0828/au0828-core.c | 4 +---
1 file changed, 1 ins
On Sat, Sep 16, 2017 at 4:28 PM, Hans Verkuil wrote:
> From: Hans Verkuil
>
> Add a simple HDMI CEC GPIO driver that sits on top of the cec-pin framework.
>
> While I have heard of SoCs that use the GPIO pin for CEC (apparently an
> early RockChip SoC used that), the main use-case of this driver
On Sat, Sep 16, 2017 at 4:28 PM, Hans Verkuil wrote:
> From: Hans Verkuil
>
> Document the bindings for the cec-gpio module for hardware where the
> CEC line and optionally the HPD line are connected to GPIO lines.
>
> Signed-off-by: Hans Verkuil
Just to make things explicit:
> +Required prope
From: Markus Elfring
Date: Sun, 17 Sep 2017 11:03:21 +0200
Replace the specification of a data structure by a pointer dereference
as the parameter for the operator "sizeof" to make the corresponding size
determination a bit safer according to the Linux coding style convention.
This issue was det
From: Markus Elfring
Date: Sun, 17 Sep 2017 11:00:09 +0200
Omit an extra message for a memory allocation failure in this function.
This issue was detected by using the Coccinelle software.
Signed-off-by: Markus Elfring
---
drivers/media/usb/airspy/airspy.c | 4 +---
1 file changed, 1 insertio
From: Markus Elfring
Date: Sun, 17 Sep 2017 11:11:02 +0200
Two update suggestions were taken into account
from static source code analysis.
Markus Elfring (2):
Delete an error message for a failed memory allocation
Improve a size determination
drivers/media/usb/airspy/airspy.c | 6 ++
From: Markus Elfring
Date: Sun, 17 Sep 2017 09:42:17 +0200
Replace the specification of data structures by variable references
as the parameter for the operator "sizeof" to make the corresponding size
determination a bit safer according to the Linux coding style convention.
Signed-off-by: Markus
From: Markus Elfring
Date: Sun, 17 Sep 2017 09:33:58 +0200
* Omit an extra message for a memory allocation failure in this function.
This issue was detected by using the Coccinelle software.
* Add a jump target so that the function "kfree" will be always called
with a non-null pointer.
Sig
From: Markus Elfring
Date: Sun, 17 Sep 2017 10:03:45 +0200
Two update suggestions were taken into account
from static source code analysis.
Markus Elfring (2):
Delete an error message for a failed memory allocation
Improve three size determinations
drivers/media/tuners/tda18212.c | 13
52 matches
Mail list logo