This message is generated daily by a cron job that builds media_tree for
the kernels and architectures in the list below.
Results of the daily build of media_tree:
date: Tue May 2 05:00:19 CEST 2017
media-tree git hash:3622d3e77ecef090b5111e3c5423313f11711dfa
media_build gi
Hi Frank,
Em Mon, 1 May 2017 16:11:51 +0200
Frank Schäfer escreveu:
> Am 01.05.2017 um 13:38 schrieb Mauro Carvalho Chehab:
> > Right now, all devices use bus 0 for eeprom. However, newer
> > versions of Terratec H6 use a different buffer for eeprom.
> >
> > So, add support to use a different I2
On Mon, May 01, 2017 at 05:49:53PM +0100, Sean Young wrote:
>On Thu, Apr 27, 2017 at 10:34:03PM +0200, David Härdeman wrote:
>> The device core infrastructure is based on the presumption that
>> once a driver calls device_add(), it must be ready to accept
>> userspace interaction.
>>
>> This requi
Le vendredi 28 avril 2017 à 17:02 +0200, Hugues Fruchet a écrit :
> Add the mpeg2 codecparser backend glue which will
> call the GStreamer parsing functions.
>
> Signed-off-by: Hugues Fruchet
> ---
> configure.ac| 21 ++
> lib/libv4l-codecparsers/Makefile.am
On Mon, May 01, 2017 at 02:49:57PM +0200, David Härdeman wrote:
> On Mon, May 01, 2017 at 11:38:30AM +0100, Sean Young wrote:
> >On Sat, Apr 29, 2017 at 12:52:12PM +0200, David Härdeman wrote:
> >> Whether we decide to go for any new keytable ioctl():s or not in rc-core,
> >> we
> >> should provid
On Thu, Apr 27, 2017 at 10:34:03PM +0200, David Härdeman wrote:
> The device core infrastructure is based on the presumption that
> once a driver calls device_add(), it must be ready to accept
> userspace interaction.
>
> This requires splitting rc_setup_rx_device() into two functions
> and reorga
On Mon, May 01, 2017 at 03:32:34PM +0200, David Härdeman wrote:
> ir_lirc_register() currently creates its own lirc_buffer before
> passing the lirc_driver to lirc_register_driver().
>
> When a module is later unloaded, ir_lirc_unregister() gets called
> which performs a call to lirc_unregister_dr
Just some debug statements to change.
Signed-off-by: David Härdeman
---
drivers/media/usb/cx231xx/cx231xx-input.c |5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)
diff --git a/drivers/media/usb/cx231xx/cx231xx-input.c
b/drivers/media/usb/cx231xx/cx231xx-input.c
index 6e80f3c573f3.
Not sure what the driver is trying to do, however, IR handling seems incomplete
ATM so deleting the offending parts shouldn't affect functionality
Signed-off-by: David Härdeman
---
drivers/media/usb/tm6000/tm6000-input.c |4
1 file changed, 4 deletions(-)
diff --git a/drivers/media/usb
Replace the REP_DELAY value with a static value, which makes more sense.
Automatic repeat handling in the input layer has no relevance for the drivers
idea of "a long time".
Signed-off-by: David Härdeman
---
drivers/media/rc/rc-ir-raw.c |4 +---
1 file changed, 1 insertion(+), 3 deletions(-)
Obvious fix, leave repeat handling to rc-core
Signed-off-by: David Härdeman
---
drivers/media/rc/ir-nec-decoder.c | 10 +++---
1 file changed, 3 insertions(+), 7 deletions(-)
diff --git a/drivers/media/rc/ir-nec-decoder.c
b/drivers/media/rc/ir-nec-decoder.c
index 3ce850314dca..75b9137f6f
Changing the protocol does not imply that the keymap changes.
Signed-off-by: David Härdeman
---
drivers/media/rc/img-ir/img-ir-hw.c |4
1 file changed, 4 deletions(-)
diff --git a/drivers/media/rc/img-ir/img-ir-hw.c
b/drivers/media/rc/img-ir/img-ir-hw.c
index 431d33b36fb0..8d143962253
Leave repeat handling to rc-core.
Signed-off-by: David Härdeman
---
drivers/media/rc/ir-sanyo-decoder.c | 10 +++---
1 file changed, 3 insertions(+), 7 deletions(-)
diff --git a/drivers/media/rc/ir-sanyo-decoder.c
b/drivers/media/rc/ir-sanyo-decoder.c
index 520bb77dcb62..e6a906a34f90 100
The following patch series fixes up various drivers which go
poking around in struct rc_dev for no good reason.
---
David Härdeman (7):
rc-core: ati_remote - leave the internals of rc_dev alone
rc-core: img-ir - leave the internals of rc_dev alone
rc-core: img-nec-decoder - leav
The REP_DELAY setting on the input device is independent of hardware. This
change should not change how to driver works (as it does a keydown/keyup and
has no real repeat handling).
Signed-off-by: David Härdeman
---
drivers/media/rc/ati_remote.c |3 ---
1 file changed, 3 deletions(-)
diff -
Most drivers return both values when the device is gone.
Signed-off-by: David Härdeman
---
drivers/media/rc/lirc_dev.c |2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/media/rc/lirc_dev.c b/drivers/media/rc/lirc_dev.c
index 57d21201ff93..e44e0b23b883 100644
--- a/dr
Remove superfluous includes and defines.
Signed-off-by: David Härdeman
---
drivers/media/rc/lirc_dev.c | 12 +---
1 file changed, 1 insertion(+), 11 deletions(-)
diff --git a/drivers/media/rc/lirc_dev.c b/drivers/media/rc/lirc_dev.c
index 7db7d4c57991..4ba6c7e2d41b 100644
--- a/driver
Remove some stuff from lirc_dev.h which is not used anywhere.
Signed-off-by: David Härdeman
---
include/media/lirc_dev.h | 11 ++-
1 file changed, 2 insertions(+), 9 deletions(-)
diff --git a/include/media/lirc_dev.h b/include/media/lirc_dev.h
index 11f455a34090..af738d522dec 100644
-
The name is only used for a few debug messages and the name of the parent
device as well as the name of the lirc device (e.g. "lirc0") are sufficient
anyway.
Signed-off-by: David Härdeman
---
drivers/media/rc/ir-lirc-codec.c|2 --
drivers/media/rc/lirc_dev.c | 25 ++
Using the kernel ida facilities, we can avoid a lot of unnecessary code and at
the same
time get rid of lirc_dev_lock in favour of per-device locks (the irctls array
was used
throughout lirc_dev so this patch necessarily touches a lot of code).
Signed-off-by: David Härdeman
---
drivers/media/r
The "debug" parameter isn't actually used anywhere.
Signed-off-by: David Härdeman
---
drivers/media/rc/lirc_dev.c |5 -
1 file changed, 5 deletions(-)
diff --git a/drivers/media/rc/lirc_dev.c b/drivers/media/rc/lirc_dev.c
index 34bd3f8bf30d..57d21201ff93 100644
--- a/drivers/media/rc/li
device_add() and friends alredy manage the references to the parent device so
these calls aren't necessary.
Signed-off-by: David Härdeman
---
drivers/media/rc/lirc_dev.c |4
1 file changed, 4 deletions(-)
diff --git a/drivers/media/rc/lirc_dev.c b/drivers/media/rc/lirc_dev.c
index 574f
Remove the "minor" module parameter in preparation for the next patch.
Signed-off-by: David Härdeman
---
drivers/staging/media/lirc/lirc_zilog.c | 16 ++--
1 file changed, 6 insertions(+), 10 deletions(-)
diff --git a/drivers/staging/media/lirc/lirc_zilog.c
b/drivers/staging/medi
These two functions only make the logic in lirc_register_driver() harder to
follow.
(Note that almost no other driver calls kobject_set_name() on their cdev so I
simply removed that part).
Signed-off-by: David Härdeman
---
drivers/media/rc/lirc_dev.c | 44 -
Merging the two means that lirc_allocate_buffer() is called before device_add()
and cdev_add() which makes more sense. This also simplifies the locking
slightly because lirc_allocate_buffer() will always be called with lirc_dev_lock
held.
Signed-off-by: David Härdeman
---
drivers/media/rc/lirc_d
Every caller of lirc_register_driver() passes their own fops and there are no
users of lirc_dev_fop_write() in the kernel tree. Thus we can make fops
mandatory and remove lirc_dev_fop_write().
Signed-off-by: David Härdeman
---
drivers/media/rc/lirc_dev.c | 41 +-
out_sysfs is misleading, sysfs only comes into play after device_add(). Also,
calling device_init() before the rest of struct dev is filled out is clearer.
Signed-off-by: David Härdeman
---
drivers/media/rc/lirc_dev.c |6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/d
There are no drivers which use this functionality.
Signed-off-by: David Härdeman
---
drivers/media/rc/lirc_dev.c | 94 +--
drivers/staging/media/lirc/lirc_zilog.c |1
include/media/lirc_dev.h| 16 -
3 files changed, 2 insertion
Since there are no users of this functionality, it can be removed altogether.
Signed-off-by: David Härdeman
---
drivers/media/rc/ir-lirc-codec.c |2 --
drivers/media/rc/lirc_dev.c | 24 ++--
include/media/lirc_dev.h |6 --
3 files changed, 6 inserti
drv->set_use_inc and drv->set_use_dec are already optional so we can remove all
dummy functions.
Signed-off-by: David Härdeman
---
drivers/media/rc/ir-lirc-codec.c| 14 ++
drivers/staging/media/lirc/lirc_zilog.c | 11 ---
2 files changed, 2 insertions(+), 23 delet
lirc_dev has lots of functionality which is unused and the code isn't exactly
up-to-date with current kernel practices. This patchset removes the unused bits
and also simplifies the locking by moving lirc_dev over to only use
per-device mutexes rather than a big lirc lock in addition to per-device
If an error is generated, nonseekable_open() shouldn't be called.
Signed-off-by: David Härdeman
---
drivers/media/rc/lirc_dev.c |6 --
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a/drivers/media/rc/lirc_dev.c b/drivers/media/rc/lirc_dev.c
index 05f600bd6c67..7f13ed479e1c
On Mon, May 1, 2017 at 10:11 AM, Frank Schäfer
wrote:
>
> Am 01.05.2017 um 13:38 schrieb Mauro Carvalho Chehab:
>> Right now, all devices use bus 0 for eeprom. However, newer
>> versions of Terratec H6 use a different buffer for eeprom.
>>
>> So, add support to use a different I2C address for eepr
Am 01.05.2017 um 13:38 schrieb Mauro Carvalho Chehab:
> Right now, all devices use bus 0 for eeprom. However, newer
> versions of Terratec H6 use a different buffer for eeprom.
>
> So, add support to use a different I2C address for eeprom.
Has this been tested ?
Did you read my reply to the previ
ir_lirc_register() currently creates its own lirc_buffer before
passing the lirc_driver to lirc_register_driver().
When a module is later unloaded, ir_lirc_unregister() gets called
which performs a call to lirc_unregister_driver() and then free():s
the lirc_buffer.
The problem is that:
a) there
On Mon, May 01, 2017 at 01:22:21PM +0100, Sean Young wrote:
>On Sat, Apr 29, 2017 at 11:22:28PM +0200, David Härdeman wrote:
>> ir_lirc_register() currently creates its own lirc_buffer before
>> passing the lirc_driver to lirc_register_driver().
>>
>> When a module is later unloaded, ir_lirc_unreg
On Mon, May 01, 2017 at 11:38:30AM +0100, Sean Young wrote:
>On Sat, Apr 29, 2017 at 12:52:12PM +0200, David Härdeman wrote:
>> Whether we decide to go for any new keytable ioctl():s or not in rc-core, we
>> should provide the protocol information of keypresses to userspace.
>>
>> Note that this m
On Mon, May 01, 2017 at 11:36:13AM +0100, Sean Young wrote:
>On Sat, Apr 29, 2017 at 12:03:29PM +0200, David Härdeman wrote:
>> Exporting the hardware type makes it possible for userspace applications
>> to know what to expect from the hardware.
>>
>> This makes it possible to write more user-frie
On Sat, Apr 29, 2017 at 11:22:28PM +0200, David Härdeman wrote:
> ir_lirc_register() currently creates its own lirc_buffer before
> passing the lirc_driver to lirc_register_driver().
>
> When a module is later unloaded, ir_lirc_unregister() gets called
> which performs a call to lirc_unregister_dr
There's a new version of Terratec H6 with uses USB ID
0ccd:10b2. This version is similar to the old one (with is
supported via the HTC entry), except that this one has the
eeprom on the second bus.
Signed-off-by: Mauro Carvalho Chehab
---
drivers/media/usb/em28xx/em28xx-cards.c | 19
Right now, all devices use bus 0 for eeprom. However, newer
versions of Terratec H6 use a different buffer for eeprom.
So, add support to use a different I2C address for eeprom.
Signed-off-by: Mauro Carvalho Chehab
---
drivers/media/usb/em28xx/em28xx-cards.c | 1 +
drivers/media/usb/em28xx/em28
On Sat, Apr 29, 2017 at 12:52:12PM +0200, David Härdeman wrote:
> Whether we decide to go for any new keytable ioctl():s or not in rc-core, we
> should provide the protocol information of keypresses to userspace.
>
> Note that this means that the RC_TYPE_* definitions become part of the
> userspac
On Sat, Apr 29, 2017 at 12:03:29PM +0200, David Härdeman wrote:
> Exporting the hardware type makes it possible for userspace applications
> to know what to expect from the hardware.
>
> This makes it possible to write more user-friendly userspace apps.
This duplicates lirc features (LIRC_GET_FEA
On Fri, Apr 28, 2017 at 09:47:05AM +0100, Kieran Bingham wrote:
> Hi Simon,
>
> On 28/04/17 08:09, Simon Horman wrote:
> > On Thu, Apr 27, 2017 at 07:25:59PM +0100, Kieran Bingham wrote:
> >> From: Kieran Bingham
> >>
> >> This is an RFC for the Analog Devices ADV748x driver, and follows on from
On Fri, Apr 28, 2017 at 11:40:20AM +0300, Laurent Pinchart wrote:
> Hi Simon,
>
> On Friday 28 Apr 2017 07:16:24 Simon Horman wrote:
> > On Wed, Apr 26, 2017 at 06:56:06PM +0300, Laurent Pinchart wrote:
> > > On Tuesday 21 Feb 2017 01:42:15 Laurent Pinchart wrote:
> > >> On Thursday 20 Oct 2016 10
45 matches
Mail list logo