On Thu, Jan 12, 2017 at 03:29:00PM -0600, Bjorn Helgaas wrote:
> Applied all three (with Tom's ack on the amd-xgbe patch) to pci/msi for
> v4.11, thanks!
Tom had just send me an event better version of the xgbe patch. Tom,
maybe you can resend that relative to the PCI tree [1], so that we don't
l
From: Sean Wang
This patchset introduces consumer IR (CIR) support on MT7623 SoC
that also works on other similar SoCs and implements raw mode for
more compatibility with different protocols. The driver simply
reports the duration of pulses and spaces to rc-core logic to
decode.
Changes since v
From: Sean Wang
This patch adds driver for IR controller on MT7623 SoC.
and should also work on similar Mediatek SoC. Currently
testing successfully on NEC and SONY remote controller
only but it should work on others (lirc, rc-5 and rc-6).
Signed-off-by: Sean Wang
Reviewed-by: Sean Young
---
From: Sean Wang
Most IR drivers uses the same label to identify the
scancdoe/key table they used by multiple bindings and lack
explanation well. So move the shared property into a common
place and give better explanation.
Signed-off-by: Sean Wang
---
.../devicetree/bindings/media/gpio-ir-recei
From: Sean Wang
This patch adds documentation for devicetree bindings for
consumer Mediatek IR controller.
Signed-off-by: Sean Wang
---
.../devicetree/bindings/media/mtk-cir.txt | 24 ++
1 file changed, 24 insertions(+)
create mode 100644 Documentation/devicetree/
This message is generated daily by a cron job that builds media_tree for
the kernels and architectures in the list below.
Results of the daily build of media_tree:
date: Fri Jan 13 05:00:18 CET 2017
media-tree git hash:40eca140c404505c09773d1c6685d818cb55ab1a
media_build git
On Sun, Jan 8, 2017 at 9:33 PM, Marek Vasut wrote:
> On 01/09/2017 06:17 AM, Matt Ranostay wrote:
>> Gentle ping on this! :)
>
> Just some high-level feedback ... You should use regmap instead. Also,
> calling a driver which is specific to a particular sensor (amg88x) by
> generic name (video_i2c)
On 01/12/2017 03:43 PM, Steve Longerbeam wrote:
On 01/12/2017 03:22 PM, Steve Longerbeam wrote:
and since my PRPVF entity roles
up the VDIC internally, it is actually receiving from the VDIC
channel.
So unless you think we should have a distinct VDIC entity, I would
like
to keep this
t
On Thu, Jan 12, 2017 at 05:32:09PM +0100, Nicolas Dichtel wrote:
> What I was trying to say is that I export those directories like other are.
> Removing those files is not related to that series.
Perhaps the correct solution is to only copy files matching "*.h" to
reduce the risk of copying files
On 01/12/2017 03:22 PM, Steve Longerbeam wrote:
and since my PRPVF entity roles
up the VDIC internally, it is actually receiving from the VDIC channel.
So unless you think we should have a distinct VDIC entity, I would like
to keep this
the way it is.
Yes, I think VDIC should be separated o
On 01/12/2017 11:37 AM, Tim Harvey wrote:
On Fri, Jan 6, 2017 at 6:11 PM, Steve Longerbeam wrote:
Add pinctrl groups for both GPT input capture channels.
Signed-off-by: Steve Longerbeam
---
arch/arm/boot/dts/imx6qdl-sabreauto.dtsi | 12
1 file changed, 12 insertions(+)
diff
Hi Philipp, JM,
First, let me say that you both have convinced me that we need a VDIC
entity. I've implemented that in the branch imx-media-staging-md-vdic.
At this point it only implements the M/C de-interlacing function, not the
plane Combiner. So it has only one input and one output pad. I wo
On 11/01/17 09:54 PM, Stephen Bates wrote:
> The iopmem patchset addressed all the use cases above and while it is not
> an in kernel API it could have been modified to be one reasonably easily.
> As Logan states the driver can then choose to pass the VMAs to user-space
> in a manner that makes s
Hi Tim,
On 01/12/2017 01:13 PM, Tim Harvey wrote:
Now that your driver is hooking into the current media framework, I'm
not at all clear on how to link and configure the media entities.
It's all documented at Documentation/media/v4l-drivers/imx.rst.
Follow the SabreAuto pipeline setup examp
On Mon, Jan 09, 2017 at 09:37:37PM +0100, Christoph Hellwig wrote:
> I had hope that we could kill these old interfaces of for 4.10-rc,
> but as of today Linus tree still has two users:
>
> (1) the cobalt media driver, for which I sent a patch long time ago,
> it got missed in the merge wind
On Wed, Jan 11, 2017 at 7:22 PM, Steve Longerbeam
wrote:
> Hi Tim,
>
>
> On 01/11/2017 03:14 PM, Tim Harvey wrote:
>>
>>
>>
>>
>> Hi Steve,
>>
>> I took a stab at testing this today on a gw51xx which has an adv7180
>> hooked up as follows:
>> - i2c3@0x20
>> - 8bit data bus from DAT12 to DAT19, HS
On Fri, Jan 6, 2017 at 6:11 PM, Steve Longerbeam wrote:
> Add pinctrl groups for both GPT input capture channels.
>
> Signed-off-by: Steve Longerbeam
> ---
> arch/arm/boot/dts/imx6qdl-sabreauto.dtsi | 12
> 1 file changed, 12 insertions(+)
>
> diff --git a/arch/arm/boot/dts/imx6qdl-
On 01/12/2017 06:43 PM, Ramiro Oliveira wrote:
> Hi Hans,
>
> Thank you for your feedback.
>
> On 1/11/2017 11:54 AM, Hans Verkuil wrote:
>> Hi Ramiro,
>>
>> See my review comments below:
>>
>> On 12/12/16 16:00, Ramiro Oliveira wrote:
>>> Add support for the DesignWare CSI-2 Host IP Prototyping
Hi Hans,
Thank you for your feedback.
On 1/11/2017 11:54 AM, Hans Verkuil wrote:
> Hi Ramiro,
>
> See my review comments below:
>
> On 12/12/16 16:00, Ramiro Oliveira wrote:
>> Add support for the DesignWare CSI-2 Host IP Prototyping Kit
>>
>> Signed-off-by: Ramiro Oliveira
[snip]
>> +static
On Thu, Jan 12, 2017 at 10:11:29AM -0500, Jerome Glisse wrote:
> On Wed, Jan 11, 2017 at 10:54:39PM -0600, Stephen Bates wrote:
> > > What we want is for RDMA, O_DIRECT, etc to just work with special VMAs
> > > (ie. at least those backed with ZONE_DEVICE memory). Then
> > > GPU/NVME/DAX/whatever dr
On Thursday 2017-01-12 16:52, Nicolas Dichtel wrote:
>Le 09/01/2017 à 13:56, Christoph Hellwig a écrit :
>> On Fri, Jan 06, 2017 at 10:43:59AM +0100, Nicolas Dichtel wrote:
>>> Regularly, when a new header is created in include/uapi/, the developer
>>> forgets to add it in the corresponding Kbuild
Le 12/01/2017 à 17:28, Jan Engelhardt a écrit :
> On Thursday 2017-01-12 16:52, Nicolas Dichtel wrote:
>
>> Le 09/01/2017 à 13:56, Christoph Hellwig a écrit :
>>> On Fri, Jan 06, 2017 at 10:43:59AM +0100, Nicolas Dichtel wrote:
Regularly, when a new header is created in include/uapi/, the dev
Le 09/01/2017 à 13:56, Christoph Hellwig a écrit :
> On Fri, Jan 06, 2017 at 10:43:59AM +0100, Nicolas Dichtel wrote:
>> Regularly, when a new header is created in include/uapi/, the developer
>> forgets to add it in the corresponding Kbuild file. This error is usually
>> detected after the release
From: Wei Yongjun
Fixes the following sparse warning:
drivers/media/usb/dvb-usb/gp8psk.c:281:28: warning:
symbol 'gp8psk_fe_ops' was not declared. Should it be static?
Signed-off-by: Wei Yongjun
---
drivers/media/usb/dvb-usb/gp8psk.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
dif
On Wed, Jan 11, 2017 at 10:54:39PM -0600, Stephen Bates wrote:
> On Fri, January 6, 2017 4:10 pm, Logan Gunthorpe wrote:
> >
> >
> > On 06/01/17 11:26 AM, Jason Gunthorpe wrote:
> >
> >
> >> Make a generic API for all of this and you'd have my vote..
> >>
> >>
> >> IMHO, you must support basic pinn
From: Wei Yongjun
Fix typo in parameter description.
Signed-off-by: Wei Yongjun
---
drivers/media/usb/tm6000/tm6000-input.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/media/usb/tm6000/tm6000-input.c
b/drivers/media/usb/tm6000/tm6000-input.c
index 7fe00a5..6856
Hi Pavel,
On Wed, Jan 11, 2017 at 11:53:35PM +0100, Pavel Machek wrote:
> From: Sakari Ailus
>
> In the vast majority of cases the bus type is known to the driver(s)
> since a receiver or transmitter can only support a single one. There
> are cases however where different options are possible.
>
On Sat 2016-12-24 16:20:31, Pavel Machek wrote:
>
> N900 contains front and back camera, with a switch between the
> two. This adds support for the switch component, and it is now
> possible to select between front and back cameras during runtime.
>
> Signed-off-by: Sebastian Reichel
> Signed-of
From: Sakari Ailus
The function to parse CSI2 bus parameters was called
v4l2_of_parse_csi_bus(), rename it as v4l2_of_parse_csi2_bus() in
anticipation of CSI1/CCP2 support.
Obtain data bus type from bus-type property. Only try parsing bus
specific properties in this case.
Separate lane parsing
Second attempt, this time with the [ANN] prefix in the hope more people will
reply...
Mauro is on vacation until the 21st, so he asked me to see who will go to the
ELC
in Portland in February.
If there are enough core developers there, then we can organize a summit meeting
on the Monday (Feb 2
30 matches
Mail list logo