cron job: media_tree daily build: WARNINGS

2016-04-23 Thread Hans Verkuil
This message is generated daily by a cron job that builds media_tree for the kernels and architectures in the list below. Results of the daily build of media_tree: date: Sun Apr 24 04:00:18 CEST 2016 git branch: test git hash: e07d46e7e0da86c146f199dae76f879096bc436a gcc versi

[PATCH 08/13] v4l: vsp1: Make vsp1_entity_get_pad_compose() more generic

2016-04-23 Thread Laurent Pinchart
Turn the helper into a function that can retrieve crop and compose selection rectangles. Signed-off-by: Laurent Pinchart --- drivers/media/platform/vsp1/vsp1_entity.c | 24 drivers/media/platform/vsp1/vsp1_entity.h | 6 +++--- drivers/media/platform/vsp1/vsp1_rpf.c|

[PATCH 06/13] v4l: vsp1: Add output node value to routing table

2016-04-23 Thread Laurent Pinchart
The output node value indicates the value to be used in a sampling point register to use the node as the source of histogram data. Signed-off-by: Laurent Pinchart --- drivers/media/platform/vsp1/vsp1_entity.c | 52 --- drivers/media/platform/vsp1/vsp1_entity.h | 6 ++

[PATCH 07/13] v4l: vsp1: Replace container_of() with dedicated macro

2016-04-23 Thread Laurent Pinchart
Add a macro to cast from a struct media_entity to a struct vsp1_entity to replace the manual implementations. Signed-off-by: Laurent Pinchart --- drivers/media/platform/vsp1/vsp1_entity.c | 10 -- 1 file changed, 8 insertions(+), 2 deletions(-) diff --git a/drivers/media/platform/vsp1/v

[PATCH 13/13] v4l: vsp1: Remove deprecated DRM API

2016-04-23 Thread Laurent Pinchart
The DRM driver has switched to the new API, remove the deprecated macros and inline wrapper. Signed-off-by: Laurent Pinchart --- drivers/media/platform/vsp1/vsp1_drm.c | 6 +++--- include/media/vsp1.h | 28 ++-- 2 files changed, 5 insertions(+), 29 dele

[PATCH 09/13] v4l: vsp1: Move frame sequence number from video node to pipeline

2016-04-23 Thread Laurent Pinchart
The frame sequence number is global to the pipeline, there's no need to store copies in each video node. Signed-off-by: Laurent Pinchart --- drivers/media/platform/vsp1/vsp1_pipe.c | 2 ++ drivers/media/platform/vsp1/vsp1_pipe.h | 2 ++ drivers/media/platform/vsp1/vsp1_video.c | 4 +--- driver

[PATCH 04/13] v4l: vsp1: Don't handle clocks manually

2016-04-23 Thread Laurent Pinchart
The power domain performs functional clock handling when using runtime PM, there's no need to enable and disable the clock manually. Signed-off-by: Laurent Pinchart --- drivers/media/platform/vsp1/vsp1.h | 1 - drivers/media/platform/vsp1/vsp1_drv.c | 20 ++-- 2 files change

[PATCH 10/13] v4l: vsp1: Group DRM RPF parameters in a structure

2016-04-23 Thread Laurent Pinchart
The vsp1_du_atomic_update_ext() function takes 7 RPF configuration parameters, and more will likely be added later. This makes the code difficult to read and error-prone as multiple parameters have the same type. Make the API safer and easier to extend in the future by grouping all parameters in a

[PATCH 05/13] v4l: vsp1: Add FCP support

2016-04-23 Thread Laurent Pinchart
On some platforms the VSP performs memory accesses through an FCP. When that's the case get a reference to the FCP from the VSP DT node and enable/disable it at runtime as needed. Signed-off-by: Laurent Pinchart --- Changes since v1: - Depend on VIDEO_RENESAS_FCP on ARM64 --- .../devicetree/bin

[PATCH 11/13] drm: rcar-du: Add alpha support for VSP planes

2016-04-23 Thread Laurent Pinchart
Make the global alpha multiplier of VSP planes configurable through the alpha property, exactly as for the native DU planes. Signed-off-by: Laurent Pinchart Acked-by: Dave Airlie --- drivers/gpu/drm/rcar-du/rcar_du_vsp.c | 38 +-- 1 file changed, 19 insertions(+)

[PATCH 02/13] v4l: Add Renesas R-Car FCP driver

2016-04-23 Thread Laurent Pinchart
The FCP is a companion module of video processing modules in the Renesas R-Car Gen3 SoCs. It provides data compression and decompression, data caching, and conversion of AXI transaction in order to reduce the memory bandwidth. The driver is not meant to be used standalone but provides an API to th

[PATCH 12/13] drm: rcar-du: Add Z-order support for VSP planes

2016-04-23 Thread Laurent Pinchart
Make the Z-order of VSP planes configurable through the zpos property, exactly as for the native DU planes. Signed-off-by: Laurent Pinchart Acked-by: Dave Airlie --- drivers/gpu/drm/rcar-du/rcar_du_vsp.c | 11 --- drivers/gpu/drm/rcar-du/rcar_du_vsp.h | 2 ++ 2 files changed, 10 insert

[PATCH 03/13] v4l: vsp1: Implement runtime PM support

2016-04-23 Thread Laurent Pinchart
Replace the manual refcount and clock management code by runtime PM. Signed-off-by: Laurent Pinchart --- drivers/media/platform/Kconfig | 1 + drivers/media/platform/vsp1/vsp1.h | 3 - drivers/media/platform/vsp1/vsp1_drv.c | 101 drivers/media

[PATCH 01/13] dt-bindings: Add Renesas R-Car FCP DT bindings

2016-04-23 Thread Laurent Pinchart
The FCP is a companion module of video processing modules in the Renesas R-Car Gen3 SoCs. It provides data compression and decompression, data caching, and conversion of AXI transaction in order to reduce the memory bandwidth. Signed-off-by: Laurent Pinchart --- .../devicetree/bindings/media/ren

[PATCH 00/13] R-Car VSP improvements for v4.7 - Round 2

2016-04-23 Thread Laurent Pinchart
Hello, This patch series is the second (and most probably last) round of vsp1 driver improvements for v4.7. In particular, it enables runtime PM support (03/13 and 04/13), adds support for the FCP (01/13, 02/13 and 05/13), prepare for HGO (histogram) support (06/13 to 09/13) and update the API tow

dvb-s2 card "TeVii S472" (cx23885)

2016-04-23 Thread Hendrik Oenings
Hi all, I'm trying to use the dvb-s2 pci-express card "TeVii S472" with the linux kernel. I haven't found a usable driver until now, but I've seen that the previous cards (S471, S470) are supported by the current linux kernel. The driver from the manufacturer's site is more than one year old and

[PATCHv4 07/13] media/platform: convert drivers to use the new vb2_queue dev field

2016-04-23 Thread Hans Verkuil
From: Hans Verkuil Stop using alloc_ctx and just fill in the device pointer. Signed-off-by: Hans Verkuil Cc: "Lad, Prabhakar" Cc: Scott Jiang Acked-by: Philipp Zabel --- drivers/media/platform/am437x/am437x-vpfe.c| 10 +- drivers/media/platform/am437x/am437x-vpfe.h| 2 -- d

[PATCHv4 10/13] media/.../soc-camera: convert drivers to use the new vb2_queue dev field

2016-04-23 Thread Hans Verkuil
From: Hans Verkuil Stop using alloc_ctx and just fill in the device pointer. Signed-off-by: Hans Verkuil Cc: Guennadi Liakhovetski Cc: Ludovic Desroches Cc: Sergei Shtylyov --- drivers/media/platform/soc_camera/atmel-isi.c | 13 + drivers/media/platform/soc_camera/rcar

[PATCHv4 12/13] media/platform: convert drivers to use the new vb2_queue dev field

2016-04-23 Thread Hans Verkuil
From: Hans Verkuil Stop using alloc_ctx and just fill in the device pointer. Signed-off-by: Hans Verkuil Cc: Kyungmin Park Cc: Sylwester Nawrocki --- drivers/media/platform/exynos4-is/fimc-capture.c | 7 ++- drivers/media/platform/exynos4-is/fimc-core.c | 11 --- drivers/

[PATCHv4 11/13] media/platform: convert drivers to use the new vb2_queue dev field

2016-04-23 Thread Hans Verkuil
From: Hans Verkuil Stop using alloc_ctx and just fill in the device pointer. Signed-off-by: Hans Verkuil Cc: Kyungmin Park Cc: Sylwester Nawrocki --- drivers/media/platform/exynos-gsc/gsc-core.c | 11 +-- drivers/media/platform/exynos-gsc/gsc-core.h | 1 - drivers/media/plat

[PATCHv4 00/13] vb2: replace allocation context by device pointer

2016-04-23 Thread Hans Verkuil
From: Hans Verkuil The opaque allocation context that allocators use and drivers have to fill in is really nothing more than a device pointer wrapped in an kmalloc()ed struct. This patch series adds a new 'struct device *dev' field that contains the default device pointer to use if the driver do

[PATCHv4 05/13] media/pci: convert drivers to use the new vb2_queue dev field

2016-04-23 Thread Hans Verkuil
From: Hans Verkuil Stop using alloc_ctx and just fill in the device pointer. Signed-off-by: Hans Verkuil Cc: Federico Vaga Cc: Mauro Carvalho Chehab --- drivers/media/pci/cobalt/cobalt-driver.c | 9 - drivers/media/pci/cobalt/cobalt-driver.h | 1 - drivers/media/p

[PATCHv4 01/13] vb2: move dma_attrs to vb2_queue

2016-04-23 Thread Hans Verkuil
From: Hans Verkuil Make the dma attributes struct part of vb2_queue. This greatly simplifies the remainder of the patch series since the dma_contig alloc context is now (as before) just a struct device pointer. Signed-off-by: Hans Verkuil Cc: Laurent Pinchart Cc: Sakari Ailus Cc: Mauro Carval

[PATCHv4 08/13] media/platform: convert drivers to use the new vb2_queue dev field

2016-04-23 Thread Hans Verkuil
From: Hans Verkuil Stop using alloc_ctx and just fill in the device pointer. Signed-off-by: Hans Verkuil Cc: Fabien Dessenne Cc: Benoit Parrot Reviewed-by: Laurent Pinchart --- drivers/media/platform/sti/bdisp/bdisp-v4l2.c | 18 -- drivers/media/platform/sti/bdisp/bdisp.h

[PATCHv4 02/13] vb2: add a dev field to use for the default allocation context

2016-04-23 Thread Hans Verkuil
From: Hans Verkuil The allocation context is nothing more than a per-plane device pointer to use when allocating buffers. So just provide a dev pointer in vb2_queue for that purpose and drivers can skip allocating/releasing/filling in the allocation context unless they require different per-plane

[PATCHv4 09/13] media/platform: convert drivers to use the new vb2_queue dev field

2016-04-23 Thread Hans Verkuil
From: Hans Verkuil Stop using alloc_ctx and just fill in the device pointer. Signed-off-by: Hans Verkuil Reviewed-by: Laurent Pinchart Cc: Mikhail Ulyanov Cc: Guennadi Liakhovetski Cc: Jonathan Corbet --- drivers/media/platform/m2m-deinterlace.c| 15 ++- drivers/media/p

[PATCHv4 06/13] staging/media: convert drivers to use the new vb2_queue dev field

2016-04-23 Thread Hans Verkuil
From: Hans Verkuil Stop using alloc_ctx and just fill in the device pointer. Signed-off-by: Hans Verkuil Cc: "Lad, Prabhakar" Reviewed-by: Laurent Pinchart --- drivers/staging/media/davinci_vpfe/vpfe_video.c | 10 +- drivers/staging/media/davinci_vpfe/vpfe_video.h | 2 -- drivers/st

[PATCHv4 03/13] v4l2-pci-skeleton: set q->dev instead of allocating a context

2016-04-23 Thread Hans Verkuil
From: Hans Verkuil Stop using alloc_ctx as that is now no longer needed. Signed-off-by: Hans Verkuil --- Documentation/video4linux/v4l2-pci-skeleton.c | 15 ++- 1 file changed, 2 insertions(+), 13 deletions(-) diff --git a/Documentation/video4linux/v4l2-pci-skeleton.c b/Documenta

[PATCHv4 13/13] vb2: replace void *alloc_ctxs by struct device *alloc_devs

2016-04-23 Thread Hans Verkuil
From: Hans Verkuil Make this a proper typed array. Drop the old allocate context code since that is no longer used. Note that the memops functions now get a struct device pointer instead of the struct device ** that was there initially (actually a void pointer to a struct containing only a struc

[PATCHv4 04/13] sur40: set q->dev instead of allocating a context

2016-04-23 Thread Hans Verkuil
From: Hans Verkuil Stop using alloc_ctx and just fill in the device pointer. Signed-off-by: Hans Verkuil Cc: Florian Echtler --- drivers/input/touchscreen/sur40.c | 13 + 1 file changed, 1 insertion(+), 12 deletions(-) diff --git a/drivers/input/touchscreen/sur40.c b/drivers/inp

Re: [PATCHv3 01/12] vb2: add a dev field to use for the default allocation context

2016-04-23 Thread Hans Verkuil
On 04/23/2016 02:14 AM, Laurent Pinchart wrote: > Hi Hans, > > Thank you for the patch. > > On Friday 22 Apr 2016 10:38:08 Hans Verkuil wrote: >> From: Hans Verkuil >> >> The allocation context is nothing more than a per-plane device pointer >> to use when allocating buffers. So just provide a d

Re: [PATCH] [media] tvp686x: Don't go past array

2016-04-23 Thread Hans Verkuil
On 04/23/2016 11:23 AM, Mauro Carvalho Chehab wrote: > Depending on the compiler version, currently it produces the > following warnings: > tw686x-video.c: In function 'tw686x_video_init': > tw686x-video.c:65:543: warning: array subscript is above array bounds > [-Warray-bounds] I pos

[PATCH] [media] tvp686x: Don't go past array

2016-04-23 Thread Mauro Carvalho Chehab
Depending on the compiler version, currently it produces the following warnings: tw686x-video.c: In function 'tw686x_video_init': tw686x-video.c:65:543: warning: array subscript is above array bounds [-Warray-bounds] This is actually bogus with the current code, as it currently ha