On 11/17/2015 08:39 AM, Ran Shalit wrote:
> Hello,
>
> I intend to use cobalt driver as a refence for new pci v4l2 driver,
> which is required to use several input simultaneously. for this cobalt
> seems like a best starting point.
> read/write streaming will probably be suffecient (at least for t
Hello,
I intend to use cobalt driver as a refence for new pci v4l2 driver,
which is required to use several input simultaneously. for this cobalt
seems like a best starting point.
read/write streaming will probably be suffecient (at least for the
dirst debugging).
The configuration in my cast is i
Protocol lists are represented as 64-bit bitmaps,
therefore use u64 instead of unsigned long.
Signed-off-by: Heiner Kallweit
---
drivers/media/pci/cx23885/cx23885-input.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/media/pci/cx23885/cx23885-input.c
b/drivers/medi
This message is generated daily by a cron job that builds media_tree for
the kernels and architectures in the list below.
Results of the daily build of media_tree:
date: Tue Nov 17 04:00:22 CET 2015
git branch: test
git hash: 6747b39441925f247f15d04b89be3588f465ad57
gcc versio
Rob Herring wrote on Mon [2015-Nov-16 09:26:16 -0600]:
> On Sun, Nov 15, 2015 at 05:53:48PM -0600, Benoit Parrot wrote:
> > Device Tree bindings for the Camera Adaptation Layer (CAL) driver
>
> Bindings are for h/w blocks, not drivers...
OK I'll fix that.
>
> >
> > Signed-off-by: Benoit Parro
Am 16.11.2015 um 21:47 schrieb kbuild test robot:
> Hi Heiner,
>
> [auto build test WARNING on linuxtv-media/master]
> [also build test WARNING on v4.4-rc1 next-20151116]
>
> url:
> https://github.com/0day-ci/linux/commits/Heiner-Kallweit/media-rc-fix-decoder-module-unlo
Hi Heiner,
[auto build test WARNING on linuxtv-media/master]
[also build test WARNING on v4.4-rc1 next-20151116]
url:
https://github.com/0day-ci/linux/commits/Heiner-Kallweit/media-rc-fix-decoder-module-unloading/20151117-035809
base: git://linuxtv.org/media_tree.git master
config: parisc
Hi Julia,
Thank you for the patch.
On Friday 13 November 2015 23:05:17 Julia Lawall wrote:
> These v4l2_ctrl_ops structures are never modified, like all the other
> v4l2_ctrl_ops structures, so declare them as const.
>
> Done with the help of Coccinelle.
>
> Signed-off-by: Julia Lawall
Acked-
Remove code for unconditional decoder module loading (except lirc).
Signed-off-by: Heiner Kallweit
---
drivers/media/rc/rc-core-priv.h | 64 -
drivers/media/rc/rc-ir-raw.c| 10 ---
2 files changed, 74 deletions(-)
diff --git a/drivers/media/rc/rc-
Introduce a protocol bit for lirc and treat it like any other protocol.
This allows to get rid of all the lirc-specific code.
Signed-off-by: Heiner Kallweit
---
drivers/media/rc/ir-lirc-codec.c | 2 +-
drivers/media/rc/rc-core-priv.h | 16 ++--
drivers/media/rc/rc-ir-raw.c | 13
Checking whether a protocol is enabled and calling the related decoder
functions should be done by the rc core, not the protocol handlers.
Properly handle lirc considering that no protocol bit is set for lirc.
Signed-off-by: Heiner Kallweit
---
drivers/media/rc/ir-jvc-decoder.c | 3 ---
dri
Currently, if a decoder module is unloadad, the respective protocol
is still shown as enabled (if it was enabled before).
Fix this by resetting the respective protocol bits if a decoder
module is unloaded.
Signed-off-by: Heiner Kallweit
---
drivers/media/rc/rc-ir-raw.c | 17 ++---
1
RC_BIT_ALL explicitely lists each single currently defined protocol bit.
To simplify the code and make adding a protocol easier set each bit
no matter whether the respective protocol is defined yet.
RC_BIT_ALL is only used in checks whether a particular protocol is allowed
therefore it has no impa
Prepare on-demand decoder module loading by adding a module_name member
to struct proto_names and introducing the related load function.
After this patch of the series the decoder modules are still loaded
unconditionally.
Signed-off-by: Heiner Kallweit
---
drivers/media/rc/rc-main.c | 72 ++
The RC_BIT_ constants are used in 64-bit bitmaps.
In case of > 32 RC_BIT_ constants the current code will fail
on 32-bit systems.
Therefore define the RC_BIT_ constants as unsigned long long.
Signed-off-by: Heiner Kallweit
---
include/media/rc-map.h | 40
Declare struct proto_names and its member name as const.
Signed-off-by: Heiner Kallweit
---
drivers/media/rc/rc-main.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/media/rc/rc-main.c b/drivers/media/rc/rc-main.c
index cede8bc..f2d5c50 100644
--- a/drivers/media
On 11/16/2015 11:36 AM, Mauro Carvalho Chehab wrote:
> Em Mon, 16 Nov 2015 01:02:56 +0200
> Sakari Ailus escreveu:
>
>> Hi Shuah,
>>
>> On Thu, Nov 12, 2015 at 07:41:47AM -0700, Shuah Khan wrote:
>>> Media core drivers (dvb, v4l2, bridge driver) unregister
>>> their entities calling media_device_
Em Mon, 16 Nov 2015 01:02:56 +0200
Sakari Ailus escreveu:
> Hi Shuah,
>
> On Thu, Nov 12, 2015 at 07:41:47AM -0700, Shuah Khan wrote:
> > Media core drivers (dvb, v4l2, bridge driver) unregister
> > their entities calling media_device_unregister_entity()
> > during device removal from their unre
Hello, Oliver, all.
Unfortunately, there are at least 4 different concerns about this patch:
1) "!dev->actconfig->interface[ifnum]" won't catch a case where the value is not
NULL but some garbage. This way the system may crash with "general protection
fault"
later. I've hit this case during my t
The usbvision driver crashes when a specially crafted usb device with invalid
number of interfaces or endpoints is detected. This fix adds checks that the
device has proper configuration expected by the driver.
Reported-by: Ralf Spenneberg
Signed-off-by: Vladis Dronov
---
drivers/media/usb/usbv
Hello,
This is a version of the patch which fixes issues mentioned in the
message "[PATCH] usbvision fix overflow of interfaces array"
(http://www.spinics.net/lists/linux-media/msg94434.html) posted on
this list earlier.
Unfortunately, there are some concerns about that patch and probable
problem
On Sun, Nov 15, 2015 at 05:53:48PM -0600, Benoit Parrot wrote:
> Device Tree bindings for the Camera Adaptation Layer (CAL) driver
Bindings are for h/w blocks, not drivers...
>
> Signed-off-by: Benoit Parrot
> ---
> Documentation/devicetree/bindings/media/ti-cal.txt | 70
> +++
On Sat, Nov 14, 2015 at 09:17:56PM +0300, Alexey Khoroshilov wrote:
> Commit af8a819a2513 ("[media] lirc_imon: simplify error handling code")
> lost mutex_unlock(&context->ctx_lock), so imon_probe() exits with
> the context->ctx_lock mutex acquired.
>
> The patch adds mutex_unlock(&context->ctx_lo
On 11/16/2015 10:47 AM, Sakari Ailus wrote:
Jacek Anaszewski wrote:
This patch depends on the preceding LED core improvements patches
from this patch set, and it would be best if it was merged through
the LED tree. Can I get your ack for this? I've already obtained acks
for the whole set from Sa
W dniu 16.11.2015 o 20:00, Mauro Carvalho Chehab pisze:
> Let's not mix platform_data headers with the core headers. Instead, let's
> create a subdir at linux/platform_data and move the headers to that
> common place, adding it to MAINTAINERS.
>
> The headers were moved with:
> mkdir include
On Mon, 16 Nov 2015, Mauro Carvalho Chehab wrote:
> Let's not mix platform_data headers with the core headers. Instead, let's
> create a subdir at linux/platform_data and move the headers to that
> common place, adding it to MAINTAINERS.
>
> The headers were moved with:
> mkdir include/linu
On Monday 16 November 2015 09:00:44 Mauro Carvalho Chehab wrote:
> Let's not mix headers used by the core with those headers that
> are needed by some driver-specific interface header.
>
> The headers used on drivers were manually moved using:
> mkdir include/media/drv-intf/
> git mv inclu
On Monday 16 November 2015 09:00:45 Mauro Carvalho Chehab wrote:
> Let's not mix platform_data headers with the core headers. Instead, let's
> create a subdir at linux/platform_data and move the headers to that
> common place, adding it to MAINTAINERS.
>
Acked-by: Arnd Bergmann
I think we can a
On Fri, Nov 13, 2015 at 10:05 PM, Julia Lawall wrote:
> These v4l2_ctrl_ops structures are never modified, like all the other
> v4l2_ctrl_ops structures, so declare them as const.
>
> Done with the help of Coccinelle.
>
> Signed-off-by: Julia Lawall
>
Acked-by: Lad, Prabhakar
Cheers,
--Prabhak
Let's not mix platform_data headers with the core headers. Instead, let's
create a subdir at linux/platform_data and move the headers to that
common place, adding it to MAINTAINERS.
The headers were moved with:
mkdir include/linux/platform_data/media/; git mv
include/media/gpio-ir-recv.h
Hi Laurent,
On Monday 09 November 2015 16:25:02 Markus Pargmann wrote:
> On Monday 09 November 2015 15:22:06 Laurent Pinchart wrote:
[...]
> >
> > Please use proper controls names.
>
> Sorry I don't really know what you mean? For me these are proper names.
Could you give me a hint how these nam
On tda665x, set_state only sets frequency. As the kABI for set_state
is meant to be used only on special cases, split the function
into two, in order to allow it to be latter used by a DVBv5
cache params logic.
Signed-off-by: Mauro Carvalho Chehab
---
drivers/media/dvb-frontends/tda665x.c | 161
Improve the comments at the header, removing kernel-doc
tag from where it doesn't belong, grouping the legacy tuner
functions, and improving the text.
No functional changes.
Signed-off-by: Mauro Carvalho Chehab
---
drivers/media/dvb-core/dvb_frontend.h | 40 ++-
The stb6100 driver has a struct tuner_state on its state
struct, that it is used only to store the bandwidth. Even so,
this struct is not really used, as every time the bandwidth
is get or set, it goes through the hardware.
So, get rid of that.
Signed-off-by: Mauro Carvalho Chehab
---
drivers/m
It is tricky to get rid of those ops here, as the stv0299 driver
wants to set frequency in separate from setting the bandwidth.
So, we use a small trick: we temporarely fill the cache with
0 for either frequency or bandwidth and add some logic at
set_params to only change the property(ies) that ar
Documents the most used functions at the Digital TV
kABI: dvb_frontend_register(), dvb_frontend_unregister()
and dvb_frontend_detach().
Signed-off-by: Mauro Carvalho Chehab
---
drivers/media/dvb-core/dvb_frontend.h | 43 ---
1 file changed, 40 insertions(+), 3 del
As SEC tone and voltage could have changed during
suspend(), restore them to their previous values at
resume().
Signed-off-by: Mauro Carvalho Chehab
---
drivers/media/dvb-core/dvb_frontend.c | 5 +
1 file changed, 5 insertions(+)
diff --git a/drivers/media/dvb-core/dvb_frontend.c
b/drivers
The dvb_frontend_reinitialise() function is a special case
used by just one frontend. Document it, for completeness.
Signed-off-by: Mauro Carvalho Chehab
---
drivers/media/dvb-core/dvb_frontend.h | 15 ++-
1 file changed, 14 insertions(+), 1 deletion(-)
diff --git a/drivers/media/dv
This header file provides the kABI functions used by the
Digital TV Frontend core support. Add a description for
this kABI, to add at the device_drivers Kernel DocBook.
Signed-off-by: Mauro Carvalho Chehab
---
Documentation/DocBook/device-drivers.tmpl | 1 +
drivers/media/dvb-core/dvb_frontend.
There are several tuner_param values that aren't by any driver or core:
DVBFE_TUNER_TUNERSTEP
DVBFE_TUNER_IFFREQ
DVBFE_TUNER_REFCLOCK
DVBFE_TUNER_IQSENSE
DVBFE_TUNER_DUMMY
Several of those correspond to the values at the tuner_state
struct with is also only
The get_state()/set_state and the corresponding data types
(struct tuner_state and enum tuner_param) are old DVB interfaces
that came from the DVBv3 time.
Nowadays, set_params() provide a better way to set the tuner
and demod parameters. So, no need to keep those legacy stuff,
as all drivers that
Those two callbacks are the ones that should be used by normal
DVB frontend drivers.
Add support for them.
Signed-off-by: Mauro Carvalho Chehab
---
drivers/media/dvb-frontends/tda665x.c | 20
1 file changed, 20 insertions(+)
diff --git a/drivers/media/dvb-frontends/tda665x
The DocBook description of this header has two issues:
- It calls the Kernel ABI as API, instead of kABI;
- It mentions that the DVB frontend kABI is not described
within the document. As this will actually generate a
single DocBook, this is actually not true, now that
the documentation for t
Those functions should be implemented on all drivers. So, document
them.
Signed-off-by: Mauro Carvalho Chehab
---
drivers/media/dvb-core/dvb_frontend.h | 40 +--
1 file changed, 38 insertions(+), 2 deletions(-)
diff --git a/drivers/media/dvb-core/dvb_frontend.h
Those ops aren't used by any driver, with is weird. I suspect
that mantis_vb3030 driver were not working properly...
Anyway, now that the driver uses the set_parms, the DVB
frontend core should do the right thing.
Signed-off-by: Mauro Carvalho Chehab
---
drivers/media/dvb-frontends/tda665x.c |
This function is used mainly at the DVB core, in order to provide
emulation for a legacy ioctl. The only current exception is
the stv0299 driver, with takes more than 8ms to switch voltage,
breaking the emulation for FE_DISHNETWORK_SEND_LEGACY_CMD.
Document that.
Signed-off-by: Mauro Carvalho Che
Those callbacks are meant to be used only on some very specific
cases. There's absolutely no need to do that at tda8261, as
the only parameter that it allows to be set/get is the frequency.
So, use the standard get_params() and get_frequency() kABI
ops.
There's no need to touch at any bridge driv
Jacek Anaszewski wrote:
> This patch depends on the preceding LED core improvements patches
> from this patch set, and it would be best if it was merged through
> the LED tree. Can I get your ack for this? I've already obtained acks
> for the whole set from Sakari.
I agree with this going through
Hi Mauro,
This patch depends on the preceding LED core improvements patches
from this patch set, and it would be best if it was merged through
the LED tree. Can I get your ack for this? I've already obtained acks
for the whole set from Sakari.
Best Regards,
Jacek Anaszewski
On 10/07/2015 11:10
Please note that this patch series assumes that my previous pull request was
merged first:
https://patchwork.linuxtv.org/patch/31872/
This is for the v4l2-pci-skeleton patch. The other three are independent of
the previous pull request.
Regards,
Hans
The following changes since commit
50 matches
Mail list logo