After adding the format check in try_fmt()/set_fmt(), we don't need any
format check in configure_geometry(). So make configure_geometry() as
void type.
Signed-off-by: Josh Wu
---
Hi, Laurent
For the similiarity between set_fmt() and try_frm() function, it need more work
than I thought.
So in t
As in set_fmt() function we only need to know which format is been set,
we don't need to access the ISI hardware in this moment.
So move the configure_geometry(), which access the ISI hardware, to
start_streaming() will make code more consistent and simpler.
Signed-off-by: Josh Wu
Reviewed-by: L
In the function configure_geometry(), we will setup the ISI CFG2
according to the sensor output format.
It make no sense to just read back the CFG2 register and just set part
of it.
So just set up this register directly makes things simpler.
Currently only support YUV format from camera sensor.
Hi Javier,
Javier Martinez Canillas wrote:
Hello Sakari,
On 09/10/2015 07:14 PM, Sakari Ailus wrote:
Hi Javier,
Thanks for the set! A few comments below.
Thanks to you for your feedback.
Javier Martinez Canillas wrote:
The media device node is registered and so made visible to user-spac
This message is generated daily by a cron job that builds media_tree for
the kernels and architectures in the list below.
Results of the daily build of media_tree:
date: Fri Sep 11 04:00:19 CEST 2015
git branch: test
git hash: 50ef28a6ac216fd8b796257a3768fef8f57b917d
gcc versi
Hello,
On 08/20/2015 09:07 AM, Javier Martinez Canillas wrote:
> The SPI core always reports the MODALIAS uevent as "spi:"
> regardless of the mechanism that was used to register the device
> (i.e: OF or board code) and the table that is used later to match
> the driver with the device (i.e: SPI i
Hello Sakari,
On 09/10/2015 07:39 PM, Sakari Ailus wrote:
> Javier Martinez Canillas wrote:
>> Also, add a media_entity_cleanup() function that will destroy the
>> graph_mutex that is initialized in media_entity_init().
>
> media_device_init() and media_device_cleanup()?
>
Right, sorry about tha
Hello Sakari,
On 09/10/2015 07:14 PM, Sakari Ailus wrote:
> Hi Javier,
>
> Thanks for the set! A few comments below.
>
Thanks to you for your feedback.
> Javier Martinez Canillas wrote:
>> The media device node is registered and so made visible to user-space
>> before entities are registered an
Javier Martinez Canillas wrote:
> Also, add a media_entity_cleanup() function that will destroy the
> graph_mutex that is initialized in media_entity_init().
media_device_init() and media_device_cleanup()?
--
Sakari Ailus
sakari.ai...@linux.intel.com
--
To unsubscribe from this list: send the li
Hello Sakari,
Thanks a lot for your feedback.
On 09/10/2015 07:15 PM, Sakari Ailus wrote:
> Javier Martinez Canillas wrote:
>> Most media functions that unregister, check if the corresponding register
>> function succeed before. So these functions can safely be called even if a
>> registration wa
Hi Javier,
Thanks for the set! A few comments below.
Javier Martinez Canillas wrote:
> The media device node is registered and so made visible to user-space
> before entities are registered and links created which means that the
> media graph obtained by user-space could be only partially enumera
Javier Martinez Canillas wrote:
> Most media functions that unregister, check if the corresponding register
> function succeed before. So these functions can safely be called even if a
> registration was never made or the component as already been unregistered.
>
> Add the same check to media_devi
On 08/09/15 17:16, Randy Dunlap wrote:
[adding linux-media + Alan Cox]
Thanks for forwarding this message (no reply so far, though). I will be
on a slow link over the weekend, so I will just be able to listen to the
linux-media list (sorry...) If anybody is able to answer, please do so
to t
On Sun, Sep 6, 2015 at 2:02 PM, Mauro Carvalho Chehab
wrote:
> Declare the interface types to be used on alsa for the new
> G_TOPOLOGY ioctl.
>
> Signed-off-by: Mauro Carvalho Chehab
>
Reviewed-by: Javier Martinez Canillas
Best regards,
Javier
--
To unsubscribe from this list: send the line "u
On Sun, Sep 6, 2015 at 2:02 PM, Mauro Carvalho Chehab
wrote:
> Interfaces are different than entities: they represent a
> Kernel<->userspace interaction, while entities represent a
> piece of hardware/firmware/software that executes a function.
>
> Let's distinguish them by creating a separate str
On Sun, Aug 30, 2015 at 5:06 AM, Mauro Carvalho Chehab
wrote:
> Declare the interface types that will be used by the new
> G_TOPOLOGY ioctl that will be defined latter on.
>
> For now, we need those types, as they'll be used on the
> internal structs associated with the new media_interface
> graph
On Sun, Aug 30, 2015 at 5:06 AM, Mauro Carvalho Chehab
wrote:
> With the new API, a link can be either between two PADs or between an
> interface
> and an entity. So, we need to use a better name for the function that create
> links between two pads.
>
> So, rename the such function to media_crea
On Sun, Aug 30, 2015 at 5:06 AM, Mauro Carvalho Chehab
wrote:
> It helps to check if the media controller is doing the
> right thing with the object creation and removal.
>
> No extra code/data will be produced if DEBUG or
> CONFIG_DYNAMIC_DEBUG is not enabled.
>
> Signed-off-by: Mauro Carvalho Ch
On Sun, Aug 30, 2015 at 5:06 AM, Mauro Carvalho Chehab
wrote:
> We can only free the media device after being sure that no
> graph object is used.
>
> In order to help tracking it, let's add debug messages
> that will print when the media controller gets registered
> or unregistered.
>
> Signed-of
On Sun, Aug 30, 2015 at 5:06 AM, Mauro Carvalho Chehab
wrote:
> Just like entities and pads, links also need to have unique
> Object IDs along a given media controller.
>
> So, let's add a media_gobj inside it and initialize
> the object then a new link is created.
>
> Signed-off-by: Mauro Carvalh
On Sun, Aug 30, 2015 at 5:06 AM, Mauro Carvalho Chehab
wrote:
> As entities are graph objects, let's embed media_gobj
> on it. That ensures an unique ID for entities that can be
> global along the entire media controller.
>
> For now, we'll keep the already existing entity ID. Such
> field need to
On Sun, Aug 30, 2015 at 5:06 AM, Mauro Carvalho Chehab
wrote:
> PADs also need unique object IDs that won't conflict with
> the entity object IDs.
>
> The pad objects are currently created via media_entity_init()
> and, once created, never change.
>
> While this will likely change in the future in
On Sun, Aug 30, 2015 at 5:06 AM, Mauro Carvalho Chehab
wrote:
> Due to the MC API proposed changes, we'll need to have an unique
> object ID for all graph objects, and have some shared fields
> that will be common on all media graph objects.
>
> Right now, the only common object is the object ID,
On Sun, Aug 30, 2015 at 5:06 AM, Mauro Carvalho Chehab
wrote:
> Instead of accessing directly entity.id, let's create a macro,
> as this field will be moved into a common struct later on.
>
> Signed-off-by: Mauro Carvalho Chehab
> Acked-by: Hans Verkuil
>
Reviewed-by: Javier Martinez Canillas
Most media functions that unregister, check if the corresponding register
function succeed before. So these functions can safely be called even if a
registration was never made or the component as already been unregistered.
Add the same check to media_device_unregister() function for consistency.
The media device node is registered and so made visible to user-space
before entities are registered and links created which means that the
media graph obtained by user-space could be only partially enumerated
if that happens too early before all the graph has been created.
To avoid this race cond
Hello,
The Media Controller framework has an issue in which the media device node
is registered before all the media entities and pads links are created so
if user-space tries to enumerate the graph too early, it may get a partial
graph since not everything has been registered yet.
This series fi
Passing format "help" to the -f option will list the supported formats and
exit.
Signed-off-by: Sakari Ailus
---
yavta.c | 19 +++
1 file changed, 19 insertions(+)
diff --git a/yavta.c b/yavta.c
index 7d8ac8e..b627725 100644
--- a/yavta.c
+++ b/yavta.c
@@ -215,6 +215,20 @@ stati
Hi Linus,
Please pull from:
git://git.kernel.org/pub/scm/linux/kernel/git/mchehab/linux-media
tags/media/v4.3-2
For a series of patches that move part of the code used to allocate memory
from the media subsystem to the mm subsystem.
PS.: there are some conflicts with upstream. Two of them are
> -Original Message-
> From: Alan Stern [mailto:st...@rowland.harvard.edu]
> Sent: Wednesday, September 9, 2015 6:30 PM
> To: Laurent Pinchart
> Cc: Hans de Goede; Kaukab, Yousaf; linux-media@vger.kernel.org;
> mche...@osg.samsung.com; linux-...@vger.kernel.org
> Subject: Re: [PATCH v1] med
30 matches
Mail list logo