Shuah Khan wrote:
> @@ -541,13 +591,19 @@ int snd_usb_create_quirk(struct snd_usb_audio *chip,
> [QUIRK_AUDIO_ALIGN_TRANSFER] = create_align_transfer_quirk,
> [QUIRK_AUDIO_STANDARD_MIXER] = create_standard_mixer_quirk,
> };
> + int ret;
>
> + if (quirk->
This message is generated daily by a cron job that builds media_tree for
the kernels and architectures in the list below.
Results of the daily build of media_tree:
date: Sat May 9 04:00:19 CEST 2015
git branch: test
git hash: c3f22501b52de17c6087b6fe6f2236e4183ac07c
gcc versi
Add new media controller API to allocate media device as a
device resource. When a media device is created on the main
struct device which is the parent device for the interface
device, it will be available to all drivers associated with
that interface. For example, if a usb media device driver
cre
Change ALSA driver to use media controller API to share tuner
with DVB and V4L2 drivers that control AU0828 media device.
Media device is created based on a newly added field value
in the struct snd_usb_audio_quirk. Using this approach, the
media controller API usage can be added for a specific dev
This patch series updates ALSA driver to use media controller
API to share tuner with DVB and V4L2 drivers that control AU0828
media device. Two new interfaces are added to media controller
API to enable creating media device as a device resource. This
allows creating media device as a device resou
> dma-buf user handles are fds, which means anything allocated can be passed
> around nicely already. The question really is whether we'll have one ioctl
> on top of a special dev node or a syscall. I thought that in these cases
> where the dev node is only ever used to allocate the real thing, a s
Em Fri, 08 May 2015 16:32:03 +0200
Hans Verkuil escreveu:
> On 05/08/2015 04:08 PM, Mauro Carvalho Chehab wrote:
> > Em Fri, 08 May 2015 15:21:39 +0200
> > Hans Verkuil escreveu:
> >
> >> On 05/08/2015 02:57 PM, Mauro Carvalho Chehab wrote:
> >>> Em Fri, 08 May 2015 14:13:22 +0200
> >>> Hans Ve
On Wed, May 06, 2015 at 09:28:09AM +0200, Jan Kara wrote:
> Provide new function get_vaddr_frames(). This function maps virtual
> addresses from given start and fills given array with page frame numbers of
> the corresponding pages. If given start belongs to a normal vma, the function
> grabs refe
On 05/08/2015 04:08 PM, Mauro Carvalho Chehab wrote:
> Em Fri, 08 May 2015 15:21:39 +0200
> Hans Verkuil escreveu:
>
>> On 05/08/2015 02:57 PM, Mauro Carvalho Chehab wrote:
>>> Em Fri, 08 May 2015 14:13:22 +0200
>>> Hans Verkuil escreveu:
>>>
On 05/08/2015 03:12 AM, Mauro Carvalho Chehab wr
Hi Andrzej,
Em Fri, 08 May 2015 15:51:16 +0200
Andrzej Hajda escreveu:
> Hi Mauro,
>
> On 05/08/2015 03:12 AM, Mauro Carvalho Chehab wrote:
> > This sensor driver is abusing MEDIA_ENT_T_V4L2_SUBDEV, creating
> > some subdevs with a non-existing type.
> >
> > As this is a sensor driver, the prop
Hi
I noticed the -C option was in the help from the -? option
but not in the manpages.
Cheers
Vince
diff --git a/utils/dvb/dvbv5-scan.1.in b/utils/dvb/dvbv5-scan.1.in
index 08e3163..8016185 100644
--- a/utils/dvb/dvbv5-scan.1.in
+++ b/utils/dvb/dvbv5-scan.1.in
@@ -35,6 +35,9 @@ Force dvbv5\-scan t
Em Fri, 08 May 2015 15:21:39 +0200
Hans Verkuil escreveu:
> On 05/08/2015 02:57 PM, Mauro Carvalho Chehab wrote:
> > Em Fri, 08 May 2015 14:13:22 +0200
> > Hans Verkuil escreveu:
> >
> >> On 05/08/2015 03:12 AM, Mauro Carvalho Chehab wrote:
> >>> Finally, let's rename the tuner entity. inside t
Hi Mauro,
On 05/08/2015 03:12 AM, Mauro Carvalho Chehab wrote:
> This sensor driver is abusing MEDIA_ENT_T_V4L2_SUBDEV, creating
> some subdevs with a non-existing type.
>
> As this is a sensor driver, the proper type is likely
> MEDIA_ENT_T_CAM_SENSOR.
This driver exposes two media entities:
- p
Add reference counting on a kernel module that exports dma-buf and
implements its operations. This prevents the module from being unloaded
while DMABUF file is in use.
The original patch [1] was submitted by Tomasz Stanislawski, but this
is a simpler way to do it.
v3: call module_put() as late as
On 05/08/2015 02:57 PM, Mauro Carvalho Chehab wrote:
> Em Fri, 08 May 2015 14:13:22 +0200
> Hans Verkuil escreveu:
>
>> On 05/08/2015 03:12 AM, Mauro Carvalho Chehab wrote:
>>> Finally, let's rename the tuner entity. inside the media subsystem,
>>> a tuner can be used by AM/FM radio, SDR radio, a
Em Fri, 08 May 2015 14:46:19 +0200
Hans Verkuil escreveu:
> On 05/08/2015 03:12 AM, Mauro Carvalho Chehab wrote:
> > Instead of relying on media subtype, use the new macros to detect
> > if an entity is a subdev or an A/V DMA entity.
> >
> > Please note that most drivers assume that there's just
On 05/08/2015 02:53 PM, Mauro Carvalho Chehab wrote:
> Em Fri, 08 May 2015 14:03:01 +0200
> Hans Verkuil escreveu:
>
>> On 05/08/2015 03:12 AM, Mauro Carvalho Chehab wrote:
>>> As explained before, the hole idea of subtypes at entities was
>>
>> hole -> whole
>>
>>> not nice. All V4L2 subdevs may
Em Fri, 08 May 2015 14:13:22 +0200
Hans Verkuil escreveu:
> On 05/08/2015 03:12 AM, Mauro Carvalho Chehab wrote:
> > Finally, let's rename the tuner entity. inside the media subsystem,
> > a tuner can be used by AM/FM radio, SDR radio, analog TV and digital TV.
> > It could even be used on other
Hi Mauro,
On 05/08/2015 02:32 PM, Mauro Carvalho Chehab wrote:
>>> and may also not be true on embedded devices
>>> that, due to DRM reasons, don't allow writing unencrypted
>>> data on a memory that could be seen by the CPU.
>>
>> This actually might still work by using opaque DMABUF handles. But
Em Fri, 08 May 2015 14:10:48 +0200
Hans Verkuil escreveu:
> On 05/08/2015 03:12 AM, Mauro Carvalho Chehab wrote:
> > In order to reflect that the entities are actually the hardware
> > (or firmware, or in-kernel software), and are not associated
> > with the DVB API, let's remove DEVNODE_ from th
Em Fri, 08 May 2015 14:03:01 +0200
Hans Verkuil escreveu:
> On 05/08/2015 03:12 AM, Mauro Carvalho Chehab wrote:
> > As explained before, the hole idea of subtypes at entities was
>
> hole -> whole
>
> > not nice. All V4L2 subdevs may have a device node associated.
> >
> > Also, the hole idea
On 05/08/2015 03:12 AM, Mauro Carvalho Chehab wrote:
> Instead of relying on media subtype, use the new macros to detect
> if an entity is a subdev or an A/V DMA entity.
>
> Please note that most drivers assume that there's just AV_DMA or
> V4L2 subdevs. This is not true anymore, as we've added MC
Em Fri, 08 May 2015 13:54:07 +0200
Hans Verkuil escreveu:
> On 05/08/2015 03:12 AM, Mauro Carvalho Chehab wrote:
> > At the Video4Linux API, the /dev/video?, /dev/vbi? and
> > /dev/radio? device nodes are used for the chipset that
I knew that this patch would cause some discussions ;)
>
> You
On 05/08/2015 03:12 AM, Mauro Carvalho Chehab wrote:
> Finally, let's rename the tuner entity. inside the media subsystem,
> a tuner can be used by AM/FM radio, SDR radio, analog TV and digital TV.
> It could even be used on other subsystems, like network, for wireless
> devices.
>
> So, it is not
On 05/08/2015 03:12 AM, Mauro Carvalho Chehab wrote:
> To keep coherency, let's also remove V4L2_SUBDEV from the analog
> TV decoder, calling it by its function, and not by the V4L2
> API mapping.
Same issue as with patch 04/18.
Hans
>
> So,
>
> MEDIA_ENT_T_V4L2_SUBDEV_DECODER ->
On 05/08/2015 03:12 AM, Mauro Carvalho Chehab wrote:
> In order to reflect that the entities are actually the hardware
> (or firmware, or in-kernel software), and are not associated
> with the DVB API, let's remove DEVNODE_ from the entity names
> and use DTV (Digital TV) for the entities.
>
> The
Hi Mauro,
On Friday 08 May 2015 09:01:28 Mauro Carvalho Chehab wrote:
> Bellow is yelling. Ok, sometimes the code is yells a lot, but
> but this is not the case there ;)
:-)
checkpatch.pl has support for finding common spelling mistakes nowadays.
Instead of fixing them one by one, should we run
On 05/08/2015 03:12 AM, Mauro Carvalho Chehab wrote:
> As explained before, the hole idea of subtypes at entities was
hole -> whole
> not nice. All V4L2 subdevs may have a device node associated.
>
> Also, the hole idea is to expose hardware IP blocks, so calling
> them as V4L2 is a very bad pra
Bellow is yelling. Ok, sometimes the code is yells a lot, but
but this is not the case there ;)
Signed-off-by: Mauro Carvalho Chehab
diff --git a/drivers/media/common/siano/smsir.c
b/drivers/media/common/siano/smsir.c
index 1d60d200d9ab..41f2a3939979 100644
--- a/drivers/media/common/siano/smsi
On 05/08/2015 03:12 AM, Mauro Carvalho Chehab wrote:
> At the Video4Linux API, the /dev/video?, /dev/vbi? and
> /dev/radio? device nodes are used for the chipset that
You should add /dev/swradio? for SDR devices.
> provides the bridge between video/radio streams and the
> USB, PCI or CPU buses.
>
Hi Mauro,
Just a typo, after that you can add my:
Acked-by: Hans Verkuil
Thanks,
Hans
On 05/08/2015 03:12 AM, Mauro Carvalho Chehab wrote:
> The media controller entity subtype doesn't make much sense,
> especially since V4L2 subdevices may also have associated devnodes.
>
> So, bett
On 05/08/2015 03:12 AM, Mauro Carvalho Chehab wrote:
> The Media Controller DVB support is still an experimental feature,
> as it is under heavy development. It is already said that it is
> an experimental feature at the help, but let make it even clearer
> and louder, as we may need to adjust some
Hi Kamil,
Just two tiny issues, and after that you can add my:
Reviewed-by: Hans Verkuil
to this.
On 05/04/2015 07:32 PM, Kamil Debski wrote:
> diff --git a/include/uapi/linux/cec.h b/include/uapi/linux/cec.h
> new file mode 100644
> index 000..67b0049
> --- /dev/null
> +++ b/include/uapi/
On 05/08/2015 01:02 PM, Hans Verkuil wrote:
> On 05/04/2015 07:32 PM, Kamil Debski wrote:
>> Add handling of remote control events coming from the HDMI CEC bus.
>> This patch includes a new keymap that maps values found in the CEC
>> messages to the keys pressed and released. Also, a new protocol h
Hi,
I'm trying to use this card for DVB-C and when I use w_scan I get this error:
-_-_-_-_ Getting frontend capabilities-_-_-_-_
Using DVB API 5.3
frontend 'TurboSight TBS 62x1 DVBT/T2 frontend' supports
INVERSION_AUTO
QAM_AUTO
FEC_AUTO
FREQ (42.00MHz ... 1002.00MHz)
This dvb driver is *buggy*:
Hi Kamil,
I've updated this patch so that it uses _clr_set instead of _and_or for the CEC
register access code.
---
Add CEC support to the adv7604 driver.
Signed-off-by: Hans Verkuil
[k.deb...@samsung.com: Merged changes from CEC Updates commit by Hans Verkuil]
[k.deb...@samsung.com: add missi
On 05/04/2015 07:32 PM, Kamil Debski wrote:
> Add handling of remote control events coming from the HDMI CEC bus.
> This patch includes a new keymap that maps values found in the CEC
> messages to the keys pressed and released. Also, a new protocol has
> been added to the core.
>
> Signed-off-by:
On 05/04/2015 07:32 PM, Kamil Debski wrote:
> Add HDMI CEC specific keycodes to the keycodes definition.
>
> Signed-off-by: Kamil Debski
Acked-by: Hans Verkuil
> ---
> include/uapi/linux/input.h | 12
> 1 file changed, 12 insertions(+)
>
> diff --git a/include/uapi/linux/input
Hi Kamil,
On 05/04/2015 07:33 PM, Kamil Debski wrote:
> This is the first version of the libGenCEC library. It was designed to
> act as an interface between the generic CEC kernel API and userspace
> applications. It provides a simple interface for applications and an
> example application that ca
On 08.05.2015 12:20, poma wrote:
>
> [0.00] Linux version 4.0.2-200.fc21.x86_64 ...
>
> [0.870875] usb 1-2: new high-speed USB device number 2 using ehci-pci
> [0.990286] usb 1-2: New USB device found, idVendor=15a4, idProduct=9016
> [0.992575] usb 1-2: New USB device strings:
Explain which clock was used to make the timestamp.
Signed-off-by: Hans Verkuil
---
Documentation/DocBook/media/v4l/vidioc-dqevent.xml | 5 -
1 file changed, 4 insertions(+), 1 deletion(-)
diff --git a/Documentation/DocBook/media/v4l/vidioc-dqevent.xml
b/Documentation/DocBook/media/v4l/vid
Looks ugly, a space before a period at the end of a sentence. Remove it.
Signed-off-by: Hans Verkuil
---
Documentation/DocBook/media/v4l/io.xml | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Documentation/DocBook/media/v4l/io.xml
b/Documentation/DocBook/media/v4l/io.xml
ind
Hi Kamil,
A few more comments about the documentation:
First of all you should add some documentation about what the passthrough mode
actually is. Right now all this says is that you can enable or disable it, but
not what it actually does.
And next I have a few small comments about the timestamp
[0.00] Linux version 4.0.2-200.fc21.x86_64 ...
[0.870875] usb 1-2: new high-speed USB device number 2 using ehci-pci
[0.990286] usb 1-2: New USB device found, idVendor=15a4, idProduct=9016
[0.992575] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[0.9948
Hi Fabien,
Some comments below:
On 05/04/2015 11:24 AM, Fabien Dessenne wrote:
> This v4l2 mem2mem driver is a 2D blitter for STMicroelectronics SoC.
> It uses the v4l2 mem2mem framework.
>
> The following features are supported and tested:
> - Color format conversion (RGB32, RGB24, RGB16, NV12,
From: "jean-michel.hautb...@vodalys.com"
All drivers use custom notifications, in particular when source changes.
The bridge only has to map the subdev that sends it to whatever video node it
is connected to.
Signed-off-by: Jean-Michel Hautbois
---
Documentation/video4linux/v4l2-framework.txt
From: Hans Verkuil
vb2_buffer_done() already allows STATE_QUEUED, but currently only when not
streaming. It is useful to allow it while streaming as well, as this makes
it possible for drivers to requeue buffers while waiting for a stable
video signal.
Signed-off-by: Hans Verkuil
---
drivers/m
From: Hans Verkuil
This makes it easier for the bridge driver to just passthrough such
events to the corresponding device node.
Signed-off-by: Hans Verkuil
---
drivers/media/i2c/adv7604.c | 12 +---
drivers/media/i2c/adv7842.c | 11 +--
include/media/adv7604.h | 1 -
inclu
From: Hans Verkuil
Replace the dummy video format operations by pad format operations that
configure the output format.
Copied from the adv7604 driver.
Note: while arch/blackfin/mach-bf609/boards/ezkit.c uses adv7842_platform_data
this source has not been updated because it is broken since the
From: Hans Verkuil
Hi all,
This driver is for the Cisco Cobalt card, which is a PCIe device with four
HDMI inputs (adv7604) and optionally one fifth input (adv7842) or one output
(adv7511).
This board is not for sale (sadly) but it is used internally for testing and
prototyping. Many of the HDM
Am 08.05.2015 um 10:37 schrieb Daniel Vetter:
dma-buf user handles are fds, which means anything allocated can be passed
around nicely already. The question really is whether we'll have one ioctl
on top of a special dev node or a syscall. I thought that in these cases
where the dev node is only
On Thu, May 07, 2015 at 05:40:03PM +0100, One Thousand Gnomes wrote:
> On Thu, 7 May 2015 15:52:12 +0200
> Daniel Vetter wrote:
>
> > On Thu, May 07, 2015 at 03:22:20PM +0200, Thierry Reding wrote:
> > > On Wed, May 06, 2015 at 03:15:32PM +0200, Daniel Vetter wrote:
> > > > Yes the idea would be
52 matches
Mail list logo