This message is generated daily by a cron job that builds media_tree for
the kernels and architectures in the list below.
Results of the daily build of media_tree:
date: Fri May 1 04:00:18 CEST 2015
git branch: test
git hash: bb17141cc57c40065462c64d61c0ae362466c0c0
gcc versi
From: "Luis R. Rodriguez"
We are burrying direct access to MTRR code support on
x86 in order to take advantage of PAT. In the future we
also want to make the default behaviour of ioremap_nocache()
to use strong UC, use of mtrr_add() on those systems
would make write-combining void.
In order to h
> +struct aat1290_led_config_data {
> + /* maximum LED current in movie mode */
> + u32 max_mm_current;
> + /* maximum LED current in flash mode */
> + u32 max_flash_current;
> + /* maximum flash timeout */
> + u32 max_flash_tm;
Ok, the comments tell us what should be alre
On Wed, 29 Apr 2015 20:05:53 -0300
Mauro Carvalho Chehab wrote:
> ov7670_s_exp() checks read error for 2 registers: REG_COM1
> and REG_COM8. But, although it uses the value latter, it
> doesn't check errors on REG_AECHH read. Yet, as it is doing
> a bitmask operation there, the read operation sho
On Tue, Mar 17, 2015 at 12:56:32PM +0100, Jan Kara wrote:
> Provide new function get_vaddr_pfns(). This function maps virtual
> addresses from given start and fills given array with page frame numbers of
> the corresponding pages. If given start belongs to a normal vma, the function
> grabs refere
Hello,
As previously discussed in this thread [1], this series is changing
clk_ops' ->round_rate()/->determine_rate() prototypes to avoid long
overflows when the returned rate is exceeding 2Ghz.
Most of those changes have been compile-tested, but none of them have
been tested on real hardware (th
Clock rates are stored in an unsigned long field, but ->round_rate()
(which returns a rounded rate from a requested one) returns a long
value (errors are reported using negative error codes), which can lead
to long overflow if the clock rate exceed 2Ghz.
Change ->round_rate() prototype to return 0
On 04/30/2015 04:08 PM, Mauro Carvalho Chehab wrote:
> drivers/media/platform/vivid/vivid-vid-out.c:1155 vivid_vid_out_g_parm()
> warn: inconsistent indenting
>
> Signed-off-by: Mauro Carvalho Chehab
Acked-by: Hans Verkuil
>
> diff --git a/drivers/media/platform/vivid/vivid-vid-out.c
> b/dr
On 04/30/2015 04:08 PM, Mauro Carvalho Chehab wrote:
> Em Thu, 30 Apr 2015 08:20:49 +0200
> Hans Verkuil escreveu:
>
>> On 04/28/2015 05:43 PM, Mauro Carvalho Chehab wrote:
>>> As reported by smatch:
>>> drivers/media/pci/saa7134/saa7134-cards.c:7197
>>> saa7134_xc2028_callback() warn: incon
On media drivers, debugging messages should be grouped into
categories, as this makes easier to debug the driver.
In the case of saa7134, the core has 2 debug categories, one
for IRQ, and another one for the core itself. The IRQ have
actually 2 levels of debug.
So, instead of using pr_dbg(), wher
Converting debug prints to use pr_foo() is not trivial, as the
result will be a way worse than what's provided here, due to the
pieces of the code that prints the I2C transfers. Those use a
lot pr_cont(), and, depending on using either level 1 or 2,
a different set of macros are selected.
So, let'
As this module doesn't use any debug level, it is easy to
just replace all debug printks by pr_debug().
Signed-off-by: Mauro Carvalho Chehab
diff --git a/drivers/media/pci/saa7134/saa7134-dvb.c
b/drivers/media/pci/saa7134/saa7134-dvb.c
index 7e0091343c87..7edb49729489 100644
--- a/drivers/media
wprintk() macro is now just a wrapper for pr_warn(). Get rid of
it!
Signed-off-by: Mauro Carvalho Chehab
diff --git a/drivers/media/pci/saa7134/saa7134-dvb.c
b/drivers/media/pci/saa7134/saa7134-dvb.c
index c7d9896a454e..7e0091343c87 100644
--- a/drivers/media/pci/saa7134/saa7134-dvb.c
+++ b/dri
Instead of implement its own hexdump logic, use the printk
format, and convert to use pr_info().
Signed-off-by: Mauro Carvalho Chehab
diff --git a/drivers/media/pci/saa7134/saa7134-i2c.c
b/drivers/media/pci/saa7134/saa7134-i2c.c
index b140143dba7d..ef3c33e3757d 100644
--- a/drivers/media/pci/sa
drivers/media/pci/cx23885/altera-ci.c:762 altera_ci_init() warn: inconsistent
indenting
Signed-off-by: Mauro Carvalho Chehab
diff --git a/drivers/media/pci/cx23885/altera-ci.c
b/drivers/media/pci/cx23885/altera-ci.c
index 0a91df2c9f08..aaf4e46ff3e9 100644
--- a/drivers/media/pci/cx23885/altera
rename the macro to vbi_dbg()/video_dbg() and use pr_fmt(),
to be coherent with the other debug macro changes.
Signed-off-by: Mauro Carvalho Chehab
diff --git a/drivers/media/pci/saa7134/saa7134-vbi.c
b/drivers/media/pci/saa7134/saa7134-vbi.c
index 109c2ffeab93..face07bf420d 100644
--- a/driver
Instead of using printk(), use pr_foo() macros.
Signed-off-by: Mauro Carvalho Chehab
diff --git a/drivers/media/pci/saa7134/saa7134-i2c.c
b/drivers/media/pci/saa7134/saa7134-i2c.c
index ef3c33e3757d..d04fbdb49158 100644
--- a/drivers/media/pci/saa7134/saa7134-i2c.c
+++ b/drivers/media/pci/saa71
drivers/media/usb/dvb-usb/af9005-fe.c:484 af9005_fe_read_status() warn:
inconsistent indenting
Signed-off-by: Mauro Carvalho Chehab
diff --git a/drivers/media/usb/dvb-usb/af9005-fe.c
b/drivers/media/usb/dvb-usb/af9005-fe.c
index 740f3f496f12..6e84a546dfdc 100644
--- a/drivers/media/usb/dvb-usb
Replaces all occurrences of printk with KERN_INFO, KERN_WARNING
and KERN_ERR to pr_info/pr_warning, pr_err, using this small
shell script:
for i in drivers/media/pci/saa7134/*.[ch]; do sed s,'printk(KERN_INFO
','pr_info(',g <$i >a && mv a $i; done
for i in drivers/media/pci/saa7134/*.[ch]; do sed
As this module doesn't use any debug level, it is easy to
just replace all debug printks by pr_debug().
Signed-off-by: Mauro Carvalho Chehab
diff --git a/drivers/media/pci/saa7134/saa7134-empress.c
b/drivers/media/pci/saa7134/saa7134-empress.c
index 5d687bcb74ce..e7db4a7166ad 100644
--- a/drive
drivers/media/usb/dvb-usb/dw2102.c:440 dw2104_i2c_transfer() warn: inconsistent
indenting
Signed-off-by: Mauro Carvalho Chehab
diff --git a/drivers/media/usb/dvb-usb/dw2102.c
b/drivers/media/usb/dvb-usb/dw2102.c
index f1f357f43ff0..28fd6bacb852 100644
--- a/drivers/media/usb/dvb-usb/dw2102.c
+
drivers/media/platform/vivid/vivid-vid-out.c:1155 vivid_vid_out_g_parm() warn:
inconsistent indenting
Signed-off-by: Mauro Carvalho Chehab
diff --git a/drivers/media/platform/vivid/vivid-vid-out.c
b/drivers/media/platform/vivid/vivid-vid-out.c
index 0af43dc7715c..00f42df947c0 100644
--- a/driv
Add a pr_fmt macro, and move saa7134.h header to the beginning,
to avoid warnings when using the pr_foo macros.
Signed-off-by: Mauro Carvalho Chehab
diff --git a/drivers/media/pci/saa7134/saa7134-alsa.c
b/drivers/media/pci/saa7134/saa7134-alsa.c
index ac3cd74e824e..d5b0610a91fb 100644
--- a/dri
drivers/media/usb/gspca/xirlink_cit.c:1776 cit_start_model2() info: ignoring
unreachable code.
drivers/media/usb/gspca/xirlink_cit.c:1858 cit_start_model2() info: ignoring
unreachable code.
drivers/media/usb/gspca/xirlink_cit.c:1910 cit_start_model2() info: ignoring
unreachable code.
Signed-off
use just one macro instead of 2, naming it as audio_dbg() and
using pr_fmt().
Signed-off-by: Mauro Carvalho Chehab
diff --git a/drivers/media/pci/saa7134/saa7134-tvaudio.c
b/drivers/media/pci/saa7134/saa7134-tvaudio.c
index e8aeea4cf422..360f447bd74d 100644
--- a/drivers/media/pci/saa7134/saa71
Rename the macros to input_dbg() and ir_dbg(), using pr_fmt()
on both, to be coherent with the other debug macro changes.
The ir_dbg() also prints the IR name.
I'm not sure if it is a good idea to keep both macros here,
but merging them would require tests on different flavors of
saaa7134-based b
On a few places, mostly during board detection, some printk()
macros were called without especifying any message level.
Those are actually warnings. So, use pr_warn() for them.
Signed-off-by: Mauro Carvalho Chehab
diff --git a/drivers/media/pci/saa7134/saa7134-cards.c
b/drivers/media/pci/saa71
instead of using dev->name, let's use pr_fmt() like on the
other parts of saa7134. Also, rename the debug macro to
ts_dbg() to match the namespace for the debug macros.
Signed-off-by: Mauro Carvalho Chehab
diff --git a/drivers/media/pci/saa7134/saa7134-ts.c
b/drivers/media/pci/saa7134/saa7134-t
On saa7134-alsa, there is just one printk macro that use a
different debug level.
It should be easy to enable/disable this one using dynamic_printk,
if one need to individually control it.
So, this module can easily use pr_debug() instead of using its
own macros.
Signed-off-by: Mauro Carvalho Ch
On a few places, the search expression used on the script that
replaced pr_info/pr_warn didn't match, because the string were
on the next line.
It is best to manually edit those lines, and re-indent the
paragraphs.
Signed-off-by: Mauro Carvalho Chehab
diff --git a/drivers/media/pci/saa7134/saa7
drivers/media/platform/m2m-deinterlace.c:1063 deinterlace_probe() info:
ignoring unreachable code.
Signed-off-by: Mauro Carvalho Chehab
diff --git a/drivers/media/platform/m2m-deinterlace.c
b/drivers/media/platform/m2m-deinterlace.c
index 92d954973ccf..c07f367aa436 100644
--- a/drivers/media/p
Em Thu, 30 Apr 2015 08:20:49 +0200
Hans Verkuil escreveu:
> On 04/28/2015 05:43 PM, Mauro Carvalho Chehab wrote:
> > As reported by smatch:
> > drivers/media/pci/saa7134/saa7134-cards.c:7197
> > saa7134_xc2028_callback() warn: inconsistent indenting
> > drivers/media/pci/saa7134/saa7134-
This pull request cleans up the dt3155 driver and moves it out of staging.
Tested with my dt3155 board.
Regards,
Hans
The following changes since commit e183201b9e917daf2530b637b2f34f1d5afb934d:
[media] uvcvideo: add support for VIDIOC_QUERY_EXT_CTRL (2015-04-10 10:29:27
-0300)
are
Hi Sakari and Sylwester,
On 04/03/2015 12:53 PM, Sylwester Nawrocki wrote:
Hello,
On 25/03/15 09:52, Jacek Anaszewski wrote:
On 03/25/2015 02:06 AM, Sakari Ailus wrote:
On Fri, Mar 20, 2015 at 04:03:29PM +0100, Jacek Anaszewski wrote:
This patch adds a description of 'flashes' property
to th
Hello.
On 4/30/2015 2:44 PM, Geert Uytterhoeven wrote:
Since there is no distintion between 12bit and 16bit YUV formats in
Вistinсtion.
Distinction?
Sorry, yes. :-)
Gr{oetje,eeting}s,
Geert
WBR, Sergei
--
To unsubscribe from this list: send the line
On Thu, Apr 30, 2015 at 1:22 PM, Sergei Shtylyov
wrote:
>> Since there is no distintion between 12bit and 16bit YUV formats in
>
>Вistinсtion.
Distinction?
Gr{oetje,eeting}s,
Geert
--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- ge...@linux-m68k.org
I
Hello.
On 4/29/2015 8:05 PM, Yoshihiro Kaneko wrote:
From: Damian Hobson-Garcia
Make sure that there are valid values in the crop rectangle to ensure
that the color plane doesn't get shifted when cropping.
Since there is no distintion between 12bit and 16bit YUV formats in
Вistinсtion.
This patch adds helper functions for registering/unregistering
LED Flash class devices as V4L2 sub-devices. The functions should
be called from the LED subsystem device driver. In case the
support for V4L2 Flash sub-devices is disabled in the kernel
config the functions' empty versions will be used
This patch adds led-flash support to Maxim max77693 chipset.
A device can be exposed to user space through LED subsystem
sysfs interface. Device supports up to two leds which can
work in flash and torch mode. The leds can be triggered
externally or by software.
Signed-off-by: Jacek Anaszewski
Sig
This patch adds a driver for the 1.5A Step-Up Current Regulator
for Flash LEDs. The device is programmed through a Skyworks proprietary
AS2Cwire serial digital interface.
Signed-off-by: Jacek Anaszewski
Acked-by: Kyungmin Park
Acked-by: Sakari Ailus
Cc: Bryan Wu
Cc: Richard Purdie
---
Fixed i
This patch extends LED Flash class documention by
the description of interactions with v4l2-flash sub-device.
Signed-off-by: Jacek Anaszewski
Acked-by: Kyungmin Park
Acked-by: Sakari Ailus
Cc: Bryan Wu
Cc: Richard Purdie
---
Documentation/leds/leds-class-flash.txt | 47
Hi Emil,
From: linux-media-ow...@vger.kernel.org [mailto:linux-media-
ow...@vger.kernel.org] On Behalf Of Emil Velikov
Sent: Wednesday, April 29, 2015 5:00 PM
>
> Hi Kamil,
>
> Allow me to put a few suggestions:
>
> On 29 April 2015 at 11:02, Kamil Debski wrote:
> > This is the first version o
On Tue, Apr 28, 2015 at 12:59 PM, Mauro Carvalho Chehab
wrote:
> drivers/media/platform/am437x/am437x-vpfe.c: In function
> 'vpfe_ccdc_update_raw_params':
> drivers/media/platform/am437x/am437x-vpfe.c:430:38: warning: variable
> 'config_params' set but not used [-Wunused-but-set-variable]
> st
On Tue, Apr 28, 2015 at 12:59 PM, Mauro Carvalho Chehab
wrote:
> drivers/media/platform/am437x/am437x-vpfe.c:513 vpfe_ccdc_set_params() warn:
> inconsistent indenting
>
> Cc: Benoit Parrot
> Signed-off-by: Mauro Carvalho Chehab
>
Acked-by: Lad, Prabhakar
Cheers,
--Prabhakar Lad
--
To unsubscr
On Tue, Apr 28, 2015 at 12:59 PM, Mauro Carvalho Chehab
wrote:
> drivers/media/platform/am437x/am437x-vpfe.c: In function
> 'vpfe_get_subdev_input_index':
> drivers/media/platform/am437x/am437x-vpfe.c:1679:27: warning: variable
> 'sdinfo' set but not used [-Wunused-but-set-variable]
> struct v
On Thu, Apr 30, 2015 at 12:06 AM, Mauro Carvalho Chehab
wrote:
> drivers/media/i2c/cx25840/cx25840-core.c:974 input_change() warn:
> inconsistent indenting
>
> Signed-off-by: Mauro Carvalho Chehab
>
Acked-by: Lad, Prabhakar
Cheers,
--Prabhakar Lad
--
To unsubscribe from this list: send the lin
On Tue, Apr 28, 2015 at 4:43 PM, Mauro Carvalho Chehab
wrote:
> As reported by smatch:
> drivers/media/pci/zoran/zoran_device.c:1594 zoran_init_hardware()
> warn: inconsistent indenting
>
> Fix indent. While here, fix CodingStyle and remove dead code, as it
> can always be recovered from
47 matches
Mail list logo