On Thu 2015-04-16 07:24:42, Sebastian Reichel wrote:
> Hi Sakari,
>
> Since this driver won't make it into 4.1 anyways, I have one more
> comment:
Like this driver did not receive enough bikesheding.
> > + } else {
> > + gpiod_set_value(flash->platform_data->enable_gpio, on);
> > +
Hi Sakari,
Since this driver won't make it into 4.1 anyways, I have one more
comment:
On Thu, Apr 16, 2015 at 02:37:13AM +0300, Sakari Ailus wrote:
> From: Pavel Machek
>
> Add device tree support for adp1653 flash LED driver.
>
> Signed-off-by: Pavel Machek
> Signed-off-by: Sakari Ailus
> -
On Thu, Apr 16, 2015 at 01:58:16AM +0200, Luis R. Rodriguez wrote:
>
> An alternative... is to just ioremap_wc() the entire region, including
> MMIO registers for these old devices. I see one ethernet driver that does
> this, myri10ge, and am curious how and why they ended up deciding this
> and i
This message is generated daily by a cron job that builds media_tree for
the kernels and architectures in the list below.
Results of the daily build of media_tree:
date: Thu Apr 16 04:00:23 CEST 2015
git branch: test
git hash: e183201b9e917daf2530b637b2f34f1d5afb934d
gcc versi
On Thu, 2015-04-16 at 01:58 +0200, Luis R. Rodriguez wrote:
> Hey Andy, thanks for your review, adding Hyong-Youb Kim for review of the
> full range ioremap_wc() idea below.
>
> On Wed, Apr 15, 2015 at 06:38:51PM -0400, Andy Walls wrote:
> > Hi All,
> >
> > On Mon, 2015-04-13 at 19:49 +0200, Lu
On Wed, 2015-04-15 at 17:58 -0700, Andy Lutomirski wrote:
> On Wed, Apr 15, 2015 at 4:59 PM, Andy Walls wrote:
> > On Wed, 2015-04-15 at 16:42 -0700, Andy Lutomirski wrote:
> >> On Wed, Apr 15, 2015 at 3:38 PM, Andy Walls
> >> wrote:
> >
> >> >
> >>
> >> IMO the right solution would be to avoid
On Wed, 2015-04-15 at 16:52 -0700, Andy Lutomirski wrote:
> On Wed, Apr 15, 2015 at 3:50 PM, Andy Walls wrote:
> > On Wed, 2015-04-15 at 13:42 -0700, Andy Lutomirski wrote:
> >> On Mon, Apr 13, 2015 at 10:49 AM, Luis R. Rodriguez
> >> wrote:
> >>
> >> > c) ivtv: the driver does not have the PCI
On Wed, Apr 15, 2015 at 4:59 PM, Andy Walls wrote:
> On Wed, 2015-04-15 at 16:42 -0700, Andy Lutomirski wrote:
>> On Wed, Apr 15, 2015 at 3:38 PM, Andy Walls wrote:
>
>> >
>>
>> IMO the right solution would be to avoid ioremapping the whole bar at
>> startup. Instead ioremap pieces once the driv
On Wed, 2015-04-15 at 16:42 -0700, Andy Lutomirski wrote:
> On Wed, Apr 15, 2015 at 3:38 PM, Andy Walls wrote:
> >
>
> IMO the right solution would be to avoid ioremapping the whole bar at
> startup. Instead ioremap pieces once the driver learns what they are.
> This wouldn't have any of these
Hi All,
On Mon, 2015-04-13 at 19:49 +0200, Luis R. Rodriguez wrote:
[snip]
> I only saw a few drivers using overlapping ioremap*()
> calls though on my MTRR review and they are all old devices so likely mostly
> used on non-PAT systems, but there might be other corner cases elsewhere.
>
> Lets r
Hey Andy, thanks for your review, adding Hyong-Youb Kim for review of the
full range ioremap_wc() idea below.
On Wed, Apr 15, 2015 at 06:38:51PM -0400, Andy Walls wrote:
> Hi All,
>
> On Mon, 2015-04-13 at 19:49 +0200, Luis R. Rodriguez wrote:
> > From the beginning it seems only framebuffer de
On Wed, Apr 15, 2015 at 3:50 PM, Andy Walls wrote:
> On Wed, 2015-04-15 at 13:42 -0700, Andy Lutomirski wrote:
>> On Mon, Apr 13, 2015 at 10:49 AM, Luis R. Rodriguez wrote:
>>
>> > c) ivtv: the driver does not have the PCI space mapped out separately, and
>> > in fact it actually does not do the
On Wed, 2015-04-15 at 13:42 -0700, Andy Lutomirski wrote:
> On Mon, Apr 13, 2015 at 10:49 AM, Luis R. Rodriguez wrote:
>
> > c) ivtv: the driver does not have the PCI space mapped out separately, and
> > in fact it actually does not do the math for the framebuffer, instead it
> > lets
> > the de
On Wed, Apr 15, 2015 at 3:38 PM, Andy Walls wrote:
> Hi All,
>
> On Mon, 2015-04-13 at 19:49 +0200, Luis R. Rodriguez wrote:
> [snip]
>> I only saw a few drivers using overlapping ioremap*()
>> calls though on my MTRR review and they are all old devices so likely mostly
>> used on non-PAT systems
From: Pavel Machek
Add device tree support for adp1653 flash LED driver.
Signed-off-by: Pavel Machek
Signed-off-by: Sakari Ailus
---
Hi folks,
Here's an updated adp1653 DT patch, with changes since v7:
- Include of.h and gpio/consumer.h instead of of_gpio.h and gpio.h.
- Don't initialise re
On Wed, Apr 15, 2015 at 01:42:47PM -0700, Andy Lutomirski wrote:
> On Mon, Apr 13, 2015 at 10:49 AM, Luis R. Rodriguez wrote:
>
> > c) ivtv: the driver does not have the PCI space mapped out separately, and
> > in fact it actually does not do the math for the framebuffer, instead it
> > lets
> >
From: "Lad, Prabhakar"
Instead of parsing the link-frequencies property in the driver, let
v4l2_of_alloc_parse_endpoint() do it.
Signed-off-by: Lad, Prabhakar
Acked-by: Sakari Ailus
---
Changes for v2:
a: Ignoring nr_of_link_frequencies if greater then one and
just using the first one.
On 04/15/2015 01:42 PM, Andy Lutomirski wrote:
>
> I disagree. We should try to NACK any new code that can't function
> without MTRRs.
>
> (Plus, ARM is growing in popularity in the server space, and ARM quite
> sensibly doesn't have MTRRs.)
>
Yes. People need to understand that MTRRs are f
On Mon, Apr 13, 2015 at 10:49 AM, Luis R. Rodriguez wrote:
> c) ivtv: the driver does not have the PCI space mapped out separately, and
> in fact it actually does not do the math for the framebuffer, instead it lets
> the device's own CPU do that and assume where its at, see
> ivtvfb_get_framebuf
Hi Sakari,
Thank you for the review.
On Tuesday 14 April 2015 23:10:05 Sakari Ailus wrote:
> On Tue, Apr 14, 2015 at 10:44:48PM +0300, Laurent Pinchart wrote:
> > The data_offset field has been introduced along with the multiplane API
> > to convey header size information between kernelspace and
On Thu, 9 Apr 2015, Hans Verkuil wrote:
> From: Hans Verkuil
>
> The g_mbus_fmt video op is a duplicate of the pad op. Replace all uses
> by the get_fmt pad op and remove the video op.
>
> Signed-off-by: Hans Verkuil
> Cc: Guennadi Liakhovetski
> Cc: Prabhakar Lad
> Cc: Kamil Debski
> ---
On Thu, 9 Apr 2015, Hans Verkuil wrote:
> From: Hans Verkuil
>
> Replace all calls to the enum_mbus_fmt video op by the pad
> enum_mbus_code op and remove the duplicate video op.
>
> Signed-off-by: Hans Verkuil
> Cc: Guennadi Liakhovetski
> Cc: Scott Jiang
> Cc: Jonathan Corbet
> Cc: Kamil
This needs to be signed or there is a risk of hitting a forever loop.
Fixes: c4c0283ab3cd ('[media] media: i2c: add support for omnivision's ov2659
sensor')
Signed-off-by: Dan Carpenter
diff --git a/drivers/media/i2c/ov2659.c b/drivers/media/i2c/ov2659.c
index edebd11..d700a1d 100644
--- a/driv
Hi Sakari,
Thanks for the review.
On 04/15/2015 11:30 AM, Sakari Ailus wrote:
Hi Jacek,
On Wed, Apr 15, 2015 at 08:48:33AM +0200, Jacek Anaszewski wrote:
...
+static int max77693_led_parse_dt(struct max77693_led_device *led,
+ struct max77693_led_config_data *cfg
Hallo!
Would you be so kindly,please check this bug again, because is seams to
be a regression.
thanks
w.pelser
--
To unsubscribe from this list: send the line "unsubscribe linux-media" in
the body of a message to majord...@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordo
From: Kozlov Sergey
Add NetUP Dual Universal CI PCIe board driver.
The board has
- two CI slots
- two I2C adapters
- SPI master bus for accessing flash memory containing
FPGA firmware
Changes in version 2:
- rename driver directory from netup to netup_unidvb
- rename MA
From: Kozlov Sergey
Add DVB SEC frontend driver for STM LNBH25PQR chip.
Changes in version 2:
- rename MAINTAINERS entry
- fix coding style
- use dynamic debug instead of module-specifig debug parameter
- fix I2C bus error handling
Signed-off-by: Kozlov Sergey
---
MAINTAINERS
From: Kozlov Sergey
Add DVB-C/T/T2/S/S2 demodulator frontend driver Sony CXD2841ER chip.
Changes in version 2:
- rename MAINTAINERS entry
- fix coding style
- use dynamic debug instead of module-specifig debug parameter
- fix I2C bus error handling
- provide signal statistics
From: Kozlov Sergey
Add support for NetUP Universal Dual DVB-CI PCIe board.
The board has:
- two CI slots
- Altera FPGA-based PCIe bridge
- two independent multistandard DTV demodulators based on
Sony CXD2841ER chip
- two Sony Horus3a DVB-S/S2 tuner chips
- two Sony
From: Kozlov Sergey
Add DVB-S/S2 frontend driver for Sony Horus3A (CXD2832AER) chip
Changes in version 2:
- rename MAINTAINERS entry
- fix coding style
- use dynamic debug instead of module-specifig debug parameter
- fix I2C bus error handling
Signed-off-by: Kozlov Sergey
---
From: Kozlov Sergey
Add DVB-T/T2/C frontend driver for Sony Ascot2e (CXD2861ER) chip.
Changes in version 2:
- rename MAINTAINERS entry
- fix coding style
- use dynamic debug instead of module-specifig debug parameter
- fix I2C bus error handling
Signed-off-by: Kozlov Sergey
---
Hi Jacek,
On Wed, Apr 15, 2015 at 08:48:33AM +0200, Jacek Anaszewski wrote:
...
> +static int max77693_led_parse_dt(struct max77693_led_device *led,
> + struct max77693_led_config_data *cfg)
> +{
> + struct device *dev = &led->pdev->dev;
> + struct max77693_sub_
Hi Jacek,
On Wed, Apr 15, 2015 at 08:48:32AM +0200, Jacek Anaszewski wrote:
> This patch adds device tree binding documentation for
> the flash cell of the Maxim max77693 multifunctional device.
>
> Signed-off-by: Jacek Anaszewski
> Signed-off-by: Andrzej Hajda
> Acked-by: Kyungmin Park
> Cc:
On Wed, Apr 15, 2015 at 08:48:31AM +0200, Jacek Anaszewski wrote:
> Part of led-trigger API was in the private drivers/leds/leds.h header.
> Move it to the include/linux/leds.h header to unify the API location
> and announce it as public. It has been already exported from
> led-triggers.c with EXPO
34 matches
Mail list logo