This message is generated daily by a cron job that builds media_tree for
the kernels and architectures in the list below.
Results of the daily build of media_tree:
date: Sat Apr 4 04:00:42 CEST 2015
git branch: test
git hash: a5562f65b1371a0988b707c10c44fcc2bba56990
gcc versi
On Fri, Apr 03, 2015 at 06:13:13PM +0100, Russell King wrote:
> clkdev_create() is a shorter way to write clkdev_alloc() followed by
> clkdev_add(). Use this instead.
>
> Signed-off-by: Russell King
Acked-by: Andrew Lunn
Andrew
> ---
> arch/arm/plat-orion/common.c | 6 +-
> 1
If i2c_add_adapter() fails, adap is not deallocated.
Found by Linux Driver Verification project (linuxtesting.org).
Signed-off-by: Alexey Khoroshilov
---
drivers/media/platform/marvell-ccic/cafe-driver.c | 12
1 file changed, 8 insertions(+), 4 deletions(-)
diff --git a/drivers/me
* Russell King [150403 10:14]:
> When creating aliases of existing clkdev clocks, use clkdev_add_alias()
> isntead of open coding the lookup and clk_lookup creation.
>
> Signed-off-by: Russell King
Acked-by: Tony Lindgren
> ---
> arch/arm/mach-omap2/omap_device.c | 24 +--
* Russell King [150403 10:14]:
> Rather than open coding the clkdev allocation, initialisation and
> addition, use the clkdev_create() helper.
>
> Signed-off-by: Russell King
Acked-by: Tony Lindgren
> ---
> arch/arm/mach-omap2/clkt2xxx_virt_prcm_set.c | 12 ++--
> 1 file changed, 2 i
* Russell King [150403 10:13]:
> clk_add_alias() is provided by clkdev, and is not part of the clk API.
> Howver, it is prototyped in two locations: linux/clkdev.h and
> linux/clk.h. This is a mess. Get rid of the redundant and unnecessary
> version in linux/clk.h.
Acked-by: Tony Lindgren
--
T
On Sat, Apr 04, 2015 at 12:45:02AM +0300, Laurent Pinchart wrote:
> From: Russell King
>
> No merged platform supplies xclks via platform data. As we want to
> slightly change the clkdev interface, rather than fixing this unused
> code, remove it instead.
>
> Signed-off-by: Russell King
> Sign
From: Russell King
No merged platform supplies xclks via platform data. As we want to
slightly change the clkdev interface, rather than fixing this unused
code, remove it instead.
Signed-off-by: Russell King
Signed-off-by: Laurent Pinchart
---
drivers/media/platform/omap3isp/isp.c | 24 -
Hi Russell,
Thank you for the patch;
On Friday 03 April 2015 18:12:58 Russell King wrote:
> No merged platform supplies xclks via platform data. As we want to
> slightly change the clkdev interface, rather than fixing this unused
> code, remove it instead.
>
> Signed-off-by: Russell King
Acke
Hi!
> >>+- flash-timeout-us : Timeout in microseconds after which the flash
> >>+ LED is turned off. If omitted this will default to the
> >>+maximum timeout allowed by the device.
> >>
> >>
> >> Examples:
> >
> >Pavel pointed out that the brightness between ma
On Fri, Apr 03, 2015 at 11:11:30AM +0100, Sean Young wrote:
>On Thu, Apr 02, 2015 at 12:19:41AM +0200, David Härdeman wrote:
>> On Tue, Mar 31, 2015 at 08:47:16PM -0300, Mauro Carvalho Chehab wrote:
>> >Em Mon, 30 Mar 2015 23:18:19 +0200
>> >David Härdeman escreveu:
>> >> And on a much more genera
On Fri, Apr 03, 2015 at 06:11:49PM +0100, Russell King - ARM Linux wrote:
> Sorry for posting this soo close to the 4.1 merge window, I had
> completely forgotten about this chunk of work I did earlier this
> month.
Correction - earlier _last_ month - 1st/2nd March to be exact.
--
FTTC broadband
When creating aliases of existing clkdev clocks, use clkdev_add_alias()
isntead of open coding the lookup and clk_lookup creation.
Signed-off-by: Russell King
---
arch/arm/mach-omap2/omap_device.c | 24 +---
1 file changed, 9 insertions(+), 15 deletions(-)
diff --git a/arch/
clkdev_create() is a shorter way to write clkdev_alloc() followed by
clkdev_add(). Use this instead.
Signed-off-by: Russell King
---
arch/arm/plat-orion/common.c | 6 +-
1 file changed, 1 insertion(+), 5 deletions(-)
diff --git a/arch/arm/plat-orion/common.c b/arch/arm/plat-orion/common.c
clkdev_create() is a shorter way to write clkdev_alloc() followed by
clkdev_add(). Use this instead.
Signed-off-by: Russell King
---
drivers/clk/clk-s2mps11.c | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)
diff --git a/drivers/clk/clk-s2mps11.c b/drivers/clk/clk-s2mps11.c
index bfa1e
clkdev_create() is a shorter way to write clkdev_alloc() followed by
clkdev_add(). Use this instead.
Acked-by: Mark Brown
Signed-off-by: Russell King
---
sound/soc/sh/migor.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/sound/soc/sh/migor.c b/sound/soc/sh/migor.c
index
Rather than open coding the clkdev allocation, initialisation and
addition, use the clkdev_create() helper.
Signed-off-by: Russell King
---
arch/arm/mach-omap2/clkt2xxx_virt_prcm_set.c | 12 ++--
1 file changed, 2 insertions(+), 10 deletions(-)
diff --git a/arch/arm/mach-omap2/clkt2xxx_
clk_add_alias() is provided by clkdev, and is not part of the clk API.
Howver, it is prototyped in two locations: linux/clkdev.h and
linux/clk.h. This is a mess. Get rid of the redundant and unnecessary
version in linux/clk.h.
Signed-off-by: Russell King
---
arch/arm/mach-davinci/da850.c
The connection id is only passed to clk_get() which is already const.
Const-ify this argument too.
Signed-off-by: Russell King
---
drivers/clk/clkdev.c | 6 +++---
include/linux/clkdev.h | 2 +-
2 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/clk/clkdev.c b/drivers/clk/c
We want to be able to call clkdev_add_table() from non-init code, so we
need to drop the __init marker from it.
Signed-off-by: Russell King
---
drivers/clk/clkdev.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/clk/clkdev.c b/drivers/clk/clkdev.c
index 043fd3633373.
No merged platform supplies xclks via platform data. As we want to
slightly change the clkdev interface, rather than fixing this unused
code, remove it instead.
Signed-off-by: Russell King
---
drivers/media/platform/omap3isp/isp.c | 18 --
drivers/media/platform/omap3isp/isp.h |
We have always had an efficient way of registering a table of clock
lookups - it's called clkdev_add_table(). However, some people seem
to really love writing inefficient and unnecessary code.
Convert LPC32xx to use the correct interface.
Signed-off-by: Russell King
---
arch/arm/mach-lpc32xx/c
Add a helper to allocate and add a clk_lookup structure. This can not
only be used in several places in clkdev.c to simplify the code, but
more importantly, can be used by callers of the clkdev code to simplify
their clkdev creation and registration.
Signed-off-by: Russell King
---
drivers/clk/
Signed-off-by: Russell King
---
drivers/clk/clkdev.c | 24
include/linux/clkdev.h | 1 +
2 files changed, 17 insertions(+), 8 deletions(-)
diff --git a/drivers/clk/clkdev.c b/drivers/clk/clkdev.c
index 5d7746d19445..8e676eafc823 100644
--- a/drivers/clk/clkdev.c
+++ b
We have always had an efficient way of registering a table of clock
lookups - it's called clkdev_add_table(). However, some people seem
to really love writing inefficient and unnecessary code.
Convert SH to use the correct interface.
Acked-by: Geert Uytterhoeven
Signed-off-by: Russell King
---
The idea is that rate = clk_round_rate(clk, r) is equivalent to:
clk_set_rate(clk, r);
rate = clk_get_rate(clk);
except that clk_round_rate() does not change the hardware in any way.
Signed-off-by: Russell King
---
include/linux/clk.h | 14 ++
1 file changed, 14 ins
Sorry for posting this soo close to the 4.1 merge window, I had
completely forgotten about this chunk of work I did earlier this
month.
The per-user struct clk patches rather badly broke clkdev and
various other places. This was reported, but was forgotten about.
Really, the per-user clk stuff sh
Hi Antti & Mauro,
It seems that dvbv5-scan makes a scan of channels, set the parameters
it gets in the initial scan file, but then reads in the frequency from
the driver before writing the channel file. It seems to get a much
lower frequency (I understand this is the LNB frequency) from the
driver
Hi Mauro,
The following changes since commit 8a56b6b5fd6ff92b7e27d870b803b11b751660c2:
[media] v4l2-subdev: remove enum_framesizes/intervals (2015-03-23 12:02:41
-0700)
are available in the git repository at:
git://linuxtv.org/snawrocki/samsung.git for-v4.1/media/next
for you to fetch ch
v2: * Let creators of the input device to decide whether it should remain
runtime suspended when the system goes into a sleep state
* Don't enable PM runtime on all evdev handlers
* Cope with another wrong wakeup setting in usb_dev_prepare
Hi,
this series contain what
Have it return 1 so that media device nodes that are runtime-suspended
won't be suspended when the system goes to a sleep state. This can make
resume times considerably shorter because these devices don't need to be
resumed when the system is awaken.
Signed-off-by: Tomeu Vizoso
---
drivers/media
So UVC devices can remain runtime-suspended when the system goes into a
sleep state, they and all of their descendant devices need to have
runtime PM enable.
Signed-off-by: Tomeu Vizoso
---
drivers/media/usb/uvc/uvc_driver.c | 11 +++
1 file changed, 11 insertions(+)
diff --git a/driver
Have it return 1 so that video devices that are runtime-suspended won't
be suspended when the system goes to a sleep state. This can make resume
times considerably shorter because these devices don't need to be
resumed when the system is awaken.
Signed-off-by: Tomeu Vizoso
---
drivers/media/v4l2
So that the UVC device can remain runtime suspended when the system goes
into a sleep state, let the input device do the same.
Signed-off-by: Tomeu Vizoso
---
drivers/media/usb/uvc/uvc_status.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/media/usb/uvc/uvc_status.c
b/drivers/medi
Hi Sakari,
On 04/03/2015 02:09 PM, Sakari Ailus wrote:
Hi Jacek,
On Tue, Mar 31, 2015 at 03:52:37PM +0200, Jacek Anaszewski wrote:
Description of flash LEDs related properties was not precise regarding
the state of corresponding settings in case a property is missing.
Add relevant statements.
Hi Jacek,
On Wed, Mar 25, 2015 at 09:52:02AM +0100, Jacek Anaszewski wrote:
> Hi Sakari,
>
> On 03/25/2015 02:06 AM, Sakari Ailus wrote:
> >Hi Jacek,
> >
> >On Fri, Mar 20, 2015 at 04:03:29PM +0100, Jacek Anaszewski wrote:
> >>This patch adds a description of 'flashes' property
> >>to the samsung
Hi Jacek,
On Tue, Mar 31, 2015 at 03:52:37PM +0200, Jacek Anaszewski wrote:
> Description of flash LEDs related properties was not precise regarding
> the state of corresponding settings in case a property is missing.
> Add relevant statements.
> Removed is also the requirement making the flash-ma
Added Android makefiles for libv4l2 and libv4lconvert.
Minor changes to include android-config.h.
Changed the plugin loading mechanism to avoid using
unsupported glob.h header.
Current mechanism supports a list of plugin search paths
including /system/lib and /vendor/lib.
Signed-off-by: Paramanand
Hi Benjamin,
On 03/27/2015 09:29 AM, Benjamin Gaignard wrote:
> Hello,
>
> On behalf of Paramanand, I would have to have your opinion on this patch.
> The goal is to enable more v4l2 lib features on Android to be able to
> do video decoding using v4l2 devices.
Can you repost the patch? It is man
- Add V4L2_DV_FL_IS_CE_VIDEO flag
- Various cx18 v4l2-compliance fixes
- More 'embed video_device' patches (tested with actual hardware)
- Add CVT/GTF timings support to vivid
- Add V4L2_CTRL_FLAG_EXECUTE_ON_WRITE support
- Improve gpiod use
Regards,
Hans
The following changes since comm
If pci_disable_device() isn't called when the driver is removed, then
the next time when it is loaded the irq isn't found.
I'm pretty sure this used to work in the past, but calling pci_disable_device()
is clearly the correct method and this makes it work again.
Signed-off-by: Hans Verkuil
---
d
Hello,
On 25/03/15 09:52, Jacek Anaszewski wrote:
> On 03/25/2015 02:06 AM, Sakari Ailus wrote:
>> On Fri, Mar 20, 2015 at 04:03:29PM +0100, Jacek Anaszewski wrote:
>>> This patch adds a description of 'flashes' property
>>> to the samsung-fimc.txt.
>>>
>>> Signed-off-by: Jacek Anaszewski
>>> Ack
Fix three v4l2-compliance failures:
- the colorspace wasn't set in vidioc_try_fmt_vid_cap().
- the field wasn't set in v4l2_buffer when vb2_buffer_done() was called.
- the sequence wasn't set in v4l2_buffer when vb2_buffer_done() was called.
This fix also removes the unused buf->count field and
On Thu, Apr 02, 2015 at 12:19:41AM +0200, David Härdeman wrote:
> On Tue, Mar 31, 2015 at 08:47:16PM -0300, Mauro Carvalho Chehab wrote:
> >Em Mon, 30 Mar 2015 23:18:19 +0200
> >David Härdeman escreveu:
> >> And on a much more general level...I still think we should start from
> >> scratch with a
The v4l2-compliance tool expects that if VIDIOC_CROPCAP is defined, then
VIDIOC_G_SELECTION for TGT_CROP_BOUNDS/DEFAULT is also defined (or COMPOSE
in the case of an output device).
In fact, all that a driver has to do to implement cropcap is to support
those two targets since the v4l2 core will i
Add support for the new flag to v4l2_print_dv_timings().
Signed-off-by: Hans Verkuil
---
Follow-up to:
http://comments.gmane.org/gmane.linux.drivers.video-input-infrastructure/89447
---
drivers/media/v4l2-core/v4l2-dv-timings.c | 6 --
1 file changed, 4 insertions(+), 2 deletions(-)
diff --
Two driver fixes and one compilation fix.
Regards,
Hans
The following changes since commit a5562f65b1371a0988b707c10c44fcc2bba56990:
[media] v4l: xilinx: Add Test Pattern Generator driver (2015-04-03 01:04:18
-0300)
are available in the git repository at:
git://linuxtv.org/hverku
Needed for mips and sh platforms
Signed-off-by: Hans Verkuil
---
drivers/media/i2c/soc_camera/ov2640.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/media/i2c/soc_camera/ov2640.c
b/drivers/media/i2c/soc_camera/ov2640.c
index 42d9ba3..e3c907a 100644
--- a/drivers/media/i2c/soc_came
On Thu, Apr 02, 2015 at 01:56:37PM -0300, Mauro Carvalho Chehab wrote:
>Em Thu, 02 Apr 2015 14:02:57 +0200
>David Härdeman escreveu:
>
>> The following two patches should show more clearly what I mean by
>> adding protocols to the keytables (and letting userspace add
>> keytable entries with expli
49 matches
Mail list logo