In certain cases, dma_alloc_coherent returns NULL. Add check for
NULL pointer.
Signed-off-by: Sachin Kamat
---
drivers/media/platform/s5p-mfc/s5p_mfc_ctrl.c |2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/media/platform/s5p-mfc/s5p_mfc_ctrl.c
b/drivers/media/platf
Hi Laurent,
On Wed, May 29, 2013 at 6:52 AM, Laurent Pinchart
wrote:
> Hi Prabhakar,
>
> Thanks for the patch.
>
> On Sunday 26 May 2013 18:49:46 Prabhakar Lad wrote:
>> From: Lad, Prabhakar
>>
>> add OF support for the tvp514x driver.
>>
>> Signed-off-by: Lad, Prabhakar
>> Cc: Hans Verkuil
>>
Hi Laurent,
On Wed, May 29, 2013 at 9:08 AM, Laurent Pinchart
wrote:
> On Sunday 26 May 2013 17:30:12 Prabhakar Lad wrote:
>> From: Lad, Prabhakar
>>
>> use devm_request_irq() instead of request_irq(). This ensures
>> more consistent error values and simplifies error paths.
>>
>> Signed-off-by:
Hi Laurent,
Thanks for the review.
On Wed, May 29, 2013 at 8:02 AM, Laurent Pinchart
wrote:
> Hi Prabhakar,
>
> Thanks for the patch.
>
> On Sunday 26 May 2013 17:30:07 Prabhakar Lad wrote:
>> From: Lad, Prabhakar
>>
>> Ideally the freeing of irq's and the global variables needs to be
>> done i
Hi Laurent,
On Wed, May 29, 2013 at 9:01 AM, Laurent Pinchart
wrote:
> Hi Prabhakar,
>
> Thanks for the patch.
>
> On Sunday 26 May 2013 18:38:54 Prabhakar Lad wrote:
>> From: Lad, Prabhakar
>>
>> add OF support for the mt9p031 sensor driver.
>> Alongside this patch sorts the header inclusion al
On Sunday 26 May 2013 17:30:12 Prabhakar Lad wrote:
> From: Lad, Prabhakar
>
> use devm_request_irq() instead of request_irq(). This ensures
> more consistent error values and simplifies error paths.
>
> Signed-off-by: Lad, Prabhakar
Acked-by: Laurent Pinchart
with a small comment below.
>
On Sunday 26 May 2013 17:30:09 Prabhakar Lad wrote:
> From: Lad, Prabhakar
>
> use devm_request_irq() instead of request_irq(). This ensures
> more consistent error values and simplifies error paths.
>
> Signed-off-by: Lad, Prabhakar
Acked-by: Laurent Pinchart
> ---
> drivers/media/platform
On Sunday 26 May 2013 17:30:11 Prabhakar Lad wrote:
> From: Lad, Prabhakar
>
> This patch uses module_platform_driver() to simplify the code.
>
> Signed-off-by: Lad, Prabhakar
Acked-by: Laurent Pinchart
> ---
> drivers/media/platform/davinci/vpif_display.c | 18 +-
> 1 fil
On Sunday 26 May 2013 17:30:08 Prabhakar Lad wrote:
> From: Lad, Prabhakar
>
> This patch uses module_platform_driver() to simplify the code.
>
> Signed-off-by: Lad, Prabhakar
Acked-by: Laurent Pinchart
> ---
> drivers/media/platform/davinci/vpif_capture.c | 28 +-
> 1
Hi Prabhakar,
Thanks for the patch.
On Sunday 26 May 2013 18:38:54 Prabhakar Lad wrote:
> From: Lad, Prabhakar
>
> add OF support for the mt9p031 sensor driver.
> Alongside this patch sorts the header inclusion alphabetically.
>
> Signed-off-by: Lad, Prabhakar
> Cc: Hans Verkuil
> Cc: Lauren
Hi Prabhakar,
Thanks for the patch.
On Sunday 26 May 2013 17:30:07 Prabhakar Lad wrote:
> From: Lad, Prabhakar
>
> Ideally the freeing of irq's and the global variables needs to be
> done in the remove() rather than module_exit(), this patch moves
> the freeing up of irq's and freeing the memor
> -Original Message-
> From: daniel.vet...@ffwll.ch [mailto:daniel.vet...@ffwll.ch] On Behalf Of
> Daniel Vetter
> Sent: Wednesday, May 29, 2013 1:50 AM
> To: Inki Dae
> Cc: Rob Clark; Maarten Lankhorst; linux-fbdev; YoungJun Cho; Kyungmin
Park;
> myungjoo.ham; DRI mailing list; linux-arm
Hi Prabhakar,
Thanks for the patch.
On Sunday 26 May 2013 18:49:46 Prabhakar Lad wrote:
> From: Lad, Prabhakar
>
> add OF support for the tvp514x driver.
>
> Signed-off-by: Lad, Prabhakar
> Cc: Hans Verkuil
> Cc: Laurent Pinchart
> Cc: Mauro Carvalho Chehab
> Cc: Guennadi Liakhovetski
> C
Hi Sergei,
On Sunday 26 May 2013 18:15:19 Sergei Shtylyov wrote:
> On 26-05-2013 4:49, Laurent Pinchart wrote:
> >> From: Lad, Prabhakar
> >>
> >> Use devm_ioremap_resource instead of reques_mem_region()/ioremap().
> >> This ensures more consistent error values and simplifies error paths.
> >>
Op 28-05-13 21:18, Daniel Vetter schreef:
> On Tue, May 28, 2013 at 04:48:45PM +0200, Maarten Lankhorst wrote:
>> This stresses the lockdep code in some ways specifically useful to
>> ww_mutexes. It adds checks for most of the common locking errors.
>>
>> Changes since v1:
>> - Add tests to verify
On Tue, May 28, 2013 at 04:48:45PM +0200, Maarten Lankhorst wrote:
> This stresses the lockdep code in some ways specifically useful to
> ww_mutexes. It adds checks for most of the common locking errors.
>
> Changes since v1:
> - Add tests to verify reservation_id is untouched.
> - Use L() and U
Hi,
with Debian kernel 3.2 I had the rare problem that dvb on my Hauppauge
WinTV-HVR1300 was not always initialized properly on boot. After an upgrade
to Debian kernel 3.8 and then for testing reasons to vanilla 3.9.4 I can
reproduce this problem on every boot. This is from my dmesg output for
va
This message is generated daily by a cron job that builds media_tree for
the kernels and architectures in the list below.
Results of the daily build of media_tree:
date: Tue May 28 19:00:18 CEST 2013
git branch: test
git hash: 7eac97d7e714429f7ef1ba5d35f94c07f4c34f8e
gcc versi
Hi All,
(replying to myself, probably a bad sign... ;))
On 05/09/2013 05:36 PM, Sylwester Nawrocki wrote:
> Currently the media device link_notify callback is invoked before the
> actual change of state of a link when the link is being enabled, and
> after the actual change of state when the link
On Tue, May 28, 2013 at 4:50 PM, Inki Dae wrote:
> I think I already used reservation stuff any time in that way except
> ww-mutex. And I'm not sure that embedded system really needs ww-mutex. If
> there is any case,
> could you tell me the case? I really need more advice and understanding :)
If
Hi Hans,
On 05/27/2013 12:56 PM, Hans Verkuil wrote:
I can revert the rename action, but I would rather not do it. I
> believe there are good reasons for doing this, especially since the
> current situation is effectively broken anyway due to the missing
> firmware files.
>
> If you really don
> -Original Message-
> From: linux-fbdev-ow...@vger.kernel.org [mailto:linux-fbdev-
> ow...@vger.kernel.org] On Behalf Of Rob Clark
> Sent: Tuesday, May 28, 2013 10:49 PM
> To: Inki Dae
> Cc: Maarten Lankhorst; Daniel Vetter; linux-fbdev; YoungJun Cho; Kyungmin
> Park; myungjoo.ham; DRI m
Version 4 already?
Small api changes since v3:
- Remove ww_mutex_unlock_single and ww_mutex_lock_single.
- Rename ww_mutex_trylock_single to ww_mutex_trylock.
- Remove separate implementations of ww_mutex_lock_slow*, normal
functions can be used. Inline versions still exist for extra
debugging
Changes since RFC patch v1:
- Updated to use atomic_long instead of atomic, since the reservation_id was a
long.
- added mutex_reserve_lock_slow and mutex_reserve_lock_intr_slow
- removed mutex_locked_set_reservation_id (or w/e it was called)
Changes since RFC patch v2:
- remove use of __mutex
This stresses the lockdep code in some ways specifically useful to
ww_mutexes. It adds checks for most of the common locking errors.
Changes since v1:
- Add tests to verify reservation_id is untouched.
- Use L() and U() macros where possible.
Changes since v2:
- Use the ww_mutex api directly.
From: Daniel Vetter
Injects EDEADLK conditions at pseudo-random interval, with exponential
backoff up to UINT_MAX (to ensure that every lock operation still
completes in a reasonable time).
This way we can test the wound slowpath even for ww mutex users where
contention is never expected, and th
This will allow me to call functions that have multiple arguments if fastpath
fails.
This is required to support ticket mutexes, because they need to be able to
pass an
extra argument to the fail function.
Originally I duplicated the functions, by adding
__mutex_fastpath_lock_retval_arg.
This e
Hi Daniel,
Thank you so much. And so very useful.:) Sorry but could be give me more
comments to the below my comments? There are still things making me
confusing.:(
> -Original Message-
> From: Daniel Vetter [mailto:daniel.vet...@ffwll.ch] On Behalf Of Daniel
> Vetter
> Sent: Tuesday, M
John, thanks for the patch.
On Thu, May 23, 2013 at 5:41 PM, John Sheu wrote:
> Save flags correctly when taking spinlocks in v4l2_m2m_try_schedule.
>
> Signed-off-by: John Sheu
Acked-by: Pawel Osciak
> ---
> drivers/media/v4l2-core/v4l2-mem2mem.c | 19 +++
> 1 file changed,
Hi Sergei, Vladimir,
> > Oops, the comments about the captured image contents are my fault.
> > However, the unhandled irq after stopping capture is still an issue.
>
> Thanks for letting us know.
The good news is that your driver works fine.
The problem I saw only occurs when your patches
Hi Sheu,
Thank you for this patch. May I also ask you to add me to Cc of next mem2mem
patches, as I am the mem2mem submaintainer?
Best wishes,
--
Kamil Debski
Linux Kernel Developer
Samsung R&D Institute Poland
> -Original Message-
> From: linux-media-ow...@vger.kernel.org [mailto:linu
On Mon, May 27, 2013 at 11:56 PM, Inki Dae wrote:
>
>
>> -Original Message-
>> From: linux-fbdev-ow...@vger.kernel.org [mailto:linux-fbdev-
>> ow...@vger.kernel.org] On Behalf Of Rob Clark
>> Sent: Tuesday, May 28, 2013 12:48 AM
>> To: Inki Dae
>> Cc: Maarten Lankhorst; Daniel Vetter; linu
On Tue, May 28, 2013 at 12:56:57PM +0900, Inki Dae wrote:
>
>
> > -Original Message-
> > From: linux-fbdev-ow...@vger.kernel.org [mailto:linux-fbdev-
> > ow...@vger.kernel.org] On Behalf Of Rob Clark
> > Sent: Tuesday, May 28, 2013 12:48 AM
> > To: Inki Dae
> > Cc: Maarten Lankhorst; Dani
Hi Hans,
Passing on the actual error code was intentional.
My main goal was to give user space ability to
distinguish between the "no-lock" and "usb failure"
conditions. HDPVR firmware instability usually
manifests itself as a "usb failure", and passing
the error code on gives the application abil
Hi Sachin,
Thanks for comment.
On 05/28/2013 10:42 AM, Sachin Kamat wrote:
> Hi Andrzej,
>
> On 28 May 2013 12:56, Andrzej Hajda wrote:
>> Many debug messages missed end-of-line.
>>
>> Signed-off-by: Andrzej Hajda
>> Signed-off-by: Kyungmin Park
>> ---
>> drivers/media/platform/s5p-mfc/s5p_mf
On 05/28/2013 10:31 AM, Sachin Kamat wrote:
> Hi Andrzej,
>
> On 28 May 2013 12:56, Andrzej Hajda wrote:
>> This patch fixes a bug which caused overwriting h264 codec
>> parameters by mpeg4 parameters during V4L2 control setting.
> Just curious, what was the use case that triggered this issue?
>
F
Hi Andrzej,
On 28 May 2013 12:56, Andrzej Hajda wrote:
> Many debug messages missed end-of-line.
>
> Signed-off-by: Andrzej Hajda
> Signed-off-by: Kyungmin Park
> ---
> drivers/media/platform/s5p-mfc/s5p_mfc.c| 2 +-
> drivers/media/platform/s5p-mfc/s5p_mfc_debug.h | 4 ++--
> drive
Hi Andrzej,
On 28 May 2013 12:56, Andrzej Hajda wrote:
> This patch fixes a bug which caused overwriting h264 codec
> parameters by mpeg4 parameters during V4L2 control setting.
Just curious, what was the use case that triggered this issue?
--
With warm regards,
Sachin
--
To unsubscribe from t
The first patch fixes a bug in querystd: if there is no signal, then
querystd should return V4L2_STD_UNKNOWN. There are more drivers that
return the wrong value here, I have a patch series pending to fix that
and also to improve the spec.
The second does a code cleanup that improves readability, b
From: Hans Verkuil
Remove an unnecessary 'else' and invert a condition which makes the code
more readable.
Signed-off-by: Hans Verkuil
---
drivers/media/usb/hdpvr/hdpvr-video.c | 54 -
1 file changed, 27 insertions(+), 27 deletions(-)
diff --git a/drivers/med
From: Hans Verkuil
If no format has been detected, then querystd should return V4L2_STD_UNKNOWN,
not V4L2_STD_ALL.
Signed-off-by: Hans Verkuil
---
drivers/media/usb/hdpvr/hdpvr-video.c |2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/media/usb/hdpvr/hdpvr-video.c
From: Hans Verkuil
get_video_info() should never return EFAULT, instead it should return
the low-level usb_control_msg() error. Add a valid field to the hdpvr_video_info
struct so the driver can easily check if a valid format was detected.
Whenever get_video_info is called and it returns an erro
Many debug messages missed end-of-line.
Signed-off-by: Andrzej Hajda
Signed-off-by: Kyungmin Park
---
drivers/media/platform/s5p-mfc/s5p_mfc.c| 2 +-
drivers/media/platform/s5p-mfc/s5p_mfc_debug.h | 4 ++--
drivers/media/platform/s5p-mfc/s5p_mfc_enc.c| 16
driver
Callback .start_streaming is called once for every queue,
so v4l2_ctrl_handler_setup was called twice during stream start.
Moving v4l2_ctrl_handler_setup to context initialization
reduces numbers of calls and seems to be more consistent with API.
Signed-off-by: Andrzej Hajda
Signed-off-by: Kyungm
This patch fixes a bug which caused overwriting h264 codec
parameters by mpeg4 parameters during V4L2 control setting.
Signed-off-by: Andrzej Hajda
Signed-off-by: Kyungmin Park
---
drivers/media/platform/s5p-mfc/s5p_mfc_common.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git
Those three independent patches are fixes for s5p-mfc encoder.
The first one is a serious bug fix - some controls were not working properly.
The latter two fixes minor issues.
Regards
Andrzej Hajda
Andrzej Hajda (3):
s5p-mfc: separate encoder parameters for h264 and mpeg4
s5p-mfc: v4l2 contro
Hey,
Op 28-05-13 04:49, Inki Dae schreef:
>
>> -Original Message-
>> From: Maarten Lankhorst [mailto:maarten.lankho...@canonical.com]
>> Sent: Tuesday, May 28, 2013 12:23 AM
>> To: Inki Dae
>> Cc: 'Daniel Vetter'; 'Rob Clark'; 'linux-fbdev'; 'YoungJun Cho'; 'Kyungmin
>> Park'; 'myungjoo.ha
47 matches
Mail list logo