Hi John Sheu,
On Thu, Mar 21, 2013 at 7:30 AM, John Sheu wrote:
> Arun Kumar K samsung.com> writes:
>
>> MFC v6 needs minimum number of capture buffers to be queued
>> for encoder depending on the stream type and profile.
>> For achieving this the sequence for allocating buffers at
>> the encode
Arun Kumar K samsung.com> writes:
> MFC v6 needs minimum number of capture buffers to be queued
> for encoder depending on the stream type and profile.
> For achieving this the sequence for allocating buffers at
> the encoder is modified similar to that of decoder.
> The new sequence is as follow
On Wed, Mar 20, 2013 at 3:20 PM, Hans Verkuil wrote:
> I want to make a pull request for this. Can I have your Acked-by or do you
> want to look at this some more?
I *looked* at all the patches, and they all look fine. That said, I
haven't actually installed them at all and seen if anything got
Previously, this has been done implicitly for video device nodes by calling
set_input() (which calls audio_input() and also modified the mute
setting).
Since input and mute setting are now untangled (as much as possible), we need to
apply the mute setting with an explicit call to audio_mute().
Also
Split function audio_mux():
move the mute setting part to function audio_mute() and the input setting part
to function audio_input().
Signed-off-by: Frank Schäfer
---
drivers/media/pci/bt8xx/bttv-driver.c | 51 -
1 Datei geändert, 24 Zeilen hinzugefügt(+), 27 Ze
'audio_input' better describes the meaning of this field.
Signed-off-by: Frank Schäfer
---
drivers/media/pci/bt8xx/bttv-cards.c |2 +-
drivers/media/pci/bt8xx/bttv-driver.c | 12 ++--
drivers/media/pci/bt8xx/bttvp.h |2 +-
3 Dateien geändert, 8 Zeilen hinzugefügt(+), 8 Z
In contrast to video devices, radio devices should not be muted on the last
close of the device node.
In cases where a device provides a video and a radio device node, tuner
ownership has to be taken into account.
The current code doesn't handle tuner ownership yet, so never mute the device if
the
Instead of applying the current mute setting on last device node close, always
mute the device.
Signed-off-by: Frank Schäfer
---
drivers/media/pci/bt8xx/bttv-driver.c |2 +-
1 Datei geändert, 1 Zeile hinzugefügt(+), 1 Zeile entfernt(-)
diff --git a/drivers/media/pci/bt8xx/bttv-driver.c
b/d
Signed-off-by: Frank Schäfer
---
drivers/media/pci/bt8xx/bttv-driver.c |4 +++-
1 Datei geändert, 3 Zeilen hinzugefügt(+), 1 Zeile entfernt(-)
diff --git a/drivers/media/pci/bt8xx/bttv-driver.c
b/drivers/media/pci/bt8xx/bttv-driver.c
index 0df4a16..55eab61 100644
--- a/drivers/media/pci/bt8
Move the GPIO part of function audio_mux() to a separate function
audio_mux_gpio().
This prepares the code for the next patch which will separate mute and input
setting.
Signed-off-by: Frank Schäfer
---
drivers/media/pci/bt8xx/bttv-driver.c | 18 --
1 Datei geändert, 12 Zeilen
We can't and do not save the mute setting in function audio_mux(), so we
should also not save the input in this function for consistency.
Signed-off-by: Frank Schäfer
---
drivers/media/pci/bt8xx/bttv-driver.c | 10 +-
1 Datei geändert, 5 Zeilen hinzugefügt(+), 5 Zeilen entfernt(-)
dif
There are cases where we want to call audio_mux() without changing the value of
the v4l2 mute control, for example
- mute mute on last close
- mute on device probing
Signed-off-by: Frank Schäfer
---
drivers/media/pci/bt8xx/bttv-driver.c |8
1 Datei geändert, 4 Zeilen hinzugefügt(+),
Function audio_mux() actually deals with two types of mute: gpio mute and
subdevice muting.
This patch claryfies the meaning of these values, but mainly prepares the code
for
the next patch.
Signed-off-by: Frank Schäfer
---
drivers/media/pci/bt8xx/bttv-driver.c |8
1 Datei geändert
This patch series refactors function audio_mux() and fixes several issues
related to muting/unmuting on probing, first open and last close.
Two thirds of the changes have already been sent as part of the RFC patch series
"bttv: fix muting/unmuting on probing, first open and last close" v1 and v2,
On Tue March 12 2013 03:05:50 Devin Heitmueller wrote:
> On Mon, Mar 11, 2013 at 5:00 PM, Hans Verkuil wrote:
> > From: Hans Verkuil
> >
> > The driver crashed when the device was disconnected while an application
> > still had a device node open. Fixed by using the release() callback of
> > str
This message is generated daily by a cron job that builds media_tree for
the kernels and architectures in the list below.
Results of the daily build of media_tree:
date: Wed Mar 20 19:00:22 CET 2013
git branch: test
git hash: 72873e51c578ae29463a5d146f68881fcd0924c0
gcc versio
From: Hans Verkuil
This prepares the driver for priority and control event handling.
This patch also checks for correct streaming ownership and it makes a
small improvement to the encoder_cmd ioctls: always zero 'flags' and
drop the memset of 'raw' as that is already done by the v4l2 core.
Sign
From: Hans Verkuil
Video nodes can be used at once after registration, so make sure the full
initialization is done before registering them.
Signed-off-by: Hans Verkuil
---
drivers/media/usb/hdpvr/hdpvr-core.c | 13 +++--
1 file changed, 7 insertions(+), 6 deletions(-)
diff --git a/
From: Hans Verkuil
- return EBUSY instead of EAGAIN.
- add missing break.
- remove unnecessary buf type check (done by the core).
Signed-off-by: Hans Verkuil
---
drivers/media/usb/hdpvr/hdpvr-video.c |6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/media/usb
From: Hans Verkuil
Signed-off-by: Hans Verkuil
---
drivers/media/usb/hdpvr/hdpvr-video.c | 62 ++---
drivers/media/usb/hdpvr/hdpvr.h |5 ++-
2 files changed, 54 insertions(+), 13 deletions(-)
diff --git a/drivers/media/usb/hdpvr/hdpvr-video.c
b/drivers/
From: Hans Verkuil
Signed-off-by: Hans Verkuil
---
drivers/media/usb/hdpvr/hdpvr-video.c | 515 +
drivers/media/usb/hdpvr/hdpvr.h |8 +
2 files changed, 145 insertions(+), 378 deletions(-)
diff --git a/drivers/media/usb/hdpvr/hdpvr-video.c
b/drivers/
From: Hans Verkuil
Signed-off-by: Hans Verkuil
---
drivers/media/usb/hdpvr/hdpvr-video.c | 217 +
drivers/media/usb/hdpvr/hdpvr.h |1 +
2 files changed, 194 insertions(+), 24 deletions(-)
diff --git a/drivers/media/usb/hdpvr/hdpvr-video.c
b/drivers/m
From: Hans Verkuil
Signed-off-by: Hans Verkuil
---
drivers/media/usb/hdpvr/hdpvr-video.c | 20
1 file changed, 12 insertions(+), 8 deletions(-)
diff --git a/drivers/media/usb/hdpvr/hdpvr-video.c
b/drivers/media/usb/hdpvr/hdpvr-video.c
index 873bb23..789d808 100644
--- a
From: Hans Verkuil
This is the latest firmware version and - it seems - the most reliable.
Signed-off-by: Hans Verkuil
---
drivers/media/usb/hdpvr/hdpvr-core.c |1 +
drivers/media/usb/hdpvr/hdpvr.h |1 +
2 files changed, 2 insertions(+)
diff --git a/drivers/media/usb/hdpvr/hdpvr-
From: Hans Verkuil
Signed-off-by: Hans Verkuil
---
drivers/media/usb/hdpvr/hdpvr-video.c |6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/media/usb/hdpvr/hdpvr-video.c
b/drivers/media/usb/hdpvr/hdpvr-video.c
index 789d808..51f05d9 100644
--- a/drivers/media/
From: Hans Verkuil
These formats are supported by the HDPVR, but they were missing in the list.
Note that these formats are different from the common PAL/NTSC/SECAM formats
since all color channels are transmitted separately and so there is no PAL
or NTSC or SECAM color encoding involved.
Signed
From: Hans Verkuil
This was set to 1 << 0 which is the same as V4L2_DV_FL_REDUCED_BLANKING.
It should be 1 << 3 instead. Luckily interlaced formats are rarely used,
which is why this bug wasn't seen until now.
Signed-off-by: Hans Verkuil
---
include/uapi/linux/videodev2.h |2 +-
1 file cha
This patch series updates the hdpvr driver to the latest v4l2 frameworks
(except, as usual, vb2).
It has been tested with my hdpvr and a HDTV signal generator and it looks
pretty good. I did discover that you need the latest firmware to have the
hdpvr handle input and format switches correctly. I
This removes the dv_preset API from s5p-tv.
Tested and acked by Tomasz. Thank you very much for testing!
After this patch series is applied there should be no more users of the
DV_PRESET API and I'll post another patch series completely removing the API.
Regards,
Hans
The following cha
On 01/31/2013 07:41 PM, Sylwester Nawrocki wrote:
> From: Guennadi Liakhovetski
>
> This patch adds a document describing common OF bindings for video
> capture, output and video processing devices. It is curently mainly
> focused on video capture devices, with data busses defined by
> standards
Hi everyone,
After successful testing (after applying "use cap instead of 0" fix),
please add:
Tested-by: Tomasz Stanislawski
Acked-by: Tomasz Stanislawski
to the commit log.
Regards,
Tomasz Stanislawski
On 03/18/2013 03:24 PM, Hans Verkuil wrote:
> On Mon March 4 2013 14:02:00 Hans Verkuil w
From: Wei Yongjun
usb_free_coherent() is safe with NULL addr and this check is
not required.
Signed-off-by: Wei Yongjun
---
drivers/media/usb/gspca/gspca.c | 9 -
1 file changed, 4 insertions(+), 5 deletions(-)
diff --git a/drivers/media/usb/gspca/gspca.c b/drivers/media/usb/gspca/gsp
Dear linux-media,
I'm getting a fatal error with the "./build --main-git" command (see log
below).
Please help!
Thank you,
-Leo.
leo@ubaduba:~/ltv3$ git clone git://linuxtv.org/media_build.git
Cloning into 'media_build'...
remote: Counting objects: 1859, done.
remote: Compressing objects: 100%
Em Wed, 20 Mar 2013 11:02:13 -0300
Mauro Carvalho Chehab escreveu:
> The original az6007 driver has the code to calculate such
> stats. Add it to the driver, reporting them via DVBv5
> stats API.
There's an scale problem with this patch for S/N ratio at carrier.
Fix patch enclosed.
Regards,
Ma
Hi,
the attached patch, adds support for manual exposure control for
sensor mt9m111.
For this purpose, the register 0x009 (Shutter width) is written with
values from 0x to 0x.
In order to test this, an mt9m131 sensor was connected to a DM3730
(omap3isp). Using yavta to capture some frames,
As reported by Jean, the drxk statistics are not ok.
While we don't have enough documentation about this device, it is possible
to do better, by using what's available. In particular, the AZ6007 driver
released a few years ago by Terratec, with served as the basis for the
Kernel's driver has a ver
The original az6007 driver has the code to calculate such
stats. Add it to the driver, reporting them via DVBv5
stats API.
Signed-off-by: Mauro Carvalho Chehab
---
drivers/media/dvb-frontends/drxk_hard.c | 179 +---
drivers/media/dvb-frontends/drxk_hard.h | 2 +
dri
The stats are cleared by the frontend. Don't do it at DTV_CLEAR.
Signed-off-by: Mauro Carvalho Chehab
---
drivers/media/dvb-core/dvb_frontend.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/media/dvb-core/dvb_frontend.c
b/drivers/media/dvb-core/dvb_frontend.c
index
The AZ6007 driver released by Terratec has a better way to
estimate the signal strength, at CtrlSigStrength(). Port it
to the driver.
It should be noticed that there are two parameters there that
are tuner-specific.
Signed-off-by: Mauro Carvalho Chehab
---
drivers/media/dvb-frontends/drxk_hard.
The BER code does nothing but filling it with zero. Remove it.
Signed-off-by: Mauro Carvalho Chehab
---
drivers/media/dvb-frontends/drxk_hard.c | 16
1 file changed, 16 deletions(-)
diff --git a/drivers/media/dvb-frontends/drxk_hard.c
b/drivers/media/dvb-frontends/drxk_hard.c
The DVBv3 signal strength indicator is bogus: it doesn't range
from 0 to 65535 as it would be expected. Also, 0 means the max
signal strength.
Now that a better way to estimate it was added, use the new
way.
Signed-off-by: Mauro Carvalho Chehab
---
drivers/media/dvb-frontends/drxk_hard.c | 33 +
Last parameter of function GetLockStatus() isn't used so drop it.
Signed-off-by: Jean Delvare
Cc: Mauro Carvalho Chehab
---
drivers/media/dvb-frontends/drxk_hard.c |5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)
--- linux-3.8.orig/drivers/media/dvb-frontends/drxk_hard.c 2013
On Wednesday 20 March 2013, Fabio Porcedda wrote:
>
> On Wed, Mar 20, 2013 at 11:20 AM, Arnd Bergmann wrote:
> > On Wednesday 20 March 2013, Fabio Porcedda wrote:
> >> I think we can check inside the deferred_probe_work_func()
> >> if the dev->probe function pointer is equal to platform_drv_prob
While migrating to common clock framework (CCF), found that the FIMD clocks
were pulled down by the CCF.
If CCF finds any clock(s) which has NOT been claimed by any of the
drivers, then such clock(s) are PULLed low by CCF.
By calling clk_prepare_enable() for FIMD clocks fixes the issue.
this patc
On Wed 20 March 2013 12:11:11 edubez...@gmail.com wrote:
> Hi Hans,
>
> My last email didn't reach the list, so re-sending.
>
> On Wed, Mar 20, 2013 at 5:04 AM, Hans Verkuil wrote:
> >
> > Hi Eduardo!
> >
> > On Tue 19 March 2013 16:41:30 Eduardo Valentin wrote:
> > > Hello Mauro and Hans,
> > >
Hi Hans,
My last email didn't reach the list, so re-sending.
On Wed, Mar 20, 2013 at 5:04 AM, Hans Verkuil wrote:
>
> Hi Eduardo!
>
> On Tue 19 March 2013 16:41:30 Eduardo Valentin wrote:
> > Hello Mauro and Hans,
> >
> > Here are a couple of minor changes for si4713 FM transmitter driver.
>
> T
On Wed, Mar 20, 2013 at 11:21:48AM +0100, Hans Verkuil wrote:
> On Wed 20 March 2013 11:16:26 Jon Arne Jørgensen wrote:
> > On Wed, Mar 20, 2013 at 11:10:57AM +0100, Hans Verkuil wrote:
> > > On Wed 20 March 2013 10:48:42 Jon Arne Jørgensen wrote:
> > > > On Mon, Mar 18, 2013 at 09:29:07AM +0100, H
On Wed, Mar 20, 2013 at 11:20 AM, Arnd Bergmann wrote:
> On Wednesday 20 March 2013, Fabio Porcedda wrote:
>> I think we can check inside the deferred_probe_work_func()
>> if the dev->probe function pointer is equal to platform_drv_probe_fail().
>
> I think it's too late by then, because that wou
On Wed 20 March 2013 11:16:26 Jon Arne Jørgensen wrote:
> On Wed, Mar 20, 2013 at 11:10:57AM +0100, Hans Verkuil wrote:
> > On Wed 20 March 2013 10:48:42 Jon Arne Jørgensen wrote:
> > > On Mon, Mar 18, 2013 at 09:29:07AM +0100, Hans Verkuil wrote:
> > > > On Thu March 14 2013 15:07:00 Jon Arne Jørg
On Wednesday 20 March 2013, Fabio Porcedda wrote:
> I think we can check inside the deferred_probe_work_func()
> if the dev->probe function pointer is equal to platform_drv_probe_fail().
I think it's too late by then, because that would only warn if we try to probe
it again, but when platform_dri
On Wed, Mar 20, 2013 at 11:10:57AM +0100, Hans Verkuil wrote:
> On Wed 20 March 2013 10:48:42 Jon Arne Jørgensen wrote:
> > On Mon, Mar 18, 2013 at 09:29:07AM +0100, Hans Verkuil wrote:
> > > On Thu March 14 2013 15:07:00 Jon Arne Jørgensen wrote:
> > > > This file is responsible for registering th
On Wed 20 March 2013 10:48:42 Jon Arne Jørgensen wrote:
> On Mon, Mar 18, 2013 at 09:29:07AM +0100, Hans Verkuil wrote:
> > On Thu March 14 2013 15:07:00 Jon Arne Jørgensen wrote:
> > > This file is responsible for registering the device with the v4l2
> > > subsystem,
> > > and the communication w
On Wed 20 March 2013 11:06:36 Jon Arne Jørgensen wrote:
> On Mon, Mar 18, 2013 at 09:58:32AM +0100, Bjørn Mork wrote:
> > Hans Verkuil writes:
> >
> > >> +/*
> > >> + *
> > >> + * The device delivers data in chunks of 0x400 bytes.
> > >> + * The four first bytes is a magic header to identify the
On Wed 20 March 2013 10:43:26 Jon Arne Jørgensen wrote:
> On Mon, Mar 18, 2013 at 09:12:31AM +0100, Hans Verkuil wrote:
> > On Thu March 14 2013 15:07:00 Jon Arne Jørgensen wrote:
> > > This file is responsible for registering the device with the v4l2
> > > subsystem,
> > > and the communication w
On Sun, Mar 17, 2013 at 09:05:08PM -0300, Ezequiel Garcia wrote:
> Hi Jon,
>
> On Sun, Mar 17, 2013 at 09:01:58PM +0100, Jon Arne Jørgensen wrote:
> > On Fri, Mar 15, 2013 at 09:08:58AM -0300, Ezequiel Garcia wrote:
> > > On Thu, Mar 14, 2013 at 03:06:56PM +0100, Jon Arne Jørgensen wrote:
> > > >
On Mon, Mar 18, 2013 at 09:58:32AM +0100, Bjørn Mork wrote:
> Hans Verkuil writes:
>
> >> +/*
> >> + *
> >> + * The device delivers data in chunks of 0x400 bytes.
> >> + * The four first bytes is a magic header to identify the chunks.
> >> + *0xaa 0xaa 0x00 0x00 = saa7113 Active Video Dat
On Mon, Mar 18, 2013 at 09:29:07AM +0100, Hans Verkuil wrote:
> On Thu March 14 2013 15:07:00 Jon Arne Jørgensen wrote:
> > This file is responsible for registering the device with the v4l2 subsystem,
> > and the communication with v4l2.
> > Most of the v4l2 ioctls are just passed on to vidbuf2.
>
On Mon, Mar 18, 2013 at 09:12:31AM +0100, Hans Verkuil wrote:
> On Thu March 14 2013 15:07:00 Jon Arne Jørgensen wrote:
> > This file is responsible for registering the device with the v4l2 subsystem,
> > and the communication with v4l2.
> > Most of the v4l2 ioctls are just passed on to vidbuf2.
>
On Mon, Mar 18, 2013 at 09:04:56AM +0100, Hans Verkuil wrote:
> On Thu March 14 2013 15:06:59 Jon Arne Jørgensen wrote:
> > This file is responsible for registering the device
> > with the kernel i2c subsystem.
> > v4l2 talks to the saa7113 chip of the device via i2c.
> >
> > Signed-off-by: Jon Ar
On Mon, Mar 18, 2013 at 09:30:38AM +0100, Hans Verkuil wrote:
> On Thu March 14 2013 15:06:58 Jon Arne Jørgensen wrote:
> > This is the core of the smi2021 module.
> > It will register the module with the kernel, and register the
> > usb probe function.
> >
> > Signed-off-by: Jon Arne Jørgensen
>
On Mon, Mar 18, 2013 at 08:58:47AM +0100, Hans Verkuil wrote:
> Hi Jon Arne,
>
> Here is my review of this driver.
>
Great, thank you.
> Regards,
>
> Hans
>
> On Thu March 14 2013 15:06:58 Jon Arne Jørgensen wrote:
> > This is the core of the smi2021 module.
> > It will register the modu
Hi Eduardo!
On Tue 19 March 2013 16:41:30 Eduardo Valentin wrote:
> Hello Mauro and Hans,
>
> Here are a couple of minor changes for si4713 FM transmitter driver.
Thanks!
Patches 2-4 are fine, but I don't really see the point of the first patch
(except for the last chunk which is a real improve
On Tue, Mar 19, 2013 at 6:59 PM, Arnd Bergmann wrote:
> On Tuesday 19 March 2013, Fabio Porcedda wrote:
>> On Tue, Mar 19, 2013 at 5:48 PM, Arnd Bergmann wrote:
>> > On Tuesday 19 March 2013, Geert Uytterhoeven wrote:
>> >> Hmm, so we may have drivers that (now) work perfectly fine with
>> >> mod
On Mon, Mar 18, 2013 at 10:31:14AM +0100, Bjørn Mork wrote:
> Jon Arne Jørgensen writes:
>
> > This is the smi2021-bootloader module.
> > This module will upload the firmware for the different somagic devices.
>
> I really don't understand why you want to make that a separate module.
> Building
64 matches
Mail list logo