On Fri, Sep 15, 2023 at 01:01:23PM +0800, David Gow wrote:
> KUnit's deferred action API accepts a void(*)(void *) function pointer
> which is called when the test is exited. However, we very frequently
> want to use existing functions which accept a single pointer, but which
> may not be of type v
Hi,
On Tue, Sep 19, 2023 at 03:48:55PM -0400, Rae Moar wrote:
> On Mon, Sep 11, 2023 at 5:51 AM Maxime Ripard wrote:
> >
> > Kunit recently gained support to setup attributes, the first one being
> > the speed of a given test, then allowing to filter out slow tests.
&
inition is less clear.
Add support to the test runner to check the test execution time, and
report tests that should be marked as slow but aren't.
Signed-off-by: Maxime Ripard
---
To: Brendan Higgins
To: David Gow
Cc: Jani Nikula
Cc: Rae Moar
Cc: linux-kselftest@vger.
On Wed, Sep 20, 2023 at 10:49:03AM +0200, Maxime Ripard wrote:
> Kunit recently gained support to setup attributes, the first one being
> the speed of a given test, then allowing to filter out slow tests.
>
> A slow test is defined in the documentation as taking more than one
> sec
Hi Rae,
On Tue, Oct 24, 2023 at 03:41:33PM -0400, Rae Moar wrote:
> On Wed, Sep 20, 2023 at 4:49 AM Maxime Ripard wrote:
> >
> > Kunit recently gained support to setup attributes, the first one being
> > the speed of a given test, then allowing to filter out slow tests.
&
Hi,
On Thu, Oct 26, 2023 at 03:06:39PM +0800, David Gow wrote:
> On Wed, 20 Sept 2023 at 16:49, Maxime Ripard wrote:
> >
> > Kunit recently gained support to setup attributes, the first one being
> > the speed of a given test, then allowing to filter out slow tests.
&
inition is less clear.
Add support to the test runner to check the test execution time, and
report tests that should be marked as slow but aren't.
Signed-off-by: Maxime Ripard
---
To: Brendan Higgins
To: David Gow
Cc: Jani Nikula
Cc: Rae Moar
Cc: linux-kselftest@vger.
than hand-coding them.
>
> Let me know if you'd prefer to take these in separately via the drm
> trees, or if you're okay with having this whole series go via
> kselftest/kunit.
You can merge it through your tree with
Acked-by: Maxime Ripard
For the patches 2 and 3
Maxime
signature.asc
Description: PGP signature
t be of type void*. While this is probably dodgy enough to be on
> the wrong side of the C standard, it's been often used for similar
>
> [ ... ]
Reviewed-by: Maxime Ripard
Thanks!
Maxime
h a wrapper for drm_dev_unregister(), but it
>
> [ ... ]
Reviewed-by: Maxime Ripard
Thanks!
Maxime
Hi Dan,
On Wed, Nov 15, 2023 at 05:42:17PM -0500, Dan Carpenter wrote:
> On Mon, Nov 06, 2023 at 02:58:12PM +0100, mrip...@kernel.org wrote:
> > > But a similar thing is happening here where we have so many bogus
> > > warnings that we missed a real bug.
> >
> > IIRC, there was a similar discussi
Hi David,
Thanks a lot for working on this.
On Tue, Dec 05, 2023 at 03:31:33PM +0800, david...@google.com wrote:
> Tests for drivers often require a struct device to pass to other
> functions. While it's possible to create these with
> root_device_register(), or to use something like a platform d
Kunit recently gained helpers to create test managed devices. This means
that we no longer have to roll our own helpers in KMS and we can reuse
them.
Signed-off-by: Maxime Ripard
---
David, feel free to integrate that patch into your series and merge it
whenever and wherever you see fit
f those APIs, and can be difficult to clean up after,
> for example, a failed assertion.
>
> [ ... ]
Reviewed-by: Maxime Ripard
Thanks!
Maxime
Hi David,
On Fri, Dec 08, 2023 at 06:09:28PM +0800, david...@google.com wrote:
> KUnit tests often need to provide a struct device, and thus far have
> mostly been using root_device_register() or platform devices to create
> a 'fake device' for use with, e.g., code which uses device-managed
> reso
allocation
anymore, which creates a regression on some (downstream for now) tests.
Let's set up a default DMA mask that should work on any platform to fix
it.
Fixes: d03c720e03bd ("kunit: Add APIs for managing devices")
Signed-off-by: Maxime Ripard
---
lib/kunit/device.c | 4 +++
Hi Christian,
On Tue, Feb 20, 2024 at 04:03:57PM +0100, Christian König wrote:
> Am 20.02.24 um 15:56 schrieb Maxime Ripard:
> > On Tue, Feb 20, 2024 at 02:28:53PM +0100, Christian König wrote:
> > > [SNIP]
> > > This kunit test is not meant to be run on real hardware
On Thu, Feb 29, 2024 at 01:07:25AM +0200, Laurent Pinchart wrote:
> > Chat Discussions
> >
> >
> > For those interested in further discussions:
> >
> > **Join Our Slack Channel:**
> > We have a Slack channel, #gitlab-ci, on the KernelCI Slack instance
> > https://kernelci.slack.
Hi Helen,
Thanks for working on this
On Wed, Feb 28, 2024 at 07:55:25PM -0300, Helen Koike wrote:
> This patch introduces a `.gitlab-ci` file along with a `ci/` folder,
> defininga basic test pipeline triggered by code pushes to a GitLab-CI
> instance. This initial version includes static checks
Hi!
On Thu, Feb 29, 2024 at 11:23:22AM +0200, Nikolai Kondrashov wrote:
> Hi everyone,
>
> On 2/29/24 11:02, Maxime Ripard wrote:
> > On Wed, Feb 28, 2024 at 07:55:25PM -0300, Helen Koike wrote:
> > > Which rating would you select?
> >
> > 4.5 :)
> >
On Mon, Mar 04, 2024 at 09:12:38AM +0100, Geert Uytterhoeven wrote:
> On Sun, Mar 3, 2024 at 10:30 AM Geert Uytterhoeven
> wrote:
> > On Sun, Mar 3, 2024 at 3:30 AM Randy Dunlap wrote:
> > > On 3/2/24 14:10, Guenter Roeck wrote:
> > > > While checkpatch is indeed of arguable value, I think it wo
On Sat, Mar 02, 2024 at 02:10:51PM -0800, Guenter Roeck wrote:
> On Thu, Feb 29, 2024 at 12:21 PM Linus Torvalds
> wrote:
> >
> > On Thu, 29 Feb 2024 at 01:23, Nikolai Kondrashov wrote:
> > >
> > > However, I think a better approach would be *not* to add the
> > > .gitlab-ci.yaml
> > > file in t
On Mon, Mar 04, 2024 at 11:07:22AM +0100, Geert Uytterhoeven wrote:
> Hi Maxime,
>
> On Mon, Mar 4, 2024 at 10:15 AM Maxime Ripard wrote:
> > On Mon, Mar 04, 2024 at 09:12:38AM +0100, Geert Uytterhoeven wrote:
> > > On Sun, Mar 3, 2024 at 10:30 AM Geert Uytterhoeven
>
On Mon, Mar 04, 2024 at 12:12:47PM +0100, Geert Uytterhoeven wrote:
> Hi Maxime,
>
> On Mon, Mar 4, 2024 at 11:20 AM Maxime Ripard wrote:
> > On Mon, Mar 04, 2024 at 11:07:22AM +0100, Geert Uytterhoeven wrote:
> > > On Mon, Mar 4, 2024 at 10:15 AM Maxime Ripard wrote
On Mon, Mar 04, 2024 at 07:46:34AM -0800, Guenter Roeck wrote:
> On Mon, Mar 4, 2024 at 1:24 AM Maxime Ripard wrote:
> [ ... ]
> >
> > If anything, it's more of a side-effect to the push for COMPILE_TEST
> > than anything.
> >
>
> If the drm subsystem
On Mon, Mar 04, 2024 at 08:17:22AM -0800, Guenter Roeck wrote:
> On Mon, Mar 4, 2024 at 8:05 AM Maxime Ripard wrote:
> >
> > On Mon, Mar 04, 2024 at 07:46:34AM -0800, Guenter Roeck wrote:
> > > On Mon, Mar 4, 2024 at 1:24 AM Maxime Ripard wrote:
> > > [ ... ]
Hi Nicolas,
On Thu, Mar 07, 2024 at 01:05:12PM -0500, Nicolas Dufresne wrote:
> Le jeudi 29 février 2024 à 10:02 +0100, Maxime Ripard a écrit :
> > On Wed, Feb 28, 2024 at 07:55:25PM -0300, Helen Koike wrote:
> > > This patch introduces a `.gitlab-ci` file along w
On Thu, Mar 14, 2024 at 07:37:13AM -0700, Guenter Roeck wrote:
> On 3/14/24 06:36, Geert Uytterhoeven wrote:
> > Hi Günter,
> >
> > On Tue, Mar 12, 2024 at 6:03 PM Guenter Roeck wrote:
> > > Some unit tests intentionally trigger warning backtraces by passing bad
> > > parameters to kernel API fun
inition is less clear.
Add support to the test runner to check the test execution time, and
report tests that should be marked as slow but aren't.
Signed-off-by: Maxime Ripard
---
lib/kunit/test.c | 16
1 file changed, 16 insertions(+)
diff --git a/lib/kunit/test.c b/li
onfig=drivers/gpu/drm/tests \
--cross_compile aarch64-linux-gnu- --arch arm64
Suggested-by: David Gow
Signed-off-by: Maxime Ripard
---
drivers/gpu/drm/tests/drm_buddy_test.c | 2 +-
drivers/gpu/drm/tests/drm_mm_test.c| 14 +++---
2 files changed, 8 insertions(+), 8 deletions(-)
Hi Jani,
On Mon, Sep 11, 2023 at 01:07:35PM +0300, Jani Nikula wrote:
> On Mon, 11 Sep 2023, Maxime Ripard wrote:
> > Kunit recently gained support to setup attributes, the first one being
> > the speed of a given test, then allowing to filter out slow tests.
> >
> >
building,
1.678s running
Let me know what you think,
Maxime
Signed-off-by: Maxime Ripard
---
Maxime Ripard (2):
kunit: Warn if tests are slow
drm/tests: Flag slow tests as such
drivers/gpu/drm/tests/drm_buddy_test.c | 2 +-
drivers/gpu/drm/tests/drm_mm_test.c| 14 +++---
Hi Sima,
(For some reason, it looks like your mailer sets up the headers to reply
to every recipient but you)
On Tue, Sep 12, 2023 at 09:36:12AM +0200, Daniel Vetter wrote:
> On Mon, Sep 11, 2023 at 11:51:06AM +0200, Maxime Ripard wrote:
> > Kunit recently gained a speed attribute that
) the name, and manage it as another KUnit allocation.
>
> [ ... ]
Reviewed-by: Maxime Ripard
Thanks!
Maxime
On Thu, 18 Apr 2024 13:00:36 -0300, Wander Lairson Costa wrote:
> Hi,
>
> These two patches fix some minor error path mistakes in the device
> module.
>
>
> [ ... ]
Reviewed-by: Maxime Ripard
Thanks!
Maxime
Hi,
On Tue, Dec 10, 2024 at 11:13:32AM -0800, Brian Norris wrote:
> This is a reasonably-helpful base for generic platform_device tests, and
> I'd like to add more tests that aren't specifically about "devm"
> functions. Drop the devm namings for the suite, for clarity.
>
> Signed-off-by: Brian N
36 matches
Mail list logo