On Feb 21 2024, Benjamin Tissoires wrote:
> They are implemented as a workqueue, which means that there are no
> guarantees of timing nor ordering.
>
> Signed-off-by: Benjamin Tissoires
>
> ---
>
> changes in v3:
> - extracted the implementation in bpf_timer only, without
> bpf_timer_set_slee
>Is the declaration of klp_get_state() visible at that >point, i.e. is
>there perhaps any warning about missing >declarations above that?
>
>Otherwise C rules would default to assume an 'int' >return type.
I wasn't aware it works like that. You're right I do see some warnings about
implicit funct
On 2024/2/21 23:19, Jason Gunthorpe wrote:
On Thu, Feb 08, 2024 at 12:23:02AM -0800, Yi Liu wrote:
If a domain is used as the parent in nested translation its mappings might
be cached using DID of the nested domain. But the existing code ignores
this fact to only invalidate the iotlb entries tag
That sequence of steps fixed the warnings. Thank you so much!
Regards,
Shresth
On Tue, Dec 12, 2023 at 12:46:22PM -0800, Sagi Shahar wrote:
> From: Ackerley Tng
>
> If guest memory is backed by restricted memfd
>
> + UPM is being used, hence encrypted memory region has to be
> registered
> + Can avoid making a copy of guest memory before getting TDX to
> initialize the
On Wed, 2024-02-21 at 17:27 +0800, David Gow wrote:
> KUNIT_FAIL() is used to fail the xe_migrate test when an error
> occurs.
> However, there's a mismatch in the format specifier: '%li' is used to
> log 'err', which is an 'int'.
>
> Use '%i' instead of '%li', and for the case where we're printin
On Tue, Dec 12, 2023 at 12:46:20PM -0800, Sagi Shahar wrote:
> From: Erdem Aktas
> +/**
> + * Adds a vCPU to a TD (Trusted Domain) with minimum defaults. It will not
> set
> + * up any general purpose registers as they will be initialized by the TDX.
> In
> + * TDX, vCPUs RIP is set to 0xFFF
Cleaning up after tests is implemented separately for individual tests
and called at the end of each test execution. Since these functions are
very similar and a more generalized test framework was introduced a
function pointer in the resctrl_test struct can be used to reduce the
amount of function
Resctrl selftests use very similar functions to cleanup after
themselves. This creates a lot of code duplication. Also not being
hooked to the test framework means that ctrl-c handler isn't aware of
what test is currently running and executes all cleanups even though
only one is needed.
Add a func
Ctrl-c handler isn't aware of what test is currently running. Because of
that it executes all cleanups even if they aren't necessary. Since the
ctrl-c handler uses the sa_sigaction system no parameters can be passed
to it as function arguments.
Add a global variable to make ctrl-c handler aware of
Every test calls its cleanup function at the end of it's test function.
After the cleanup function pointer is added to the test framework this
can be simplified to executing the callback function at the end of the
generic test running function.
Make test cleanup functions static and call them from
On Thu, 22 Feb 2024, Maciej Wieczor-Retman wrote:
> Ctrl-c handler isn't aware of what test is currently running. Because of
> that it executes all cleanups even if they aren't necessary. Since the
> ctrl-c handler uses the sa_sigaction system no parameters can be passed
> to it as function argume
On Thu, 22 Feb 2024, Ilpo Järvinen wrote:
> On Thu, 22 Feb 2024, Maciej Wieczor-Retman wrote:
>
> > Ctrl-c handler isn't aware of what test is currently running. Because of
> > that it executes all cleanups even if they aren't necessary. Since the
> > ctrl-c handler uses the sa_sigaction system n
On 2024-02-22 at 12:12:44 +0200, Ilpo Järvinen wrote:
>On Thu, 22 Feb 2024, Maciej Wieczor-Retman wrote:
>
>> Ctrl-c handler isn't aware of what test is currently running. Because of
>> that it executes all cleanups even if they aren't necessary. Since the
>> ctrl-c handler uses the sa_sigaction sy
Hi Elizabeth,
On Mon, Feb 19, 2024 at 11:42 PM Elizabeth Figura
wrote:
> ntsync uses a misc device as the simplest and least intrusive uAPI interface.
>
> Each file description on the device represents an isolated NT instance,
> intended
> to correspond to a single NT virtual machine.
>
> Signed
On 1/11/24 10:48, Nina Schoetterl-Glausch wrote:
If an integer's type has x bits, shifting the integer left by x or more
is undefined behavior.
This can happen in the rotate function when attempting to do a rotation
of the whole value by 0.
Fixes: 0dd714bfd200 ("KVM: s390: selftest: memop: Add c
Benjamin Tissoires writes:
> @@ -1245,6 +1294,7 @@ BPF_CALL_3(bpf_timer_set_callback, struct
> bpf_timer_kern *, timer, void *, callb
> ret = -EPERM;
> goto out;
> }
> + down(&t->sleepable_lock);
> prev = t->prog;
> if (prev != prog) {
>
Resctrl selftests use very similar functions to cleanup after
themselves. This creates a lot of code duplication. Also not being
hooked to the test framework means that ctrl-c handler isn't aware of
what test is currently running and executes all cleanups even though
only one is needed.
Add a func
Ctrl-c handler isn't aware of what test is currently running. Because of
that it executes all cleanups even if they aren't necessary. Since the
ctrl-c handler uses the sa_sigaction system no parameters can be passed
to it as function arguments.
Add a global variable to make ctrl-c handler aware of
Cleaning up after tests is implemented separately for individual tests
and called at the end of each test execution. Since these functions are
very similar and a more generalized test framework was introduced a
function pointer in the resctrl_test struct can be used to reduce the
amount of function
Every test calls its cleanup function at the end of it's test function.
After the cleanup function pointer is added to the test framework this
can be simplified to executing the callback function at the end of the
generic test running function.
Make test cleanup functions static and call them from
On 2024/2/5 21:21, Steven Rostedt wrote:
On Mon, 5 Feb 2024 21:12:33 +0800
Yuanhe Shu wrote:
While sched* events being traced and sched* events continuously happen,
"[xx] event tracing - enable/disable with subsystem level files" would
never stop as it cat an endless output.
Select the fir
On Thu, Feb 22, 2024 at 12:49:33PM +0500, Muhammad Usama Anjum wrote:
> The config fragment doesn't follow the correct format to enable those
> config options which make the config options getting missed while
> merging with other configs.
>
> ➜ merge_config.sh -m .config tools/testing/selftests/i
On Wed, Feb 21, 2024 at 04:47:11PM -0800, Deepak Gupta wrote:
> On Tue, Feb 06, 2024 at 04:01:28PM +, Mark Brown wrote:
> > > +#define SHADOW_STACK_SET_TOKEN (1ULL << 0) /* Set up a restore token
> > > in the shadow stack */
> > For arm64 I also added a SHADOW_STACK_SET_MARKER for adding
On Wed, Feb 21, 2024 at 07:22:21PM +, Edgecombe, Rick P wrote:
> On Wed, 2024-02-21 at 14:06 -0500, dal...@libc.org wrote:
> > It's fine to turn RDSSP into an actual emulated read of the SSP, or
> > at
> > least an emulated load of zero so that uninitialized data is not left
> > in the target
On 2/21/24 02:27, David Gow wrote:
KUnit has several macros which accept a log message, which can contain
printf format specifiers. Some of these (the explicit log macros)
already use the __printf() gcc attribute to ensure the format specifiers
are valid, but those which could fail the test, and
Add new basic kselftest that checks if the available rust sample modules
can be added and removed correctly.
Signed-off-by: Laura Nao
Reviewed-by: Sergio Gonzalez Collado
Reviewed-by: Muhammad Usama Anjum
---
Changes in v2:
- Added missing SPDX line
- Edited test_probe_samples.sh script to use
On Thu, Feb 22, 2024 at 04:34:10PM +0800, Yi Liu wrote:
> > It doesn't mean that the S2 is globally shared across all the nesting
> > translations (like ARM does), and you still have to iterate over every
> > nesting DID.
> >
> > In light of that this design seems to have gone a bit off..
> >
> >
On 1/2/24 15:25, Laura Nao wrote:
> I agree factoring out the helpers might be a better solution. I sent a
> patch to move the ktap_helpers.sh file to the kselftest common
> directory, so that kselftests written in bash can make use of the helper
> functions more easily:
>
> https://lore.kernel.or
On Wed, Feb 21, 2024 at 02:26:20PM -0800, Kees Cook wrote:
> Replace deprecated 0-length array in struct bpf_lpm_trie_key with
> flexible array. Found with GCC 13:
Nope, still breaking CI. I will respin again...
https://github.com/kernel-patches/bpf/actions/runs/7996482005/job/21839056683?pr=6451
> diff --git a/tools/testing/selftests/rust/test_probe_samples.sh
> b/tools/testing/selftests/rust/test_probe_samples.sh
> new file mode 100755
> index ..6fcc2cd83d89
> --- /dev/null
> +++ b/tools/testing/selftests/rust/test_probe_samples.sh
> @@ -0,0 +1,42 @@
> +#!/bin/bash
> +# SPDX-
Replace deprecated 0-length array in struct bpf_lpm_trie_key with
flexible array. Found with GCC 13:
../kernel/bpf/lpm_trie.c:207:51: warning: array subscript i is outside array
bounds of 'const __u8[0]' {aka 'const unsigned char[]'} [-Warray-bounds=]
207 |
Add new basic kselftest that checks if the available rust sample modules
can be added and removed correctly.
Signed-off-by: Laura Nao
Reviewed-by: Sergio Gonzalez Collado
Reviewed-by: Muhammad Usama Anjum
---
Changes in v3:
- Removed useless KSFT_PASS, KSFT_FAIL, KSFT_SKIP constants
- Used ktap
On 2/22/24 16:53, Valentin Obst wrote:
>
> Aren't those constants now defined in `ktap_helpers.sh` as well, i.e.,
> could those be removed here?
>
> - Best Valentin
>
Definitely, I forgot to remove them. Thanks for the heads up!
I also noticed there's a ktap_finished function now availabl
Hi Shuah,
Could you please consider this series for inclusion?
Thank you very much.
Reinette
On 2/16/2024 12:34 AM, Maciej Wieczor-Retman wrote:
> Non-contiguous CBM support for Intel CAT has been merged into the kernel
> with Commit 0e3cd31f6e90 ("x86/resctrl: Enable non-contiguous CBMs in
> I
On Wed, Feb 21, 2024 at 10:22 PM David Gow wrote:
>
> On Thu, 22 Feb 2024 at 04:10, 'Justin Stitt' via KUnit Development
> wrote:
> >
> > Hi,
> >
> > On Wed, Feb 21, 2024 at 05:27:15PM +0800, David Gow wrote:
> > > The correct format specifier for p - n (both p and n are pointers) is
> > > %td, a
On Thu, 22 Feb 2024 at 09:36, Daniel Latypov wrote:
>
> Copying the line for context, it's about `p-r` where
> p = memchr_inv(&r[1], 0, sizeof(r) - sizeof(r[0]));
> `p-r` should never be negative unless something has gone horribly
> horribly wrong.
Sure it would - if 'p' is NULL.
Of course, th
On Thu, Feb 22, 2024 at 07:56:15AM -0800, Kees Cook wrote:
> Replace deprecated 0-length array in struct bpf_lpm_trie_key with
> flexible array. Found with GCC 13:
Yay! This finally passes all of CI:
https://patchwork.kernel.org/project/netdevbpf/patch/20240222155612.it.533-k...@kernel.org/
--
K
On Mon, Feb 19, 2024 at 11:15:57PM -0300, Thiago Jung Bauermann wrote:
> The only issue as can be seen above is that the can_call_function test
> is failing. The child is getting a GCS Segmentation fault when returning
> from fork().
> I tried debugging it with GDB, but I don't see what's wrong s
On Thursday, 22 February 2024 04:56:21 CST Geert Uytterhoeven wrote:
> > --- a/drivers/misc/Kconfig
> > +++ b/drivers/misc/Kconfig
> > @@ -506,6 +506,17 @@ config OPEN_DICE
> >
> > If unsure, say N.
> >
> > +config NTSYNC
> > + tristate "NT synchronization primitive emulation"
> > +
On Wed, 2024-02-21 at 17:25 +0100, Benjamin Tissoires wrote:
[...]
> diff --git a/drivers/hid/bpf/hid_bpf_dispatch.c
> b/drivers/hid/bpf/hid_bpf_dispatch.c
> index e630caf644e8..52abb27426f4 100644
> --- a/drivers/hid/bpf/hid_bpf_dispatch.c
> +++ b/drivers/hid/bpf/hid_bpf_dispatch.c
> @@ -143,48
On Wed, Feb 21, 2024 at 8:25 AM Benjamin Tissoires wrote:
> /* the actual struct hidden inside uapi struct bpf_timer */
> @@ -1113,6 +1120,55 @@ struct bpf_timer_kern {
> struct bpf_spin_lock lock;
> } __attribute__((aligned(8)));
>
> +static u32 __bpf_timer_compute_key(struct bpf_hrtime
On Wed, Feb 21, 2024 at 8:25 AM Benjamin Tissoires wrote:
>
> In this patch, bpf_timer_set_sleepable_cb() is functionally equivalent
> to bpf_timer_set_callback(), to the exception that it enforces
> the timer to be started with BPF_F_TIMER_SLEEPABLE.
>
> But given that bpf_timer_set_callback() is
On Wed, Feb 21, 2024 at 4:28 AM David Gow wrote:
>
> KUnit's executor_test logs the filter string in KUNIT_ASSERT_EQ_MSG(),
> but passed a random character from the filter, rather than the whole
> string.
>
> This was found by annotating KUNIT_ASSERT_EQ_MSG() to let gcc validate
> the format strin
This series fixes a bug in the complete phase of UDP in GRO, in which
socket lookup fails due to using network_header when parsing encapsulated
packets. The fix is to keep track of both outer and inner offsets.
The last commit leverages the first commit to remove some state from
napi_gro_cb, and s
Commits a602456 ("udp: Add GRO functions to UDP socket") and 57c67ff ("udp:
additional GRO support") introduce incorrect usage of {ip,ipv6}_hdr in the
complete phase of gro. The functions always return skb->network_header,
which in the case of encapsulated packets at the gro complete phase, is
alwa
Add local address bind support to existing udpgro_fwd.sh vxlan selftest, to
ensure UDP socket lookup in GRO is working.
Signed-off-by: Richard Gobert
---
tools/testing/selftests/net/udpgro_fwd.sh | 10 +++---
1 file changed, 7 insertions(+), 3 deletions(-)
diff --git a/tools/testing/selftes
{inet,ipv6}_gro_receive functions perform flush checks (ttl, flags,
iph->id, ...) against all packets in a loop. These flush checks are
relevant only to tcp flows, and as such they're used to determine whether
the packets can be merged later in tcp_gro_receive.
These checks are not relevant to UDP
On Thu, Feb 22, 2024 at 10:05 PM Richard Gobert
wrote:
>
> Commits a602456 ("udp: Add GRO functions to UDP socket") and 57c67ff ("udp:
> additional GRO support") introduce incorrect usage of {ip,ipv6}_hdr in the
> complete phase of gro. The functions always return skb->network_header,
> which in t
The MBM (Memory Bandwidth Monitoring) and MBA (Memory Bandwidth Allocation)
features are not enabled for AMD systems. The reason was lack of perf
counters to compare the resctrl test results.
Starting with the commit
25e56847821f ("perf/x86/amd/uncore: Add memory controller support"), AMD
now su
In an effort to support MBM and MBA tests for AMD, renaming for variable
and functions to generic names. For Intel, the memory controller is called
Integrated Memory Controllers (IMC). For AMD, it is called Unified
Memory Controller (UMC). No functional change.
Signed-off-by: Babu Moger
---
tool
Detect the vendor and pass the sysfs name for the vendor for searching
the controller information.
Signed-off-by: Babu Moger
---
tools/testing/selftests/resctrl/resctrl_val.c | 16 +---
1 file changed, 13 insertions(+), 3 deletions(-)
diff --git a/tools/testing/selftests/resctrl/res
Add support to read UMC (Unified Memory Controller) perf events to compare
the numbers with QoS monitor for AMD.
Signed-off-by: Babu Moger
---
.../testing/selftests/resctrl/resctrl_tests.c | 6 +-
tools/testing/selftests/resctrl/resctrl_val.c | 62 +--
2 files changed, 58 insert
Older systems do not support UMC (Unified Memory Controller) perf counters.
Skip the tests if the system does not support UMC counters.
Signed-off-by: Babu Moger
---
tools/testing/selftests/resctrl/resctrl.h | 1 +
tools/testing/selftests/resctrl/resctrl_tests.c | 10 ++
tools/tes
Add ability to parse all files within a directory. Additionally add the
ability to parse all results in the KUnit debugfs repository.
How to parse all files in directory:
./tools/testing/kunit/kunit.py parse [directory path]
How to parse KUnit debugfs repository:
./tools/testing/kunit/kunit.py
On Wed, 2024-02-21 at 17:25 +0100, Benjamin Tissoires wrote:
[...]
> @@ -1282,7 +1333,7 @@ BPF_CALL_3(bpf_timer_start, struct bpf_timer_kern *,
> timer, u64, nsecs, u64, fla
>
> if (in_nmi())
> return -EOPNOTSUPP;
> - if (flags & ~(BPF_F_TIMER_ABS | BPF_F_TIMER_CPU_PIN)
On Thu, Feb 22, 2024 at 2:18 PM Rae Moar wrote:
>
> Add ability to parse all files within a directory. Additionally add the
> ability to parse all results in the KUnit debugfs repository.
Nice, I'd been hoping for this.
It's enough to pull me back in for a bit :)
> tools/testing/kunit/kunit.p
On Fri, Feb 16, 2024 at 05:05:54PM -0800, Stephen Boyd wrote:
> Call this function unconditionally so that we can populate an empty DTB
> on platforms that don't boot with a firmware provided or builtin DTB.
> When ACPI is in use, unflatten_device_tree() ignores the
> 'initial_boot_params' pointer
On Wed, 2024-02-21 at 17:25 +0100, Benjamin Tissoires wrote:
[...]
> diff --git a/kernel/bpf/verifier.c b/kernel/bpf/verifier.c
> index f81c799b2c80..2b11687063ff 100644
> --- a/kernel/bpf/verifier.c
> +++ b/kernel/bpf/verifier.c
> @@ -5444,6 +5444,26 @@ static int check_map_access(struct bpf_ver
On Fri, 2024-02-23 at 02:22 +0200, Eduard Zingerman wrote:
[...]
> > + case BPF_TIMER:
> > + /* FIXME: kptr does the above, should we use
> > the same? */
[...]
> I tried the following simple program and it verifies fine:
Sorry, I meant that I tried
Hi Sagi,
On 2023-12-12 at 12:46:23 -0800, Sagi Shahar wrote:
> From: Erdem Aktas
>
> Adding a test to verify TDX lifecycle by creating a TD and running a
> dummy TDG.VP.VMCALL inside it.
>
> Signed-off-by: Erdem Aktas
> Signed-off-by: Ryan Afranji
> Signed-off-by: Sagi Shahar
> Co-developed
On Wed, Feb 21, 2024 at 8:25 AM Benjamin Tissoires wrote:
> @@ -18193,7 +18198,7 @@ static int resolve_pseudo_ldimm64(struct
> bpf_verifier_env *env)
> return -E2BIG;
> }
>
> - if (env->prog->aux->sleepable)
> +
Mark Brown writes:
> On Mon, Feb 19, 2024 at 11:15:57PM -0300, Thiago Jung Bauermann wrote:
>
>> The only issue as can be seen above is that the can_call_function test
>> is failing. The child is getting a GCS Segmentation fault when returning
>> from fork().
>
>> I tried debugging it with GDB,
On Wed, Feb 21, 2024 at 09:29:47AM -0300, Marcos Paulo de Souza wrote:
> On Mon, 19 Feb 2024 15:16:51 +0800 kernel test robot wrote:
>
> > Hi Marcos,
> >
> > kernel test robot noticed the following build warnings:
> >
> > [auto build test WARNING on 345e8abe4c355bc24bab3f4a5634122e55be8665]
> >
tree/branch:
https://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git master
branch HEAD: e31185ce00a9623230838db193416ceb9769 Add linux-next specific
files for 20240222
Error/Warning reports:
https://lore.kernel.org/oe-kbuild-all/20240223.h9rfmyj4-...@intel.com
https
65 matches
Mail list logo