On 30/11/2023 04:01, Hangbin Liu wrote:
Here is the test result after conversion.
]# ./l2tp.sh
TEST: IPv4 basic L2TP tunnel[ OK ]
TEST: IPv4 route through L2TP tunnel[ OK ]
TEST: IPv6 basic L2TP tunnel
Hangbin Liu writes:
> Add a lib.sh for net selftests. This file can be used to define commonly
> used variables and functions. Some commonly used functions can be moved
> from forwarding/lib.sh to this lib file. e.g. busywait().
>
> Add function setup_ns() for user to create unique namespaces w
On 11/30/23 05:01, Hangbin Liu wrote:
Here is the test result after conversion.
]# ./ioam6.sh
--
OUTPUT tests
--
TEST: Unknown IOAM namespace (inline m
Humble ping :)
On Tue, Oct 31, 2023 at 06:10:50PM -0300, Marcos Paulo de Souza wrote:
> This patchset moves the current kernel testing livepatch modules from
> lib/livepatches to tools/testing/selftest/livepatch/test_modules, and compiles
> them as out-of-tree modules before testing.
>
> There is
On 11/29/23 07:54, Meng Li wrote:
Hi all:
The core frequency is subjected to the process variation in semiconductors.
Not all cores are able to reach the maximum frequency respecting the
infrastructure limits. Consequently, AMD has redefined the concept of
maximum frequency of a part. This me
On Fri, 24 Nov 2023 16:34:51 +,
Joey Gouly wrote:
>
> Define the new system registers that POE introduces and context switch them.
Thinking about it some more, I don't think this is enough.
One fundamental thing that POE changes is that read permissions can
now be removed from S1 by the gue
This series expands XDP TX metadata framework to include HW launch time offload.
Song Yoong Siang (3):
xsk: add launch time support to XDP Tx metadata
net: stmmac: Add launch time support to XDP ZC
selftests/bpf: Add launch time to xdp_hw_metadata
Documentation/netlink/specs/netdev.yaml
This patch extends the XDP Tx metadata framework to include Time-Based
Scheduling (TBS) support where the NIC will schedule a packet for
transmission at a pre-determined time called launch time. The value of
launch time is communicated from user space to Ethernet driver via
launch_time field of str
This patch enables launch time support to XDP zero copy via XDP Tx
metadata framework.
Signed-off-by: Song Yoong Siang
---
drivers/net/ethernet/stmicro/stmmac/stmmac.h | 2 ++
drivers/net/ethernet/stmicro/stmmac/stmmac_main.c | 13 +
2 files changed, 15 insertions(+)
diff --gi
This patch adds launch time support to xdp_hw_metadata. User can configure
the delta of HW launch time to HW RX-time by using "-l" argument.
This patch is tested with stmmac on Intel Tiger Lake platform. Refer to
result below, the delta between pre-determined launch time and actual
transmit time i
Hi Linus,
Please pull the following KUnit fixes update for Linux 6.7-rc4.
This KUnit fixes update for Linux 6.7-rc4 consists of three fixes to
warnings and run-time test behavior. With these fixes, test suite
counter will be reset correctly before running tests, kunit will warn
if tests are too
Hi Mark,
Thanks for putting this together and sorry it took me some time to catch
up (well, still not fully, so rather more questions below).
On Tue, Nov 28, 2023 at 06:22:38PM +, Mark Brown wrote:
> Since clone3() is readily extensible let's add support for specifying a
> shadow stack when c
Changelog:
v8:
* Fixed a couple of build errors in the case of !CONFIG_MEMCG
* Simplified the online memcg selection scheme for the zswap global
limit reclaim (suggested by Michal Hocko and Johannes Weiner)
(patch 2 and patch 3)
* Added a new kconfig to allows users to enable zsw
The interface of list_lru is based on the assumption that the list node
and the data it represents belong to the same allocated on the correct
node/memcg. While this assumption is valid for existing slab objects LRU
such as dentries and inodes, it is undocumented, and rather inflexible
for certain
This patch implements a helper function that try to get a reference to
an memcg's css, as well as checking if it is online. This new function
is almost exactly the same as the existing mem_cgroup_tryget(), except
for the onlineness check. In the !CONFIG_MEMCG case, it always returns
true, analogous
From: Domenico Cerasuolo
The memcg-zswap self test is updated to adjust to the behavior change
implemented by commit 87730b165089 ("zswap: make shrinking memcg-aware"),
where zswap performs writeback for specific memcg.
Signed-off-by: Domenico Cerasuolo
Signed-off-by: Nhat Pham
---
tools/test
From: Domenico Cerasuolo
Since zswap now writes back pages from memcg-specific LRUs, we now need a
new stat to show writebacks count for each memcg.
Suggested-by: Nhat Pham
Signed-off-by: Domenico Cerasuolo
Signed-off-by: Nhat Pham
---
include/linux/vm_event_item.h | 1 +
mm/memcontrol.c
Currently, we only shrink the zswap pool when the user-defined limit is
hit. This means that if we set the limit too high, cold data that are
unlikely to be used again will reside in the pool, wasting precious
memory. It is hard to predict how much zswap space will be needed ahead
of time, as this
From: Domenico Cerasuolo
Currently, we only have a single global LRU for zswap. This makes it
impossible to perform worload-specific shrinking - an memcg cannot
determine which pages in the pool it owns, and often ends up writing
pages from other memcgs. This issue has been previously observed in
On Thu, Nov 30, 2023 at 11:40:18AM -0800, Nhat Pham wrote:
> This patch changes list_lru interface so that the caller must explicitly
> specify numa node and memcg when adding and removing objects. The old
> list_lru_add() and list_lru_del() are renamed to list_lru_add_obj() and
> list_lru_del_obj(
On Thu, Nov 30, 2023 at 11:57 AM Matthew Wilcox wrote:
>
> On Thu, Nov 30, 2023 at 11:40:18AM -0800, Nhat Pham wrote:
> > This patch changes list_lru interface so that the caller must explicitly
> > specify numa node and memcg when adding and removing objects. The old
> > list_lru_add() and list_l
On 11/28/23 20:45, angquan yu wrote:
From: angquan yu
In tools/testing/selftests/proc/proc-empty->because the return value
of a write call was being ignored. This call was partof a conditional
debugging block (if (0) { ... }), which meant it would neveractually
execute.
This patch removes the
Song Yoong Siang wrote:
> This patch extends the XDP Tx metadata framework to include Time-Based
> Scheduling (TBS) support where the NIC will schedule a packet for
> transmission at a pre-determined time called launch time. The value of
> launch time is communicated from user space to Ethernet dri
On Thu, Nov 30, 2023 at 12:07:41PM -0800, Nhat Pham wrote:
> On Thu, Nov 30, 2023 at 11:57 AM Matthew Wilcox wrote:
> >
> > On Thu, Nov 30, 2023 at 11:40:18AM -0800, Nhat Pham wrote:
> > > This patch changes list_lru interface so that the caller must explicitly
> > > specify numa node and memcg wh
On Wed, Nov 29, 2023 at 08:08:16PM -0400, Jason Gunthorpe wrote:
> On Wed, Nov 29, 2023 at 02:07:58PM -0800, Nicolin Chen wrote:
> > On Wed, Nov 29, 2023 at 03:58:04PM -0400, Jason Gunthorpe wrote:
> > > On Tue, Nov 28, 2023 at 05:09:07PM -0800, Nicolin Chen wrote:
> > >
> > > > > > With that bein
On Mon, Oct 30, 2023 at 6:47 AM Richard Fitzgerald
wrote:
>
> Check the stream pointer passed to string_stream_destroy() for
> IS_ERR_OR_NULL() instead of only NULL.
>
> Whatever alloc_string_stream() returns should be safe to pass
> to string_stream_destroy(), and that will be an ERR_PTR.
>
> It'
On Wed, Nov 29, 2023 at 11:02 PM Hangbin Liu wrote:
>
> Here is the test result after conversion.
>
> ]# ./sctp_vrf.sh
> Testing For SCTP VRF:
> TEST 01: nobind, connect from client 1, l3mdev_accept=1, Y [PASS]
> ...
> TEST 12: bind vrf-2 & 1 in server, connect from client 1 & 2, N [PASS]
> ***v6
On Mon, Oct 30, 2023 at 6:48 AM Richard Fitzgerald
wrote:
>
> Move the call to kunit_suite_has_succeeded() after the check that
> the kunit_suite pointer is valid.
>
> This was found by smatch:
>
> lib/kunit/debugfs.c:66 debugfs_print_results() warn: variable
> dereferenced before check 'suite'
On Mon, Oct 30, 2023 at 6:47 AM Richard Fitzgerald
wrote:
>
> In kunit_debugfs_create_suite() give up and skip creating the debugfs
> file if any of the alloc_string_stream() calls return an error or NULL.
> Only put a value in the log pointer of kunit_suite and kunit_test if it
> is a valid point
On Thu, 30 Nov 2023 11:40:17 -0800 Nhat Pham wrote:
> This patch series solves these issues by separating the global zswap
> LRU into per-memcg and per-NUMA LRUs, and performs workload-specific
> (i.e memcg- and NUMA-aware) zswap writeback under memory pressure.
Thanks, I've updated mm-unstable
On 11/28/23 14:48, angquan yu wrote:
From: angquan yu
In the function 'tools/testing/selftests/breakpoints/run_test' within
step_after_suspend_test.c, the ksft_print_msg function call incorrectly
used '$s' as a format specifier. This commit corrects this typo to use the
proper '%s' format speci
On 11/28/23 20:57, angquan yu wrote:
From: angquan yu
This commit resolves a compiler warning regardingthe
use of non-literal format strings in breakpoint_test.c.
The functions `ksft_test_result_pass` and `ksft_test_result_fail`
were previously called with a variable `msg` directly, which coul
On Thu, Nov 30, 2023 at 07:00:58PM +, Catalin Marinas wrote:
> My hope when looking at the arm64 patches was that we can completely
> avoid the kernel allocation/deallocation of the shadow stack since it
> doesn't need to do this for the normal stack either. Could someone
> please summarise wh
On 11/23/23 03:45, Mark Brown wrote:
These patches update the output of the vdso_test_abi test program to
bring it into line with expected KTAP usage, the main one being the
first patch which ensures we log distinct test names for each reported
result making it much easier for automated systems t
On Thu, 30 Nov 2023 02:36:43 + SeongJae Park wrote:
> The core logic uses the below simple feedback loop algorithm to
> calculate the next aggressiveness level of the scheme from the current
> aggressiveness level and the current feedback (target_score and
> current_score). It calculates the
On 10/31/23 15:10, Marcos Paulo de Souza wrote:
The test proves that a syscall can be livepatched. It is interesting
because syscalls are called a tricky way. Also the process gets
livepatched either when sleeping in the userspace or when entering
or leaving the kernel space.
The livepatch is a
On 11/11/23 12:23, Osama Muhammad wrote:
Signed-off-by: Osama Muhammad
---
.../selftests/prctl/set-process-name.c| 32 +++
1 file changed, 32 insertions(+)
Applied to linux-kselftest next for Linux 6.8-rc1.
thanks,
-- Shuah
On Thu, 2023-11-30 at 21:51 +, Mark Brown wrote:
> On Thu, Nov 30, 2023 at 07:00:58PM +, Catalin Marinas wrote:
>
> > My hope when looking at the arm64 patches was that we can
> > completely
> > avoid the kernel allocation/deallocation of the shadow stack since
> > it
> > doesn't need to d
On 11/11/23 10:38, Swarup Laxman Kotiaklapudi wrote:
This patchset fixes TODO:
"If we're already root, we could skip creating the userns."
Change namespace creation for root and non-root
user differently in create_and_enter_ns() function
in this file:
tools/testing/selftests/capabilities/test_ex
On 11/6/23 11:11, Atul Kumar Pant wrote:
Fixes following checkpatch.pl issues:
ERROR: do not use assignment in if condition
ERROR: Macros starting with if should be enclosed by a do - while
Signed-off-by: Atul Kumar Pant
---
tools/testing/selftests/cgroup/cgroup_util.c | 14 --
t
On Friday, December 1, 2023 4:29 AM, Willem de Bruijn wrote:
>Song Yoong Siang wrote:
>> This patch extends the XDP Tx metadata framework to include Time-Based
>> Scheduling (TBS) support where the NIC will schedule a packet for
>> transmission at a pre-determined time called launch time. The value
On Thu, Nov 30, 2023 at 12:41:20PM -0800, Nicolin Chen wrote:
> > So userspace would have to read the event FD
> > before returning to be correct?
> >
> > Maybe the kernel can somehow return a flag to indicate the event fd
> > has data in it?
> >
> > If yes then all errors would flow through the
On Mon, 30 Oct 2023 at 18:47, Richard Fitzgerald
wrote:
>
> Check the stream pointer passed to string_stream_destroy() for
> IS_ERR_OR_NULL() instead of only NULL.
>
> Whatever alloc_string_stream() returns should be safe to pass
> to string_stream_destroy(), and that will be an ERR_PTR.
>
> It's
On Mon, 30 Oct 2023 at 18:47, Richard Fitzgerald
wrote:
>
> In kunit_debugfs_create_suite() give up and skip creating the debugfs
> file if any of the alloc_string_stream() calls return an error or NULL.
> Only put a value in the log pointer of kunit_suite and kunit_test if it
> is a valid pointer
On 2023/11/29 08:57, Jason Gunthorpe wrote:
On Tue, Nov 28, 2023 at 04:51:21PM -0800, Nicolin Chen wrote:
I also thought about making this out_driver_error_code per HW.
Yet, an error can be either per array or per entry/quest. The
array-related error should be reported in the array structure
tha
On Thu, Nov 30, 2023 at 08:45:23PM -0400, Jason Gunthorpe wrote:
> On Thu, Nov 30, 2023 at 12:41:20PM -0800, Nicolin Chen wrote:
>
> > > So userspace would have to read the event FD
> > > before returning to be correct?
> > >
> > > Maybe the kernel can somehow return a flag to indicate the event
On Fri, Dec 01, 2023 at 11:51:26AM +0800, Yi Liu wrote:
> On 2023/11/29 08:57, Jason Gunthorpe wrote:
> > On Tue, Nov 28, 2023 at 04:51:21PM -0800, Nicolin Chen wrote:
> > > > > I also thought about making this out_driver_error_code per HW.
> > > > > Yet, an error can be either per array or per ent
> From: Nicolin Chen
> Sent: Friday, December 1, 2023 12:50 PM
>
> On Fri, Dec 01, 2023 at 11:51:26AM +0800, Yi Liu wrote:
> > On 2023/11/29 08:57, Jason Gunthorpe wrote:
> > > On Tue, Nov 28, 2023 at 04:51:21PM -0800, Nicolin Chen wrote:
> > > > > > I also thought about making this out_driver_er
The pull request you sent on Thu, 30 Nov 2023 09:58:39 -0700:
> git://git.kernel.org/pub/scm/linux/kernel/git/shuah/linux-kselftest
> tags/linux_kselftest-kunit-fixes-6.7-rc4
has been merged into torvalds/linux.git:
https://git.kernel.org/torvalds/c/47669f40b14c32c9771e0852f7cd3a12eb044c2f
Than
kselftest/next build: 6 builds: 0 failed, 6 passed, 1 warning
(v6.7-rc1-9-g130a83879954a)
Full Build Summary:
https://kernelci.org/build/kselftest/branch/next/kernel/v6.7-rc1-9-g130a83879954a/
Tree: kselftest
Branch: next
Git Describe: v6.7-rc1-9-g130a83879954a
Git Commit: 130a83879954a9fed35cf
On Wed, Nov 29, 2023 at 04:24:27PM +0100, Benjamin Tissoires wrote:
> vmtest.sh works great for a one shot test, but not so much for CI where
> I want to build (with different configs) the bzImage in a separate
> job than the one I am running it.
>
> Add a "build_only" option to specify whether we
On Wed, Nov 29, 2023 at 04:24:34PM +0100, Benjamin Tissoires wrote:
> Turns out that there are transitions that are unlikely to happen:
> for example, having both the tip switch and a button being changed
> at the same time (in the same report) would require either a very talented
> and precise use
On Wed, Nov 29, 2023 at 04:24:37PM +0100, Benjamin Tissoires wrote:
> To accommodate for legacy devices, we rely on the last state of a
> transition to be valid:
> for example when we test PEN_IS_OUT_OF_RANGE to PEN_IS_IN_CONTACT,
> any "normal" device that reports an InRange bit would insert a
> P
On Thu, Nov 30, 2023 at 12:01 PM Hangbin Liu wrote:
>
> Add a lib.sh for net selftests. This file can be used to define commonly
> used variables and functions. Some commonly used functions can be moved
> from forwarding/lib.sh to this lib file. e.g. busywait().
>
> Add function setup_ns() for use
On Fri, Dec 01, 2023 at 01:56:51PM +0800, Po-Hsu Lin wrote:
> > +# setup netns with given names as prefix. e.g
> > +# setup_ns local remote
> > +setup_ns()
> > +{
> > + local ns=""
> > + local ns_name=""
> > + local ns_list=""
> > + for ns_name in "$@"; do
> > +
This series expands XDP TX metadata framework to include ETF HW offload.
Changes since v1:
- rename Time-Based Scheduling (TBS) to Earliest TxTime First (ETF)
- rename launch-time to txtime
v1:
https://patchwork.kernel.org/project/netdevbpf/cover/20231130162028.852006-1-yoong.siang.s...@intel.co
This patch extends the XDP Tx metadata framework to include Earliest
TxTime First (ETF) HW offload support where the NIC will schedule the
packet for transmission at a pre-determined time called txtime. The value
of txtime is communicated from user space to Ethernet driver via txtime
field of struc
This patch enables txtime support to XDP zero copy via XDP Tx
metadata framework.
Signed-off-by: Song Yoong Siang
---
drivers/net/ethernet/stmicro/stmmac/stmmac.h | 2 ++
drivers/net/ethernet/stmicro/stmmac/stmmac_main.c | 13 +
2 files changed, 15 insertions(+)
diff --git a/d
This patch adds txtime support to xdp_hw_metadata. User can configure the
delta of HW txtime to HW RX-time by using "-l" argument. The default delta
is set to 1 second.
This patch is tested with stmmac on Intel Tiger Lake platform. Refer to
result below, the delta between pre-determined ETF txtime
On Thu, Nov 30, 2023 at 02:28:51PM +0100, Justin Iurman wrote:
> On 11/30/23 05:01, Hangbin Liu wrote:
> > Here is the test result after conversion.
> >
> > ]# ./ioam6.sh
> >
> > --
> > OUTPUT tests
> > --
On 2023/12/1 13:19, Tian, Kevin wrote:
From: Nicolin Chen
Sent: Friday, December 1, 2023 12:50 PM
On Fri, Dec 01, 2023 at 11:51:26AM +0800, Yi Liu wrote:
On 2023/11/29 08:57, Jason Gunthorpe wrote:
On Tue, Nov 28, 2023 at 04:51:21PM -0800, Nicolin Chen wrote:
I also thought about making this
> From: Liu, Yi L
> Sent: Friday, December 1, 2023 3:05 PM
>
> On 2023/12/1 13:19, Tian, Kevin wrote:
> >> From: Nicolin Chen
> >> Sent: Friday, December 1, 2023 12:50 PM
> >>
> >> On Fri, Dec 01, 2023 at 11:51:26AM +0800, Yi Liu wrote:
> >>> On 2023/11/29 08:57, Jason Gunthorpe wrote:
> On
On Wed, 29 Nov 2023 19:24:22 -0300 Pedro Tammela wrote:
> Patchwork CI didn't like the extra './', so remove it.
Thanks!
Hello:
This series was applied to netdev/net-next.git (main)
by Jakub Kicinski :
On Wed, 29 Nov 2023 19:24:20 -0300 you wrote:
> Follow-up on a feedback from Jakub and random cleanups from related
> net/sched patches
>
> Pedro Tammela (4):
> selftests: tc-testing: remove spurious nsPlugin usag
On Thu, Nov 30, 2023 at 04:11:18PM -0500, Rae Moar wrote:
> > + stream = alloc_string_stream(GFP_KERNEL);
> > + if (IS_ERR_OR_NULL(stream))
>
> In response to Dan Carpenter's comment from the last version, I see
> the benefits of changing IS_ERR_OR_NULL() to IS_ERR() instead because
>
65 matches
Mail list logo