ned-off-by: Martin Peschke
Cc: sta...@vger.kernel.org #2.6.35+
Cc: Andrew Morton
Cc: David Howells
Cc: Jens Axboe
Cc: "Paul E. McKenney"
Cc: Daniel Vetter
Cc: linux-kernel@vger.kernel.org
Signed-off-by: Steffen Maier
---
drivers/s390/scsi/zfcp_qdio.c |
ned-off-by: Martin Peschke
Cc: sta...@vger.kernel.org #2.6.35+
Cc: Andrew Morton
Cc: David Howells
Cc: Jens Axboe
Cc: "Paul E. McKenney"
Cc: Daniel Vetter
Cc: linux-kernel@vger.kernel.org
Signed-off-by: Steffen Maier
---
drivers/s390/scsi/zfcp_qdio.c |
Hi Julia,
sorry for the long delay until I finally responded.
Thanks a lot for your report and patch.
I'll queue this and send it for v3.6rcX hopefully soon.
On 07/08/2012 01:37 PM, Julia Lawall wrote:
> From: Julia Lawall
>
> If list_for_each_entry, etc complete a traversal of the list, the ite
ance user friendlyness by
* introduction of a procfs interface.
*
* Linux kernel module for Linux version 2.6.
*
* (c) 2007 Steffen Maier <[EMAIL PROTECTED]>
*
* This program is free software; you can redistribute it and/or modify
* it under the terms of the GNU General Public License as pu
ck: make unplug timer trace
event correspond to the schedule() unplug") and commit d9c978331790
("block: remove block_unplug_timer() trace point").
Signed-off-by: Steffen Maier
---
include/trace/events/block.h | 10 +-
1 file changed, 9 insertions(+), 1 deletion(-)
dif
r check for q->kobj.parent is certainly racy and
I don't have enough experience if it's good enough for a trace event.
Since I don't know when above cases would occur,
I'm not sure this is worth it.
Signed-off-by: Steffen Maier
---
include/trace/events/block.h | 12 +---
8,81 17 0.000238527 240240 D R 2048 + 32 [dd]
8,81 22 0.000613741 0 C R 2048 + 32 [0]
Signed-off-by: Steffen Maier
---
include/trace/events/block.h | 13 +++--
1 file changed, 11 insertions(+), 2 deletions(-)
diff --git a/include/trace/events/b
.
Steffen Maier (3):
tracing/events: block: track and print if unplug was explicit or
schedule
tracing/events: block: dev_t via driver core for plug and unplug
events
tracing/events: block: also try to get dev_t via driver core for some
events
include/trace/events/block.h | 33
+ mempool_destroy(adapter->pool.scsi_abort);
+ mempool_destroy(adapter->pool.qtcb_pool);
+ mempool_destroy(adapter->pool.status_read_req);
+ mempool_destroy(adapter->pool.sr_data);
+ mempool_destroy(adapter->pool.gid_pn);
}
/**
--
Mit freundlichen Gruesse
(host_byte(result)) {
+ case DID_OK:
+ return BLK_STS_OK;
case DID_TRANSPORT_FAILFAST:
return BLK_STS_TRANSPORT;
case DID_TARGET_FAILURE:
--
Mit freundlichen Gruessen / Kind regards
Steffen Maier
Linux on IBM Z Development
IBM Deutschland Rese
int result)
{
switch (host_byte(result)) {
+ case DID_OK:
+ return BLK_STS_OK;
case DID_TRANSPORT_FAILFAST:
return BLK_STS_TRANSPORT;
case DID_TARGET_FAILURE:
--
Mit freundlichen Gruessen / Kind regards
Steffen
move location works for me, too. After all, the kdoc of
device_unregister explicitly mentions the possibility that other refs might
continue to exist after device_unregister was called:
device_register() --+
get_device() -|--+
device_unregister() --+ |
pu
;
--
Mit freundlichen Gruessen / Kind regards
Steffen Maier
Linux on IBM Z Development
https://www.ibm.com/privacy/us/en/
IBM Deutschland Research & Development GmbH
Vorsitzender des Aufsichtsrats: Matthias Hartmann
Geschaeftsfuehrung: Dirk Wittkopp
Sitz der Gesellschaft: Boebli
ut_device(&port->dev);
return -ENXIO; [1]
}
}
if (ret) {
/*
* if LLDD reports slave not present, don't clutter
* console with alloc failure messages
*/
if (ret == -ENXIO)
On 10/14/2013 03:32 PM, Hannes Reinecke wrote:
On 10/14/2013 03:18 PM, Hannes Reinecke wrote:
On 10/14/2013 02:51 PM, Steffen Maier wrote:
On 10/14/2013 01:13 PM, Hannes Reinecke wrote:
On 10/13/2013 07:23 PM, Vaughan Cao wrote:
[1.] One line summary of the problem:
special sense code asc
it though,
Acked-by: Steffen Maier
- strncpy(busid, token, ZFCP_BUS_ID_SIZE);
+ strlcpy(busid, token, ZFCP_BUS_ID_SIZE);
token = strsep(&str, ",");
if (!token || kstrtoull(token, 0, (unsigned long long *) &wwpn))
--
Mit freundlichen Grüßen / Kind
for the zfcp part:
Acked-by: Steffen Maier
On 03/08/2015 04:19 AM, David Rientjes wrote:
Allocating a large number of elements in atomic context could quickly
deplete memory reserves, so just disallow atomic resizing entirely.
Nothing currently uses mempool_resize() with anything other than
unt;
-}
-
-/**
* zfcp_qdio_real_bytes - count bytes used
* @sg: pointer to struct scatterlist
*/
--
Mit freundlichen Grüßen / Kind regards
Steffen Maier
Linux on z Systems Development
IBM Deutschland Research & Development GmbH
Vorsitzende des Aufsichtsrats: Martina Koederitz
Geschaeftsf
t_device(&sdkp->dev);
}
/**
--
Mit freundlichen Gruessen / Kind regards
Steffen Maier
Linux on IBM Z Development
https://www.ibm.com/privacy/us/en/
IBM Deutschland Research & Development GmbH
Vorsitzender des Aufsichtsrats: Matthias Hartmann
Geschaeftsfuehrung: Dirk Wittkopp
Sitz der Gesellschaft: Boeblingen
Registergericht: Amtsgericht Stuttgart, HRB 243294
_segment_size = UINT_MAX;
}
EXPORT_SYMBOL(blk_queue_virt_boundary);
Wild guess: Do we need to make the call to blk_queue_virt_boundary()
conditional?
Cf. https://www.spinics.net/lists/linux-scsi/msg131077.html ("[PATCH v2] iser:
explicitly set shost max_segment_size if non virt
impse with zfcp)
--
Mit freundlichen Gruessen / Kind regards
Steffen Maier
Linux on IBM Z Development
https://www.ibm.com/privacy/us/en/
IBM Deutschland Research & Development GmbH
Vorsitzender des Aufsichtsrats: Matthias Hartmann
Geschaeftsfuehrung: Dirk Wittkopp
Sitz der Gesellschaft: Boeblin
Complements previous ("s390: include/asm/debug.h add kerneldoc markups")
which seemed to have dropped important non-kdoc parts such as
user space interface (level, size, flush)
as well as views and caution regarding strings in the sprintf view.
Signed-off-by: Steffen Maier
---
Doc
msg24691.html
("[PATCH v2 1/2] tracing/events: block: track and print if unplug was
explicit or schedule")
--
Mit freundlichen Grüßen / Kind regards
Steffen Maier
Linux on z Systems Development
IBM Deutschland Research & Development GmbH
Vorsitzende des Aufsichtsrats: Martina Koederi
d format'')
v2.6.31 commit f3948f8857ef (``blktrace: fix context-info when
mixed-using blk tracer and trace events'')
--
Mit freundlichen Grüßen / Kind regards
Steffen Maier
Linux on z Systems Development
IBM Deutschland Research & Development GmbH
Vorsitzende des Aufs
et) {
> mutex_unlock(&q->sysfs_lock);
> kobject_uevent(&q->kobj, KOBJ_REMOVE);
> kobject_del(&q->kobj);
> blk_trace_remove_sysfs(dev);
> kobject_put(&de
r check for q->kobj.parent is certainly racy and
I don't have enough experience if it's good enough for a trace event.
Since I don't know when above cases would occur,
I'm not sure this is worth it.
Signed-off-by: Steffen Maier
---
include/trace/events/block.h | 12 +---
ck: make unplug timer trace
event correspond to the schedule() unplug") and commit d9c978331790
("block: remove block_unplug_timer() trace point").
Signed-off-by: Steffen Maier
---
Changes since v1:
Use 0 and 1 instead of false and true for __print_symbolic table.
Now "trace
.
Changes since v1:
[PATCH v2 1/2]
Use 0 and 1 instead of false and true for __print_symbolic table.
Now "trace-cmd report" can decode it. [Steven Rostedt]
Steffen Maier (3):
tracing/events: block: track and print if unplug was explicit or
schedule
tracing/events: block: dev_t via drive
8,81 17 0.000238527 240240 D R 2048 + 32 [dd]
8,81 22 0.000613741 0 C R 2048 + 32 [0]
Signed-off-by: Steffen Maier
---
include/trace/events/block.h | 13 +++--
1 file changed, 11 insertions(+), 2 deletions(-)
diff --git a/include/trace/events/b
Hi Greg,
On 04/15/2018 10:31 AM, Greg Kroah-Hartman wrote:
On Fri, Apr 13, 2018 at 03:07:18PM +0200, Steffen Maier wrote:
Complements v2.6.31 commit 55782138e47d ("tracing/events: convert block
trace points to TRACE_EVENT()") to be equivalent to traditional blktrace
output. Also t
://www.ibm.com/support/knowledgecenter/ST3FR7_8.1.2/com.ibm.storwize.v7000.812.doc/svc_zs_statechange_3fgeri.html
--
Mit freundlichen Grüßen / Kind regards
Steffen Maier
Linux on z Systems Development
IBM Deutschland Research & Development GmbH
Vorsitzende des Aufsichtsrats: Martina Koede
On 10/13/2016 06:24 PM, Johannes Thumshirn wrote:
On Thu, Oct 13, 2016 at 05:15:25PM +0200, Steffen Maier wrote:
I'm puzzled.
$ git bisect start fc_bsg master
3087864ce3d7282f59021245d8a5f83ef1caef18 is the first bad commit
commit 3087864ce3d7282f59021245d8a5f83ef1caef18
Author: Joh
On 10/28/2016 01:31 PM, Hannes Reinecke wrote:
On 10/28/2016 11:53 AM, Steffen Maier wrote:
On 10/13/2016 06:24 PM, Johannes Thumshirn wrote:
On Thu, Oct 13, 2016 at 05:15:25PM +0200, Steffen Maier wrote:
I'm puzzled.
$ git bisect start fc_bsg m
/scsi_transport_fc.c | 409 ++-
include/linux/bsg-lib.h | 4 +
include/scsi/libfc.h | 2 +-
include/scsi/scsi_transport_fc.h | 62 ++
20 files changed, 745 insertions(+), 856 deletions(-)
--
Mit freundlichen Grüßen / Kind reg
ould be obvious in
testing.
Fixes: aceeffbb59bb ("zfcp: trace full payload of all SAN records
(req,resp,iels)")
Cc: #2.6.38+
Signed-off-by: Dan Carpenter
Signed-off-by: Steffen Maier
diff --git a/drivers/s390/scsi/zfcp_dbf.c b/drivers/s390/scsi/zfcp_dbf.c
index 637cf89..581
east */
if (job->request_len < sizeof(uint32_t)) {
BUG_ON(job->reply_len < sizeof(uint32_t));
- job->reply->reply_payload_rcv_len = 0;
- job->reply->result = -ENOMSG;
+ bsg_reply =
32_t);
fc_bsg_jobdone(job);
spin_lock_irq(q->queue_lock);
--
Mit freundlichen Grüßen / Kind regards
Steffen Maier
Linux on z Systems Development
IBM Deutschland Research & Development GmbH
Vorsitzende des Aufsichtsrats: Martina Koederitz
Geschaeftsf
Hi Johannes,
On 11/15/2016 12:56 PM, Johannes Thumshirn wrote:
On Tue, Oct 25, 2016 at 09:43:14AM +0200, Johannes Thumshirn wrote:
On Fri, Oct 14, 2016 at 09:38:21AM +0200, Johannes Thumshirn wrote:
On Thu, Oct 13, 2016 at 05:55:11PM +0200, Steffen Maier wrote:
Hm, still behaves for me like
ot;: " fmt
-#include
#include
#include
#include
--
Mit freundlichen Grüßen / Kind regards
Steffen Maier
Linux on z Systems Development
IBM Deutschland Research & Development GmbH
Vorsitzende des Aufsichtsrats: Martina Koederitz
Geschaeftsfuehrung: Dirk Wittkopp
Sitz der Gesellschaft: Boeblingen
Registergericht: Amtsgericht Stuttgart, HRB 243294
fields. It improves readability.
Signed-off-by: Lukáš Korenčik
Signed-off-by: Jiri Slaby
Cc: Steffen Maier
Cc: Martin Schwidefsky
Cc: Heiko Carstens
Cc:
---
drivers/s390/scsi/zfcp_erp.c | 5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)
diff --git a/drivers/s390/scsi/zfcp_erp.c b/dr
Fixes: f40609d1591f ("zram: convert remaining CLASS_ATTR() to CLASS_ATTR_RO()")
Link: https://bugzilla.redhat.com/show_bug.cgi?id=1847832
Signed-off-by: Greg Kroah-Hartman
Reviewed-by: Steffen Maier
---
v2: fix read/write confusion in the changelog, thanks to Steffen for the
case FSF_LUN_ALREADY_OPEN:
break;
case FSF_PORT_BOXED:
Acked-by: Steffen Maier # for zfcp
--
Mit freundlichen Gruessen / Kind regards
Steffen Maier
Linux on IBM Z Development
https://www.ibm.com/privacy/us/en/
IBM Deutschland Research & Development GmbH
Vorsitzender des Auf
__ATTR(hot_add, 0400, hot_add_show, NULL);
static ssize_t hot_remove_store(struct class *class,
struct class_attribute *attr,
--
Mit freundlichen Gruessen / Kind regards
Steffen Maier
Linux on IBM Z Development
https://www.ibm.com/privacy/us/en/
IBM Deutschland Rese
Hi Jiri,
On 06/26/2017 02:06 PM, Jiri Slaby wrote:
On 03/07/2017, 02:06 PM, Steffen Maier wrote:
Thanks, Lukáš, Jiri, queued for next zfcp feature submission to
linux-scsi as:
"zfcp: use setup_timer instead of init_timer"
Hi,
was this actually submitted somewhere or did it fall t
If this has not been picked/merged yet (it's not in Linus' tree yet),
could you please drop it because it's buggy?
This would buy me time to come up with a proper solution,
otherwise I would be forced to fix it within 4.15-rc and
am not sure I can make it.
On 11/08/2017 03:17 PM
Fixes the following false warning:
WARNING: Missing a blank line after declarations
#71: FILE: drivers/s390/scsi/zfcp_fsf.c:422:
+ struct hlist_node *tmp;
+ HLIST_HEAD(remove_queue);
Signed-off-by: Steffen Maier
---
scripts/checkpatch.pl | 2 +-
1 file changed, 1 insertion
Another place in lib/Kconfig.debug was already fixed in commit f8998c226587
("lib/Kconfig.debug: correct documentation paths").
Fixes: 9d85025b0418 ("docs-rst: create an user's manual book")
Signed-off-by: Steffen Maier
---
Documentation/admin-guide/kernel-paramete
Fixes the following false warning
among others for LLIST_HEAD and PLIST_HEAD:
WARNING: Missing a blank line after declarations
#71: FILE: drivers/s390/scsi/zfcp_fsf.c:422:
+ struct hlist_node *tmp;
+ HLIST_HEAD(remove_queue);
Signed-off-by: Steffen Maier
---
Changes from v1
lude/linux/list.h:595:#define HLIST_HEAD(name) struct hlist_head name
= { .first = NULL }
tools/include/linux/list.h:596:#define INIT_HLIST_HEAD(ptr) ((ptr)->first =
NULL)
tools/usb/usbip/libsrc/list.h:24:#define LIST_HEAD(name) \
On 06/14/2017 03:35 PM, Steffen Maier wrote:
> F
ice.
FYI: Originally, I only thought about using set_host_byte in that one
place fix of yours; I did not expect a full framework rework.
--
Mit freundlichen Grüßen / Kind regards
Steffen Maier
Linux on z Systems Development
IBM Deutschland Research & Development GmbH
Vorsitzende des Aufsichtsrats
eturning FAST_IO_FAIL would be more appropriate here in
this case, in order to have scsi_eh let the pending I/O bubble up for a
timely path failover?
--
Mit freundlichen Grüßen / Kind regards
Steffen Maier
Linux on z Systems Development
IBM Deutschland Research & Development GmbH
Vorsitzende des A
yte() by:
sc->result = 0;
set_host_byte(sc, DID_REQUEUE);
goto fault;
}
--
Mit freundlichen Grüßen / Kind regards
Steffen Maier
Linux on z Systems Development
IBM Deutschland Research & Development GmbH
Vorsitzende des Aufsichtsrats:
apply for the upcoming merge window.
In http://www.spinics.net/lists/linux-scsi/msg114581.html I saw a decision
to have such changes go in via the timer tree. I would be happy with that.
Kees Cook (1):
zfcp: convert timers to use timer_setup()
Steffen Maier (2):
zfcp: purely mechanical update
ument type")
Signed-off-by: Steffen Maier
Reviewed-by: Jens Remus
---
drivers/s390/scsi/zfcp_fsf.c | 5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)
diff --git a/drivers/s390/scsi/zfcp_fsf.c b/drivers/s390/scsi/zfcp_fsf.c
index 51b81c0a0652..c8e368f0f299 100644
--- a/drivers/s390/
4-rc3 commit 686fef928bba ("timer: Prepare to change timer
callback argument type")
Signed-off-by: Steffen Maier
Reviewed-by: Jens Remus
---
drivers/s390/scsi/zfcp_erp.c | 5 ++---
drivers/s390/scsi/zfcp_ext.h | 2 +-
drivers/s390/scsi/zfcp_fsf.c | 1 +
3 files changed, 4 insertio
From: Kees Cook
In preparation for unconditionally passing the struct timer_list pointer to
all timer callbacks, switch to using the new timer_setup() and from_timer()
to pass the timer pointer explicitly.
Cc: Steffen Maier
Cc: Benjamin Block
Cc: Martin Schwidefsky
Cc: Heiko Carstens
Cc
56 matches
Mail list logo