On 09/13/2016 10:42 AM, Andy Shevchenko wrote:
> On Mon, 2016-07-04 at 17:07 +0100, Dan O'Donovan wrote:
>> [Re-sending to a wider audience suggested by Darren Hart]
>>
>> The UP Board is a new SBC based on the Intel Atom X5-Z8350 "Cherry
>> Trail" So
Thanks for your review feedback, Andy! I'll send a v3 shortly with those
changes you suggested. I've added some comments inline below.
On 10/20/2018 12:40 PM, Andy Shevchenko wrote:
> On Fri, Oct 19, 2018 at 8:24 PM Dan O'Donovan wrote:
>
>> +static int upboard
On 10/20/2018 12:49 PM, Andy Shevchenko wrote:
> On Fri, Oct 19, 2018 at 8:26 PM Dan O'Donovan wrote:
>> From: Javier Arteaga
>>
>> UP Squared (UP2) is a x86 SBC from AAEON based on Intel Apollo Lake. It
>> features a MAX 10 FPGA that routes lines from both SoC
Allow userspace to use the on-board LEDs as "upboard::".
Acked-by: Pavel Machek
Signed-off-by: Dan O'Donovan
---
drivers/leds/Kconfig| 10 +
drivers/leds/Makefile | 1 +
drivers/leds/leds-upboard.c | 103
3 fil
. The needed
mapping for this is retrieved via ACPI properties.
Signed-off-by: Dan O'Donovan
---
drivers/pinctrl/Kconfig | 13 +
drivers/pinctrl/Makefile | 1 +
drivers/pinctrl/pinctrl-upboard.c | 496 ++
3 files changed, 510 inser
tch as MFD driver and simplified them
* Promoted some dev_dbg instances to dev_err for probe error cases
* Decoupled MFD cell reference from ACPI driver data
* Miscellanous coding style improvements
* Fixed license mismatches
Dan O'Donovan (3):
mfd: upboard: Add UP2 platform controller driver
lines. These can be driven
SoC-to-header, header-to-SoC or set in high impedance.
- On-board LEDs and enable lines for other platform devices.
Add core support for this platform controller as a MFD device, exposing
these registers as a regmap.
Acked-by: Linus Walleij
Signed-off-by: Dan O
On 10/31/2018 09:30 PM, Linus Walleij wrote:
> Hi Dan,
>
> On Wed, Oct 31, 2018 at 9:45 PM Dan O'Donovan wrote:
>
>> The UP2 board features a Raspberry Pi compatible pin header (HAT) and a
>> board-specific expansion connector (EXHAT). Both expose assorted
>>
On 11/01/2018 08:07 AM, Lee Jones wrote:
> On Wed, 31 Oct 2018, Dan O'Donovan wrote:
>
>> UP Squared (UP2) is a x86 SBC from AAEON based on Intel Apollo Lake. It
>> features a MAX 10 FPGA that routes lines from both SoC and on-board
>&g
ed of_match_ptr removal last as this patch is less important to us
Dan O'Donovan (1):
iio: adc128s052: use SPDX-License-Identifier
Javier Arteaga (1):
iio: adc128s052: Add pin-compatible IDs
Nicola Lunghi (1):
iio: adc128s052: add ACPI _HID AANT1280
.../devicetree/bindings/iio/adc/ti-
From: Nicola Lunghi
ACPI _HID AANT1280 matches an ADC124S101 present on E3940 SKUs of the UP
Squared board.
Add it to the driver.
Signed-off-by: Nicola Lunghi
[jav...@emutex.com: fix up commit message and one checkpatch warning]
Signed-off-by: Javier Arteaga
Signed-off-by: Dan O'Do
This updates the ti-adc128s052.c file to use SPDX-License-Identifier
instead of more verbose license text.
Signed-off-by: Dan O'Donovan
---
drivers/iio/adc/ti-adc128s052.c | 5 +
1 file changed, 1 insertion(+), 4 deletions(-)
diff --git a/drivers/iio/adc/ti-adc128s052.c b/drivers/ii
From: Javier Arteaga
The datasheets for ADC122S021 and ADC124S021 list two more
pin-compatible alternatives for each device.
Add their IDs as compatible strings.
Suggested-by: Jonathan Cameron
Signed-off-by: Javier Arteaga
Signed-off-by: Dan O'Donovan
---
.../devicetree/bindings/iio/a
On 10/25/2018 06:46 PM, Andy Shevchenko wrote:
> On Thu, Oct 25, 2018 at 04:35:41PM +0100, Dan O'Donovan wrote:
>> From: Nicola Lunghi
>>
>> ACPI _HID AANT1280 matches an ADC124S101 present on E3940 SKUs of the UP
>> Squared board.
>>
>> Add it to th
matching SoC GPIO line. The needed
mapping for this is retrieved via ACPI properties.
Signed-off-by: Javier Arteaga
Signed-off-by: Dan O'Donovan
---
drivers/pinctrl/Kconfig | 13 +
drivers/pinctrl/Makefile | 1 +
drivers/pinctrl/pinctrl-upboard.c
From: Javier Arteaga
Allow userspace to use the on-board LEDs as "upboard::".
Acked-by: Pavel Machek
Signed-off-by: Javier Arteaga
Signed-off-by: Dan O'Donovan
---
drivers/leds/Kconfig| 10 +
drivers/leds/Makefile | 1 +
drivers/leds/leds-
ff-by: Javier Arteaga
Signed-off-by: Dan O'Donovan
---
drivers/mfd/Kconfig | 17 +++
drivers/mfd/Makefile| 1 +
drivers/mfd/upboard.c | 344
include/linux/mfd/upboard.h | 44 ++
4 files changed, 406 insertions(+)
c
Hi all,
This series adds platform support for AAEON's UP Squared, a x86 SBC
based on Apollo Lake [1]. Specifically, it enables control for the board
pin headers and for the LEDs, as both of these features are only
available behind a FPGA-based platform controller.
This is structured around a MFD
On Sat, 2014-04-12 at 18:28 +0100, Jonathan Cameron wrote:
> On 09/04/14 19:09, Joel Porquet wrote:
> > As suggested by checkpatch.pl, use dev_info() instead of
> > printk(KERN_INFO ...) to print message.
> >
> > Signed-off-by: Joel Porquet
> > ---
> > Only tested by compilation.
> > drivers/sta
Hi Linus
Many thanks for your feedback below, and sorry that I'm only getting to follow
up on this now. I've added some initial responses inline below.
On 10/22/18 10:07 AM, Linus Walleij wrote:
> On Fri, Oct 19, 2018 at 7:16 PM Dan O'Donovan wrote:
>
>> From: Ja
(Re-submitting this patch set originally created by Leonard Crestez,
possibly abandoned by Leonard due to a change in employment)
When using devicetree, stuff like i2c_client.name or spi_device.modalias
is initialized to the first DT compatible id with the vendor prefix
stripped. Since some driver
"PRP0001:00".
If the of_compatible property is present try to use that instead. This
makes it easier to instantiate i2c drivers through ACPI with DT ids.
Signed-off-by: Crestez Dan Leonard
Signed-off-by: Dan O'Donovan
---
drivers/i2c/i2c-core.c | 8 +++-
1 file changed, 7 i
Signed-off-by: Dan O'Donovan
Reviewed-by: Mika Westerberg
---
drivers/acpi/bus.c | 35 +++
include/acpi/acpi_bus.h | 1 +
2 files changed, 36 insertions(+)
diff --git a/drivers/acpi/bus.c b/drivers/acpi/bus.c
index 95855cb..8b9657f 100644
--- a/drivers
"PRP0001".
Change acpi_register_spi_device to use the of_compatible property if
present. This makes it easier to instantiate spi drivers through ACPI
with DT ids.
Signed-off-by: Crestez Dan Leonard
Signed-off-by: Dan O'Donovan
---
drivers/spi/spi.c | 10 +-
1 file change
On 01/23/2017 05:11 PM, Andy Shevchenko wrote:
> On Mon, Jan 23, 2017 at 6:08 PM, Dan O'Donovan wrote:
>> From: Crestez Dan Leonard
>>
>> When using devicetree spi_device.modalias is set to the compatible
>> string with the vendor prefix removed. For SPI d
Signed-off-by: Dan O'Donovan
Reviewed-by: Mika Westerberg
Reviewed-by: Andy Shevchenko
Reviewed-by: Jarkko Nikula
Tested-by: Jarkko Nikula
---
drivers/acpi/bus.c | 35 +++
include/acpi/acpi_bus.h | 1 +
2 files changed, 36 insertions(+)
diff --git a/dr
When using devicetree, stuff like i2c_client.name or spi_device.modalias
is initialized to the first DT compatible id with the vendor prefix
stripped. Since some drivers rely on this in order to differentiate between
hardware variants, try to replicate it when using ACPI with DT ids.
This also mak
"PRP0001:00".
If the of_compatible property is present try to use that instead. This
makes it easier to instantiate i2c drivers through ACPI with DT ids.
Signed-off-by: Crestez Dan Leonard
Signed-off-by: Dan O'Donovan
Reviewed-by: Andy Shevchenko
Reviewed-by: Jarkko Nikula
Tested-by
"PRP0001".
Change acpi_register_spi_device to use the of_compatible property if
present. This makes it easier to instantiate spi drivers through ACPI
with DT ids.
Signed-off-by: Crestez Dan Leonard
Signed-off-by: Dan O'Donovan
Reviewed-by: Andy Shevchenko
Reviewed-by: Jarkko Ni
variants try to replicate it when using ACPI with DT ids.
>
> This also makes it so that the i2c_device_id parameter passed to probe is
> non-NULL when matching with ACPI and DT ids.
This solves a problem for me, thanks Leonard! For the series (in case
it helps):
Tested-by: Dan O'Donov
pin header.
Signed-off-by: Dan O'Donovan
---
drivers/platform/x86/Kconfig| 13
drivers/platform/x86/Makefile | 5 ++
drivers/platform/x86/up_board.c | 167
3 files changed, 185 insertions(+)
create mode 100644 drivers/platform/x86/up_bo
https://up-community.org
Dan O'Donovan (5):
platform: x86: add driver for UP Board I/O CPLD
platform: x86: add UP Board I/O pinctrl driver
platform: x86: add UP Board I/O gpio driver
platform: x86: add UP Board CPLD LED driver
platform: x86: add platform driver for UP Board
drivers/platf
This pinctrl driver manages the Pin Control functions provided by
the I/O CPLD integrated on the UP Board. This includes dynamic pin
direction and pin mux configuration.
Signed-off-by: Dan O'Donovan
---
drivers/platform/x86/up_board_pinctrl.c | 285
dr
This pinctrl driver manages the LED Control function provided by
the I/O CPLD integrated on the UP Board. This allows basic on/off
brightness control for each of the individual LEDs.
Signed-off-by: Dan O'Donovan
---
drivers/platform/x86/up_board_leds.c
logical GPIO chip to access the GPIO functions on
the UP Board I/O pins.
Signed-off-by: Dan O'Donovan
---
drivers/platform/x86/up_board_gpio.c | 254 +++
drivers/platform/x86/up_board_gpio.h | 59
2 files changed, 313 insertions(+)
create mode 1
provided in separate commits
to manage the functions provided by that CPLD.
This commit registers a platform driver to manage the configuration
of the CPLD itself.
Signed-off-by: Dan O'Donovan
---
drivers/platform/x86/up_board_cpld.c | 560 +++
drivers/platfor
0. The
aforementioned commit appears to have assumed the inverse of this.
Signed-off-by: Dan O'Donovan
---
drivers/acpi/acpi_lpss.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/acpi/acpi_lpss.c b/drivers/acpi/acpi_lpss.c
index 8ea836c..4b3f2d5 100644
---
On 02/02/2017 11:41 AM, Rafael J. Wysocki wrote:
> On Friday, January 27, 2017 01:30:13 PM Dan O'Donovan wrote:
>> From: Crestez Dan Leonard
>>
>> When using devicetree stuff like i2c_client.name or spi_device.modalias
>> is initialized to the first DT comp
;.
If the of_compatible property is present try to use that instead. This
makes it easier to instantiate i2c drivers through ACPI with DT ids.
Signed-off-by: Dan O'Donovan
Reviewed-by: Andy Shevchenko
Reviewed-by: Jarkko Nikula
Tested-by: Jarkko Nikula
Acked-by: Wolfram Sang
---
drivers/i2c/i2c-co
When using devicetree stuff like i2c_client.name or spi_device.modalias
is initialized to the first DT compatible id with the vendor prefix
stripped. Since some drivers rely on this try to replicate it when using
ACPI with DT ids.
Signed-off-by: Dan O'Donovan
Reviewed-by: Mika Weste
;.
Change acpi_register_spi_device to use the of_compatible property if
present. This makes it easier to instantiate spi drivers through ACPI
with DT ids.
Signed-off-by: Dan O'Donovan
Reviewed-by: Andy Shevchenko
Reviewed-by: Jarkko Nikula
Tested-by: Jarkko Nikula
---
drivers/spi/spi.c | 4 +++-
1
smetic/readability improvements (Rafael J. Wysocki)
Link to v1: https://www.spinics.net/lists/linux-acpi/msg66469.html
Changes:
* Rebase on after acpi overlays got it.
* Change acpi_of_modalias outlen param to size_t
* Use {} after else
Dan O'Donovan (3):
ACPI / bus: Export acpi_of_mod
When using devicetree stuff like i2c_client.name or spi_device.modalias
is initialized to the first DT compatible id with the vendor prefix
stripped. Since some drivers rely on this try to replicate it when using
ACPI with DT ids.
Signed-off-by: Dan O'Donovan
Reviewed-by: Mika Weste
;.
Change acpi_register_spi_device to use the of_compatible property if
present. This makes it easier to instantiate spi drivers through ACPI
with DT ids.
Signed-off-by: Dan O'Donovan
Reviewed-by: Andy Shevchenko
Reviewed-by: Jarkko Nikula
Tested-by: Jarkko Nikula
Acked-by: Mark Brown
---
driver
;.
If the of_compatible property is present try to use that instead. This
makes it easier to instantiate i2c drivers through ACPI with DT ids.
Signed-off-by: Dan O'Donovan
Reviewed-by: Andy Shevchenko
Reviewed-by: Jarkko Nikula
Tested-by: Jarkko Nikula
Acked-by: Wolfram Sang
---
drivers/i2c/i2c-co
cpi overlays got it.
* Change acpi_of_modalias outlen param to size_t
* Use {} after else
Dan O'Donovan (3):
ACPI / bus: Export acpi_of_modalias equiv of of_modalias_node
i2c: acpi: Initialize info.type from of_compatible
spi: acpi: Init
On 06/30/2016 08:47 AM, Michal Suchanek wrote:
> On 29 June 2016 at 20:02, Mark Brown wrote:
>> On Wed, Jun 29, 2016 at 05:32:48AM +0200, Michal Suchanek wrote:
>>
>>> The other is to get a generic expansion board and jumper wires. Of
>>> course, you will not use all pins of your expansion connect
47 matches
Mail list logo