Add a test which checks that the kstkesp field in /proc/pid/stat can be
read for all threads of a coredumping process.
For full details including the motivation for this test and how it works,
see the README file added by this commit.
Reviewed-by: John Ogness
Signed-off-by: Nam Cao
---
tools/t
Hi,
In /proc/PID/stat, there is the kstkesp field which is the stack pointer of
a thread. While the thread is active, this field reads zero. But during a
coredump, it should have a valid value.
However, at the moment, kstkesp is zero even during coredump.
The first commit fixes this problem, and
The field "eip" (instruction pointer) and "esp" (stack pointer) of a task
can be read from /proc/PID/stat. These fields can be interesting for
coredump.
However, these fields were disabled by commit 0a1eb2d474ed ("fs/proc: Stop
reporting eip and esp in /proc/PID/stat"), because it is generally uns
On Fri, Dec 20, 2024 at 06:41:42PM +0100, Sebastian Andrzej Siewior wrote:
> __module_address() can be invoked within a RCU section, there is no
> requirement to have preemption disabled.
>
> I'm not sure if using rcu_read_lock() will introduce the regression that
> has been fixed in commit 14c4c8
On Mon, Dec 30, 2024 at 03:46:25PM +0100, Greg Kroah-Hartman wrote:
> On Wed, Dec 18, 2024 at 04:29:31PM +, Conor Dooley wrote:
> > On Tue, Dec 17, 2024 at 09:28:18AM +0100, Greg Kroah-Hartman wrote:
> > > On Tue, Dec 17, 2024 at 04:11:21PM +0800, Z qiang wrote:
> > > > >
> > > > > On Sat, Dec
* Stefan Schmidt (ste...@datenfreihafen.org) wrote:
> Hello li...@treblig.org.
>
> On Wed, 25 Dec 2024 01:24:23 +, li...@treblig.org wrote:
> > ieee802154_mlme_tx_one() was added in 2022 by
> > commit ddd9ee7cda12 ("net: mac802154: Introduce a synchronous API for MLME
> > commands") but has re
Hello li...@treblig.org.
On Wed, 25 Dec 2024 01:24:23 +, li...@treblig.org wrote:
> ieee802154_mlme_tx_one() was added in 2022 by
> commit ddd9ee7cda12 ("net: mac802154: Introduce a synchronous API for MLME
> commands") but has remained unused.
>
> Remove it.
>
> Note, there's still a ieee80
Hello Dave,
On 30.12.24 18:44, Dr. David Alan Gilbert wrote:
* Stefan Schmidt (ste...@datenfreihafen.org) wrote:
Hello li...@treblig.org.
On Wed, 25 Dec 2024 01:24:23 +, li...@treblig.org wrote:
ieee802154_mlme_tx_one() was added in 2022 by
commit ddd9ee7cda12 ("net: mac802154: Introduce
On Mon, Dec 30, 2024 at 11:17:30AM +0100, Nam Cao wrote:
> The field "eip" (instruction pointer) and "esp" (stack pointer) of a task
> can be read from /proc/PID/stat. These fields can be interesting for
> coredump.
>
> However, these fields were disabled by commit 0a1eb2d474ed ("fs/proc: Stop
> r
On Mon, Dec 30, 2024 at 11:17:31AM +0100, Nam Cao wrote:
> Add a test which checks that the kstkesp field in /proc/pid/stat can be
> read for all threads of a coredumping process.
>
> For full details including the motivation for this test and how it works,
> see the README file added by this comm
On 12/20/24 18:41, Sebastian Andrzej Siewior wrote:
> __module_address() can be invoked within a RCU section, there is no
> requirement to have preemption disabled.
>
> I'm not sure if using rcu_read_lock() will introduce the regression that
> has been fixed in commit 14c4c8e41511a ("cfi: Use
> rc
On 26/12/2024 23:30, Frederic Weisbecker wrote:
> It's now ok to perform a wake-up from an offline CPU because the
> resulting armed scheduler bandwidth hrtimers are now correctly targeted
> by hrtimer infrastructure.
>
> Remove the obsolete hackerry.
>
> Signed-off-by: Frederic Weisbecker
R
On 26/12/2024 23:30, Frederic Weisbecker wrote:
> This reverts commit f7345ccc62a4b880cf76458db5f320725f28e400.
>
> swake_up_one_online() has been removed because hrtimers can now assign
> a proper online target to hrtimers queued from offline CPUs. Therefore
> remove the related hackery.
>
>
On 12/28/24 16:45, Masahiro Yamada wrote:
> Commit 71810db27c1c ("modversions: treat symbol CRCs as 32 bit
> quantities") changed the CRC fields to s32 because the __kcrctab and
> __kcrctab_gpl sections contained relative references to the actual
> CRC values stored in the .rodata section when CONF
Hello,
On 25/12/2024 at 01:24:23 GMT, li...@treblig.org wrote:
> From: "Dr. David Alan Gilbert"
>
> ieee802154_mlme_tx_one() was added in 2022 by
> commit ddd9ee7cda12 ("net: mac802154: Introduce a synchronous API for MLME
> commands") but has remained unused.
>
> Remove it.
>
> Note, there's st
On 26/12/2024 23:30, Frederic Weisbecker wrote:
> hrtimers are migrated away from the dying CPU to any online target at
> the CPUHP_AP_HRTIMERS_DYING stage in order not to delay bandwidth timers
> handling tasks involved in the CPU hotplug forward progress.
>
> However wake ups can still be per
On Wed, Dec 11, 2024 at 1:55 AM Stefano Garzarella wrote:
>
> On Wed, Dec 11, 2024 at 12:41:46AM +0800, Cindy Lu wrote:
> >Add a new UAPI to enable setting the vhost device to task mode.
> >The userspace application can use VHOST_SET_INHERIT_FROM_OWNER
> >to configure the mode if necessary.
> >Thi
In commit 6e890c5d5021 ("vhost: use vhost_tasks for worker threads"),
the vhost now uses vhost_task and operates as a child of the
owner thread. This aligns with containerization principles.
However, this change has caused confusion for some legacy
userspace applications. Therefore, we
The vhost now uses vhost_task and workers as a child of the owner
thread. While this aligns with containerization principles, it confuses
some legacy userspace applications. Therefore, we are reintroducing
support for the kthread API.
Introduce a new parameter to enable users to choose between kth
Add the previously removed function vhost_worker() back to support the
kthread and rename it to vhost_run_work_kthread_list.
The old function vhost_worker() was changed to support tasks in
commit 6e890c5d5021 ("vhost: use vhost_tasks for worker threads")
and to support multiple workers per device
Reintroduce the previously removed functions vhost_attach_cgroups_work()
and vhost_attach_cgroups() to support kthread mode. Rename
vhost_attach_cgroups() to vhost_attach_task_to_cgroups(), and include
the implementation of the old function vhost_dev_flush() in this
new function.
These function wa
Add a new UAPI to enable setting the vhost device to task mode.
The userspace application can use VHOST_SET_INHERIT_FROM_OWNER
to configure the mode if necessary.
This setting must be applied before VHOST_SET_OWNER, as the worker
will be created in the VHOST_SET_OWNER function
Signed-off-by: Cindy
Restore the previously removed functions kthread_wakeup and
kthread_stop, and add two new function pointers to wake up and stop
the workers. The function vhost_worker_create will initialize these
pointers based on the value of inherit_owner.
The functions vhost_worker_queue() and vhost_worker_dest
The vhost_scsi VHOST_NEW_WORKER requires the inherit_owner
setting to be true. So we need to implement a check for this.
Signed-off-by: Cindy Lu
---
drivers/vhost/scsi.c | 8
1 file changed, 8 insertions(+)
diff --git a/drivers/vhost/scsi.c b/drivers/vhost/scsi.c
index 718fa4e0b31e..0d
On Wed, Dec 18, 2024 at 04:29:31PM +, Conor Dooley wrote:
> On Tue, Dec 17, 2024 at 09:28:18AM +0100, Greg Kroah-Hartman wrote:
> > On Tue, Dec 17, 2024 at 04:11:21PM +0800, Z qiang wrote:
> > > >
> > > > On Sat, Dec 14, 2024 at 09:53:13PM +0100, Greg Kroah-Hartman wrote:
> > > > > I'm announci
On Sat, Dec 28, 2024 at 12:43 AM Thomas Weißschuh wrote:
>
> Most users use this function through the BIN_ATTR_SIMPLE* macros,
> they can handle the switch transparently.
>
> This series is meant to be merged through the driver core tree.
hmm. why?
I'd rather take patches 2 and 3 into bpf-next t
Hello:
This series was applied to bpf/bpf-next.git (master)
by Alexei Starovoitov :
On Tue, 17 Dec 2024 22:23:33 -0500 you wrote:
> Hi All,
>
> This patch-set aims to improve precision of BPF_MUL and add testcases
> to illustrate precision gains using signed and unsigned bounds.
>
> Thanks for
On 20/12/24 05:02, Jakub Kicinski wrote:
On Thu, 19 Dec 2024 02:42:20 +0100 Antonio Quartulli wrote:
+uint64_t nla_get_uint(struct nlattr *attr)
+{
+ if (nla_len(attr) == sizeof(uint32_t))
+ return nla_get_u32(attr);
+ else
+ return nla_get_u64(attr);
+}
Hi Will,
Thanks a lot for chiming in and sorry for the delay.
See below.
On 19/12/24 18:20, Will Deacon wrote:
[...]
+/**
+ * refcount_dec_and_lock_sock - return holding locked sock if able to decrement
+ * refcount to 0
+ * @r: the refcount
+ * @sock: the sock to be
29 matches
Mail list logo