Signed-off-by: Guenter Roeck
---
drivers/hwmon/vexpress.c |4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/hwmon/vexpress.c b/drivers/hwmon/vexpress.c
index 59fd126..86d7f6d 100644
--- a/drivers/hwmon/vexpress.c
+++ b/drivers/hwmon/vexpress.c
@@ -196,7 +196,7 @@
Fix:
vexpress.c: In function ‘vexpress_hwmon_name_show’:
vexpress.c:34:2: error: implicit declaration of function
‘of_get_property’ [-Werror=implicit-function-declaration]
vexpress.c:34:27: warning: initialization makes pointer from integer
without a cast [enabled by default]
vexpress.c: In functio
On Sun, Dec 30, 2012 at 04:47:22PM +0100, Oleg Nesterov wrote:
> Change handle_swbp() to set regs->ip = bp_vaddr in advance, this is
> what consumer->handler() needs but uprobe_get_swbp_addr() is not
> exported.
>
> This also simplifies the code and makes it more consistent across
> the supported
Kindly let me know if I am posting query in wrong Forum. If yes, then
could anyone point me to the appropriate forum ?
Thanks in advance,
Vivek Satpute
On Sun, Dec 30, 2012 at 5:02 PM, Vivek Satpute wrote:
> Hi All,
>
> I am working on RHEL5.8 (kernel-2.6.18-308) and facing weird behavior
> wit
On 12/24/2012 03:19 PM, Chuansheng Liu wrote:
> This patch fix the below build error:
> drivers/built-in.o: In function `twl_probe':
> drivers/mfd/twl-core.c:1256: undefined reference to `devm_regmap_init_i2c'
> make: *** [vmlinux] Error 1
Thanks Liu, I have missed this one.
Acked-by: Peter Ujfal
On Sun, Dec 30, 2012 at 05:03:07PM -0500, Eric Paris wrote:
> On Sat, 2012-12-29 at 15:00 +0400, Andrey Vagin wrote:
> > The address should be bigger than dac_mmap_min_addr, because
> > a process with CAP_RAWIO can map a vma bellow mmap_min_addr.
>
> NAK
Currently prctl(PR_SET_MM_*, addr, ) retur
On Mon, Dec 31, 2012 at 02:42:07AM +0800, Du Jiulun wrote:
> CPU 2: Machine Check Exception: 4 Bank 2: b205
> TSC 6568f53a1cee
> HARDWARE ERROR. This is *NOT* a software problem!
> Please contact your hardware vendor
> CPU 2 BANK 2 TSC 6568f53a1cee
> TIME 1356717945 Sat Dec 29 02:05:45
Hello,
Second part of the cleanup of twl-core which aims to make the code a bit more
readable.
It has been tested on: OMAP4 PandaBoard, OMAP4 Blaze, OMAP3 BeagleBoard, OMAP3
Zoom2.
Regards,
Peter
---
Peter Ujfalusi (10):
mfd: twl-core: Clean up module id lookup and definitions
mfd: twl-core:
Instead of using SUB_CHIP_ID* or magic numbers use the twl_mapping table to
look for the subchip ID.
Signed-off-by: Peter Ujfalusi
---
drivers/mfd/twl-core.c | 56 --
1 file changed, 27 insertions(+), 29 deletions(-)
diff --git a/drivers/mfd/twl-c
At boot time we can allocate the twl_modules array dynamically based on the
twl class we are using with devm_kzalloc() instead of the static
twl_modules[] array.
Signed-off-by: Peter Ujfalusi
---
drivers/mfd/twl-core.c | 31 +--
1 file changed, 21 insertions(+), 10 de
There is really no point to retry to add children devices in case the
of_platform_populate() fails.
We do not have any information provided via pdata in this case anyways.
Depending on the boot type (legacy or DT) only execute either one.
Signed-off-by: Peter Ujfalusi
---
drivers/mfd/twl-core.c
twl_i2c_read/write_u8 become as a simple wrapper over the twl_i2c_read/write.
Signed-off-by: Peter Ujfalusi
---
drivers/mfd/twl-core.c | 28
include/linux/i2c/twl.h | 17 +++--
2 files changed, 11 insertions(+), 34 deletions(-)
diff --git a/drivers/mfd/
With the regmap conversion there is no longeer a need to allocate bigger
buffer for writes
Signed-off-by: Peter Ujfalusi
---
drivers/mfd/twl-core.c | 3 ---
include/linux/i2c/twl.h | 3 ---
2 files changed, 6 deletions(-)
diff --git a/drivers/mfd/twl-core.c b/drivers/mfd/twl-core.c
index e2895
The module id table no longer can have invalid/unused entries.
No need for checking the ID for validity.
Signed-off-by: Peter Ujfalusi
---
drivers/mfd/twl-core.c | 13 ++---
1 file changed, 2 insertions(+), 11 deletions(-)
diff --git a/drivers/mfd/twl-core.c b/drivers/mfd/twl-core.c
ind
Gather the global variables under a single structure and allocate it with
devm_kzalloc(). It is easier to see them and if in the future we try to add
support for multiple instance of twl in the system it is going to be much
simpler.
Signed-off-by: Peter Ujfalusi
---
drivers/mfd/twl-core.c | 104
We can fail earlier in case multiple instance of the twl-core is tried to
be loaded.
The twl-core by design only supports one instance.
Signed-off-by: Peter Ujfalusi
---
drivers/mfd/twl-core.c | 12 ++--
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/drivers/mfd/twl-core.c
When booted with DT we can manage without the dummy pdata.
Signed-off-by: Peter Ujfalusi
---
drivers/mfd/twl-core.c | 31 +++
1 file changed, 7 insertions(+), 24 deletions(-)
diff --git a/drivers/mfd/twl-core.c b/drivers/mfd/twl-core.c
index 86cca9e..547fed5 100644
-
Use enums for all module definitions:
twl_module_ids for common functionality among twl4030/twl6030
twl4030_module_ids for twl4030 specific ids
twl6030_module_ids for twl6030 specific ids
In this way the list can be managed easier when new functionality going to
be implemented.
Signed-off-by: Pet
I repeat my question:
the driver for lsm303dlh in the 3.5 kernel calls regulator_get(&client->dev,
"vdd");
from that it got the return-value fdfb triggering IS_ERR().
but I cannot find any errorcode for -0x205.
does anyone know the meaning of this error-code?
P
--
To unsubscribe from this lis
On Sun 30-12-12 14:59:50, Namjae Jeon wrote:
> From: Namjae Jeon
>
> Consider Process A: huge I/O on sda
> doing heavy write operation - dirty memory becomes more
> than dirty_background_ratio
> on HDD - flusher thread flush-8:0
>
> Consider Process B: small I/O on sdb
>
On 12/21/2012 06:06 PM, Ezequiel Garcia wrote:
> On Fri, Dec 21, 2012 at 12:07 PM, Javier Martinez Canillas
> wrote:
>> commit a99d76f leds: leds-gpio: use gpio_request_one
>>
>> changed the leds-gpio driver to use gpio_request_one() instead
>> of gpio_request() + gpio_direction_output()
>>
>> Unf
This patch seems to fix my issue with ppoll() being stuck on my
SMP machine: http://article.gmane.org/gmane.linux.file-systems/70414
The change to sock_poll_wait() in
commit 626cf236608505d376e4799adb4f7eb00a8594af
(poll: add poll_requested_events() and poll_does_not_wait() functions)
seems to h
Hey,
I used uswusp till now and it worked for my old HW configuration. Now
I updated to a new
I'm running Ubuntu 12.04 with a self-compiled Linux 3.7.0 kernel (uname -a):
Linux linux 3.7.0-custom #2 SMP Sat Dec 22 15:07:12 CET 2012 x86_64
x86_64 x86_64 GNU/Linux
Mainboard is (dmesg | grep Gigaby
On Mon, 2012-12-31 at 14:14 +0400, Andrew Vagin wrote:
> On Sun, Dec 30, 2012 at 05:03:07PM -0500, Eric Paris wrote:
> > On Sat, 2012-12-29 at 15:00 +0400, Andrey Vagin wrote:
> > > The address should be bigger than dac_mmap_min_addr, because
> > > a process with CAP_RAWIO can map a vma bellow mmap
Hi,
>> Sylvan Munaut did something similar
>> https://lkml.org/lkml/2012/12/5/168
>
> Missed that and duplicated the debugging :(
> Sorry Sylvain.
I should have followed up on the patch sooner, but I basically
finished testing it fixed all the issues and posted it just before
leaving for vacation
With kernel 3.8-rc1, my nightly Bacula backup job reproducibly aborts
20 minutes into spooling with a "broken pipe" error on the network
socket connecting the file and storage daemons:
31-Dec 00:45 xenon-sd JobId 859: Spooling data ...
31-Dec 01:04 xenon-fd JobId 859: Error: bsock.c:429 Write erro
On Sat, Dec 29, 2012 at 11:03:03AM +0100, Daniel Lezcano wrote:
>
> Hi Russ,
>
> Is it possible you try this patch on your 2048 cpus ?
Yes, I will try it later today.
Thanks
> Thanks
>
> -- Daniel
>
> On 12/26/2012 11:01 AM, Daniel Lezcano wrote:
> > The commit bf4d1b5ddb78f86078ac6ae04158
On Mon, Dec 31, 2012 at 09:27:14AM -0500, Eric Paris wrote:
> On Mon, 2012-12-31 at 14:14 +0400, Andrew Vagin wrote:
> > On Sun, Dec 30, 2012 at 05:03:07PM -0500, Eric Paris wrote:
> > > On Sat, 2012-12-29 at 15:00 +0400, Andrey Vagin wrote:
> > > > The address should be bigger than dac_mmap_min_ad
Acked-by: chas williams - CONTRACTOR
On Fri, 28 Dec 2012 10:46:36 +0530
Tushar Behera wrote:
> Ping.
>
> On 11/16/2012 12:20 PM, Tushar Behera wrote:
> > No need to check whether unsigned variable is less than 0.
> >
> > CC: Chas Williams
> > CC: linux-atm-gene...@lists.sourceforge.net
> > C
On Mon, 2012-12-31 at 19:13 +0400, Cyrill Gorcunov wrote:
> On Mon, Dec 31, 2012 at 09:27:14AM -0500, Eric Paris wrote:
> > On Mon, 2012-12-31 at 14:14 +0400, Andrew Vagin wrote:
> > > On Sun, Dec 30, 2012 at 05:03:07PM -0500, Eric Paris wrote:
> > > > On Sat, 2012-12-29 at 15:00 +0400, Andrey Vagi
On Mon, Dec 31, 2012 at 10:20:47AM -0500, Eric Paris wrote:
>
> Is there anything which prevents an unpriv application from changing
> mm.mm_start_code and mm.mm_end_code in the image, thus taking advantage
> of the privileged restore code to bypass the mmap_min_addr
> restrictions?
Well, you ca
On Sat 22-12-12 00:43:30, Andy Lutomirski wrote:
> On Sat, Dec 22, 2012 at 12:29 AM, Christoph Hellwig
> wrote:
> > NAK, we went through great trouble to get rid of the nasty layering
> > violation where the VM called file_update_time directly just a short
> > while ago, reintroducing that is a m
On 12/29/2012 10:32 PM, Olof Johansson wrote:
> On Fri, Dec 28, 2012 at 05:42:46PM -0700, Stephen Warren wrote:
>> From: Stephen Warren
>>
>> if_changed (used by the *.dts->*.dtc rule) rebuilds files if they aren't
>> contained in $(targets). (make V=2 indicates this). Add $(dtb-y) to
>> $(targets
On 12/31/2012 10:39 AM, Stephen Warren wrote:
> On 12/29/2012 10:32 PM, Olof Johansson wrote:
>> On Fri, Dec 28, 2012 at 05:42:46PM -0700, Stephen Warren wrote:
>>> From: Stephen Warren
>>>
>>> if_changed (used by the *.dts->*.dtc rule) rebuilds files if they aren't
>>> contained in $(targets). (m
Hello.
This series fixes the minor bug and cleanups the usage of add_utask()
and xol_alloc_area(). Plus it cleanups the initializaion of ->utask
in handle_swbp() paths.
Anton, this conflicts with your uretprobe patches, but I think we
should do this to avoid the code duplication. IOW, I consider
Currently only xol_get_insn_slot() does get_xol_area() + xol_alloc_area(),
but this will have more users and we do not want to copy-and-paste this
code. This patch simply moves xol_alloc_area() into get_xol_area() to
simplify the current and future code.
Signed-off-by: Oleg Nesterov
---
kernel/e
Rename add_utask() into get_utask() and change it to allocate on
demand to simplify the caller. Like get_xol_area() it will have
more users.
Signed-off-by: Oleg Nesterov
---
kernel/events/uprobes.c | 27 +--
1 files changed, 9 insertions(+), 18 deletions(-)
diff --git
pre_ssout()->xol_get_insn_slot() path is confusing and buggy. This patch
cleanups the code, the next one fixes the bug.
Change xol_get_insn_slot() to only allocate the slot and do nothing more,
move the initialization of utask->xol_vaddr/vaddr into pre_ssout().
Signed-off-by: Oleg Nesterov
---
pre_ssout() should do xol_free_insn_slot() if arch_uprobe_pre_xol()
fails, otherwise nobody will free the allocated slot.
Signed-off-by: Oleg Nesterov
---
kernel/events/uprobes.c |9 -
1 files changed, 8 insertions(+), 1 deletions(-)
diff --git a/kernel/events/uprobes.c b/kernel/eve
utask->xol_vaddr is either zero or valid, remove the bogus
IS_ERR_VALUE() check in xol_free_insn_slot().
Signed-off-by: Oleg Nesterov
---
kernel/events/uprobes.c |3 +--
1 files changed, 1 insertions(+), 2 deletions(-)
diff --git a/kernel/events/uprobes.c b/kernel/events/uprobes.c
index ad1
handle_swbp() does get_utask() before can_skip_sstep() for no reason,
we do not need ->utask if can_skip_sstep() succeeds.
Move get_utask() to pre_ssout() who actually starts to use it. Move
the initialization of utask->active_uprobe/state as well. This way
the whole initialization is consolidated
Move alloc_page() from xol_add_vma() to xol_alloc_area() to cleanup
the code. This separates the memory allocations and consolidates the
-EALREADY cleanups and the error handling.
Signed-off-by: Oleg Nesterov
---
kernel/events/uprobes.c | 32 +---
1 files changed, 1
Cho KyongHo wrote:
>
> notice: v6 patch-set is rebased on next/iommu-exynos branch of
> linux-samsung.git. This patch-set does not include 2 patches (05 and 06
> patches in v5 patch-se) because they alread exist already in the branch.
>
> The current exynos-iommu(System MMU) driver does not work
use module_pci_driver macro and simplify the module init and exit code
Signed-off-by: Devendra Naga
---
drivers/uio/uio_sercos3.c | 14 +-
1 file changed, 1 insertion(+), 13 deletions(-)
diff --git a/drivers/uio/uio_sercos3.c b/drivers/uio/uio_sercos3.c
index 81a10a5..5419832 1006
This patch is for the pagemap.h. This checks to see if the
page_size_int is 2, if not, set the value to 2, and return 1.
The code is under the double-dashed lines.
--
Signed-off-by: Christopher P. Sacchi chris.sac...@gmail.com
--- pagemap.h 2012-12-21 20:19:00.0 -0500
+++ pagemap.h 201
This patch is for the pagemap.h. This checks to see if the
page_size_int is 2, if not, set the value to 2, and return 1.
The code is under the double-dashed lines. It is for Kernel Version 3.8-rc1.
This is a rewrite.
--
Signed-off-by: Christopher P. Sacchi chris.sac...@gmail.com
--- pagemap.h 20
use devm_kzalloc and no need of free's at error path and unload
Signed-off-by: Devendra Naga
---
Please apply this after
changeid: 1fb4ec94e7e955a1e26bf81f2634e5be2fa5f1d5
[PATCH] uio: uio_sercos3: use module_pci_driver macro
sorry for sending as patch should be patch 2/2.
drivers/uio/uio_se
bookjovi wrote:
> [...] This mail is RFC for discuss on a new dynamic tracing tool, I
> name it ktap. (only experimental project now)
Welcome to the problem domain!
> [...]
> what ktap differentiates with Systemtap is:
> [...]
> 2). ktap have good portability, because it compile source file
On 12/26/2012 02:53 AM, Cho KyongHo wrote:
> This commit adds device tree support for System MMU.
>
> Signed-off-by: KyongHo Cho
Cc: devicetree-disc...@lists.ozlabs.org
Please note any patches adding new device tree bindings should be sent
to this mailing list. I have few comments, please see be
Hi Tony,
On Mon, Dec 31, 2012 at 03:04:59PM +1300, Tony Prisk wrote:
> This patch adds support for the Power Button keypad found on
> Wondermedia netbooks/tablets.
>
> Signed-off-by: Tony Prisk
> ---
> v2:
> Remove devicetree binding for keycode
> Add dependency on OF in Kconfig
> Move static va
In the privcmd Linux driver two checks in the functions
privcmd_ioctl_mmap and privcmd_ioctl_mmap_batch are not needed as they
are trying to enforce hypervisor-level access control. They should be
removed as they break secondary control domains when performing dom0
disaggregation. Xen itself provi
On Mon, 2012-12-31 at 12:37 -0800, Dmitry Torokhov wrote:
> Hi Tony,
>
> On Mon, Dec 31, 2012 at 03:04:59PM +1300, Tony Prisk wrote:
> > This patch adds support for the Power Button keypad found on
> > Wondermedia netbooks/tablets.
> >
> > Signed-off-by: Tony Prisk
> > ---
> > v2:
> > Remove dev
Quoting Cyrill Gorcunov (gorcu...@openvz.org):
> > The kernel makes the decision on what is valid via security_mmap_addr().
> > Assuming there are no security fears of an untrusted application
> > tricking some priviledged application to set up these maps the answer is
> > just calling security_mma
This patch adds support for the Power Button keypad found on
Wondermedia netbooks/tablets.
A keymap property is exposed to allowing defining the key
event to be generated when the power button is pressed.
Signed-off-by: Tony Prisk
---
CC: linux-kernel@vger.kernel.org
CC: linux-arm-ker...@lists.i
> From: Seth Jennings [mailto:sjenn...@linux.vnet.ibm.com]
> Subject: [PATCH 7/8] zswap: add to mm/
>
> zswap is a thin compression backend for frontswap. It receives
> pages from frontswap and attempts to store them in a compressed
> memory pool, resulting in an effective partial memory reclaim a
Eric Wong wrote:
> This patch seems to fix my issue with ppoll() being stuck on my
> SMP machine: http://article.gmane.org/gmane.linux.file-systems/70414
OK, it doesn't fix my issue, but it seems to make it harder-to-hit...
> The change to sock_poll_wait() in
> commit 626cf236608505d376e4799adb4
Hi,
Please find the latest report on new defect(s) that have been introduced to the
Linux Kernel found with Coverity SCAN.
Defect(s) Reported-by: Coverity Scan:
___
** CID 753114: Use after free (USE_AFTER_FREE)
/drivers/
The latest feature release Git v1.8.1 is now available at the
usual places.
The release tarballs are found at:
http://code.google.com/p/git-core/downloads/list
and their SHA-1 checksums are:
ac8dced9c3232c0ec6a88d04600a4d0eaf2ba4e3 git-1.8.1.tar.gz
a256fc56c89dc3c8d58b81a2c02dc89299f1f29b
On Mon, Dec 31, 2012 at 03:34:59AM +0200, Aaro Koskinen wrote:
> Check that the AGP aperture can be mapped. This follows a similar change
> done for Radeon (commit 365048ff, drm/radeon: AGP memory is only I/O if
> the aperture can be mapped by the CPU.).
>
> The patch fixes the following error see
From b41864867464bfe0e2d114528bc9b39e2d9f546e Mon Sep 17 00:00:00 2001
From: Nigel Cunningham
Date: Tue, 1 Jan 2013 13:03:50 +1100
Subject: [PATCH] Fix rbd use after free.
This patch addresses Coverity #753114.
The use of ceph_opts in rbd_add is currently confusing - there
are three possible ou
From b4a7ab768df17e1cda7d0ae8744e986215a644c3 Mon Sep 17 00:00:00 2001
From: Nigel Cunningham
Date: Tue, 1 Jan 2013 13:53:51 +1100
Subject: [PATCH] Remove unused variable in rbd_dev_probe_update_spec.
As an aside to the previous patch, remove the unused local
variable reply_buf in that function.
From 68e866b8eac534405ae16b79b7ffd9de05c11c67 Mon Sep 17 00:00:00 2001
From: Nigel Cunningham
Date: Tue, 1 Jan 2013 13:50:22 +1100
Subject: [PATCH] Fix uninitialised variable in rbd_dev_probe_update_spec.
The local variable ret can be used uninitialised in the error path
if the kstrdup at line 2
On Tue, Jan 1, 2013 at 1:55 AM, Sasha Levin wrote:
> Hi all,
>
> While fuzzing with trinity inside a KVM tools guest, running latest -next
> kernel,
> I've stumbled on the following hang:
>
> [ 7204.030178] INFO: task khugepaged:3257 blocked for more than 120 seconds.
> [ 7204.031043] "echo 0 > /
On Fri, 2012-12-28 at 02:32 +0100, Petr Holasek wrote:
> Introduces new sysfs boolean knob /sys/kernel/mm/ksm/merge_across_nodes
> which control merging pages across different numa nodes.
> When it is set to zero only pages from the same node are merged,
> otherwise pages from all nodes can be merg
On Tuesday 13 November 2012 01:20 AM, Thomas Gleixner wrote:
> On Wed, 7 Nov 2012, Vineet Gupta wrote:
>> + **
>> + * Inline ASM macros to read/write AUX Regs
>> + * Essentially invocation of lr/sr insns from "C"
>> + */
>> +
65 matches
Mail list logo