On Tue, Jul 10, 2018 at 04:04:55PM +0100, Al Viro wrote:
> First of all, I'm still not at all convinced that this "noaccount" thing is
> sane, especially since path_open() is exported. But that aside,
> __get_empty_filp()
> needs to be shot, just for the name and calling conventions alone.
>
> I
On Tue, Jul 10, 2018 at 10:17:36AM +1000, Stephen Rothwell wrote:
> --- a/fs/open.c
> +++ b/fs/open.c
> @@@ -731,7 -732,6 +721,7 @@@ static int do_dentry_open(struct file *
> static const struct file_operations empty_fops = {};
> int error;
>
> - WARN_ON(f->f_mode & ~FMODE_NOACCO
On Tue, Jun 19, 2018 at 10:40 AM, David Howells wrote:
> Stephen Rothwell wrote:
>
>> /* These sb flags are internal to the kernel */
>> #define MS_SUBMOUNT (1<<26)
>> -#define MS_NOREMOTELOCK (1<<27)
>> #define MS_NOSEC (1<<28)
>> #define MS_BORN (1<<29)
>> #define
Stephen Rothwell wrote:
> /* These sb flags are internal to the kernel */
> #define MS_SUBMOUNT (1<<26)
> -#define MS_NOREMOTELOCK (1<<27)
> #define MS_NOSEC (1<<28)
> #define MS_BORN (1<<29)
> #define MS_ACTIVE(1<<30)
Ummm... Can MS_NOREMOTELOCK be removed?
Hi all,
On Tue, 29 May 2018 11:30:35 +1000 Stephen Rothwell
wrote:
>
> Today's linux-next merge of the vfs tree got a conflict in:
>
> fs/read_write.c
>
> between commit:
>
> 63ea46a359b2 ("vfs: dedupe: extract helper for a single dedup")
>
> from the overlayfs tree and commit:
>
> 22
Hi all,
On Tue, 29 May 2018 11:30:35 +1000 Stephen Rothwell
wrote:
>
> Today's linux-next merge of the vfs tree got a conflict in:
>
> fs/read_write.c
>
> between commit:
>
> 63ea46a359b2 ("vfs: dedupe: extract helper for a single dedup")
>
> from the overlayfs tree and commit:
>
> 22
Hi all,
On Thu, 25 Jan 2018 14:31:55 +1100 Stephen Rothwell
wrote:
>
> Today's linux-next merge of the vfs tree got a conflict in:
>
> fs/dcache.c
>
> between commit:
>
> f9c34674bc60 ("vfs: factor out helpers d_instantiate_anon() and
> d_alloc_anon()")
>
> from the overlayfs tree and c
Hi all,
On Thu, 25 Jan 2018 14:31:55 +1100 Stephen Rothwell
wrote:
>
> + if (!disconnected) {
> -hlist_bl_lock(&tmp->d_sb->s_roots);
> -hlist_bl_add_head(&tmp->d_hash, &tmp->d_sb->s_roots);
> -hlist_bl_unlock(&tmp->d_sb->s_roots);
> ++hlist_
On Mon, Jul 25, 2016 at 2:30 AM, Al Viro wrote:
> On Mon, Jul 25, 2016 at 10:24:53AM +1000, Stephen Rothwell wrote:
>> Hi Al,
>>
>> Today's linux-next merge of the vfs tree got a conflict in:
>>
>> fs/overlayfs/super.c
>>
>> between commit:
>>
>> e2475b7276d0 ("ovl: check mounter creds on unde
On Mon, Jul 25, 2016 at 10:24:53AM +1000, Stephen Rothwell wrote:
> Hi Al,
>
> Today's linux-next merge of the vfs tree got a conflict in:
>
> fs/overlayfs/super.c
>
> between commit:
>
> e2475b7276d0 ("ovl: check mounter creds on underlying lookup")
>
> from the overlayfs tree and commit:
On Mon, May 2, 2016 at 3:08 AM, Al Viro wrote:
> On Mon, May 02, 2016 at 10:59:43AM +1000, Stephen Rothwell wrote:
>> Hi Al,
>>
>> Today's linux-next merge of the vfs tree got a conflict in:
>>
>> fs/overlayfs/super.c
>>
>> between commit:
>>
>> d478d6a8b8b7 ("ovl: ignore permissions on underl
On Mon, May 02, 2016 at 02:08:39AM +0100, Al Viro wrote:
> Should use lookup_one_len_unlocked(), actually. lookup_hash() is
> a microoptimization, losing a lot more on excessive i_mutex contention.
> Either variant works, though.
PS: if anybody has a better name for lookup_one_len_unlocked(), I'
On Mon, May 02, 2016 at 10:59:43AM +1000, Stephen Rothwell wrote:
> Hi Al,
>
> Today's linux-next merge of the vfs tree got a conflict in:
>
> fs/overlayfs/super.c
>
> between commit:
>
> d478d6a8b8b7 ("ovl: ignore permissions on underlying lookup")
>
> from the overlayfs tree and commit:
13 matches
Mail list logo