Re: [RFC PATCH 04/11] Add a function to start/reduce a timer

2017-11-08 Thread David Howells
Thomas Gleixner wrote: > > +extern int reduce_timer(struct timer_list *timer, unsigned long expires); > > For new timer functions we really should use the timer_() > convention. The historic naming convention is horrible. > > Aside of that timer_reduce() is kinda ugly but I failed to come u

Re: [RFC PATCH 04/11] Add a function to start/reduce a timer

2017-10-20 Thread Thomas Gleixner
On Fri, 1 Sep 2017, David Howells wrote: > Add a function, similar to mod_timer(), that will start a timer it isn't s/it /if it / > running and will modify it if it is running and has an expiry time longer > than the new time. If the timer is running with an expiry time that's the > same or soo

[RFC PATCH 04/11] Add a function to start/reduce a timer

2017-09-01 Thread David Howells
Add a function, similar to mod_timer(), that will start a timer it isn't running and will modify it if it is running and has an expiry time longer than the new time. If the timer is running with an expiry time that's the same or sooner, no change is made. The function looks like: int red