在 2024/10/30 18:49, Matthieu Baerts 写道:
Hi Tao Chen,
Thank you for having shared this patch.
On 30/10/2024 11:01, Tao Chen wrote:
Fix compile error when MPTCP feature not support, though eBPF core check
already done which seems invalid in this situation, the error info like:
progs
sts/bpf: Add MPTCP test base")
Signed-off-by: Tao Chen
---
.../testing/selftests/bpf/progs/mptcp_sock.c | 42 ++-
1 file changed, 32 insertions(+), 10 deletions(-)
diff --git a/tools/testing/selftests/bpf/progs/mptcp_sock.c
b/tools/testing/selftests/bpf/progs/mptcp_sock.c
, remove it. It will format the code.
These all make the readability of the code become better.
Signed-off-by: Tao Chen
---
v2:
- Replace all DPRINTK with pr sentences, and get rid of DPRINTK macro.
---
drivers/block/xen-blkback/blkback.c | 62 ++---
drivers/block
readability of the code become better.
Signed-off-by: Tao Chen
---
drivers/block/xen-blkback/blkback.c | 62 ++---
drivers/block/xen-blkback/common.h | 6
drivers/block/xen-blkback/xenbus.c | 18 ++-
3 files changed, 42 insertions(+), 44 deletions
The blkback name is like blkback.domid.xvd[a-z], if domid has four digits
(means larger than 1000), then the backmost xvd wouldn't be fully shown.
Define a BLKBACK_NAME_LEN macro to be 20, enlarge the array size of
blkback name, so it will be fully shown in any case.
Signed-off-by: Tao
igned-off-by: Tao Chen
---
drivers/block/xen-blkback/xenbus.c | 7 +--
1 file changed, 5 insertions(+), 2 deletions(-)
diff --git a/drivers/block/xen-blkback/xenbus.c
b/drivers/block/xen-blkback/xenbus.c
index e3afe97..0289e21 100644
--- a/drivers/block/xen-blkback/xenbus.c
+++ b/drivers/bloc
Add the {xen-pvscsi: } prefix in pr_fmt and remove DPRINTK, then
replace all DPRINTK with pr_debug.
Also fixed up some comments just as eliminate redundant whitespace
and format the code.
These will make the code easier to read.
Signed-off-by: Tao Chen
---
drivers/xen/xen-scsiback.c | 75
Add the {xen-pvscsi: } prefix in pr_fmt and remove DPRINTK, then
replace all DPRINTK with pr_debug.
Also fixed up some comments just as eliminate redundant whitespace
and format the code.
These will make the code easier to read.
Signed-off-by: Tao Chen
---
drivers/xen/xen-scsiback.c | 72
Defined the string of {xen-pvscsi: } as DRV_PFX, then use it in the pr
sentences and DPRINTK.
Also fixed up some comments just as eliminate redundant white spaces and format
the code.
These will make the code easier to read.
Signed-off-by: Tao Chen
---
drivers/xen/xen-scsiback.c | 70
Replace the string of {xen-pvscsi:} in the pr sentences with DRV_PFX,
it makes the code easier to read.
Signed-off-by: Tao Chen
---
drivers/xen/xen-scsiback.c | 67 +++---
1 file changed, 34 insertions(+), 33 deletions(-)
diff --git a/drivers/xen/xen
10 matches
Mail list logo