On Wed, Apr 04, 2018 at 04:49:07PM -0700, Deepak Rawat wrote:
> With damage property in drm_plane_state, this patch adds helper iterator
> to traverse the damage clips. Iterator will return the damage rectangles
> in framebuffer, plane or crtc coordinates as need by driver
> implementation.
>
> Si
Thanks!
Reviewed-by: Sinclair Yeh
On Wed, Mar 07, 2018 at 11:33:22PM +0530, Himanshu Jha wrote:
> Use kasprintf instead of combination of kmalloc and sprintf. Also,
> remove the local variables used for storing the string length as they
> are not required now.
>
> Signed-off-b
This looks okay to me.
On Mon, Dec 18, 2017 at 07:26:03PM -0500, Woody Suwalski wrote:
> The 4.15 drm_atomic_helper driver shows a warning during boot (both 32 and
> 64 bit x86)
> It is caused by a mismatch between the result of vmw_enable_vblank() and
> what the drm_atomic_helper expects:
> /.
Hi Woody,
On Wed, Nov 22, 2017 at 04:05:50PM -0500, Woody Suwalski wrote:
> The 4.15 vmwgfx driver shows a warning during boot (32 bit x86)
> It is caused by a mismatch between the result of vmw_enable_vblank() and
> what the drm_atomic_helper expects:
> /...
> ret = drm_crtc_vblank_get(crtc
This looks okay to me. Although we should change eaction->tv_* type
to 64-bit as well.
I'll roll this in to our next pull request.
thanks,
Sinclair
On Mon, Nov 27, 2017 at 12:16:19PM +0100, Arnd Bergmann wrote:
> DRM_VMW_EVENT_FENCE_SIGNALED (struct drm_vmw_event_fence) and
> DRM_EVENT_VBLANK
On Wed, Aug 30, 2017 at 10:30:24AM +0200, Daniel Vetter wrote:
> On Wed, Aug 30, 2017 at 08:21:46AM +0200, Thomas Hellstrom wrote:
> > On 08/30/2017 07:47 AM, Arvind Yadav wrote:
> > > vmw_fence_ops are not supposed to change at runtime. Functions
> > > "dma_fence_init" working with const vmw_fenc
173f0616 ("drm/vmwgfx: Don't use drm_irq_[un]install")
This one is Reviewed-by: Sinclair Yeh
> ef369904aaf7 ("drm/vmwgfx: Move irq bottom half processing to threads")
> 65b97a2bec2f ("drm/vmwgfx: Restart command buffers after errors")
> 5f55b
Thanks. Queued.
On Sat, Jul 15, 2017 at 12:44:53PM +0530, Arvind Yadav wrote:
> pci_device_id are not supposed to change at runtime. All functions
> working with pci_device_id provided by work with
> const pci_device_id. So mark the non-const structs as const.
>
> File size before:
>text
On Fri, Jul 14, 2017 at 10:28:29PM +0200, Arnd Bergmann wrote:
> On Fri, Jul 14, 2017 at 9:23 PM, Linus Torvalds
> wrote:
> > On Fri, Jul 14, 2017 at 12:21 PM, Linus Torvalds
> > wrote:
> >>
> >> NAK. This takes unintentionally insane code and turns it intentionally
> >> insane. Any non-zero retu
Looks good. Thanks.
I've queued this for my next pull request.
On Sun, Jul 02, 2017 at 01:26:55PM +0530, Arvind Yadav wrote:
> ttm_place are not supposed to change at runtime. All functions
> working with ttm_place provided by work
> with const ttm_place. So mark the non-const structs as const.
Thanks. Reviewed and queued.
On Sat, May 27, 2017 at 07:52:30PM +0100, Colin King wrote:
> From: Colin Ian King
>
> Trivial fix to spelling mistake in DRM_ERROR error message.
>
> Signed-off-by: Colin Ian King
> ---
> drivers/gpu/drm/vmwgfx/vmwgfx_surface.c | 2 +-
> 1 file changed, 1 insert
vmwgfx part: Reviewed-by: Sinclair Yeh
On Wed, May 17, 2017 at 09:39:11PM -0400, Robert Foss wrote:
> Add DRM_MODE_ROTATE_ and DRM_MODE_REFLECT_ defines to the UAPI
> as a convenience.
>
> Ideally the DRM_ROTATE_ and DRM_REFLECT_ property ids are looked up
> through the
Hi,
On Wed, May 10, 2017 at 12:31:39PM +0200, m...@ox.io wrote:
>
> > Thomas Hellstrom hat am 10. Mai 2017 um 10:35 geschrieben:
> >
> > Hi,
> >
> > Thanks for reporting.
>
> I would have reported earlier if it had not taken 3 days on the vm to bisect.
>
> > I think there is a fix for this ei
Thanks Vladis!
Reviewed-by: Sinclair Yeh
On Thu, Apr 06, 2017 at 02:33:40PM +0200, Vladis Dronov wrote:
> The 'req->mip_levels' parameter in vmw_gb_surface_define_ioctl() is
> a user-controlled 'uint32_t' value which is used as a loop count limit.
> This can lead
Minor nits, otherwise the vmwgfx part,
Reviewed-by: Sinclair Yeh
On Tue, Apr 18, 2017 at 06:17:00PM -0600, Logan Gunthorpe wrote:
> Seeing the kunmap_atomic dma_buf_op shares the same name with a macro
s^
> in higmem.h, the former can be aliased if a
Thanks for this. This and "drm/vmwgfx: merge fixup for set_config API change":
Reviewed-by: Sinclair Yeh
On Mon, Apr 03, 2017 at 01:31:29PM +1000, Stephen Rothwell wrote:
> Hi all,
>
> After merging the drm-misc tree, today's linux-next build (x86_64
> all
Hi Vladis,
On Thu, Mar 30, 2017 at 12:27:12PM +0200, Vladis Dronov wrote:
> The 'req->mip_levels' parameter in vmw_gb_surface_define_ioctl() is
> a user-controlled 'uint32_t' value which is used as a loop count limit.
> This can lead to a kernel lockup and DoS. Add check for 'req->mip_levels'.
>
Hi,
thank you for this patch. Murray McAllister reported this one a couple
of months ago, and this is already in our queue.
Sinclair
On Fri, Mar 24, 2017 at 04:37:10PM +0100, Vladis Dronov wrote:
> In vmw_surface_define_ioctl(), a num_sizes parameter is assigned a
> user-controlled value which
For drm/vmwgfx: Acked-by: Sinclair Yeh
On Tue, Feb 28, 2017 at 04:55:54AM -0800, Joe Perches wrote:
> Use a more common logging style.
>
> Miscellanea:
>
> o Coalesce formats and realign arguments
> o Neaten a few macros now using pr_
>
> Signed-off-by: Joe Perches
On Fri, Feb 24, 2017 at 11:06:03AM -0800, Sinclair Yeh wrote:
> Hi Oyvind,
>
> Thanks for looking at this.
>
> At this moment, I don't really see a benefit one way or anther, so
> I am going to stick with the macro version for now, changing the one
> remaining module_p
Hi Oyvind,
Thanks for looking at this.
At this moment, I don't really see a benefit one way or anther, so
I am going to stick with the macro version for now, changing the one
remaining module_param_named() you mentioned to using the macros to
keep things consistent.
If one day we have a paramter
>
> >>Cc: sta...@vger.kernel.org
> >>Signed-off-by: Michel Dänzer
> >Reviewed-by: Thomas Hellstrom
>
> Reviewed-by: Christian König .
Reviewed-by: Sinclair Yeh
>
> >
> >>---
> >> drivers/gpu/drm/ttm/ttm_bo.c | 4 ++--
> >>
Reviewed-by: Sinclair Yeh
thanks!
On Fri, Dec 16, 2016 at 05:04:02PM -0800, Kees Cook wrote:
> Prepare to mark sensitive kernel structures for randomization by making
> sure they're using designated initializers. These were identified during
> allyesconfig builds of x86, arm, a
Good catch.
Reviewed-by: Sinclair Yeh
On Tue, Nov 29, 2016 at 07:49:19AM +0100, Christophe JAILLET wrote:
> 'vmw_cotable_alloc()' returns an error pointer on error, not NULL.
> Propagate the error code, instead of returning -ENOMEM unconditionally
>
> Signed-off-
Looks good to me, thanks!
I'll incorporate this into the next pull request.
Reviewed-by: Sinclair Yeh
On Wed, Nov 16, 2016 at 03:19:31PM +0100, Arnd Bergmann wrote:
> gcc-7 warns about slightly suspicious code in vmw_cmd_invalid:
>
> drivers/gpu/drm/vmwgfx/vmwgfx_execbuf.
Thanks!
Reviewed-by: Sinclair Yeh
On Tue, Nov 08, 2016 at 05:30:31PM +0530, Ravikant Bijendra Sharma wrote:
> From: Ravikant B Sharma
>
> Replace direct comparisons to NULL i.e.
> 'x == NULL' with '!x'. As per coding standard.
>
> Signed-off-by: Ravik
Thomas has already acked the earlier version, but in case you need
it for this one, too.
vmwgfx portion: Acked-by: Sinclair Yeh
On Mon, Nov 07, 2016 at 12:48:09AM +, Eric Engestrom wrote:
> Fixes: 90844f00049e9f42573fd31d7c32e8fd31d3fd07
>
> drm: make drm_get_format_name th
This series looks good to me: Reviewed-by: Sinclair Yeh
Thanks!
On Fri, Sep 23, 2016 at 06:39:04PM +0200, SF Markus Elfring wrote:
> From: Markus Elfring
> Date: Fri, 23 Sep 2016 17:53:49 +0200
> MIME-Version: 1.0
> Content-Type: text/plain; charset=UTF-8
> Content-Transfer
Reviewed-by: Sinclair Yeh
On Wed, Sep 07, 2016 at 11:08:45AM -0700, Kees Cook wrote:
> A custom allocator without __GFP_COMP that copies to userspace has been
> found in vmw_execbuf_process[1], so this disables the page-span checker
> by placing it behind a CONFIG for future work w
Reviewed-by: Sinclair Yeh
On Tue, Aug 02, 2016 at 06:50:25PM +0800, Baole Ni wrote:
> I find that the developers often just specified the numeric value
> when calling a macro which is defined with a parameter for access permission.
> As we know, these numeric value for access permission
Looks good. Thanks!
Reviewed-by: Sinclair Yeh
On Fri, Jul 22, 2016 at 01:45:40PM +0200, SF Markus Elfring wrote:
> From: Markus Elfring
> Date: Fri, 22 Jul 2016 13:31:00 +0200
>
> The vfree() function performs also input parameter validation.
> Thus the test around the cal
On Thu, Mar 31, 2016 at 09:30:37AM -0700, Greg KH wrote:
> On Thu, Mar 31, 2016 at 07:39:53AM -0700, Sinclair Yeh wrote:
> > Hi,
> >
> > Does any one know when this series will be applied?
>
> No idea, it's not going through my tree, as I don't have these
Hi,
Does any one know when this series will be applied?
Sinclair
On Mon, Feb 08, 2016 at 11:41:57AM -0800, Greg KH wrote:
> On Tue, Jan 19, 2016 at 01:46:05PM -0800, Sinclair Yeh wrote:
> > Updated VMWARE_BALLOON_CMD to use the common VMW_PORT macro.
> > Doing this rather tha
Updated the VMWARE_PORT macro to use the new VMW_PORT
macro. Doing this instead of replacing all existing
instances of VMWARE_PORT to minimize code change.
Signed-off-by: Sinclair Yeh
Reviewed-by: Thomas Hellstrom
Reviewed-by: Alok N Kataria
Cc: Thomas Gleixner
Cc: Ingo Molnar
Cc: "H.
required when accessing
the port in this manner.
Signed-off-by: Sinclair Yeh
Reviewed-by: Thomas Hellstrom
Cc: pv-driv...@vmware.com
Cc: linux-graphics-maintai...@vmware.com
Cc: virtualizat...@lists.linux-foundation.org
Cc: linux-kernel@vger.kernel.org
Cc: Greg Kroah-Hartman
---
drivers/input
Updated VMWARE_BALLOON_CMD to use the common VMW_PORT macro.
Doing this rather than replacing all instances of VMWARE_BALLOON_CMD
to minimize code change.
Signed-off-by: Sinclair Yeh
Reviewed-by: Thomas Hellstrom
Reviewed-by: Alok N Kataria
Cc: pv-driv...@vmware.com
Cc: Xavier Deguillard
Cc
Updated the VMMOUSE macro to use the new VMW_PORT macro. Doing
this instead of replacing all existing instances of VMWMOUSE
to minimize code change.
Signed-off-by: Sinclair Yeh
Reviewed-by: Thomas Hellstrom
Reviewed-by: Alok N Kataria
Cc: pv-driv...@vmware.com
Cc: linux-graphics-maintai
We should no longer have mailing address of Free Software
Foundation in the copyright header. Since this patch series
touches this file, taking this opportunity to fix the header.
Signed-off-by: Sinclair Yeh
Reviewed-by: Thomas Hellstrom
Reviewed-by: Alok N Kataria
Cc: pv-driv...@vmware.com
These macros will be used by multiple VMWare modules for handling
host communication.
Signed-off-by: Sinclair Yeh
Reviewed-by: Thomas Hellstrom
Reviewed-by: Alok N Kataria
Cc: Thomas Gleixner
Cc: Ingo Molnar
Cc: "H. Peter Anvin"
Cc: Alok Kataria
Cc: linux-kernel@vger.ker
Thanks Peter.
On Tue, Dec 01, 2015 at 02:49:11PM -0800, H. Peter Anvin wrote:
> On 12/01/15 14:18, Sinclair Yeh wrote:
> > These macros will be used by multiple VMWare modules for handling
> > host communication.
>
> > + __asm__
On Wed, Dec 02, 2015 at 10:45:28AM -0800, Greg Kroah-Hartman wrote:
> On Wed, Dec 02, 2015 at 09:26:34AM -0800, Dmitry Torokhov wrote:
> > On Wed, Dec 02, 2015 at 07:31:24AM -0800, Greg Kroah-Hartman wrote:
> > > On Tue, Dec 01, 2015 at 06:21:06PM -0800, Sinclair Yeh wrote:
>
On Wed, Dec 02, 2015 at 07:31:24AM -0800, Greg Kroah-Hartman wrote:
> On Tue, Dec 01, 2015 at 06:21:06PM -0800, Sinclair Yeh wrote:
> > On Tue, Dec 01, 2015 at 04:04:08PM -0800, Greg Kroah-Hartman wrote:
> > > On Tue, Dec 01, 2015 at 02:54:20PM -0800, Sinclair Yeh
On Tue, Dec 01, 2015 at 04:04:08PM -0800, Greg Kroah-Hartman wrote:
> On Tue, Dec 01, 2015 at 02:54:20PM -0800, Sinclair Yeh wrote:
> > Hi,
> >
> > On Tue, Dec 01, 2015 at 02:45:27PM -0800, Dmitry Torokhov wrote:
> > > On Tue, Dec 1, 2015 at 2:32 PM, S
Thanks! Done.
On Tue, Dec 01, 2015 at 02:38:01PM -0800, Xavier Deguillard wrote:
> Hey Sinclair,
>
> On Tue, Dec 01, 2015 at 02:18:52PM -0800, Sinclair Yeh wrote:
> > +#define VMWARE_BALLOON_CMD(cm
Hi,
On Tue, Dec 01, 2015 at 02:30:05PM -0800, Dmitry Torokhov wrote:
> Hi Sinclair,
>
> On Tue, Dec 1, 2015 at 2:18 PM, Sinclair Yeh wrote:
> > Port reservation is not required.
>
> You need to expand on why we do not need to reserve port.
Thomas gave me this input ear
Hi,
On Tue, Dec 01, 2015 at 02:45:27PM -0800, Dmitry Torokhov wrote:
> On Tue, Dec 1, 2015 at 2:32 PM, Sinclair Yeh wrote:
> > Hi,
> >
> >> > */
> >> > -#define VMMOU
Hi,
On Tue, Dec 01, 2015 at 02:24:14PM -0800, Dmitry Torokhov wrote:
> On Tue, Dec 01, 2015 at 02:18:49PM -0800, Sinclair Yeh wrote:
> > v2:
> > Instead of replacing existing VMMOUSE defines, only modify enough
> > to use the new VMW_PORT define.
> >
> > v3:
&g
v2:
Instead of replacing all existing instances of VMWARE_PORT
with VMW_PORT, update VMWARE_PORT to use the new VMW_PORT.
v3:
Using updated VMWARE_PORT() macro, which needs hypervisor magic in the
parameter
Signed-off-by: Sinclair Yeh
Reviewed-by: Thomas Hellstrom
Reviewed-by: Alok N Kataria
v2:
Instead of replacing existing VMMOUSE defines, only modify enough
to use the new VMW_PORT define.
v3:
Use updated VMWARE_PORT() which requires hypervisor magic as an added
parameter
Signed-off-by: Sinclair Yeh
Reviewed-by: Thomas Hellstrom
Reviewed-by: Alok N Kataria
Cc: pv-driv
We should no longer have mailing address of Free Software
Foundation in the copyright header. Since this patch series
touches this file, taking this opportunity to fix the header.
Signed-off-by: Sinclair Yeh
Reviewed-by: Thomas Hellstrom
Reviewed-by: Alok N Kataria
Cc: pv-driv...@vmware.com
Port reservation is not required. Furthermore, this port is shared
by other VMware services for host-side communication.
Signed-off-by: Sinclair Yeh
Reviewed-by: Thomas Hellstrom
Cc: pv-driv...@vmware.com
Cc: linux-graphics-maintai...@vmware.com
Cc: virtualizat...@lists.linux-foundation.org
Cc
Signed-off-by: Sinclair Yeh
Reviewed-by: Thomas Hellstrom
Reviewed-by: Alok N Kataria
Cc: pv-driv...@vmware.com
Cc: Xavier Deguillard
Cc: linux-kernel@vger.kernel.org
Cc: virtualizat...@lists.linux-foundation.org
---
drivers/misc/vmw_balloon.c | 29 -
1 file
These macros will be used by multiple VMWare modules for handling
host communication.
v2:
* Keeping only the minimal common platform defines
* added vmware_platform() check function
v3:
* Added new field to handle different hypervisor magic values
Signed-off-by: Sinclair Yeh
Reviewed-by
Reviewed-by: Sinclair Yeh
On Wed, Nov 25, 2015 at 09:12:15PM +0800, Geliang Tang wrote:
> WARN_ON() takes a condition rather than a format string. This patch
> converted WARN_ON() to WARN() instead.
>
> Signed-off-by: Geliang Tang
> ---
> drivers/gpu/drm/vmwgfx/vmwgfx_fifo.
Reviewed-by: Sinclair Yeh
On Sat, Sep 19, 2015 at 12:32:24AM +0200, Christian Engelmayer wrote:
> Function vmw_kms_helper_dirty() uses the uninitialized variable ret as
> return value. Make the result deterministic and directly return as the
> variable is unused anyway. Detected by Cov
Good catch!
Reviewed-by: Sinclair Yeh
On Sat, Sep 19, 2015 at 12:31:10AM +0200, Christian Engelmayer wrote:
> Function vmw_cotable_unbind() uses the uninitialized variable ret as
> return value. Make the result deterministic and directly return as
> the variable is unused anyway. De
This patch: Reviewed-by: Sinclair Yeh
On Fri, Jul 31, 2015 at 02:08:24PM +0530, Viresh Kumar wrote:
> IS_ERR(_OR_NULL) already contain an 'unlikely' compiler flag and there
> is no need to do that again from its callers. Drop it.
>
> Signed-off-by: Viresh Kumar
> -
Reviewed-by: Sinclair Yeh
On Thu, Mar 12, 2015 at 03:42:34AM +0800, kbuild test robot wrote:
>
> Signed-off-by: Fengguang Wu
> ---
> vmwgfx_kms.c |2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/gpu/drm/vmwgfx/vmwgfx_kms.c
>
58 matches
Mail list logo