This patch fixes the following checkpatch.pl warning
- EXPORT_SYMBOL(foo); should immediately follow its function/variable
Signed-off-by: Shiva Kerdel
---
drivers/staging/fbtft/fbtft-core.c | 25 +++--
1 file changed, 15 insertions(+), 10 deletions(-)
diff --git a/drivers
the future.
Thanks,
S. Kerdel
On 03/12/17 04:00, Tobin C. Harding wrote:
On Sun, Mar 12, 2017 at 03:29:59AM +0100, Shiva Kerdel wrote:
Fix prefer kernel type 'u8' over 'uint8_t' checks.
Signed-off-by: Shiva Kerdel
---
drivers/staging/ks7010/ks_hostif.c | 4 +-
drivers/stag
Fix prefer kernel type 'u16' over 'uint16_t' checks.
Signed-off-by: Shiva Kerdel
---
drivers/staging/ks7010/ks_hostif.c | 20 +++---
drivers/staging/ks7010/ks_hostif.h | 134 ++---
2 files changed, 77 insertions(+), 77 deletions(-)
diff --g
Fix prefer kernel type 'u32' over 'uint32_t' checks.
Signed-off-by: Shiva Kerdel
---
drivers/staging/ks7010/ks_hostif.c | 18 +-
drivers/staging/ks7010/ks_hostif.h | 30 +++---
2 files changed, 24 insertions(+), 24 deletions(-)
Fix prefer kernel type 'u8' over 'uint8_t' checks.
Signed-off-by: Shiva Kerdel
---
drivers/staging/ks7010/ks_hostif.c | 4 +-
drivers/staging/ks7010/ks_hostif.h | 114 +--
drivers/staging/ks7010/ks_wlan_net.c | 2 +-
3 files changed,
Braces should be used on all arms of these statements (CHECK)..
Signed-off-by: Shiva Kerdel
---
drivers/staging/ks7010/ks_hostif.c | 6 --
drivers/staging/ks7010/ks_wlan_net.c | 42 +++-
2 files changed, 31 insertions(+), 17 deletions(-)
diff --git a
Changed bit swifting operators to BIT macros (preferred),
This change will also solve the preferred space surrounding
the operator checks.
Signed-off-by: Shiva Kerdel
---
drivers/staging/ks7010/ks_hostif.h | 20 ++--
drivers/staging/ks7010/ks_wlan.h | 30
Spaces should be added around operators to improve readability
and are required in some cases.
Signed-off-by: Shiva Kerdel
---
drivers/staging/ks7010/ks_hostif.c | 2 +-
drivers/staging/ks7010/ks_hostif.h | 64 +-
drivers/staging/ks7010/ks_wlan.h
Multiple blank lines shouldn't be used.
Signed-off-by: Shiva Kerdel
---
drivers/staging/ks7010/ks7010_sdio.c | 1 -
drivers/staging/ks7010/ks_wlan_net.c | 2 --
2 files changed, 3 deletions(-)
diff --git a/drivers/staging/ks7010/ks7010_sdio.c
b/drivers/staging/ks7010/ks7010_sdio.c
A blank line should be added after function/struct/union/enum
declarations.
Signed-off-by: Shiva Kerdel
---
drivers/staging/ks7010/ks7010_sdio.h | 1 +
drivers/staging/ks7010/ks_wlan.h | 1 +
2 files changed, 2 insertions(+)
diff --git a/drivers/staging/ks7010/ks7010_sdio.h
b/drivers
Removing unnecessary blank lines around braces to solve CHECKS.
Signed-off-by: Shiva Kerdel
---
drivers/staging/ks7010/ks_hostif.c | 11 ---
drivers/staging/ks7010/ks_wlan.h | 1 -
drivers/staging/ks7010/ks_wlan_net.c | 5 -
3 files changed, 17 deletions(-)
diff --git a
On Tue, Dec 06, 2016 at 09:59:58AM +0100, Shiva Kerdel wrote:
In most cases, usleep_range is better than udelay, as the precise wakeup
from udelay is unnecessary.
But, udelay does something different than usleep, are you sure you
should be giving up the cpu at this point in time?
Are you
In most cases, usleep_range is better than udelay, as the precise wakeup
from udelay is unnecessary.
usleep_range gives a much better chance of coalescing processor wakeups.
Signed-off-by: Shiva Kerdel
---
Changes for v2:
- Squashed the two commits to one patch.
drivers/staging/dgnc
In most cases, usleep_range is better than udelay, as the precise wakeup
from udelay is unnecessary.
usleep_range gives a much better chance of coalescing processor wakeups.
Signed-off-by: Shiva Kerdel
---
drivers/staging/dgnc/dgnc_neo.c | 10 +-
1 file changed, 5 insertions(+), 5
In most cases, usleep_range is better than udelay, as the precise wakeup
from udelay is unnecessary.
usleep_range gives a much better chance of coalescing processor wakeups.
Signed-off-by: Shiva Kerdel
---
drivers/staging/dgnc/dgnc_cls.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions
The indent code blocks of the else statements were unnecessary
and are better written without them.
Signed-off-by: Shiva Kerdel
---
drivers/staging/rtl8712/rtl871x_ioctl_linux.c | 4 ++--
drivers/staging/rtl8712/rtl871x_mlme.c| 4 ++--
2 files changed, 4 insertions(+), 4 deletions
Fixed spaces around operators to fix their coding style issues.
Signed-off-by: Shiva Kerdel
---
drivers/staging/wlan-ng/prism2mgmt.c | 14 +++---
1 file changed, 7 insertions(+), 7 deletions(-)
diff --git a/drivers/staging/wlan-ng/prism2mgmt.c
b/drivers/staging/wlan-ng/prism2mgmt.c
After following a discussion about the used integer types Dan Carpenter
pointed out that 'int' types should be used over the current change to
's16'. The reason for this is to have an upper bound instead of overflowing
the 's16' so we could still remove devices
-Original Message-
From: Dan Carpenter [mailto:dan.carpen...@oracle.com]
Sent: Monday, November 14, 2016 4:06 AM
To: Stuart Yoder
Cc: Shiva Kerdel ; de...@driverdev.osuosl.org;
gre...@linuxfoundation.org; linux-
ker...@vger.kernel.org; Nipun Gupta ; tred...@nvidia.com;
Laurentiu
Follow the kernel type preferrences of using 's32' over 'int32_t'.
Signed-off-by: Shiva Kerdel
Acked-by: Stuart Yoder
---
Changes for v2:
- None
Changes for v3:
- None
Changes for v4:
- corrected patch version number.
Changes for v5:
- version tag was missin
Follow the kernel type preferrences of using 's16' over 'int16_t'.
Signed-off-by: Shiva Kerdel
Acked-by: Stuart Yoder
---
Changes for v2:
- corrected an error in the log message, wrote 's32' instead of 's16'.
Changes for v3:
- added the missing an
Follow the kernel type preferrences of using 's16' over 'int16_t'.
Signed-off-by: Shiva Kerdel
Acked-by: Stuart Yoder
---
Changes for v2:
- corrected an error in the log message, wrote 's32' instead of 's16'.
Changes for v3:
- added the missing an
Follow the kernel type preferrences of using 's32' over 'int32_t'.
Signed-off-by: Shiva Kerdel
Acked-by: Stuart Yoder
---
Changes for v2:
- None
Changes for v3:
- None
Changes for v4:
- corrected patch version number.
drivers/staging/fsl-mc/include/mc.h | 2 +
Follow the kernel type preferrences of using 's32' over 'int32_t'.
Signed-off-by: Shiva Kerdel
Acked-by: Stuart Yoder
---
drivers/staging/fsl-mc/include/mc.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/fsl-mc/include/mc.h
b/dr
Follow the kernel type preferrences of using 's16' over 'int16_t'.
Signed-off-by: Shiva Kerdel
Acked-by: Stuart Yoder
---
Changes for v2:
- corrected an error in the log message, wrote 's32' instead of 's16'.
Changes for v3:
- added the missing
I corrected the log message because I wrote 's32' instead of 's16' in
this patch (confused with the other one that I sent too).
Thank you for your guidance,
Shiva Kerdel
On 11/10/16 15:20, Greg KH wrote:
On Thu, Nov 10, 2016 at 03:09:07PM +0100, Shiva Kerdel wrote:
Fo
Follow the kernel type preferrences of using 's16' over 'int16_t'.
Signed-off-by: Shiva Kerdel
Acked-by: Stuart Yoder
---
drivers/staging/fsl-mc/include/mc-bus.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/fsl-mc/include/mc-bus.
Follow the kernel type preferrences of using 's32' over 'int32_t'.
Signed-off-by: Shiva Kerdel
Acked-by: Stuart Yoder
---
drivers/staging/fsl-mc/include/mc.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/fsl-mc/include/mc.h
b/dr
Follow the kernel type preferrences of using 's32' over 'int32_t'.
Signed-off-by: Shiva Kerdel
Acked-by: Stuart Yoder
---
drivers/staging/fsl-mc/include/mc.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/fsl-mc/include/mc.h
b/dr
Follow the kernel type preferrences of using 's32' over 'int16_t'.
Signed-off-by: Shiva Kerdel
Acked-by: Stuart Yoder
---
drivers/staging/fsl-mc/include/mc-bus.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/fsl-mc/include/mc-bus.
eally clear to me at the beginning.
I hope that you could still use these patches and I am trying to avoid
misunderstandings like these.
Do I still need to resend them and is there anything left for me to do
with these?
Best regards,
Shiva Kerdel
On 11/10/16 13:24, Greg KH wrote:
On Tue, N
Replaced decimal permissions with 4 digit octal to solve checkpatch errors.
Signed-off-by: Shiva Kerdel
---
drivers/staging/xgifb/XGI_main_26.c | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/xgifb/XGI_main_26.c
b/drivers/staging/xgifb/XGI_main_26.c
Follow the kernel type preferrences of using 's32' over 'int32_t'.
Signed-off-by: Shiva Kerdel
---
drivers/staging/fsl-mc/include/mc.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/fsl-mc/include/mc.h
b/drivers/staging/fsl-mc/includ
Follow the kernel type preferrences of using 's16' over 'int16_t'.
Signed-off-by: Shiva Kerdel
---
drivers/staging/fsl-mc/include/mc-bus.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/fsl-mc/include/mc-bus.h
b/drivers/staging/fsl
Follow the kernel type preferrences of using 'u16' over 'uint16_t'.
Signed-off-by: Shiva Kerdel
---
drivers/staging/fsl-mc/bus/dpmcp.h | 30 +++---
1 file changed, 15 insertions(+), 15 deletions(-)
diff --git a/drivers/staging/fsl-mc/bus/dpmcp.h
b
Follow the kernel type preferrences of using 'u8' over 'uint8_t'.
Signed-off-by: Shiva Kerdel
---
drivers/staging/fsl-mc/bus/dpmcp.h | 18 +-
1 file changed, 9 insertions(+), 9 deletions(-)
diff --git a/drivers/staging/fsl-mc/bus/dpmcp.h
b/drivers/stagin
Follow the kernel type preferrences of using 'u32' over 'uint32_t'.
Signed-off-by: Shiva Kerdel
---
drivers/staging/fsl-mc/bus/dpmcp.h | 34 +-
1 file changed, 17 insertions(+), 17 deletions(-)
diff --git a/drivers/staging/fsl-mc/bus/dpmcp.
Follow the kernel type preferrences of using 's16' over 'int16_t'.
Signed-off-by: Shiva Kerdel
---
drivers/staging/fsl-mc/include/mc-bus.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/fsl-mc/include/mc-bus.h
b/drivers/staging/fsl
Follow the kernel type preferrences of using 's32' over 'int32_t'.
Signed-off-by: Shiva Kerdel
---
drivers/staging/fsl-mc/include/mc.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/fsl-mc/include/mc.h
b/drivers/staging/fsl-mc/includ
Follow the kernel type preferrences of using 'u64' over 'uint64_t'.
Signed-off-by: Shiva Kerdel
---
drivers/staging/fsl-mc/bus/dpmcp.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/fsl-mc/bus/dpmcp.h
b/drivers/staging/fsl-mc/bus/d
Fixed reports from checkpatch that pointed out that the code was not
using the preferred types of the kernel.
Signed-off-by: Shiva Kerdel
---
drivers/staging/fsl-mc/bus/dpmcp.h | 80 -
drivers/staging/fsl-mc/include/mc-bus.h | 4 +-
drivers/staging/fsl-mc
The affected files have been modified to remove redundant spaces after
casts to solve checkpatch.pl checks.
Signed-off-by: Shiva Kerdel
---
drivers/staging/speakup/main.c | 42 ++---
drivers/staging/speakup/selection.c | 2 +-
drivers/staging/speakup
Replace all occurences of (1 << x) by BIT(x) in the file vme_pio2.h to
get rid of checkpatch.pl "check" output "Prefer using the BIT macro".
Signed-off-by: Shiva Kerdel
---
drivers/staging/vme/devices/vme_pio2.h | 86 +-
1 file cha
Fixed spaces around operators to fix their coding style issues.
Signed-off-by: Shiva Kerdel
---
drivers/staging/rtl8723au/core/rtw_ieee80211.c | 80 +-
1 file changed, 40 insertions(+), 40 deletions(-)
diff --git a/drivers/staging/rtl8723au/core/rtw_ieee80211.c
b
Fixed some coding style issues that were detected as errors.
Signed-off-by: Shiva Kerdel
---
drivers/staging/rtl8723au/core/rtw_xmit.c | 26 ++
1 file changed, 10 insertions(+), 16 deletions(-)
diff --git a/drivers/staging/rtl8723au/core/rtw_xmit.c
b/drivers/staging
Fixed spaces around operators to fix their coding style issues.
Signed-off-by: Shiva Kerdel
---
drivers/staging/rtl8723au/core/rtw_xmit.c | 24
1 file changed, 12 insertions(+), 12 deletions(-)
diff --git a/drivers/staging/rtl8723au/core/rtw_xmit.c
b/drivers/staging
46 matches
Mail list logo