get_dma_channel may return ERR_PTR or NULL, so a check is added.
Changes since v1:
- Removed unnecessary parentheses
- Replaced IS_ERR with IS_ERR_OR_NULL
Signed-off-by: Rolf Evers-Fischer
---
arch/sh/drivers/dma/dma-api.c | 20 +++-
arch/sh/drivers/dma/dma-sysfs.c | 2
On Sat, 8 Jun 2019, Geert Uytterhoeven wrote:
Hi Geert,
thank you for your reply and your additional findings.
> Hi Rolf,
>
> Thanks for your patch!
>
> On Fri, Jun 7, 2019 at 2:04 PM Rolf Evers-Fischer
> wrote:
> > get_dma_channel may return ERR_PTR, so a check is
Hello Sergei,
thanks for your feedback.
On Sat, 8 Jun 2019, Sergei Shtylyov wrote:
> Hello!
>
> On 07.06.2019 14:54, Rolf Evers-Fischer wrote:
>
> > get_dma_channel may return ERR_PTR, so a check is added.
> >
> > Signed-off-by: Rolf Evers-Fischer
> > ---
get_dma_channel may return ERR_PTR, so a check is added.
Signed-off-by: Rolf Evers-Fischer
---
arch/sh/drivers/dma/dma-api.c | 20 +++-
arch/sh/drivers/dma/dma-sysfs.c | 2 +-
2 files changed, 20 insertions(+), 2 deletions(-)
diff --git a/arch/sh/drivers/dma/dma-api.c b/arch
Kishon,
On Tue, 26 Feb 2019, Kishon Vijay Abraham I wrote:
> Rolf,
>
> On 26/02/19 2:54 PM, Rolf Evers-Fischer wrote:
> > From: Rolf Evers-Fischer
> >
> > Previously, ti_pipe3_calibrate() wrote all bits in the
> > PCIEPHYRX_ANA_PROGRAMMABILITY register, thus o
From: Rolf Evers-Fischer
Previously, ti_pipe3_calibrate() wrote all bits in the
PCIEPHYRX_ANA_PROGRAMMABILITY register, thus overwriting bits,
which should not be modified.
Fix ti_pipe3_calibrate() so that it only modifies LOSD and
INTERFACE bits.
Signed-off-by: Rolf Evers-Fischer
---
drivers
From: Rolf Evers-Fischer
Removes the goto labels completely, handles the errors at the
respective call site and just returns instead of jumping around.
Signed-off-by: Rolf Evers-Fischer
---
drivers/pci/endpoint/pci-epf-core.c | 32
1 file changed, 12
From: Rolf Evers-Fischer
'put_device()' calls the relase function 'pci_epf_dev_release()',
which already frees 'epf->name' and 'epf'.
Therefore we must not free them again after 'put_device()'.
Fixes: 5e8cb4033807 ("PCI: endpoint: A
From: Rolf Evers-Fischer
This commit replaces allocating and freeing the intermediate
'buf'/'func_name' with a combination of 'kstrndup()' and 'len'.
'len' is the required length of 'epf->name'.
'epf->name' should be
reworked in order to eliminate the
need for the second 'kstrdup' allocation and the 'kfree' of
the first allocation.
It was tested with name="pci_epf_test.0" and name="pci_epb":
The 'epf->name' was "pci_epf_test" or "pci_epb"
Hi Kishon and Lorenzo,
On Wed, 28 Feb 2018, Lorenzo Pieralisi wrote:
> On Wed, Feb 28, 2018 at 02:07:19PM +0100, Rolf Evers-Fischer wrote:
> > From: Rolf Evers-Fischer
> >
> > Removes the goto labels completely, handles the errors at the
> > respective call site
From: Rolf Evers-Fischer
Removes the goto labels completely, handles the errors at the
respective call site and just returns instead of jumping around.
Signed-off-by: Rolf Evers-Fischer
---
drivers/pci/endpoint/pci-epf-core.c | 30 +-
1 file changed, 9 insertions
From: Rolf Evers-Fischer
'put_device()' calls the relase function 'pci_epf_dev_release()',
which already frees 'epf->name' and 'epf'.
Therefore we must not free them again after 'put_device()'.
Fixes: 5e8cb4033807 ("PCI: endpoint: A
From: Rolf Evers-Fischer
This commit replaces allocating and freeing the intermediate
'buf'/'func_name' with a combination of 'kstrndup()' and 'len'.
'len' is the required length of 'epf->name'.
'epf->name' should be
rked in order to eliminate the
need for the second 'kstrdup' allocation and the 'kfree' of
the first allocation.
It was tested with name="pci_epf_test.0" and name="pci_epb":
The 'epf->name' was "pci_epf_test" or "pci_epb"
Hello Bjorn!
On Tue, 27 Feb 2018, Bjorn Helgaas wrote:
> On Tue, Feb 27, 2018 at 10:20:30AM +, Lorenzo Pieralisi wrote:
> > On Tue, Feb 27, 2018 at 11:02:28AM +0100, Rolf Evers-Fischer wrote:
> > > This is version 3 of a patchset to avoid double free in function
>
Hello Lorenzo!
On Tue, 27 Feb 2018, Lorenzo Pieralisi wrote:
> On Tue, Feb 27, 2018 at 11:02:30AM +0100, Rolf Evers-Fischer wrote:
> > From: Rolf Evers-Fischer
> >
> > 'put_device()' calls the relase function 'pci_epf_dev_release()',
>
Hello Lorenzo,
On Tue, 27 Feb 2018, Lorenzo Pieralisi wrote:
> On Tue, Feb 27, 2018 at 11:02:28AM +0100, Rolf Evers-Fischer wrote:
> > This is version 3 of a patchset to avoid double free in function
> > 'pci_epf_create()'.
> >
> > When I accidentally create
Hi,
On Tue, 27 Feb 2018, Kishon Vijay Abraham I wrote:
> Hi,
>
> On Tuesday 27 February 2018 03:32 PM, Rolf Evers-Fischer wrote:
> > From: Rolf Evers-Fischer
> >
> > This commit replaces allocating and freeing the intermediate
> > 'buf'/'func_n
From: Rolf Evers-Fischer
This commit replaces allocating and freeing the intermediate
'buf'/'func_name' with a combination of 'kstrndup()' and 'len'.
'len' is the required length of 'epf->name'.
'epf->name' should be
From: Rolf Evers-Fischer
'put_device()' calls the relase function 'pci_epf_dev_release()',
which already frees 'epf->name' and 'epf'.
Therefore we must not free them again after 'put_device()'.
Fixes: 5e8cb4033807 ("PCI: endpoint: A
the first allocation.
It was tested with name="pci_epf_test.0" and name="pci_epb":
The 'epf->name' was "pci_epf_test" or "pci_epb" (=unchanged).
Rolf Evers-Fischer (2):
pci: endpoint: Simplify name allocation for epf device
pci: endpoin
From: Rolf Evers-Fischer
'put_device()' calls the relase function 'pci_epf_dev_release()',
which already frees 'epf->name' and 'epf'.
Therefore we must not free them again after 'put_device()'.
Signed-off-by: Rolf Evers-Fischer
---
drive
From: Rolf Evers-Fischer
This commit replaces allocating and freeing the intermediate
'buf'/'func_name' with a combination of 'kstrndup()' and 'len'.
'len' is the required length of 'epf->name'.
'epf->name' should be
Change IDs removed
- First patch completely reworked in order to eliminate the
need for the second 'kstrdup' allocation and the 'kfree' of
the first allocation.
It was tested with name="pci_epf_test.0" and name="pci_epb":
The 'epf->name
18 11:49 PM, Lorenzo Pieralisi wrote:
> >>> On Wed, Feb 21, 2018 at 01:47:06PM +0100, Rolf Evers-Fischer wrote:
> >>>> From: Rolf Evers-Fischer
> >>>>
> >>>> This commit decreases the number of jump labels and ensures
> >>>> that t
> > Signed-off-by: Rolf Evers-Fischer
> > Signed-off-by: Rolf Evers-Fischer
>
> Looks like bipolar disorder?
>
You are right: One "Signed-off" should be enough.
> To the topic.
> This is a slow path and your change makes code slightly less readable
> b/c of
From: Rolf Evers-Fischer
'put_device()' calls the relase function 'pci_epf_dev_release()',
which already frees 'epf->name' and 'epf'.
Therefore we must not free them again after 'put_device()'.
Change-Id: I14ca19f96abfbbb489dd1f4d489e08532
From: Rolf Evers-Fischer
This commit decreases the number of jump labels and ensures
that the next commit doesn't increase the number of occurrences
of 'kfree(func_name)'.
Change-Id: I0d1b6fd652395b85f82b11c43bf9b7db512854d1
Signed-off-by: Rolf Evers-Fischer
Signed-off-by: Rol
'epf->name' and 'epf'.
The first patch just simplifies the code, while the second patch
fixes the problem.
Rolf Evers-Fischer (2):
pci: endpoint: Free func_name after last usage
pci: endpoint: Fix kernel panic after put_device()
drivers/pci/endpoint/pci-epf-core.c | 9 ++
From: Rolf Evers-Fischer
Fixed a spelling error in a comment.
Signed-off-by: Rolf Evers-Fischer
---
drivers/tty/serial/8250/8250_omap.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/tty/serial/8250/8250_omap.c
b/drivers/tty/serial/8250/8250_omap.c
index
On Wed, 6 Dec 2017, Joe Perches wrote:
> On Wed, 2017-12-06 at 15:13 +0100, Rolf Evers-Fischer wrote:
> > Hello,
> > I've just checked the file drivers/tty/serial/8250/8250_omap.c, using
> > checkpatch.pl, but I forgot the '-f' option (for file).
> &g
Hello,
I've just checked the file drivers/tty/serial/8250/8250_omap.c, using
checkpatch.pl, but I forgot the '-f' option (for file).
Surprisingly the checkpatch script reported a misspelling:
"WARNING: 'additionaly' may be misspelled - perhaps 'additionally'?
#417:
* We enable TRIG_GRA
From: Rolf Evers-Fischer
Signed-off-by: Rolf Evers-Fischer
---
drivers/tty/serial/8250/8250_omap.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/tty/serial/8250/8250_omap.c
b/drivers/tty/serial/8250/8250_omap.c
index bd40ba402410..57f6eba47f44 100644
--- a
For
some reason that commit did not remove all select statements for that
symbol. These statements are now useless.
Commit adad5621f3e1 ("PM / devfreq: Remove ARCH_HAS_OPP completely")
removed it for devfreq. Remove one from mach-shmobile too.
Signed-off-by: Rolf Evers-Fischer
---
arch
35 matches
Mail list logo