Hi Hannes,
On Tue, Jan 13, 2015 at 3:41 PM, Hannes Frederic Sowa
wrote:
> On Di, 2015-01-13 at 09:53 +0530, Rahul Sharma wrote:
>> On Mon, Jan 12, 2015 at 5:21 PM, Pablo Neira Ayuso
>> wrote:
>> > On Mon, Jan 12, 2015 at 04:38:16PM +0530, Rahul Sharma wrote
Hi
On Mon, Jan 12, 2015 at 5:21 PM, Pablo Neira Ayuso wrote:
> On Mon, Jan 12, 2015 at 04:38:16PM +0530, Rahul Sharma wrote:
>> Hi Pablo, Hannes
>>
>> On Fri, Jan 9, 2015 at 9:20 PM, Hannes Frederic Sowa
>> wrote:
>> > On Fr, 2015-01-09 at 12:45 +0100, Pabl
Hi Pablo, Hannes
On Fri, Jan 9, 2015 at 9:20 PM, Hannes Frederic Sowa
wrote:
> On Fr, 2015-01-09 at 12:45 +0100, Pablo Neira Ayuso wrote:
>> Hi Hannes,
>>
>> On Fri, Jan 09, 2015 at 12:34:15PM +0100, Hannes Frederic Sowa wrote:
>> > On Fri, Jan 9, 2015, at 08:18,
e fragment header will be NEXTHDR_AUTH which is correct but
ipv6_find_hdr will return ENOENT since AH is an extension header
resulting in second fragment getting dropped. This check for the
presence of non-extension header needs to be removed.
Signed-off-by: Rahul Sharma
---
net/ipv6/exthdrs_cor
e fragment header will be NEXTHDR_AUTH which is correct but
ipv6_find_hdr will return ENOENT since AH is an extension header
resulting in second fragment getting dropped. This check for the
presence of non-extension header needs to be removed.
Signed-off-by: Rahul Sharma
---
net/ipv6/exthdrs_cor
Hi Pablo,
On Fri, Jan 9, 2015 at 5:35 AM, Pablo Neira Ayuso wrote:
> On Thu, Jan 08, 2015 at 11:39:16PM +0100, Hannes Frederic Sowa wrote:
>> Hi Pablo,
>>
>> On Thu, Jan 8, 2015, at 21:53, Pablo Neira Ayuso wrote:
>> > I'm afraid we cannot just get rid of that !ipv6_ext_hdr() check. The
>> > ipv6
Hi Hannes,
On Wed, Jan 7, 2015 at 4:13 PM, Hannes Frederic Sowa
wrote:
> Hi,
>
> On Mi, 2015-01-07 at 11:11 +0530, Rahul Sharma wrote:
>> On Wed, Jan 7, 2015 at 4:17 AM, Pablo Neira Ayuso
>> wrote:
>> > On Wed, Jan 07, 2015 at 03:03:20AM +0530, Rahul Sha
Hi Pablo,
On Wed, Jan 7, 2015 at 4:17 AM, Pablo Neira Ayuso wrote:
> On Wed, Jan 07, 2015 at 03:03:20AM +0530, Rahul Sharma wrote:
>> ipv6_find_hdr() currently assumes that the next-header field in the
>> fragment header of the non-first fragment is the "protocol number o
e fragment header will be NEXTHDR_AUTH which is correct but
ipv6_find_hdr will return ENOENT since AH is an extension header
resulting in second fragment getting dropped. This check for the
presence of non-extension header needs to be removed.
Signed-off-by: Rahul Sharma
---
--- linux-3.18.
On 19 May 2014 16:24, Tomasz Figa wrote:
> On 19.05.2014 09:10, Rahul Sharma wrote:
>> On 16 May 2014 20:19, Tomasz Figa wrote:
>>> On 16.05.2014 16:30, Rahul Sharma wrote:
>>>> On 16 May 2014 16:20, Tomasz Figa wrote:
>>>>> On 16.05.2014 12:35, Ra
On 16 May 2014 20:19, Tomasz Figa wrote:
> On 16.05.2014 16:30, Rahul Sharma wrote:
>> On 16 May 2014 16:20, Tomasz Figa wrote:
>>> On 16.05.2014 12:35, Rahul Sharma wrote:
>>>> On 16 May 2014 15:12, Rahul Sharma wrote:
>>>>> On 16 May 2014 03:14, T
On 16 May 2014 16:22, Tomasz Figa wrote:
> Hi Rahul,
>
> On 16.05.2014 12:39, Rahul Sharma wrote:
>> [snip]
>>> + gate->lock = &clkout_lock;
>>> +
>>> + mux->reg = reg + EXYNOS_PMU_DEBUG_REG;
>>> +
On 16 May 2014 16:20, Tomasz Figa wrote:
> On 16.05.2014 12:35, Rahul Sharma wrote:
>> On 16 May 2014 15:12, Rahul Sharma wrote:
>>> On 16 May 2014 03:14, Tomasz Figa wrote:
>>>> On 15.05.2014 06:01, Rahul Sharma wrote:
>> [snip]
>>>>>> the
t; + if (IS_ERR(clk))
> + goto err_unmap;
> +
Hi Tomasz,
Do we really need a composite clock here? How about registering
a mux and a gate separately?
Regards,
Rahul Sharma.
> + of_clk_add_provider(node, of_clk_src_simple_get, clk);
> +
> + return;
&
On 16 May 2014 15:12, Rahul Sharma wrote:
> On 16 May 2014 03:14, Tomasz Figa wrote:
>> On 15.05.2014 06:01, Rahul Sharma wrote:
[snip]
>>>> the PHY provider.
>>>>
>>>
>>> Please correct me if I got you wrong. You want somthing like this:
>&g
On 16 May 2014 03:14, Tomasz Figa wrote:
> On 15.05.2014 06:01, Rahul Sharma wrote:
>> Thanks Tomasz,
>>
>> On 15 May 2014 01:31, Tomasz Figa wrote:
>>> Hi Rahul, Tomasz,
>> [snip]
>>>> + simplephys: simple-phys@1004 {
>>>&g
On 15 May 2014 19:37, Tomasz Figa wrote:
> Hi Rahul, Tushar,
>
> On 15.05.2014 15:44, Rahul Sharma wrote:
>> Hi Tushar,
>>
>> Basically you are adding a new clock-type for Clkout. IMO clkout
>> is not a special hardware. Existing clock types can be reused to
On 15 May 2014 19:11, Kishon Vijay Abraham I wrote:
>
>
> On Thursday 15 May 2014 07:05 PM, Rahul Sharma wrote:
>> Hi,
>>
>> On 15 May 2014 19:01, Bartlomiej Zolnierkiewicz
>> wrote:
>>>
>>> Hi,
>>>
>>> On Thursday, May 15
O a independent clock provider with
iomap, is relatively cleaner approach till CCF is not ready with regmap based
reg access for clock registers.
Experts!! please comment.
Regards,
Rahul Sharma.
On 12 May 2014 10:16, Tushar Behera wrote:
> On 05/10/2014 09:21 AM, Pankaj Dubey wrote:
>> On 05/09/2
Hi,
On 15 May 2014 19:01, Bartlomiej Zolnierkiewicz
wrote:
>
> Hi,
>
> On Thursday, May 15, 2014 12:47:21 AM Rahul Sharma wrote:
>> From: Tomasz Stanislawski
>>
>> Add exynos-simple-phy driver to support a single register
>> PHY interfaces present on Exyn
awski
Signed-off-by: Rahul Sharma
---
drivers/gpu/drm/exynos/exynos_hdmi.c | 11 ++-
1 file changed, 6 insertions(+), 5 deletions(-)
diff --git a/drivers/gpu/drm/exynos/exynos_hdmi.c
b/drivers/gpu/drm/exynos/exynos_hdmi.c
index 9a6d652..ef1cdd0 100644
--- a/drivers/gpu/drm/exynos/exynos_h
awski
Signed-off-by: Rahul Sharma
---
drivers/media/platform/s5p-tv/hdmi_drv.c | 11 ++-
1 file changed, 6 insertions(+), 5 deletions(-)
diff --git a/drivers/media/platform/s5p-tv/hdmi_drv.c
b/drivers/media/platform/s5p-tv/hdmi_drv.c
index 534722c..8013e52 100644
--- a/drivers/media/pla
From: Tomasz Stanislawski
Add exynos-simple-phy driver to support a single register
PHY interfaces present on Exynos4 SoC.
Signed-off-by: Tomasz Stanislawski
Signed-off-by: Rahul Sharma
---
.../devicetree/bindings/phy/samsung-phy.txt| 57 ++
drivers/phy/Kconfig
From: Rahul Sharma
Changelog:
v4:
* Rename files to follow "phy-exynos-simple" names.
* Rename Macros to this convention PHY_EXYNOS_SIMPLE_.
* Added list of phy specifier values to documentation file.
* Removed of_match_ptr from driver probe.
On 15 May 2014 13:12, Thierry Reding wrote:
> On Thu, May 15, 2014 at 10:49:37AM +0530, Rahul Sharma wrote:
>> Hi Thierry,
>>
>> On 15 May 2014 03:44, Thierry Reding wrote:
>> > On Thu, May 15, 2014 at 12:47:21AM +0530, Rahul Sharma wrote:
> [...]
>> &g
Hi Thierry,
On 15 May 2014 03:44, Thierry Reding wrote:
> On Thu, May 15, 2014 at 12:47:21AM +0530, Rahul Sharma wrote:
> [...]
>> diff --git a/Documentation/devicetree/bindings/phy/samsung-phy.txt
>> b/Documentation/devicetree/bindings/phy/samsung-phy.txt
> [...]
>&g
@1004 {
...
simple_phys: simple-phys {
compatible = "samsung,exynos5420-simple-phy";
...
};
};
Regards,
Rahul Sharma.
> Otherwise looks good.
>
> Best regards,
> Tomasz
>
awski
Signed-off-by: Rahul Sharma
---
drivers/media/platform/s5p-tv/hdmi_drv.c | 11 ++-
1 file changed, 6 insertions(+), 5 deletions(-)
diff --git a/drivers/media/platform/s5p-tv/hdmi_drv.c
b/drivers/media/platform/s5p-tv/hdmi_drv.c
index 534722c..8013e52 100644
--- a/drivers/media/pla
From: Tomasz Stanislawski
Add exynos-simple-phy driver to support a single register
PHY interfaces present on Exynos4 SoC.
Signed-off-by: Tomasz Stanislawski
Signed-off-by: Rahul Sharma
---
.../devicetree/bindings/phy/samsung-phy.txt| 56 ++
drivers/phy/Kconfig
From: Rahul Sharma
Hi All,
This series has been originally proposed by Tomasz Stanislawski. With
his permission, I have addressed the following review comments in V3.
Changelog:
v3:
* Implement lazy-init of PHYs.
* Use MACROs instead of numbers to represent phys.
* Use
awski
Signed-off-by: Rahul Sharma
---
drivers/gpu/drm/exynos/exynos_hdmi.c | 11 ++-
1 file changed, 6 insertions(+), 5 deletions(-)
diff --git a/drivers/gpu/drm/exynos/exynos_hdmi.c
b/drivers/gpu/drm/exynos/exynos_hdmi.c
index 9a6d652..ef1cdd0 100644
--- a/drivers/gpu/drm/exynos/exynos_h
On 7 May 2014 21:03, Tomasz Figa wrote:
> [CCing more DT-folks :)]
>
> On 07.05.2014 16:19, Rahul Sharma wrote:
>> On 7 May 2014 19:06, Tomasz Stanislawski wrote:
>>> On 05/07/2014 12:38 PM, Rahul Sharma wrote:
>>>> On 5 May 2014 15:14, Kishon Vijay Abraha
On 7 May 2014 19:06, Tomasz Stanislawski wrote:
> On 05/07/2014 12:38 PM, Rahul Sharma wrote:
>> On 5 May 2014 15:14, Kishon Vijay Abraham I wrote:
>>> Hi,
>>>
>>> On Wednesday 09 April 2014 03:31 PM, Sylwester Nawrocki wrote:
>>>> Hi,
>>>
On 5 May 2014 15:14, Kishon Vijay Abraham I wrote:
> Hi,
>
> On Wednesday 09 April 2014 03:31 PM, Sylwester Nawrocki wrote:
>> Hi,
>>
>> On 09/04/14 11:12, Rahul Sharma wrote:
>>> Idea looks good. How about keeping compatible which is independent
>>>
Sure (5250, 5420). I will wait for the same to update DT patches, if any.
Regards,
Rahul Sharma.
On 30 April 2014 14:02, Tomasz Stanislawski wrote:
> Hi Rahul,
> I will prepare we v3 version.
> Do you want me to add your patches for exynos5?50 to the patchset?
> Regards,
> Toma
Hi Tomasz,
I have tested your patches for exynos5250 and 5420. Works fine. Are
you planning to post v3? If you want I can share hand with you for v3.
Regards,
Rahul Sharma
On 9 April 2014 17:17, Andreas Oberritter wrote:
> Hello Andrzej,
>
> On 09.04.2014 10:37, Andrzej Ha
-- Forwarded message --
From:
Date: 15 April 2014 14:32
Subject: [Bug 74121] New: [3.15-rc1] Exynos: Sandbox report fatal
error "Unexpected 64bit argument detected"
To: dri-de...@lists.freedesktop.org
https://bugzilla.kernel.org/show_bug.cgi?id=74121
Bug ID: 74121
ase of clk it would be easier.
If it is really required to change this divider, it should be registered as
a clock provider in clock driver exposing single divider clock.
Regards,
Rahul Sharma
>
> Regards
> Andrzej
>
>
> ___
_provider;
>> +
>> + /* count number of phys to create */
>> + for (count = 0; offsets[count] != ~0; ++count)
>> + ;
>
> count = ARRAY_SIZE(offsets) - 1;
>
>> +
>> + phys = devm_kzalloc(dev, (count + 1) * sizeof(phys[0]), GFP_KERNE
On Fri, Aug 2, 2013 at 12:12 PM, Cho KyongHo wrote:
>> -Original Message-
>> From: Rahul Sharma [mailto:r.sh.o...@gmail.com]
>> Sent: Friday, August 02, 2013 2:18 PM
>>
>> Hi Cho,
>>
>> On Fri, Jul 26, 2013 at 5:00 PM, Cho KyongHo wrote:
&g
int ret;
> +
> + ret = cb(dev);
> + if (ret)
> + return ret;
> + }
> +
> + for (i = 0; i < client->num_sysmmu; i++)
> + sysmmu_save_state(client->sysmmu[i]);
&g
x Kernel'; 'Linux
>> Samsung SOC'
>> Cc: 'Kukjin Kim'; 'Hyunwoong Kim'; 'Prathyush'; 'Grant Grundler'; 'Joerg
>> Roedel'; 'Keyyoung Park';
>> 'Subash Patel'; 'Sachin Kamat'; 'T
ver_data;
> -
> + sec_pmic->type = sec_i2c_get_driver_data(i2c, id);
> +
> + if (sec_pmic->dev->of_node) {
> + pdata = sec_pmic_i2c_parse_dt_pdata(sec_pmic->dev);
> + if (IS_ERR(pdata)) {
> + ret = PTR_ERR(pdata);
Hi Arnd Bergmann,
It looks good to me. My patch caused this issue.
Thanks for the fix.
regards,
Rahul Sharma.
On Fri, Jan 25, 2013 at 8:58 PM, Arnd Bergmann wrote:
> Patch 9eb3e9e6f3 "drm/exynos: add support for ARCH_MULTIPLATFORM"
> allowed building the exynos hdmi drive
Hi Mr. Cho,
We have verified the above patchset for following usecases on exynos5.
1) MFC decoding using Sysmmu_L and R. (with the bit Inversion fix)
2) GSC operations.
3) FIMD and MIXER (HDMI) as displays.
Thanks for your effort.
regards,
Rahul Sharma.
On Thu, Nov 29, 2012 at 4:25 PM, Cho
45 matches
Mail list logo