itialization failure")
AFAICS this still is in Martin's tree and not yet in Linus' tree.
Anyways, looks good.
Reviewed-by: Johannes Thumshirn
On 04/02/2021 08:37, Yang Li wrote:
> This patch removes unneeded return variables, using only
> '1' instead.
> It fixes the following warning detected by coccinelle:
>
> Reported-by: Abaci Robot
> Signed-off-by: Yang Li
> ---
> drivers/scsi/lpfc/lpfc_sli.c | 3 +--
> 1 file changed, 1 insertio
On 04/02/2021 08:20, Yang Li wrote:
> This patch removes unneeded return variables, using only
> '0' instead.
> It fixes the following warning detected by coccinelle:
> ./drivers/scsi/qla4xxx/ql4_os.c:3642:5-7: Unneeded variable: "rc".
> Return "0" on line 3741
>
> Reported-by: Abaci Robot
> Sign
On 04/02/2021 08:28, Yang Li wrote:
> This patch removes unneeded return variables, using only
> '0' instead.
> It fixes the following warning detected by coccinelle:
> ./drivers/scsi/ipr.c:9508:5-7: Unneeded variable: "rc". Return "0" on
> line 9524
>
> Reported-by: Abaci Robot
> Signed-off-by:
On 13/01/2021 17:07, Li Feng wrote:
> The nvme spec(1.4a, figure 248) says:
> "A value smaller than 9 (i.e., 512 bytes) is not supported."
>
> Signed-off-by: Li Feng
> ---
> drivers/nvme/host/core.c | 6 ++
> 1 file changed, 6 insertions(+)
>
> diff --git a/drivers/nvme/host/core.c b/driver
On 12/01/2021 18:38, Joe Perches wrote:
> static void
> _base_display_OEMs_branding(struct MPT3SAS_ADAPTER *ioc)
> {
> + const char *b = NULL; /* brand */
> + const char *v = NULL; /* vendor */
Any reason you didn't spell out brand and vendor as the variable names?
On 12/01/2021 18:29, Feng Li wrote:
> I use the nvme-tcp as the host, the target is spdk nvme-tcp target,
> and set a wrong block size(i.g. bs=8), then the host prints this oops:
I think the better fix here is to reject devices which report a block size
small than a sector.
On 11/01/2021 21:27, Jonathan Corbet wrote:
> Sorry, I've been distracted by holidays, merge window, network issues, and
> generally watching the news in horror. The patch is applied now, thanks.
Thanks Jon
On 18/12/2020 16:35, Johannes Thumshirn wrote:
> Hannes reported a problem with setting up dma transfers on a mcb device.
> The problem boiled down to the use of a wrong 'device' for the dma
> functions.
>
> Document how to setup dma transfers for a IP core on a mcb carrier.
Ping?
Hannes reported a problem with setting up dma transfers on a mcb device.
The problem boiled down to the use of a wrong 'device' for the dma
functions.
Document how to setup dma transfers for a IP core on a mcb carrier.
Reported-by: Hannes Duerr
Signed-off-by: Johannes
On 11/12/2020 15:57, SelvaKumar S wrote:
[...]
> +int blk_copy_emulate(struct block_device *bdev, struct blk_copy_payload
> *payload,
> + gfp_t gfp_mask)
> +{
> + struct request_queue *q = bdev_get_queue(bdev);
> + struct bio *bio;
> + void *buf = NULL;
> + int i, nr_s
On 08/12/2020 14:13, Javier González wrote:
> On 08.12.2020 12:37, Johannes Thumshirn wrote:
>> On 08/12/2020 13:22, Javier González wrote:
>>> Good idea. Are you thinking of a sysfs entry to select the backend?
>>
>> Not sure on this one, initially I thought of a sys
On 08/12/2020 13:22, Javier González wrote:
> Good idea. Are you thinking of a sysfs entry to select the backend?
Not sure on this one, initially I thought of a sysfs file, but then
how would you do it. One "global" sysfs entry is probably a bad idea.
Having one per block device to select native v
On 07/12/2020 20:27, Javier González wrote:
> Good point. We can share some performance data on how Simple Copy scales
> in terms of bw / latency and the CPU usage. Do you have anything else in
> mind?
>
With an emulation in the kernel, we could make the usd "backend"
implementation configurable
On 01/12/2020 08:14, SelvaKumar S wrote:
> +static inline int bio_check_copy_eod(struct bio *bio, sector_t start,
> + sector_t nr_sectors, sector_t maxsector)
> +{
> + if (nr_sectors && maxsector && (nr_sectors > maxsector ||
> + start > maxsector - nr_se
On 03/06/2020 09:10, AGeissler wrote:
> [resend; because of missing cc]
>
> Remove Andreas Werner as Maintainer of the F21 BMC driver, as he is no
> longer with the company and add Andreas Geissler as additional
> Maintainer for all MEN Hardware.
>
> Acked-by: Johannes
On 26/10/2020 16:01, Stephen Rothwell wrote:
> Hi all,
>
> In commit
>
> ae1a53ee21a5 ("btrfs: don't fallback to buffered read if we don't need to")
>
> Fixes tag
>
> Fixes: b5ff9f1a96e8f ("btrfs: switch to iomap for direct IO")
>
> has these problem(s):
>
> - Target SHA1 does not exist
On 21/10/2020 11:04, Sergei Shtepa wrote:
> + help
> + Enabling this lets third-party kernel modules intercept
> + bio requests for any block device. This allows them to implement
The "third-party kernel modules" part sounds a bit worrisome to me. Especially
as this functionality i
On 19/10/2020 16:30, 苏辉 wrote:
> Yeah, you are right, thanks for your explanationMaybe we should
> define a MASK to do this?
Why? I personally find a '& 1' way more understandable than a
REQ_OP_IS_WRITE_MASK or sth like that. The former I can just read,
for the latter I would need to look up the
On 19/10/2020 16:06, Hui Su wrote:
> use REQ_OP_WRITE instead of hard code in
> op_is_write().
>
> Signed-off-by: Hui Su
> ---
> include/linux/blk_types.h | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/include/linux/blk_types.h b/include/linux/blk_types.h
> index 7d7c1
On 23/09/2020 08:03, Zhang, Qiang wrote:
> Hello Johannes Thumshirn
>
> the crash happend in "snprintf(s->s_id, sizeof(s->s_id), "%pg", bdev)" in
> btrfs_mount_root func, the "bdev" may be destroyed in btrfs_close_devices.
> I think add btrf
On 17/09/2020 09:57, Niklas Cassel wrote:
> On Mon, Sep 07, 2020 at 08:18:26AM +, Niklas Cassel wrote:
>> On Fri, Aug 28, 2020 at 12:54:00PM +0200, Niklas Cassel wrote:
>>> Add support for user space to set a max open zone and a max active zone
>>> limit via configfs. By default, the default va
On 21/09/2020 16:32, syzbot wrote:
> Hello,
>
> syzbot found the following issue on:
>
> HEAD commit:860461e4 Add linux-next specific files for 20200917
> git tree: linux-next
> console output: https://syzkaller.appspot.com/x/log.txt?x=141fc5d990
> kernel config: https://syzkaller.
On 21/09/2020 13:00, qiang.zh...@windriver.com wrote:
> From: Zqiang
>
> When the btrfs fill super error, we should first close devices and
> then call deactivate_locked_super func to free fs_info.
>
> Signed-off-by: Zqiang
> ---
> fs/btrfs/super.c | 1 +
> 1 file changed, 1 insertion(+)
>
>
On 21/09/2020 11:14, Zhang, Qiang wrote:
>
>
> ____
> 发件人: Johannes Thumshirn
> 发送时间: 2020年9月21日 16:52
> 收件人: Zhang, Qiang; c...@fb.com; jo...@toxicpanda.com; dste...@suse.com
> 抄送: linux-bt...@vger.kernel.org; linux-kernel@vger.kernel
On 21/09/2020 07:38, syzbot wrote:
> syzbot has found a reproducer for the following issue on:
>
> HEAD commit:325d0eab Merge branch 'akpm' (patches from Andrew)
> git tree: upstream
> console output: https://syzkaller.appspot.com/x/log.txt?x=1512df5390
> kernel config: https://syzk
On 21/09/2020 10:27, qiang.zh...@windriver.com wrote:
> From: Zqiang
>
> When the btrfs fill super error, we should first close devices and
> then call deactivate_locked_super func to free fs_info.
>
> Signed-off-by: Zqiang
> ---
> fs/btrfs/super.c | 1 +
> 1 file changed, 1 insertion(+)
>
>
On 21/09/2020 07:38, syzbot wrote:
> syzbot has found a reproducer for the following issue on:
>
> HEAD commit:325d0eab Merge branch 'akpm' (patches from Andrew)
> git tree: upstream
> console output: https://syzkaller.appspot.com/x/log.txt?x=1512df5390
> kernel config: https://syzk
On 21/09/2020 09:58, Anand Jain wrote:
> On 21/9/20 6:42 am, syzbot wrote:
>> syzbot has found a reproducer for the following issue on:
>>
>> HEAD commit:b652d2a5 Add linux-next specific files for 20200918
>> git tree: linux-next
>> console output: https://syzkaller.appspot.com/x/log.txt?
Looks good,
Reviewed-by: Johannes Thumshirn
On 18/09/2020 14:48, Christoph Hellwig wrote:
> We only have not compat_sys_readv64v2 syscall, only a
We have no?
On 16/09/2020 10:19, syzbot wrote:
> syzbot has bisected this issue to:
>
> commit 3951e7f050ac6a38bbc859fc3cd6093890c31d1c
> Author: Johannes Thumshirn
> Date: Mon Oct 7 09:11:01 2019 +
>
> btrfs: add xxhash64 to checksumming algorithms
>
On 12/09/2020 04:31, Damien Le Moal wrote:
> On 2020/09/12 8:07, Borislav Petkov wrote:
>> On Sat, Sep 12, 2020 at 12:17:59AM +0200, Borislav Petkov wrote:
>>> Enabling it, fixes the issue.
>>
>> Btw, I just hit the below warn with 5.8, while booting with the above
>> config option enabled. Looks f
On 12/09/2020 00:22, Randy Dunlap wrote:
> On 9/11/20 3:17 PM, Borislav Petkov wrote:
>> On Fri, Sep 11, 2020 at 09:53:12PM +0200, Borislav Petkov wrote:
>>> Now, looking at that patch:
>>>
>>> 5795eb443060 ("scsi: sd_zbc: emulate ZONE_APPEND commands")
>>>
>>> yeah, that doesn't revert cleanly.
Looks good,
Reviewed-by: Johannes Thumshirn
On 05/09/2020 11:41, Miaohe Lin wrote:
> When bio_add_hw_page() failed, we left page reference still held in pages.
I'd add "from iov_iter_get_pages()" to the above sentence.
Otherwise
Reviewed-by: Johannes Thumshirn
Looks good,
Reviewed-by: Johannes Thumshirn
Looks good,
Reviewed-by: Johannes Thumshirn
Looks good,
Reviewed-by: Johannes Thumshirn
Looks good,
Reviewed-by: Johannes Thumshirn
Looks good,
Reviewed-by: Johannes Thumshirn
On 02/09/2020 16:21, Christoph Hellwig wrote:
> call cd_revalidate_disk manually. As sd also calls sd_revalidate_disk
^~ sd_revalidate_disk
Otherwise,
Reviewed-by: Johannes Thumshirn
On 02/09/2020 16:16, Christoph Hellwig wrote:
> The pcd driver does not have a ->revalidate_disk method, so it can just
md ~^
Otherwise looks good,
Reviewed-by: Johannes Thumshirn
Looks good,
Reviewed-by: Johannes Thumshirn
Looks good,
Reviewed-by: Johannes Thumshirn
Looks good,
Reviewed-by: Johannes Thumshirn
Looks good,
Reviewed-by: Johannes Thumshirn
Looks good,
Reviewed-by: Johannes Thumshirn
Looks good,
Reviewed-by: Johannes Thumshirn
Looks good,
Reviewed-by: Johannes Thumshirn
And down by one,
Reviewed-by: Johannes Thumshirn
Looks good,
Reviewed-by: Johannes Thumshirn
> +static int floppy_revalidate(struct gendisk *disk);
Completely unrelated to this series but, this is the 3rd floppy
driver in the series defining it's own floppy_revalidate() and
naming it floppy_revalidate().
This makes grepping and rev
Looks good,
Reviewed-by: Johannes Thumshirn
Looks good,
Reviewed-by: Johannes Thumshirn
Looks good,
Reviewed-by: Johannes Thumshirn
Looks good,
Reviewed-by: Johannes Thumshirn
Looks good,
Reviewed-by: Johannes Thumshirn
Looks good,
Reviewed-by: Johannes Thumshirn
Looks good,
Reviewed-by: Johannes Thumshirn
Looks good,
Reviewed-by: Johannes Thumshirn
Looks good,
Reviewed-by: Johannes Thumshirn
Looks good,
Reviewed-by: Johannes Thumshirn
On 04/08/2020 16:45, Coly Li wrote:
> Yes, Ming just posts a patch with a very similar change to loop device
> driver.
Ah ok. I'll go and have a look at Ming's patch then.
On 04/08/2020 16:23, Coly Li wrote:
> This is the procedure to reproduce the panic,
> # modprobe scsi_debug delay=0 dev_size_mb=2048 max_queue=1
> # losetup -f /dev/nvme0n1 --direct-io=on
> # blkdiscard /dev/loop0 -o 0 -l 0x200
losetup -f /dev/sdX isn't it?
On 04/08/2020 16:37, Johannes Thumshirn wrote:
> On 04/08/2020 16:34, Coly Li wrote:
>> On 2020/8/4 22:31, Johannes Thumshirn wrote:
>>> On 04/08/2020 16:23, Coly Li wrote:
>>>> This is the procedure to reproduce the panic,
>>>> # modprobe scsi_
On 04/08/2020 16:34, Coly Li wrote:
> On 2020/8/4 22:31, Johannes Thumshirn wrote:
>> On 04/08/2020 16:23, Coly Li wrote:
>>> This is the procedure to reproduce the panic,
>>> # modprobe scsi_debug delay=0 dev_size_mb=2048 max_queue=1
>>> # lo
Looks good,
Reviewed-by: Johannes Thumshirn
Reviewed-by: Johannes Thumshirn
Looks good,
Reviewed-by: Johannes Thumshirn
Looks good,
Reviewed-by: Johannes Thumshirn
Looks good,
Reviewed-by: Johannes Thumshirn
Looks good,
Reviewed-by: Johannes Thumshirn
Looks good,
Reviewed-by: Johannes Thumshirn
Looks good,
Reviewed-by: Johannes Thumshirn
Looks good,
Reviewed-by: Johannes Thumshirn
On 22/07/2020 08:27, Christoph Hellwig wrote:
> it is know to support cgroup writeback, or the bdi comes from the block
knwon ~^
Apart from that,
Reviewed-by: Johannes Thumshirn
Looks good,
Reviewed-by: Johannes Thumshirn
Looks good,
Reviewed-by: Johannes Thumshirn
On 22/07/2020 09:07, Christoph Hellwig wrote:
> As far as I can tell this is a netlink user ABI.
>
I guess it has to stay then
On 22/07/2020 08:27, Christoph Hellwig wrote:
> + q->backing_dev_info->ra_pages =
> + max(queue_io_opt(q) * 2 / PAGE_SIZE, VM_READAHEAD_PAGES);
Dumb question, wouldn't a '>> PAGE_SHIFT' be better instead of a potentially
costly division?
Or aren't we caring at all as it's a) not
Looks good,
Reviewed-by: Johannes Thumshirn
On 22/07/2020 08:28, Christoph Hellwig wrote:
> Ever since the switch to blk-mq, a lower device not use by VM
in-use/used? ~^
Also this looks like the last user of 'dev_lower_blocked' so it could
be removed from device_statistics if it's not an ABI (not s
A little bit of git archeology shows the last user of SB_I_MULTIROOT is gone
with
f2aedb713c28 ("NFS: Add fs_context support.")
Reviewed-by: Johannes Thumshirn
Looks good,
Reviewed-by: Johannes Thumshirn
Looks good,
Reviewed-by: Johannes Thumshirn
Looks good,
Reviewed-by: Johannes Thumshirn
s(struct scsi_disk *sdkp,
>
Woops that looks like some leftover from development. My bad.
Reviewed-by: Johannes Thumshirn
On 08/07/2020 14:04, Lee Jones wrote:
> Description should state 'remote' port, not 'local'.
>
> Fixes the following W=1 kernel build warning(s):
>
> drivers/scsi/libfc/fc_rport.c:1452: warning: Function parameter or member
> 'rdata_arg' not described in 'fc_rport_logo_resp'
> drivers/scsi/lib
On 08/07/2020 14:04, Lee Jones wrote:
> @@ -1445,7 +1445,7 @@ static void fc_rport_recv_rtv_req(struct fc_rport_priv
> *rdata,
> * fc_rport_logo_resp() - Handler for logout (LOGO) responses
> * @sp: The sequence the LOGO was on
> * @fp: The LOGO response frame
> - * @
On 08/07/2020 14:12, Lee Jones wrote:
> Obviously I'd be okay with that, but it will depend on whether his
> tree is able to be rebased. Many public trees are unrebasable (if
> that's a word).
Yeah but in this early stage SCSI usually is re-baseable.
Looks good,
Reviewed-by: Johannes Thumshirn
I think Martin can fold this one into the original one
On 07/07/2020 16:01, Lee Jones wrote:
> + * @disc: The descovery context
s/descovery/discovery
On 03/07/2020 14:09, Johannes Thumshirn wrote:
> On 03/07/2020 11:23, Niklas Cassel wrote:
>> On Fri, Jul 03, 2020 at 08:22:45AM +, Johannes Thumshirn wrote:
>>> On 02/07/2020 20:20, Niklas Cassel wrote:
>>>> Documentation/block/queue-sysfs.rst | 7 +
On 03/07/2020 08:56, Kanchan Joshi wrote:
[...]
> Yes, zonefs does not use bvec iter. But while enabling io-uring path for
> zone-append, I hit into this condition returning -EINVAL.
>
> Reference (from user zone-append series cover letter):
> "Append using io_uring fixed-buffer --->
> This is fl
On 03/07/2020 11:23, Niklas Cassel wrote:
> On Fri, Jul 03, 2020 at 08:22:45AM +0000, Johannes Thumshirn wrote:
>> On 02/07/2020 20:20, Niklas Cassel wrote:
>>> Documentation/block/queue-sysfs.rst | 7 +++
>>> block/blk-sysfs.c | 15 +++
On 02/07/2020 20:20, Niklas Cassel wrote:
> Documentation/block/queue-sysfs.rst | 7 +++
> block/blk-sysfs.c | 15 +++
> drivers/nvme/host/zns.c | 1 +
> drivers/scsi/sd_zbc.c | 4
> include/linux/blkdev.h | 16 +++
Looks good,
Reviewed-by: Johannes Thumshirn
Looks good,
Reviewed-by: Johannes Thumshirn
Looks good,
Reviewed-by: Johannes Thumshirn
Looks good,
Reviewed-by: Johannes Thumshirn
1 - 100 of 1053 matches
Mail list logo